Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
slot conflicts installing Gnome with systemd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
BWStevens
n00b
n00b


Joined: 10 Jun 2015
Posts: 61
Location: Hobart

PostPosted: Wed Mar 23, 2016 4:12 pm    Post subject: slot conflicts installing Gnome with systemd Reply with quote

Hello Community, I'm trying to install Gnome 3 but am having a slot conflict and I've tried to resolve it but its just a no go.
I've got this error when trying to install gnome-base/gnome

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

(dev-libs/openssl-1.0.2g-r2:0/0::gentoo, installed) pulled in by
>=dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.2_p2:0/0::gentoo, installed)


(dev-libs/openssl-1.0.2g-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/openssl-0.9.8g:0[-bindist] required by (net-voip/telepathy-gabble-0.18.3:0/0::gentoo, ebuild scheduled for merge)

I tried emerge -av gnome-base/gnome --backtrack=30 but that didn't solve anything.
I need to mask a package but out of the list I don't know what one.
Sorry for the inconvenience

Brett
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1702

PostPosted: Wed Mar 23, 2016 8:01 pm    Post subject: Reply with quote

Quote:
(dev-libs/openssl-1.0.2g-r2:0/0::gentoo, installed) pulled in by
>=dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.2_p2:0/0::gentoo, installed)


(dev-libs/openssl-1.0.2g-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/openssl-0.9.8g:0[-bindist] required by (net-voip/telepathy-gabble-0.18.3:0/0::gentoo, ebuild scheduled for merge)


There's the problem straight out ( just like everyone else that has the idea to enable bindist USE flag). Disable that USE flag!!! It causes nothing but problems, as too many packages require it turned off (that USE flag only disables several encryption algorithms that most stuff require). Note: Openssh needs to also have the bindist USE flag turned off!
Back to top
View user's profile Send private message
g2g591
Apprentice
Apprentice


Joined: 17 Sep 2007
Posts: 217

PostPosted: Thu Mar 24, 2016 3:27 am    Post subject: Re: slot conflicts installing Gnome with systemd Reply with quote

BWStevens wrote:


dev-libs/openssl:0

(dev-libs/openssl-1.0.2g-r2:0/0::gentoo, installed) pulled in by
>=dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.2_p2:0/0::gentoo, installed)


(dev-libs/openssl-1.0.2g-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/openssl-0.9.8g:0[-bindist] required by (net-voip/telepathy-gabble-0.18.3:0/0::gentoo, ebuild scheduled for merge)

This means that you need openssl built with -bindist for net-voip/telepathy-gabble which is part of the scheduled installation, but you need openssl built WITH bindist for how your current net-misc/openssh install is built. Try setting openssh to not be built with bindist and then rebuilding it then trying again install gnome
Back to top
View user's profile Send private message
BWStevens
n00b
n00b


Joined: 10 Jun 2015
Posts: 61
Location: Hobart

PostPosted: Thu Mar 24, 2016 5:54 am    Post subject: solved Reply with quote

Thank you very much gentlemen.
Built with -bindist and good to go
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum