Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kde(intel GPU) drop fps [Solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 29 Mar 2015
Posts: 42

PostPosted: Mon Mar 21, 2016 7:18 am    Post subject: Kde(intel GPU) drop fps [Solved] Reply with quote


After update (full emerge of @system and @world) i notice that my box is dropping frames from time to time - it is visible as little hangs/freezes of desktop. It's happening very often during normal load and work. I had enabled "Show FPS" plug-in for KDE and when it comes to freeze, fps drops to 0 and than suddenly increasing to normal value which is 58-60 fps. I think it can be releted to Intel HD GPU driver.

Some info about hardware:
- Intel(R) Core(TM) i5 CPU M520 (2 cores + HT)
- 8 GB of RAM
- 2 disk (root on SSD and home on HDD)
- GPU Intel HD Gen 5 Nehalem (Ironlake)
Use flags for intel:
- x11-drivers/xf86-video-intel dri3 sna
Xorg conf(i tried different things here - nothing helps):
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "TearFree" "true"
Option "AccelMethod" "sna"
Option "DRI" "3"

I've had experimented with different kernel parameters but nothing helps, i made boots with:
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda3" #my actual kernel parameters
#GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda3 i915.semaphores=1 i915.enable_fbc=0 i915.disable_power_well=0 i915.preliminary_hw_support=1"
#GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda3 i915.semaphores=1 i915.enable_fbc=0 i915.disable_power_well=0"

KDE is in version:
- 4.14.16

emerge --info
elitebook ~ # emerge --info
Portage 2.2.26 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.9.3, glibc-2.21-r2, 4.1.15-gentoo-r1 x86_64)
System uname: Linux-4.1.15-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5_CPU_M_520_@_2.40GHz-with-gentoo-2.2
KiB Mem: 8038812 total, 4691112 free
KiB Swap: 9437180 total, 9437180 free
Timestamp of repository gentoo: Sat, 19 Mar 2016 12:15:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.1.9 [disabled]
app-shells/bash: 4.3_p42-r1::gentoo
dev-java/java-config: 2.2.0::gentoo
dev-lang/perl: 5.20.2::gentoo
dev-lang/python: 2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/ccache: 3.1.9-r4::gentoo
dev-util/cmake: 3.3.1-r1::gentoo
dev-util/pkgconfig: 0.28-r2::gentoo
sys-apps/baselayout: 2.2::gentoo
sys-apps/openrc: 0.19.1::gentoo
sys-apps/sandbox: 2.10-r1::gentoo
sys-devel/autoconf: 2.13::gentoo, 2.69::gentoo
sys-devel/automake: 1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils: 2.25.1-r1::gentoo
sys-devel/gcc: 4.9.3::gentoo
sys-devel/gcc-config: 1.7.3::gentoo
sys-devel/libtool: 2.4.6::gentoo
sys-devel/make: 4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc: 2.21-r2::gentoo

location: /usr/portage
sync-type: rsync
sync-uri: rsync://
priority: -1000

location: /var/lib/layman/anders-larsson
sync-type: laymansync
masters: gentoo
priority: 50

location: /var/lib/layman/betagarden
sync-type: laymansync
sync-uri: git://
masters: gentoo
priority: 50

location: /var/lib/layman/gnome15
sync-type: laymansync
sync-uri: git://
masters: gentoo
priority: 50

location: /var/lib/layman/tox-overlay
sync-type: laymansync
sync-uri: git://
masters: gentoo
priority: 50

CFLAGS="-march=corei7 -mtune=corei7 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -mtune=corei7 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acc acl acpi aes aiglx alsa amd64 aoss aperfmperf apic arat arch_perfmon asf bash-completion berkdb bindist bluetooth branding bts bzip2 cairo cdda cdparanoia cdr clflush cli cmov consolekit constant_tsc cracklib crypt css cups cx16 cx8 cxx dbus de declarative doc dot dri ds_cpl dtes64 dtherm dts dv dvb dvd dvdr dvdread emboss encode ept est exif fam fame ffmpeg firefox flac flexpriority fonts fortran fpu fuse fxsr g19 gdbm gif glamor gnutls google gpm gtk gudev ht hwdb iconv icu ida imagemagic ipv6 jadetex java javasript jpeg kde kdeenablefinal kipi lahf_lm lame lcms ldap lg4l-module libass libkms libnotify lirc lm lm_sensor mad mca mce mjpeg mms mmx mmxext mng modules monitor motif mozilla mp3 mp4 mpeg msr mtrr multilib musepack mysql ncurses nls nonstop_tsc nopl nptl nsplugin nx ogg oggvorbis ohci1394 opengl openmp pae pam pango pat pbe pclmulqdq pcmcia pcre pcsc-lite pdcm pdf pebs pge phonon plasma png pni policykit popcnt ppds pse pse36 python qt3support qt4 rdesktop rdtscp readline real rep_good samba scanner script sdl seccomp semantic-desktop sep session smx spell sql sqlite ss sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg symlink sync-plugin-portage syscall syslog systray taglib tcpd themes theora threads tiff tm tm2 tpr_shadow truetype tsc udev udisks unicode upower usb v4l v4l2 vaapi vcd vdpau vme vmx vnmi vorbis vpid wavpack weather webkit wifi win32codecs wxwidgets x264 xa xattr xcb xcomposite xinerama xml xml2 xorgxv xscreensaver xtopology xtpr xv xvid xvmc yahoo zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="g19" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7.0" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by sebekk23 on Mon Mar 21, 2016 11:42 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 29 Mar 2015
Posts: 42

PostPosted: Mon Mar 21, 2016 7:22 am    Post subject: Reply with quote

Kernel .config ->

3d games are working but with hangs/freezes too
Back to top
View user's profile Send private message

Joined: 29 Mar 2015
Posts: 42

PostPosted: Mon Mar 21, 2016 8:40 am    Post subject: Reply with quote

I have downgrade my kernel to previous release 4.1.12-gentoo - and on single screen (i have two monitors connected to my laptop) i didn't notice this weird freezes, but "Show FPS" plug-in showed me less fps :) (around 40). On Dual View freezes came back :( and "Show FPS" plug-in again showing me 58-60 fps ... WTF!?!
Back to top
View user's profile Send private message

Joined: 29 Mar 2015
Posts: 42

PostPosted: Mon Mar 21, 2016 11:42 am    Post subject: Reply with quote

Ok - i've got it (i think so :) ) i had enabled IOMMU( after disable it in kernel and rebuild it (of course :) ) i don't see fps drops.

What is IOMMU for ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum