Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore durante aggiornamento [Risolto].
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
Lux-68
n00b
n00b


Joined: 19 May 2013
Posts: 34
Location: Provincia di Torino

PostPosted: Sun Mar 06, 2016 1:28 pm    Post subject: Errore durante aggiornamento [Risolto]. Reply with quote

Ciao a tutti,
durante l'aggiornamento del sistema, la compilazione si blocca con il messaggio:

Code:

 * Messages for package net-libs/webkit-gtk-2.10.7:

 * ERROR: net-libs/webkit-gtk-2.10.7::gentoo failed (pretend phase):
 *   The active compiler needs to be gcc 4.9 (or newer)
 *
 * Call stack:
 *                  ebuild.sh, line 133:  Called pkg_pretend
 *   webkit-gtk-2.10.7.ebuild, line 134:  Called die
 * The specific snippet of code:
 *                      die 'The active compiler needs to be gcc 4.9 (or newer)'
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.10.7::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.10.7::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.10.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.10.7/temp/die.env'.
 * Working directory: '/usr/lib64/python3.3/site-packages'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.10.7/work/webkitgtk-2.10.7'


Il compilatore disponibile è
Code:

gcc-config --list-profiles
 [1] x86_64-pc-linux-gnu-4.6.3
 [2] x86_64-pc-linux-gnu-4.7.3
 [3] x86_64-pc-linux-gnu-4.8.4 *



A qualcuno è già successo?
Come avete risolto?

Grazie.
_________________
Luciano.


Last edited by Lux-68 on Sun Mar 06, 2016 8:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
Guru
Guru


Joined: 03 Jan 2012
Posts: 525

PostPosted: Sun Mar 06, 2016 6:37 pm    Post subject: Reply with quote

The active compiler needs to be gcc 4.9 (o superiore)

ti serve gcc-4.9 per net-libs/webkit-gtk-2.10.7
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
Lux-68
n00b
n00b


Joined: 19 May 2013
Posts: 34
Location: Provincia di Torino

PostPosted: Sun Mar 06, 2016 8:42 pm    Post subject: Reply with quote

sabayonino wrote:
The active compiler needs to be gcc 4.9 (o superiore)

ti serve gcc-4.9 per net-libs/webkit-gtk-2.10.7


Grazie.
Credevo erronemente che in qualche modo il sistema riuscisse a aggiornarlo (come dipendenza).
Ho provveduto ad aggiornarlo e cambiare il compilatore.

Code:

#  emerge -av gcc

# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3
 [2] x86_64-pc-linux-gnu-4.7.3
 [3] x86_64-pc-linux-gnu-4.8.4 *
 [4] x86_64-pc-linux-gnu-4.9.3

# gcc-config 4
* Switching native-compiler to x86_64-pc-linux-gnu-4.9.3 ...
>>> Regenerating /etc/ld.so.cache...                                                                                                                                          [ ok ]

 * If you intend to use the gcc from the new profile in an already
 * running shell, please remember to do:

 *   . /etc/profile


Ho fatto ripartire la compilazione del world senza problemi...per ora.
_________________
Luciano.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum