Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-apps/kmod won't build under crossdev setup [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
psychedup
n00b
n00b


Joined: 02 Oct 2012
Posts: 14
Location: Bremerton, WA, US

PostPosted: Sat Jan 02, 2016 6:20 am    Post subject: sys-apps/kmod won't build under crossdev setup [solved] Reply with quote

I'm trying to build a minimal system that will be used on a Raspberry pi model 2B, using this blog post as a guide. I was able to build all of the packages listed in the blog post, except for 2.

When I try to build sys-apps/kmod with the zlib USE flag enabled, the configure script can't find zlib, even though both zlib and gzip are already installed in the buildroot directory. Here's a snippet of the error message:

Code:
checking for zlib... no
configure: error: Package requirements (zlib) were not met:

No package 'zlib' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables zlib_CFLAGS
and zlib_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


(emerging with USE="-zlib" worked but I expect to really want compression since the target system will have limited storage capacity).
I'm not sure if this is a bug or a problem with my configuration.

Links to more info:


My ROOT for this build is in /mnt/media1/portage_roots/rpi2B1_build. I created an env.sh script in that directory that I run before building, which sets the ROOT and PORTAGE_CONFIGROOT variables to the same directory (/mnt/media1/portage_roots/rpi2B1_build).

Any help figuring out what's wrong would be appreciated.

Thanks,
Chris


Last edited by psychedup on Thu Jan 07, 2016 1:36 am; edited 1 time in total
Back to top
View user's profile Send private message
psychedup
n00b
n00b


Joined: 02 Oct 2012
Posts: 14
Location: Bremerton, WA, US

PostPosted: Thu Jan 07, 2016 1:35 am    Post subject: Reply with quote

I finally got it to work, by setting:

zlib_CFLAGS="-I/usr/include"
zlib_LIBS="-L/usr/lib -L/usr/lib -lz"

but it seems like there ought to be a better way.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum