Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help installing plasma
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 2:25 pm    Post subject: Reply with quote

Post your /etc/portage/package.accept_keywords and /etc/portage/make.conf.
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 2:28 pm    Post subject: Reply with quote

Make.conf

Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j4"
CHOST="x86_64-pc-linux-gnu"
USE="-qt4 gt5 -gtk -gnome python icu bindist mmx sse sse2"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
EMERGE_DEFAULT_OPTS="--autounmask-write"
VIDEO_CARDS=" "
INPUT_DEVICES=" "
GRUB_PLATFORMS=efi-64



package accept

Code:
Gentop ~ # more /etc/portage/package.accept_keywords
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knewstuff-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdeclarative-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kguiaddons-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwindowsystem-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[sddm,display-manager]
# required by kde-plasma/plasma-meta (argument)
=x11-misc/sddm-0.13.0-r1 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kconfigwidgets-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/ksshaskpass-5.5.1 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/extra-cmake-modules-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ktexteditor-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcmutils-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kitemmodels-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kgamma-5.5.1 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/user-manager-5.5.1 ~amd64
# required by kde-plasma/kwrited-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpty-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/milou-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdesu-5.17.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kunitconversion-5.17.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-workspace-5.5.1.1 ~amd64
# required by kde-plasma/ksysguard-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdbusaddons-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ktextwidgets-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kinfocenter-5.5.1 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwrited-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kidletime-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knotifications-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/breeze-icons-5.17.0 ~amd64
# required by kde-plasma/milou-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/krunner-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwallet-pam-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knotifyconfig-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/ksysguard-5.5.1 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kactivities-5.17.0 ~amd64
# required by kde-plasma/milou-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kconfig-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ki18n-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-apps/kio-extras-15.08.3 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kbookmarks-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kscreen-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/attica-5.17.0 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kinit-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/bluedevil-5.5.1 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[wallpapers]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-workspace-wallpapers-5.5.1 ~amd64
# required by kde-frameworks/kiconthemes-5.17.0::gentoo
# required by kde-frameworks/kio-5.17.0::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kf-env-3 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjobwidgets-5.17.0 ~amd64
# required by kde-plasma/bluedevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kio-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpeople-5.17.0 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdnssd-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo[handbook]
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdoctools-5.17.0 ~amd64
# required by x11-misc/sddm-0.13.0-r1::gentoo[consolekit]
# required by kde-plasma/plasma-meta-5.5.1::gentoo[sddm,display-manager]
# required by kde-plasma/plasma-meta (argument)
=sys-auth/consolekit-1.0.0-r1 ~amd64
# required by kde-frameworks/kdelibs4support-5.17.0::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdesignerplugin-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/khelpcenter-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwin-5.5.1 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kross-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kscreenlocker-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/solid-5.17.0 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwidgetsaddons-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjs-5.17.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/karchive-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/powerdevil-5.5.1 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kservice-5.17.0 ~amd64
# required by kde-plasma/ksshaskpass-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwallet-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=dev-qt/qtpaths-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/oxygen-5.5.1 ~amd64
# required by kde-plasma/kwin-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcrash-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[sddm]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/sddm-kcm-5.5.1 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcodecs-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/systemsettings-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kitemviews-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kmenuedit-5.5.1 ~amd64
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-meta-5.5.1 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcoreaddons-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kxmlrpcclient-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwayland-integration-5.5.1 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kde-cli-tools-5.5.1 ~amd64
# required by kde-frameworks/krunner-5.17.0::gentoo
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/threadweaver-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kglobalaccel-5.17.0 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kiconthemes-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/sonnet-5.17.0 ~amd64
# required by kde-plasma/bluedevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/bluez-qt-5.17.0 ~amd64
# required by kde-plasma/ksysguard-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/libksysguard-5.5.1 ~amd64
# required by kde-plasma/kmenuedit-5.5.1::gentoo[hotkeys]
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/khotkeys-5.5.1 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdelibs4support-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/breeze-5.5.1 ~amd64
# required by kde-plasma/systemsettings-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=dev-qt/qtcore-5.5.1 ~amd64
# required by kde-plasma/systemsettings-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/khtml-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kdecoration-5.5.1 ~amd64
# required by kde-plasma/kwin-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/plasma-5.17.0-r2 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kded-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/polkit-kde-agent-5.5.1 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/frameworkintegration-5.17.0 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwayland-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/baloo-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kxmlgui-5.17.0 ~amd64
# required by kde-frameworks/baloo-5.17.0::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kfilemetadata-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kdeplasma-addons-5.5.1 ~amd64
# required by kde-plasma/kwin-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpackage-5.17.0 ~amd64
# required by kde-plasma/kscreen-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/libkscreen-5.5.1 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kparts-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kemoticons-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcompletion-5.17.0 ~amd64
# required by kde-frameworks/frameworkintegration-5.17.0::gentoo
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/oxygen-fonts-5.4.3 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjsembed-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kauth-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo[geolocation]
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/networkmanager-qt-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-desktop-5.5.1 ~amd64
dev-qt/* ~amd64
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 2:37 pm    Post subject: Reply with quote

RoboGrinch wrote:
Make.conf
Code:
USE="-qt4 gt5 -gtk -gnome python icu bindist mmx sse sse2"

Change to:
USE="-qt4 qt5 -gtk -gnome python icu bindist mmx sse sse2"
You mis-typed
gt5 instead of qt5

Quote:
Code:
Gentop ~ # more /etc/portage/package.accept_keywords
dev-qt/* ~amd64


Add the following to /etc/portage/package.accept_keywords:
kde-apps/* ~amd64
kde-plasma/* ~amd64
kde-frameworks/* ~amd64
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Fri Jan 01, 2016 2:42 pm    Post subject: Reply with quote

qt4 and qt5 flags need not be set at all using the plasma profile. In fact, you will be missing out on integration if you deselect qt4, you will still need it in many places.

Your suggested changes don't help with the qt conflict.

@RoboGrinch: Are you still adding the backtrack option? (you should)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 2:48 pm    Post subject: Reply with quote

genstorm wrote:
qt4 and qt5 flags need not be set at all using the plasma profile. In fact, you will be missing out on integration if you deselect qt4, you will still need it in many places.

Your statement isn't totally accurate. If you don't enable qt5, there will be the issues we are seeing now is this thread as well as in other threads of this type. Also other qt4 requirements will be prompted as needed.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Fri Jan 01, 2016 2:50 pm    Post subject: Reply with quote

No that's wrong, qt5 is set by the plasma profile. qt4 will be deselected if you set -qt4, such as in plasma-desktop, making you lack qt4 integration.

The blocks seen here are unrelated to use flag setting.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 2:52 pm    Post subject: Reply with quote

genstorm wrote:
No that's wrong, qt5 is set by the plasma profile. qt4 will be deselected if you set -qt4, such as in plasma-desktop, making you lack qt4 integration.

If what you are saying is absolute then why is the opposite happening for me and others?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Fri Jan 01, 2016 2:53 pm    Post subject: Reply with quote

If you are using the plasma profile, you are simply misinterpreting what's happening. ;)

Please notice the difference of _not setting_ and _deselecting_ use flags. It's not the same.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 3:04 pm    Post subject: Reply with quote

genstorm wrote:
If you are using the plasma profile, you are simply misinterpreting what's happening. ;)

Please notice the difference of _not setting_ and _deselecting_ use flags. It's not the same.

I'm not going to play your game....
Please post the correct way to install KDE5 on Gentoo stable in the same format as I have provided for new users or users that are having issues. Or stop the "nitpicking".
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Fri Jan 01, 2016 3:21 pm    Post subject: Reply with quote

davidbrooke, your support is appreciated but it doesn't make you immune to errors. ;)

You can easily check the facts if you remove your definitions of qt4 and qt5 from make.conf and see the impact in emerge --info. And please be aware that yes, there is e.g. plasma-desktop setting +qt4 by default, but this is ultimately overridden by your -qt4 suggestion in make.conf.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 3:31 pm    Post subject: Reply with quote

genstorm wrote:
davidbrooke, your support is appreciated but it doesn't make you immune to errors. ;)

If you would bother to read my posts, you would see that your statement wasn't needed since I don't declare to be "infallible". Please read the last line the url I posted.

Please stop posting here if you don't have anything else to contribute to the resolution of the original posters issue.
Thanks
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Fri Jan 01, 2016 3:39 pm    Post subject: Reply with quote

davidbrooke wrote:
genstorm wrote:
davidbrooke, your support is appreciated but it doesn't make you immune to errors. ;)

If you would bother to read my posts, you would see that your statement wasn't needed since I don't declare to be "infallible".

Calling it 'nitpicking' when I explain to you that USE=-qt4 on a global scale is wrong? I know it is the easy way out of some REQUIRED_USE conflicts in the past that are all solved by plasma profile as well now, on a per-package basis.

In case it got lost, I'm renewing my last suggestion:
genstorm wrote:
@RoboGrinch: Are you still adding the backtrack option? (you should)

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 3:48 pm    Post subject: Reply with quote

Hi guys

I appreciate both of your help. I wish I had the knowledge either of you had about these issues. I am sure that will come with time.

I have had to leave my house for a few hours I will try as soon as I am back and post results.

I did actually remove the backtrack option last time. I will try this again when back.

Thank you for both of your times
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 10:45 pm    Post subject: Reply with quote

Hi Guys

Thanks so much for all the help.

Plasma is finally installing.......

Added qt5 to the make.conf

Added
kde-apps/* ~amd64
kde-plasma/* ~amd64
kde-frameworks/* ~amd64

to /etc/portage/package.accept_keywords:

done emerge -avuND world

Then emerge --ask plasma-meta

Its now running...

Really appreciate it.

I think I have a lot of learning to do still but I think Gentoo is the right distro... I have worked with Linux professionally for years but only had set tasks to do. The install alone has taught me much....

Shame it was so tough installing plasma. I wouldn't mind but I dont think I have learnt anything except for these forum are great and there is a lot of helpful people on them...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Fri Jan 01, 2016 10:56 pm    Post subject: Reply with quote

What profile are you using?

Code:
# eselect profile list


RoboGrinch wrote:
done emerge -avuND world

I guess this was updating your dev-qt/ packages, helping portage ease the dependency graph and thus making possible the following command without adding backtrack:
RoboGrinch wrote:
Then emerge --ask plasma-meta


You've made a few shortcuts here wrt using wildcards in package.keywords and unmasking whole ranges of packages. In the future though you should be more cautious unless you want to end up with a fully ~amd64 system anyway. Note that updates to those packages will often require you to unmask more dependencies. You should make it a habit of unmasking only specific versions.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Fri Jan 01, 2016 11:05 pm; edited 2 times in total
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 11:02 pm    Post subject: Reply with quote

You will still need to install some apps. To do so you will need to follow steps 5 and 6:
https://forums.gentoo.org/viewtopic-t-1033066-highlight-.html
Then install what apps you like or install the meta package:
emerge -av kde-apps-meta
I just updated the package.unmask file to the latest apps for 15.12.
Let me know if there are any mistakes or other issues.
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Sat Jan 02, 2016 2:50 pm    Post subject: Reply with quote

Hi

Well after 9 hours it finished installing...

Am I suppose to do anything else?

I tried

Code:
startx


But I get this

Code:
Gentop ~ # startx
xauth:  file /root/.serverauth.3078 does not exist


X.Org X Server 1.17.4
Release Date: 2015-10-28
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.1.12-gentoo x86_64 Gentoo
Current Operating System: Linux Gentop 4.1.12-gentoo #1 SMP Wed Dec 30 22:29:28 GMT 2015 x86_64
Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-4.1.12-gentoo root=UUID=c7c217eb-f82f-4b76-96f7-e59f4fdf1968 ro
Build Date: 01 January 2016  11:29:07PM

Current version of pixman: 0.32.8
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan  2 14:48:15 2016
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
gbm: failed to open any driver (search paths /usr/lib64/dri)
gbm: Last dlopen error: /usr/lib64/dri/i965_dri.so: cannot open shared object file: No such file or directory
failed to load driver: i965
EGL_MESA_drm_image required.
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 59: xclock: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.


I am using an nvidia graphics card....

Thanks
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Sat Jan 02, 2016 3:07 pm    Post subject: Reply with quote

Don't startx as root!

Your ~/.xinitrc should contain something like that:

Code:
#!/bin/sh
exec ck-launch-session dbus-launch --exit-with-session startkde

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sat Jan 02, 2016 3:25 pm    Post subject: Reply with quote

RoboGrinch, it tells you what your issues are mate:

Code:
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 59: xclock: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found
xinit: connection to X server lost


Code:
# emerge -av xclock xterm twm


Try startx after those packages are installed.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sat Jan 02, 2016 3:31 pm    Post subject: Reply with quote

Just noticed an error in your USE flags, you have gt5, and you need qt5. Also:
Code:
# emerge -av wgetpaste

Use wgetpaste for things like # more /etc/portage/package.accept_keywords.[/code]
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Sat Jan 02, 2016 3:36 pm    Post subject: Reply with quote

Hi

Thanks for the help....

Ok I have emerged those installs

startx now starts but not plasma.... it starts an oldschool gui... x11 or something...
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sat Jan 02, 2016 3:36 pm    Post subject: Reply with quote

You also should run KDE or just about any WM with a display manager. Makes life MUCH easier. For your plasma, type
Code:
# emerge -av kdm


As well, follow this wiki:
https://wiki.gentoo.org/wiki/Display_manager
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sat Jan 02, 2016 3:37 pm    Post subject: Reply with quote

Yes, that is why you need a DM. You will have plasma as soon as kdm is installed and you edit xdm.
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Sat Jan 02, 2016 3:40 pm    Post subject: Reply with quote

ok, great thanks.....

Tried installing... Its blocked :( :(

Code:
Gentop ~ # emerge -av kdm

 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] kde-base/kdebase-pam-9::gentoo  0 KiB
[ebuild  N     ] media-libs/qimageblitz-0.0.6-r1::gentoo  USE="(-altivec) -debug" CPU_FLAGS_X86="mmx sse sse2 -3dnow" 57 KiB
[ebuild  N     ] kde-base/kcheckpass-4.11.19:4/4.11::gentoo  USE="pam (-aqua) -debug" 13,231 KiB
[ebuild  N     ] kde-base/libkworkspace-4.11.19:4/4.11::gentoo  USE="(-aqua) -debug" 0 KiB
[ebuild  N     ] kde-base/libkgreeter-4.11.19:4/4.11::gentoo  USE="(-aqua) -debug" 0 KiB
[ebuild  N    ~] kde-apps/libkonq-15.08.3:4/15.08::gentoo  USE="(-aqua) -debug -minimal {-test}" 2,004 KiB
[ebuild  N    ~] kde-apps/kdepasswd-15.08.3:4/15.08::gentoo  USE="handbook (-aqua) -debug" 0 KiB
[ebuild  N     ] kde-base/kdm-4.11.19:4/4.11::gentoo  USE="consolekit handbook pam (-aqua) -debug -kerberos -systemd" 0 KiB
[blocks B      ] kde-apps/kdepasswd ("kde-apps/kdepasswd" is blocking kde-plasma/plasma-desktop-5.5.1)
[blocks B      ] <kde-base/kcheckpass-4.11.22-r1:4 ("<kde-base/kcheckpass-4.11.22-r1:4" is blocking kde-plasma/kscreenlocker-5.5.1)

Total: 8 packages (8 new), Size of downloads: 15,290 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kdepasswd-15.08.3:4/15.08::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdepasswd-4.11.19:4[aqua=] (>=kde-apps/kdepasswd-4.11.19:4[-aqua]) required by (kde-base/kdm-4.11.19:4/4.11::gentoo, ebuild scheduled for merge)

  (kde-plasma/plasma-desktop-5.5.1:5/5::gentoo, installed) pulled in by
    >=kde-plasma/plasma-desktop-5.5.1:5 required by (kde-plasma/plasma-meta-5.5.1:5/5::gentoo, installed)

  (kde-base/kcheckpass-4.11.19:4/4.11::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kcheckpass-4.11.19:4[aqua=] (>=kde-base/kcheckpass-4.11.19:4[-aqua]) required by (kde-base/kdm-4.11.19:4/4.11::gentoo, ebuild scheduled for merge)

  (kde-plasma/kscreenlocker-5.5.1:5/5::gentoo, installed) pulled in by
    >=kde-plasma/kscreenlocker-5.5.1:5 required by (kde-plasma/plasma-workspace-5.5.1.1:5/5::gentoo, installed)
    >=kde-plasma/kscreenlocker-5.5.1:5 required by (kde-plasma/kwin-5.5.1:5/5::gentoo, installed)
    >=kde-plasma/kscreenlocker-5.5.1:5 required by (kde-plasma/plasma-meta-5.5.1:5/5::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sat Jan 02, 2016 3:45 pm    Post subject: Reply with quote

Code:
emerge --autounmask-write =kdm-5.5.1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum