Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Python-3.4.3 fail in install phase
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 471
Location: Hawaii

PostPosted: Sun Nov 29, 2015 4:24 am    Post subject: Python-3.4.3 fail in install phase Reply with quote

Python-3.4.3 install phase fail:

* ERROR: dev-lang/python-3.4.3::gentoo failed (install phase):
* python_do* and python_new* helpers are banned in EAPIs older than 5.
*
* Call stack:
* ebuild.sh, line 93: Called src_install
* environment, line 4126: Called python_domodule 'epython.py'
* environment, line 3312: Called die
* The specific snippet of code:
* die "python_do* and python_new* helpers are banned in EAPIs older than 5.";

Anyone else getting this? Where do I begin with this?
_________________
Asus Prime x370 Pro
Ryzen 2700x
32Gb Samsung B-die (16GB dual rank x2) DDR4
Geforce GTX 1060 6GB
Samsung Evo 840 500Gb +Seagate 1TB HDD
Etc....
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Nov 29, 2015 4:59 am    Post subject: Reply with quote

bammbamm808 ...

That particular ebuild is EAPI=4 ... but uses 'python_domodule()' inherited from python-utils-r1.eclass ... which has the following:

python-utils-r1.eclass:
python_domodule() {
  debug-print-function ${FUNCNAME} "${@}"

  [[ ${EPYTHON} ]] || die 'No Python implementation set (EPYTHON is null).'
    if [[ ${EAPI:-0} == [01234] ]]; then
      die "python_do* and python_new* helpers are banned in EAPIs older than 5."
    fi

... so, it dies.

I expect it'll be the outcome of some hasty commit ... reverted as and when the issue is reported.

best ... khay
Back to top
View user's profile Send private message
zoomersam
n00b
n00b


Joined: 29 Nov 2015
Posts: 1

PostPosted: Sun Nov 29, 2015 5:43 pm    Post subject: Reply with quote

Problem also exists with upgrading 2.7 python:
Quote:
* ERROR: dev-lang/python-2.7.10-r1::gentoo failed (install phase):
* python_do* and python_new* helpers are banned in EAPIs older than 5.
*
* Call stack:
* ebuild.sh, line 133: Called src_install
* environment, line 4178: Called python_domodule 'epython.py'
* environment, line 3352: Called die
* The specific snippet of code:
* die "python_do* and python_new* helpers are banned in EAPIs older than 5.";


I've previously updated on another gentoo instance to this ebuild correctly. I suppose this error caused by this: https://www.mail-archive.com/gentoo-commits@lists.gentoo.org/msg169167.html
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Nov 29, 2015 6:32 pm    Post subject: Reply with quote

zoomersam wrote:
Problem also exists with upgrading 2.7 python:

zoomersam ... yes, and there is even another thread where 2.7 is the effected package.

zoomersam wrote:
I suppose this error caused by this: https://www.mail-archive.com/gentoo-commits@lists.gentoo.org/msg169167.html

No surprise as to who committed it.

best ... khay
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Sun Nov 29, 2015 7:21 pm    Post subject: Reply with quote

So...run ~ until then?

EDIT: Nevermind

I'm not going to wade into this.

Quote:
The following mask changes are necessary to proceed:
(see "package.unmask" in the portage(5) man page for more details)
# required by =dev-lang/python-3.4.3-r4 (argument)
# /usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (11 Nov 2015)
# Cleaned up Python versions masked for testing:
# - python-config-X.Y compatibility removed,
# - python[23] choice is now stored in config file rather than symlink,
# - eselect-python reworked to reuse python-exec and wrap all execs,
# - ABIFLAGS reintroduced for 3.3+.
# Resulting API/ABI change can break reverse dependencies, especially
# if upstream hardcodes paths or library names.
=dev-lang/python-3.4.3-r4
# required by =dev-lang/python-2.7.10-r4 (argument)
# /usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (11 Nov 2015)
# Cleaned up Python versions masked for testing:
# - python-config-X.Y compatibility removed,
# - python[23] choice is now stored in config file rather than symlink,
# - eselect-python reworked to reuse python-exec and wrap all execs,
# - ABIFLAGS reintroduced for 3.3+.
# Resulting API/ABI change can break reverse dependencies, especially
# if upstream hardcodes paths or library names.
=dev-lang/python-2.7.10-r4

_________________
Greg
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Sun Nov 29, 2015 7:47 pm    Post subject: Reply with quote

khayyam wrote:
zoomersam wrote:
Problem also exists with upgrading 2.7 python:

zoomersam ... yes, and there is even another thread where 2.7 is the effected package.

zoomersam wrote:
I suppose this error caused by this: https://www.mail-archive.com/gentoo-commits@lists.gentoo.org/msg169167.html

No surprise as to who committed it.

best ... khay


Yeah, let's not bother to test it first. It's not like python is important or anything.
_________________
Greg
Back to top
View user's profile Send private message
herr_tichy
n00b
n00b


Joined: 09 Aug 2012
Posts: 11
Location: NRW, Germany

PostPosted: Sun Nov 29, 2015 8:54 pm    Post subject: Reply with quote

Sooo... is anything happening regarding that bug or am I just screwed now?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Nov 29, 2015 9:21 pm    Post subject: Reply with quote

herr_tichy wrote:
Sooo... is anything happening regarding that bug or am I just screwed now?

herr_tichy ... it is reported, see bug 567106 ... otherwise, you can correct the eclass in a local overlay.

trigggl wrote:
Yeah, let's not bother to test it first. It's not like python is important or anything.

trigggl ... it's a change in an eclass, these by nature effect many packages, each of which would need testing. Anyhow, yes, its the sort of change that shouldn't have got through to the tree ...

best ... khay
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Sun Nov 29, 2015 10:32 pm    Post subject: Reply with quote

khayyam wrote:
herr_tichy wrote:
Sooo... is anything happening regarding that bug or am I just screwed now?

herr_tichy ... it is reported, see bug 567106 ... otherwise, you can correct the eclass in a local overlay.

Is correcting the eclass an easy thing to do?
_________________
Greg
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Mon Nov 30, 2015 7:27 am    Post subject: Reply with quote

trigggl wrote:
khayyam wrote:
herr_tichy ... it is reported, see bug 567106 ... otherwise, you can correct the eclass in a local overlay.

Is correcting the eclass an easy thing to do?

trigggl ... from the commit it looks fairly trivial ... if you want to go that route you might simply revert the change.

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum