Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blokowane pakiety udev systemd aktualizacja Pythona SOLVED
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Sun Aug 16, 2015 7:04 pm    Post subject: blokowane pakiety udev systemd aktualizacja Pythona SOLVED Reply with quote

Witam,

Chciałem przebudować system z nowo zakutalizowanym plikiem make.conf oto on:
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more

# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"

MAKEOPTS="-j3"
# WARNING: Changing your CHOST is not something that should be done lightly.

# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.

CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.

USE = "debug gptfdisk mmx portage sse sse2 tty-helpers -bindist -tcpd"
PORTDIR = "/usr/portage"
DISTDIR = "${PORTDIR}/distfiles"
PKGDIR = "${PORTDIR}/packages"
# PYTHON_TARGETS = "pyton3_4" 

# Variables for screen, keyboard and mouse
   
VIDEO_CARDS = "nvidia"
INPUT_DEVICES = "evdev"

# Special but not so pretty for me
#FEATURES = "candy"


używam do przebudowy komendy:
Code:
emerge --ask --changed-use --deep @world


i emerge zwraca mi błąd poblokowanych pakietów:
Code:
Calculating dependencies... done!
[ebuild   R    ] dev-libs/libffi-3.0.13-r1  USE="debug*"
[ebuild  N     ] app-arch/lz4-0_p120  USE="{-test} -valgrind" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/libseccomp-2.1.1  USE="-static-libs"
[ebuild   R    ] net-libs/libasyncns-0.8-r3  USE="debug*"
[ebuild   R    ] dev-games/ode-0.12  USE="debug*"
[ebuild   R    ] media-libs/libid3tag-0.15.1b-r4  USE="debug*"
[ebuild   R    ] dev-libs/boost-1.56.0-r1  USE="debug*" PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] dev-libs/pth-2.0.7-r3  USE="debug*"
[ebuild   R    ] dev-lang/perl-5.20.2  USE="debug*"
[ebuild   R    ] dev-libs/nspr-4.10.8  USE="debug*"
[ebuild   R    ] dev-libs/icu-55.1  USE="debug*"
[ebuild   R    ] media-libs/alsa-lib-1.0.29  USE="debug*"
[ebuild   R    ] media-libs/libmad-0.15.1b-r8  USE="debug*"
[ebuild   R    ] media-libs/libdca-0.0.5-r3  USE="debug*"
[ebuild   R    ] dev-libs/openssl-1.0.1p  USE="-bindist*"
[ebuild   R    ] dev-libs/libevent-2.0.22  USE="debug*"
[ebuild   R    ] net-libs/rb_libtorrent-0.16.17  USE="debug*"
[ebuild   R    ] media-libs/freetype-2.5.5  USE="debug* -bindist*"
[ebuild   R    ] sys-apps/kmod-20  USE="debug*" PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] app-crypt/p11-kit-0.20.7  USE="debug*"
[ebuild   R    ] media-libs/flac-1.3.1-r1  USE="debug*"
[ebuild   R    ] sys-apps/help2man-1.46.6  ELIBC="(-glibc%*)"
[ebuild   R    ] sys-libs/pam-1.2.1  USE="debug*"
[ebuild   R    ] sys-apps/busybox-1.23.1-r1  USE="debug*"
[ebuild   R    ] media-gfx/feh-2.9.3  USE="debug*"
[ebuild   R    ] dev-db/sqlite-3.8.10.2  USE="debug*"
[ebuild   R    ] net-misc/wget-1.16  USE="debug*"
[ebuild   R    ] dev-libs/libxml2-2.9.2-r1  USE="debug*" PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] dev-python/setuptools-12.0.1  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] dev-python/pyxdg-0.25-r1  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] dev-libs/libxslt-1.1.28-r4  USE="debug*"
[ebuild   R    ] x11-proto/xcb-proto-1.11  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] dev-python/numpy-1.9.0-r1  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] dev-util/gdbus-codegen-2.42.2  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] dev-libs/glib-2.42.2  USE="debug*"
[ebuild   R    ] x11-libs/gdk-pixbuf-2.30.8-r1  USE="debug*"
[ebuild   R    ] dev-qt/qtcore-4.8.6-r2  USE="debug*"
[ebuild   R    ] dev-qt/qtscript-4.8.6-r2  USE="debug*"
[ebuild   R    ] dev-qt/qtgui-4.8.6-r4  USE="debug*"
[ebuild   R    ] dev-qt/qtsql-4.8.6-r1  USE="debug*"
[ebuild   R    ] dev-qt/qt3support-4.8.6-r1  USE="debug*"
[ebuild   R    ] dev-qt/qtxmlpatterns-4.8.6-r1  USE="debug*"
[ebuild   R    ] dev-qt/qtsvg-4.8.6-r1  USE="debug*"
[ebuild   R    ] dev-qt/qtwebkit-4.8.6-r1  USE="debug*"
[ebuild   R    ] dev-libs/libusb-1.0.19  USE="debug*"
[ebuild   R    ] app-text/djvu-3.5.25.3  USE="debug*"
[ebuild   R    ] sys-libs/ncurses-5.9-r3  USE="debug*"
[ebuild   R    ] media-sound/lame-3.99.5-r1  USE="debug*"
[ebuild   R    ] app-editors/vim-7.4.273  USE="debug*" PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] media-sound/moc-2.5.0  USE="debug*"
[ebuild   R    ] app-editors/nano-2.3.6  USE="debug*"
[ebuild   R    ] www-client/elinks-0.12_pre6  USE="debug*"
[ebuild   R    ] app-admin/conky-1.9.0-r3  USE="debug*"
[ebuild   R    ] dev-scheme/guile-1.8.8-r1  USE="debug*"
[ebuild   R    ] sys-fs/udisks-2.1.4  USE="debug*"
[ebuild   R    ] net-nds/openldap-2.4.38-r2  USE="debug* -tcpd*"
[ebuild   R    ] media-libs/taglib-1.9.1-r2  USE="debug*"
[ebuild   R    ] app-crypt/qca-2.1.0.3  USE="debug*"
[ebuild   R    ] dev-qt/qtopengl-4.8.6-r1  USE="debug*"
[ebuild   R    ] media-libs/freeglut-2.8.1-r1  USE="debug*"
[ebuild   R    ] dev-python/pyopengl-3.0.2-r1  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] sys-boot/grub-2.02_beta2-r7  USE="debug*"
[ebuild   R    ] x11-libs/cairo-1.14.2  USE="debug*"
[ebuild   R    ] x11-libs/pango-1.36.8  USE="debug*"
[ebuild   R    ] app-text/poppler-0.32.0  USE="debug*"
[ebuild   R    ] dev-python/pycairo-1.10.0-r4  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] x11-libs/fltk-1.3.2  USE="debug*"
[ebuild   R    ] x11-libs/gtk+-3.14.13  USE="debug*"
[ebuild   R    ] net-print/cups-2.0.3  USE="debug*"
[ebuild   R    ] x11-libs/gtk+-2.24.28-r1  USE="debug*"
[ebuild   R    ] net-print/libgnomecups-0.2.3-r5  USE="debug*"
[ebuild   R    ] x11-misc/xlockmore-5.45  USE="debug*"
[ebuild   R    ] x11-libs/vte-0.28.2-r207  USE="debug*"
[ebuild   R    ] dev-libs/dbus-glib-0.102  USE="debug*"
[ebuild   R    ] sys-auth/consolekit-0.4.6  USE="debug*"
[ebuild   R    ] sys-libs/glibc-2.20-r2  USE="debug*"
[ebuild   R    ] sys-devel/gcc-4.8.4  USE="debug%*"
[ebuild   R    ] sys-devel/llvm-3.5.0  USE="debug*"
[ebuild   R    ] media-libs/mesa-10.3.7-r1  USE="debug* -bindist*"
[ebuild  N     ] sys-apps/systemd-218-r3  USE="acl gudev introspection kmod lz4 pam policykit seccomp (-apparmor) -audit -cryptsetup -curl -doc -elfutils -gcrypt -http -idn -kdbus -lzma -python -qrcode (-selinux) (-ssl) -sysv-utils -terminal {-test} -vanilla -xkb" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4
[ebuild   R    ] sys-apps/dbus-1.8.16  USE="debug* systemd*"
[ebuild   R    ] app-crypt/gcr-3.14.0  USE="debug*"
[ebuild   R    ] dev-qt/qtdbus-4.8.6-r1  USE="debug*"
[ebuild   R    ] gnome-base/gconf-3.2.6-r3  USE="debug*"
[ebuild   R    ] net-wireless/bluez-5.25  USE="debug*"
[ebuild   R    ] dev-python/dbus-python-1.2.0-r1  PYTHON_TARGETS="python3_4* -python3_3*"
[ebuild   R    ] gnome-base/gnome-keyring-3.14.0  USE="debug*"
[ebuild   R    ] x11-libs/wxGTK-2.8.12.1-r1  USE="debug*"
[ebuild   R    ] app-text/djview-4.9  USE="debug*"
[ebuild   R    ] net-p2p/qbittorrent-3.1.12  USE="debug*"
[ebuild   R    ] sys-auth/pambase-20150213  USE="debug* systemd*"
[ebuild   R   ~] dev-util/codeblocks-13.12  USE="debug*"
[ebuild   R    ] sys-apps/openrc-0.17  USE="debug*"
[ebuild   R    ] net-misc/openssh-6.9_p1-r2  USE="debug* -bindist*"
[ebuild   R    ] media-sound/pulseaudio-5.0-r7  USE="-tcpd*"
[ebuild   R    ] media-video/ffmpeg-2.6.3  USE="debug*"
[ebuild   R    ] media-plugins/alsa-plugins-1.0.29  USE="debug*"
[ebuild   R    ] www-client/firefox-38.1.1  USE="debug*"
[ebuild   R    ] mail-client/thunderbird-38.1.0  USE="debug*"
[ebuild   R    ] media-video/mplayer-1.2_pre20150214-r1  USE="debug*"
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-216)
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/gentoo-systemd-integration-4, sys-apps/systemd-218-r3)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-216)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-216:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)
    >=sys-fs/udev-208-r1 required by (virtual/udev-215:0/0::gentoo, installed)
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev(-),introspection(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev(-),introspection(-)]) required by (virtual/libgudev-215-r3:0/0::gentoo, installed)

  (sys-apps/systemd-218-r3:0/2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-204[pam] required by (sys-auth/pambase-20150213:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.8.16:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

experimental lab linux # emerge --pretend systemd

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-arch/lz4-0_p120  USE="{-test} -valgrind" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/libseccomp-2.1.1  USE="-static-libs"
[ebuild  N     ] sys-apps/systemd-218-r3  USE="acl gudev introspection kmod lz4 pam policykit seccomp (-apparmor) -audit -cryptsetup -curl -doc -elfutils -gcrypt -http -idn -kdbus -lzma -python -qrcode (-selinux) (-ssl) -sysv-utils -terminal {-test} -vanilla -xkb" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild   R    ] sys-apps/dbus-1.8.16  USE="debug* systemd*"
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-216)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-216)
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-218-r3, sys-apps/gentoo-systemd-integration-4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-218-r3:0/2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4:0/0::gentoo, ebuild scheduled for merge)
    systemd
    sys-apps/systemd:0= required by (sys-apps/dbus-1.8.16:0/0::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-216:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-208-r1 required by (virtual/udev-215:0/0::gentoo, installed)
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev(-),introspection(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev(-),introspection(-)]) required by (virtual/libgudev-215-r3:0/0::gentoo, installed)
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Rozumiem z komunikatów, że przyczyną blokady jest udev, lecz wydaje mi się że jest to pakiet istotny dla działania systemu. Zdaje sobię sprawę z tego że jest to popularny błąd który można rozwiązać na własną rękę jednak boję się po prostu aby nie zepsuć sobie systemu. A więc jak można rozwiązać ten konflik tak żeby wszystko działało? :)


Last edited by truthSEeker71 on Thu Aug 27, 2015 7:25 pm; edited 2 times in total
Back to top
View user's profile Send private message
robertsurma
n00b
n00b


Joined: 17 Jan 2008
Posts: 47
Location: Tychy

PostPosted: Sun Aug 16, 2015 9:20 pm    Post subject: Reply with quote

Małymi żmudnymi krokami. Wprowadzaj po jednej fladze i aktualizuj @world... potem następną flagę, itd.... W razie potrzeby minusuj flagi.
Dłużej nieaktualizowany system tak ma.

BTW, na pewno chcesz mieć systemd?
_________________
Free as a bird...
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Mon Aug 17, 2015 4:02 pm    Post subject: Reply with quote

Bardzo dziękuje za odpowiedź. :)
Hmm... Aktualizuje system poprzez:
Code:
emerge --sync
emerge --ask --update --deep --with-bdeps=y @world


Uzywam tych komend jakoś co 3 dni więc wydaje mi się że system jest aktualny. Jeślu chodzi o systemd to w zasadzie nie znam plusów i minusów tego pakietu więc póki co jest mi obojętny. Odnośnie flag bo nie wiem czy dobrze rozumiem zalecasz wprowadzanianie wszystkich flag USE "małymi żmudnymi krokami" czy chodzi ci tylko o te flagi które chciałem pozmieniać?
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1548
Location: /mnt/Gentoo/Europe

PostPosted: Sat Aug 22, 2015 8:47 am    Post subject: Reply with quote

A próbowałeś python-updater?
Back to top
View user's profile Send private message
znal
Apprentice
Apprentice


Joined: 12 Jul 2007
Posts: 190

PostPosted: Sat Aug 22, 2015 2:32 pm    Post subject: Reply with quote

sys-fs/udev i sys-apps/systemd nie może być zainstalowany jednocześnie. Więcej szczegółów na Gentoo Wiki: https://wiki.gentoo.org/wiki/Systemd#Installation
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Thu Aug 27, 2015 7:22 pm    Post subject: Reply with quote

Dziękuję za link do wiki, bardzo edukacyjny materiał. :) Udało mi się zakualizować Pythona używając:
Code:
python-updater

Dziękuje za pomoc! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum