Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Skype stops working shortly after starting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Tue Aug 18, 2015 3:37 pm    Post subject: Skype stops working shortly after starting Reply with quote

I installed skype with apulse (the pulseaudio replacement) and there seems to be an issue of skype "freezing" after <5 minutes of use. When skype first loads, I get initial skype sound. I can send and recieve messages but then it stops working correctly. I can type messages and they post on the screen but they don't send. Also I can't receive any messages. I can re-start skype and the maddness starts all over again.
I re-installed skype without apulse and it works as expected without sound.
The following is the installation info:

add to package.accept_keywords
net-im/skype ~amd64
media-sound/apulse ~amd64

add to package.use
net-im/skype -pulseaudio apulse

emerge generated package.use entries
Code:
# Skype
# required by dev-qt/qtgui-4.8.6-r4::gentoo[qt3support]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-qt/qt3support-4.8.6-r1 abi_x86_32
# required by media-libs/gst-plugins-base-0.10.36-r2::gentoo
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo[gstreamer]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=media-libs/gstreamer-0.10.36-r2:0.10 abi_x86_32
# required by dev-qt/qtsql-4.8.6-r1::gentoo[mysql]
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by dev-qt/qtgui-4.8.6-r4::gentoo[qt3support]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=virtual/mysql-5.6-r2 abi_x86_32
# required by dev-qt/qtgui-4.8.6-r4::gentoo
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by kde-apps/kalgebra-4.14.3::gentoo
# required by kde-apps/kdeedu-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtscript-4.8.6-r2 abi_x86_32
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=x11-libs/libXScrnSaver-1.2.2-r1 abi_x86_32
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-qt/qtdbus-4.8.6-r1 abi_x86_32
# required by virtual/mysql-5.6-r2::gentoo
# required by dev-qt/qtsql-4.8.6-r1::gentoo[mysql]
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by dev-qt/qtgui-4.8.6-r4::gentoo[qt3support]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-db/mariadb-10.0.19 abi_x86_32
# required by media-libs/gst-plugins-base-0.10.36-r2::gentoo[orc]
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo[gstreamer]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-lang/orc-0.4.23 abi_x86_32
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by kde-apps/kalgebra-4.14.3::gentoo
# required by kde-apps/kdeedu-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtgui-4.8.6-r4 abi_x86_32
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-db/sqlite-3.8.10.2 abi_x86_32
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo[gstreamer]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=media-libs/gst-plugins-base-0.10.36-r2:0.10 abi_x86_32
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-qt/qtwebkit-4.8.6-r1 abi_x86_32
# required by x11-libs/libXScrnSaver-1.2.2-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=x11-proto/scrnsaverproto-1.2.2-r1 abi_x86_32
# required by dev-qt/qtgui-4.8.6-r4::gentoo[xv]
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by kde-apps/kalgebra-4.14.3::gentoo
# required by kde-apps/kdeedu-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
>=x11-proto/videoproto-2.3.2 abi_x86_32
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-qt/qtxmlpatterns-4.8.6-r1 abi_x86_32
# required by dev-db/mariadb-10.0.19::gentoo[-bindist]
# required by virtual/mysql-5.6-r2::gentoo
# required by dev-qt/qtsql-4.8.6-r1::gentoo[mysql]
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by dev-qt/qtgui-4.8.6-r4::gentoo[qt3support]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=sys-libs/readline-6.3_p8-r2 abi_x86_32
# required by dev-qt/qtgui-4.8.6-r4::gentoo[xv]
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by kde-apps/kalgebra-4.14.3::gentoo
# required by kde-apps/kdeedu-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
>=x11-libs/libXv-1.0.10 abi_x86_32
# required by dev-qt/qtgui-4.8.6-r4::gentoo
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by kde-apps/kalgebra-4.14.3::gentoo
# required by kde-apps/kdeedu-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtcore-4.8.6-r2 abi_x86_32
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by dev-qt/qtgui-4.8.6-r4::gentoo[qt3support]
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
>=dev-qt/qtsql-4.8.6-r1 abi_x86_32
# required by dev-qt/qtgui-4.8.6-r4::gentoo[mng]
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by kde-apps/kalgebra-4.14.3::gentoo
# required by kde-apps/kdeedu-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/libmng-2.0.2-r1 abi_x86_32
# required by net-im/skype-4.3.0.37-r5::gentoo[apulse]
# required by @selected
# required by @world (argument)
>=media-sound/apulse-0.1.6 abi_x86_32

emerge install:
Code:
sudo emerge -av apulse
media-sound/apulse-0.1.6::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB


Code:
sudo emerge -av skype
net-im/skype-4.3.0.37-r5::gentoo  USE="apulse* -pax_kernel -pulseaudio (-selinux)" 0 KiB
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Sat Aug 22, 2015 1:18 am    Post subject: Reply with quote

This is what I get when I start skype from terminal:
Code:
@CI7S ~ $ apulse skype
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.0.29/work/alsa-lib-1.0.29/src/pcm/pcm_dsnoop.c:614:(snd_pcm_dsnoop_open) unable to open slave
[apulse] [error] do_connect_pcm, snd_pcm_open, No such file or directory
[apulse] [error] do_connect_pcm, snd_pcm_open, No such file or directory


Not sure what it's telling me.
I'm using alsa only.
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Sat Aug 22, 2015 2:27 am    Post subject: Reply with quote

I use ~/.asoundrc
Code:
defaults.pcm.!card 0
defaults.pcm.!device 7


This for my hdmi connection.
I'm wondering if I'm going to need an additional entry in the asoundrc file for skype only? Or a new asoundrc file?
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Thu Aug 27, 2015 2:14 am    Post subject: Reply with quote

Since I'm not well versed in alsa I'm wondering if I set the pulseaudio use flag, will that just enable pulseaudio for skype? If not is it possible to do so another way?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Aug 27, 2015 6:53 am    Post subject: Reply with quote

I removed any qt pckage in my system with skype.

Recently i decided to install skype again, but the ebuild lacks some dependencies which I had before. I also enabled the qt4 flag again and rebuilded everything but still something missing. Another example of an ebuild with half of it dependencies missing.

Code:
roman@Knight ~ $ emerge -pv skype

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-im/skype-4.3.0.37-r5::gentoo  USE="pulseaudio -apulse -pax_kernel (-selinux)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
roman@Knight ~ $ skype
Aborted
roman@Knight ~ $


It means that i started skype from command line interface and it stops itself with the message aborted.

Please note that pulseaudio is defiinitely not the cause because I removed qt4 / qt5 / kde stuff recently with skype. so there is some missing dependencies for skype.

it ma be useful for someone else who stumble accross issues with skype.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 799

PostPosted: Thu Nov 05, 2015 2:30 am    Post subject: Reply with quote

have you solved the problem?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Nov 05, 2015 11:11 am    Post subject: Reply with quote

Nope.

I changed hardware, just tried to start skype again after fresh emerge.

Code:
ASUS-G75VW roman # emerge -av skype

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for net-im/skype
... done!

!!! The ebuild selected to satisfy "skype" has unmet requirements.
- net-im/skype-4.3.0.37-r5::gentoo USE="apulse pulseaudio -pax_kernel -plasma (-selinux)" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    apulse? ( !pulseaudio )


I use pulseaudio, when i try to enable apulse it complains about pulseaudio. I doubt my setup will allow skype without pulseaudio.

equery u skype
[ Legend : U - final flag setting for installation]
[ : I - package is installed with flag ]
[ Colors : set, unset ]
* Found these USE flags for net-im/skype-4.3.0.37-r5:
U I
+ - apulse : Use media-sound/apulse for PulseAudio emulation
- - pax_kernel : Triggers a paxmarking of the main skype binary
- - plasma : Build optional KDE plasma addons
+ + pulseaudio : Add support for PulseAudio sound server


I do not want or need apulse because i have a working pulseaudio here

Code:
 * Updating icons cache ...                                                                                                               [ ok ]
 * For webcam support, see "LD_PRELOAD" section of "README.lib" document provided by
 * media-libs/libv4l package and "README" document of this package.
>>> net-im/skype-4.3.0.37-r5 merged.

>>> Recording net-im/skype in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
ASUS-G75VW roman # exit
roman@ASUS-G75VW ~ $ skype
Aborted


Fresh emerge. Start of skype, and it dies instantly. SAme as 2 months back. Basically I gave up, as it is a binary and nowhere listed what's needed for that mirnosoft skype. i am sorry for my skype friends but it does not works here for at least 5 months now.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 799

PostPosted: Thu Nov 05, 2015 2:29 pm    Post subject: Reply with quote

@tw04l124, after rebuilding world with gcc-5.2.0, skype stopped working. after reverting changes and returning to gcc-4.9.3 back and rebuilding world, skype started working again.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Nov 05, 2015 4:09 pm    Post subject: Reply with quote

do you mind sharing

Code:
ldd -v /opt/bin/skype


ty, so i can have a look

skype did not worked even on gcc 4.9 slot before, i miss some dependency, which is definitely not in the ebuild
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 799

PostPosted: Fri Nov 06, 2015 4:42 am    Post subject: Reply with quote

http://pastebin.com/fY16zrqd
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Nov 06, 2015 8:36 am    Post subject: Reply with quote

Thank you.

Sadly I have all those things.

In the past I removed any qt / kde related thing and since that point it does not work anymore. that was even at gcc 4.9 slot. So it was not gcc related anyway in my opinion.
I checked the output, i have everything, as it is a binary no chance to see / guess why it crashes with the comment, aborted.

Using binaries is not in my flavour anyway. Adobe flash has issues since i remember.
I have to use nvidia-drivers, but else I doubt I have many binaries in use anyway.

Back to ignoring skype. it does not work, it is from mirnosoft, nothing surprises me, topic over for myself.
Back to top
View user's profile Send private message
optional95
n00b
n00b


Joined: 05 Apr 2009
Posts: 15

PostPosted: Thu Dec 31, 2015 7:50 pm    Post subject: same thing over here Reply with quote

I did as well a full rebuild with GCC5.2 an sykpe now wont start any more. Did anyone solve this issue?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Dec 31, 2015 8:53 pm    Post subject: Reply with quote

Code:
tail /etc/portage/package.use
media-sound/pulseaudio -libsamplerate

dev-scheme/guile -deprecated
dev-vcs/git -gtk
sys-apps/microcode-data initramfs
app-crypt/pinentry -gnome-keyring qt4


#skype: need dev-qt/qtwebkit with USE="-exceptions"
dev-qt/qtwebkit -exceptions


Skype should call to hell with their outdated, binary builds which are hardlinked to some weired settings.
Well it is mirnosoft behind, ....

skype is a batteryeater on android.
sucks on linux
never used it in recent years on windows ...
Back to top
View user's profile Send private message
optional95
n00b
n00b


Joined: 05 Apr 2009
Posts: 15

PostPosted: Fri Jan 01, 2016 11:57 am    Post subject: Reply with quote

Dear tw04l124,

the
Code:
dev-qt/qtwebkit -exceptions
did it's trick.

Thank you
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum