Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Occasional kernel panic after a fresh Gentoo install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
manmadescience
n00b
n00b


Joined: 06 Jun 2015
Posts: 7

PostPosted: Sat Jun 06, 2015 10:14 pm    Post subject: Occasional kernel panic after a fresh Gentoo install Reply with quote

Hey guys,

I own an MSI GX70 laptop which offers a free slot for an additional hard disk, so when I got an SSD disk some days ago, I decided to give Linux a try. I already had Win8.1 preinstalled in UEFI mode on my first hard disk, so my goal was to install Gentoo on the second hard drive leaving the first hard drive with win installation untouched and configure both systems, so that I can boot both Gentoo and Windows from GRUB boot menu. followed the instructions given in Gentoo Installation Handbook for amd64 combined with GRUB page in Arch Wiki for EFI/dual-boot configuration. And I was pretty surprised how I managed to install Gentoo for the first time in my life without having a single issue. Here I want to thank every handbook/wiki contributor for such precise but detailed explanations.

Now, when I boot Gentoo from GRUB menu, I sometimes get an unrecoverable error. This error also occurs almost every time when I try to reboot the running system: screenshot. When I reboot by holding the power button and choose Windows in the GRUB menu, it also fails to boot with the message that the fs_uuid and thus the path to efibootmgfw file were not found. Otherwise, booting Windows from GRUB menu works like a charm.

Also, I noticed that when trying to access the system (I use systemrescuecd on an usb stick for that) after the kernel error happens, I get the following error message: screenshot. I'm curious if these two errors may have the same source.

I will post some system infos I collected shortly.

Update:
emerge info
dmesg output
kernel config file
grub.cfg
/etc/default/grub
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2118

PostPosted: Sun Jun 21, 2015 6:03 am    Post subject: Reply with quote

Hardwareinfo?
Back to top
View user's profile Send private message
manmadescience
n00b
n00b


Joined: 06 Jun 2015
Posts: 7

PostPosted: Sat Jun 27, 2015 8:54 am    Post subject: Reply with quote

Here the lspci output:

Code:

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8650G]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:03.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Port
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 09)
00:10.1 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 09)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 16)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD] FCH IDE Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40)
00:14.7 SD Host controller: Advanced Micro Devices, Inc. [AMD] FCH SD Flash Controller
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 0)
00:15.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 1)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 5
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Neptune XT [Radeon HD 8970M]
03:00.0 Ethernet controller: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller (rev 13)
04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter


After some try-and-error attempts. I managed to avoid the kernel panic by turning off the hybrid graphics support in kernel and disabling the AGP support for the weaker GPU. I still don't think this is the solution, though.

Also, I'm still experiencing the dual-boot problem with GRUB. I fully described it here, so I would also appreciate any help on this. Thank you in advance!
Back to top
View user's profile Send private message
manmadescience
n00b
n00b


Joined: 06 Jun 2015
Posts: 7

PostPosted: Sat Jul 11, 2015 9:23 am    Post subject: Reply with quote

For reasons of completeness and to anyone who should experience similar problems: upgrading the kernel to the most recent version (4.0.5 as of writing this) seems to eliminate kernel panics, so the hybrid graphics option can be turned on now. Nevertheless, there are still some severe issues with the discrete card when booting:

Code:

[    1.996988] ACPI Error: Field [TEMP] at 524288 exceeds Buffer [TVGA] size 512000 (bits) (20150204/dsopcode-236)
[    1.997023] ACPI Error: Method parse/execution failed [\_SB_.PCI0.VGA_.ATRM] (Node ffff88043c83d748), AE_AML_BUFFER_LIMIT (20150204/psparse-536)
...
[drm:r600_ring_test] *ERROR* radeon: ring 0 test failed (scratch(0x850C)=0xCAFEDEAD)
[    2.730740] radeon 0000:01:00.0: disabling GPU acceleration
...
radeon 0000:01:00.0: No VRAM object for PCIE GART.
[   26.627476] [drm:si_resume] *ERROR* si startup failed on resume


so I guess I have to start with DSDT patching. Thank you for your efforts, mods may close the thread if they want.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum