Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] DHCPCD fails to build with ipv6
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 25 Apr 2015
Posts: 8

PostPosted: Sat Apr 25, 2015 9:14 am    Post subject: [SOLVED] DHCPCD fails to build with ipv6 Reply with quote

I need help. I recently went from amd64 to ~amd64. There were few small issues, all resolved simply by googling. There was always someone with simillar problem here or there. But now I'm stuck. I did python-updater and perl-cleaner. This happens to all dhcpcd versions with ipv6, otherwise it compiles successfully.
I don't really need ipv6 yet, so no big deal, I just have no idea why there is error in glibc headers (/usr/include/sys/socket.h).
 * Package:    net-misc/dhcpcd-6.8.1
 * Repository: gentoo
 * Maintainer:
 * USE:        abi_x86_64 amd64 elibc_glibc embedded ipv6 kernel_linux udev userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking dhcpcd-6.8.1.tar.bz2 to /var/tmp/portage/net-misc/dhcpcd-6.8.1/work
>>> Source unpacked in /var/tmp/portage/net-misc/dhcpcd-6.8.1/work
>>> Preparing source in /var/tmp/portage/net-misc/dhcpcd-6.8.1/work/dhcpcd-6.8.1 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-misc/dhcpcd-6.8.1/work/dhcpcd-6.8.1 ...
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/lib64 --prefix= --libexecdir=/lib/dhcpcd --dbdir=/var/lib/dhcpcd --localstatedir=/var --rundir=/run --enable-embedded --enable-ipv6 CC=x86_64-pc-linux-gnu-gcc --with-hook=ntp.conf --with-hook=yp.conf
configure args: --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/lib64 --prefix= --libexecdir=/lib/dhcpcd --dbdir=/var/lib/dhcpcd --localstatedir=/var --rundir=/run --enable-embedded --enable-ipv6 CC=x86_64-pc-linux-gnu-gcc --with-hook=ntp.conf --with-hook=yp.conf
Deriving operating system from ... x86_64-pc-linux-gnu
Configuring dhcpcd for ... linux
dhcpcd-definitions.conf will be embedded in dhcpcd itself
Using compiler .. x86_64-pc-linux-gnu-gcc
x86_64-pc-linux-gnu-gcc (Gentoo 4.9.2 p1.3, pie-0.6.2) 4.9.2
Testing for nl80211 ... yes
Testing for getifaddrs ... yes
Testing for clock_gettime ... yes
Testing for inet_ntoa ... yes
Testing for arc4random ... no
Testing for arc4random_uniform ... no
Testing for closefrom ... no
Testing for getline ... yes
Testing for strlcpy ... no
Testing for strtoi ... no
Testing for dprintf ... yes
Testing for TAILQ_FOREACH_SAFE ... no
Testing for TAILQ_CONCAT ...yes
Testing for posix_spawn ... yes
Testing for kqueue1 ... no
Testing for kqueue ... no
Testing for epoll ... yes
Testing for be64enc ... no
Testing for MD5Init ... no
Testing for sha2.h ... no
Testing for SHA256_Init ... no
Testing for SHA256Init ... no
Checking for libudev ... yes
Checking udev_monitor_filter_add_match_subsystem_devtype ... yes
Checking udev_device_get_is_initialized ... yes
Testing for dlopen ... yes (-ldl)
Checking for ntpd ... /usr/sbin/ntpd (50-ntp.conf)
Checking for ypbind ... not found
Finding hook ntp.conf ... 50-ntp.conf
Finding hook yp.conf ... 50-yp.conf

   SYSCONFDIR =         /etc
   SBINDIR =            /sbin
   LIBDIR =             /lib64
   LIBEXECDIR =         /lib/dhcpcd
   DBDIR =              /var/lib/dhcpcd
   RUNDIR =             /run
   MANDIR =             /usr/share/man
   HOOKSCRIPTS =        50-ntp.conf 50-yp.conf

>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-misc/dhcpcd-6.8.1/work/dhcpcd-6.8.1 ...
make -j1 -l1
x86_64-pc-linux-gnu-gcc  -march=core2 -O2 -pipe -std=c99 -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_DEFAULT_SOURCE -DINET -DINET6 -DPLUGIN_DEV -I./crypt -c common.c -o common.o
x86_64-pc-linux-gnu-gcc  -march=core2 -O2 -pipe -std=c99 -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_DEFAULT_SOURCE -DINET -DINET6 -DPLUGIN_DEV -I./crypt -c control.c -o control.o
x86_64-pc-linux-gnu-gcc  -march=core2 -O2 -pipe -std=c99 -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_DEFAULT_SOURCE -DINET -DINET6 -DPLUGIN_DEV -I./crypt -c dhcpcd.c -o dhcpcd.o
In file included from /usr/include/sys/socket.h:38:0,
                 from dhcpcd.c:33:
ipv6.h:211:41: error: invalid application of ‘sizeof’ to incomplete type ‘struct in6_pktinfo’
  unsigned char sndbuf[CMSG_SPACE(sizeof(struct in6_pktinfo))];
ipv6.h:195:38: error: invalid application of ‘sizeof’ to incomplete type ‘struct in6_pktinfo’
 #define IP6BUFLEN (CMSG_SPACE(sizeof(struct in6_pktinfo)) + \
ipv6.h:214:23: note: in expansion of macro ‘IP6BUFLEN’
  unsigned char rcvbuf[IP6BUFLEN];
Makefile:81: recipe for target 'dhcpcd.o' failed
make: *** [dhcpcd.o] Error 1
 * ERROR: net-misc/dhcpcd-6.8.1::gentoo failed (compile phase):
 *   emake failed
 * ......

emerge --info:
Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.9.2, glibc-2.20-r2, 4.0.0-gentoo x86_64)
                         System Settings
System uname: Linux-4.0.0-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-gentoo-2.2
KiB Mem:     3343444 total,    867848 free
KiB Swap:    4194300 total,   3655948 free
Timestamp of repository gentoo: Sat, 25 Apr 2015 08:15:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.25 p1.0) 2.25
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p33-r2::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r2::gentoo, 3.3.5-r1::gentoo, 3.4.3::gentoo
dev-util/cmake:           3.2.1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.11::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25::gentoo
sys-devel/gcc:            4.9.2::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.0::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

    location: /var/lib/layman/grub2-themes
    masters: gentoo
    priority: 50

    location: /var/lib/layman/kde
    sync-type: git
    masters: gentoo
    priority: 50

    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --quiet-build --color=y --tree --ask --ask-enter-invalid --jobs=3 --load-average 3.0 --backtrack=30"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2 -l3"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo caps cdda cdr cli consolekit corefonts cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam fbcon fbcondecor ffmpeg firefox flac fortran gdbm gif glamor glib gpm gstreamer iconv ipv6 jpeg kde kipi lcms ldap libnotify lirc mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl nvidia ogg opengl openmp openrc orc pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 sse3 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

net-misc/dhcpcd-6.8.1::gentoo was built with the following:
USE="embedded udev -ipv6" ABI_X86="64"

Last edited by j000 on Sat Apr 25, 2015 1:46 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 03 Sep 2007
Posts: 3710
Location: Germany

PostPosted: Sat Apr 25, 2015 12:55 pm    Post subject: Reply with quote

See Bug 546734
Back to top
View user's profile Send private message

Joined: 25 Apr 2015
Posts: 8

PostPosted: Sat Apr 25, 2015 1:45 pm    Post subject: Reply with quote

Wow. Why isn't it on google? Now I will remember too look on separately.
CPPFLAGS=-D_GNU_SOURCE using package.env works.
Thank you very much.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum