Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updating and keeping your Gentoo non-poetterized
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Wed Mar 04, 2015 9:11 pm    Post subject: Updating and keeping your Gentoo non-poetterized Reply with quote

Updating and keeping your Gentoo non-poetterized
===============================================

This topic follows up on a previous topic of mine:

Uninstalling dbus and *kits (to Unfacilitate Remote Seats)
https://forums.gentoo.org/viewtopic-t-992146.html

I am starting to wonder how hard it is going to get to keep a non-poetterized Gentoo an option.

In emerge talk, I want to give the Gentoo folks a case study.

It's another topic, but completeness is a good thing: I'm trying to get myself a replacement browser for the one that I learned the hard way through the years up to now, and way back since:

System attacked, Konqueror went on window-popping spree!
https://forums.gentoo.org/viewtopic-t-905472.html

and I finally figured it out for nearly certain, that Mozilla Firefox has gone the data-harvesting way completely in the arms of Google the Surveillance Engine and Octopus of the Internet, and that there is no privacy and no defence from intrusion by, say local regime Google or Yahoo personnel for you, with the Firefox browser.

Case studies for your checking on my claim I'd have many (cases numerouos, time to present them lacking), but I've got these two clear cut undeniables:

a clickjacking that only packets captured show:
Postfix smtp/TLS, Bkp/Cloning Mthd, Censorship/Intrusion
https://forums.gentoo.org/viewtopic-t-999436.html#7685200

and brute mess-up of my connection:
Air-Gapped Gentoo Install, Tentative
https://forums.gentoo.org/viewtopic-t-987268-start-25.html#7552466
(identified the files right after it happened back in 2014, revealed all only these days)

If you haven't read around the posts linked above, then you need either this old explanation of my on how I screencast-packetcapture on my time online, or look up this idea of mine for a program (the latter also on GitHub).

Lynx and dillo do not suffice, as they have no Javascript, so I can't exampli gratia, pay my bills online with any of them...

And, for some reason, and I might try and seek help on it separately, www-client/netsurf failed to install in my box.

And here's what www-client/midori wants to pull in:
(I have --ask and --verbose in make.conf)

Code:

emerge -tuDN midori

These are the packages that would be merged, in reverse order:

Calculating dependencies  ... done!

!!! All ebuilds that could satisfy ">=app-accessibility/at-spi2-atk-2.5.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]"
have been masked.
!!! One of the following masked packages is required to complete your request:
- app-accessibility/at-spi2-atk-2.14.1::gentoo (masked by: package.mask)
- app-accessibility/at-spi2-atk-2.12.1-r1::gentoo (masked by: package.mask)
- app-accessibility/at-spi2-atk-2.12.1::gentoo (masked by: package.mask)

(dependency required by "x11-libs/gtk+-3.14.9::gentoo" [ebuild])
(dependency required by "www-clieng/midori-0.5.8-r1::gentoo[-deprecated]" [ebuild])
(dependency required by "midori" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I'm currently stuck with:

Code:

mybox ~ # emerge -s '%^gtk' |grep  -B2 -A5 'Latest version installed: [^[]'
*  app-vim/gtk-syntax
      Latest version available: 20130716
      Latest version installed: 20130716
      Size of files: 230 KiB
      Homepage:      http://www.vim.org/scripts/script.php?script_id=1000
      Description:   vim plugin: Syntax highlighting for GLib, Gtk+, Xlib, Gimp, Gnome, and more
      License:       vim

--
*  dev-util/gtk-doc-am
      Latest version available: 1.21
      Latest version installed: 1.21
      Size of files: 633 KiB
      Homepage:      http://www.gtk.org/gtk-doc/
      Description:   Automake files from gtk-doc
      License:       GPL-2 FDL-1.1

--
*  x11-libs/gtk+
      Latest version available: 3.14.9
      Latest version installed: 3.4.4
      Size of files: 15,349 KiB
      Homepage:      http://www.gtk.org/
      Description:   Gimp ToolKit +
      License:       LGPL-2+

--
*  x11-libs/gtksourceview
      Latest version available: 3.14.3
      Latest version installed: 2.10.5-r2
      Size of files: 1,228 KiB
      Homepage:      https://wiki.gnome.org/Projects/GtkSourceView
      Description:   A text widget implementing syntax highlighting and other features
      License:       GPL-2+ LGPL-2.1+

*  x11-misc/gtk2fontsel
      Latest version available: 0.1
      Latest version installed: 0.1
      Size of files: 60 KiB
      Homepage:      http://gtk2fontsel.sourceforge.net/
      Description:   A font selection tool similar to xfontsel
      License:       GPL-2

mybox ~ #


which is fine for now. But the problem lies in wait as I'll try to explain.

I could probably just keep app-accessibility/at-spi2-atk packege masked as it has been for long now and maybe try masking the newer gtk+-3 versions.

Since:

Code:

mybox ~ # ls -l /usr/portage/x11-libs/gtk+/
total 220
-rw-r--r-- 1 portage portage 20631 2015-02-26 21:31 ChangeLog
media-video/libav
-rw-r--r-- 1 portage portage 98793 2013-01-01 14:29 ChangeLog-2012
drwxr-xr-x 2 portage portage  4096 2015-02-22 11:10 files
-rw-r--r-- 1 portage portage  2406 2013-05-01 05:22 gtk+-1.2.10-r12.ebuild
-rw-r--r-- 1 portage portage  9303 2015-01-02 13:31 gtk+-2.24.25.ebuild
-rw-r--r-- 1 portage portage  9932 2015-02-08 22:31 gtk+-2.24.25-r1.ebuild
-rw-r--r-- 1 portage portage  9942 2015-02-18 13:05 gtk+-2.24.26.ebuild
-rw-r--r-- 1 portage portage  6597 2014-10-11 14:01 gtk+-3.12.2.ebuild
-rw-r--r-- 1 portage portage  8223 2015-02-08 22:31 gtk+-3.12.2-r2.ebuild
-rw-r--r-- 1 portage portage  7964 2015-02-03 15:17 gtk+-3.14.8.ebuild
-rw-r--r-- 1 portage portage  7262 2015-02-26 21:15 gtk+-3.14.9.ebuild
-rw-r--r-- 1 portage portage 12011 2015-02-26 21:31 Manifest
-rw-r--r-- 1 portage portage   763 2015-02-26 21:31 metadata.xml
mybox ~ #


I'm trying adding:

Code:

>=x11-libs/gtk+-3.12.2-r2


to /etc/portage/package.mask.

Or, it gets me the same result further below, shanging that line to two:

Code:

=x11-libs/gtk+-3.14.8
=x11-libs/gtk+-3.14.9


and I stuck:

Code:

=x11-libs/gtk+-3.12.2-r2


in /etc/portage/package.keywords

and got me slightly different lines for midori, but the same resident problem:

Code:

mybox ~ # emerge -tuDN midori |& tee emerge-tuDN_midori_`date +%s`

These are the packages that would be merged, in reverse order:

Calculating dependencies  .... ... done!

!!! All ebuilds that could satisfy ">=app-accessibility/at-spi2-atk-2.5.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]"
have been masked.
!!! One of the following masked packages is required to complete your request:
- app-accessibility/at-spi2-atk-2.14.1::gentoo (masked by: package.mask)
- app-accessibility/at-spi2-atk-2.12.1-r1::gentoo (masked by: package.mask)
- app-accessibility/at-spi2-atk-2.12.1::gentoo (masked by: package.mask)

(dependency required by "x11-libs/gtk+-3.12.2-r2::gentoo" [ebuild])
(dependency required by "www-client/midori-0.5.8-r1::gentoo[-deprecated]" [ebuild])
(dependency required by "midori" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

mybox ~ #


And this is now a problem (well maybe not a big one yet, for a little time longer [*]), because I've seen it before:

those freaking packages want dbus into my system.

I'll show how (unless my memory betrays me, or things have changed from previously), in the next post. But in this post I want to expound how I see the dbus affair in the big picture.

I'm not an expert, but I think my topics have gained some interest because the underlining laborious attempts and tentatives of mine have shown some standing. They couldn't be and won't be easily dismissed, well unless Gentoo as well gets good leaders overturned and chooses the poetterizing disaster as recently the mooonlighters in Debian took over all the remaining reason from Debian and took to windozing/poetterizing Debian mercilessly... I hope to move to http://www.devuan.org with my Debian boxes.

https://lists.dyne.org/lurker/message/20150305.220104.d3713c58.en.html
about the term poetterize, poetterizing and such. It is an established term in Devuan.

I fear my topics and posts in Debian Forums might now be in joepardy, and I really don't know if I am going to see those saved or be able to save all that work of mine which I contributed there. I do hope Gentoo might be, in the future as it has been since it's inception, faithful to its FOSS nature and the freedom that FOSS nourishes on and which FOSS begets for its users. I do worry less for my work and my thoughts that I confided to folks here in Gentoo. I'm not saying it's much at all, neither here nor in Debian, but it is my best.

I don't trust dbus, although it may not be strictly poetteringware. It manages IPC (Inter Pocess Communication) and RPC (Remote Procedure Call) systems in encrypted way against the user, just the kind of encryption that I pointed out for you in the case studies on Firefox above:

How to avoid stealth installation of systemd?
http://forums.debian.net/viewtopic.php?f=20&t=116770&start=45#p552566
(and if this link remains live in the future, I'll be glad I was wrong fearing for my contributions in Debian Forums)

And, from what steveL wrote about that *!~@ware, I made my coclusions and confirmed my previous distrust of it. It's among other points not of our interest here, in this topic:

KDE for surveillance-aware people
https://forums.gentoo.org/viewtopic-t-1002800.html

and here's the paragraphs of that topic of our interest:

steveL wrote:
...[snip]...
I agree dbus is a busted idea,
...[snip]...
miroR wrote:
It'd be huge work for me to try KDE out. It's beyond what I can do at this time. Too stretched. But I take your word on the sanity of KDE.

Just, can it be installed without dbus? I don't think so...

I did give KDE a try, some two weeks ago, on a cloned Gentoo machine (same MBOs, a few boxes in my SOHO, perfectly clonable from one onto another, dd dumping and dd restoring...), and tried to get Kaffeine.

Nope! It was dbus back in there. And it just wouldn't install without replacing my gnupg-1, which I want, with gnupg-2 which introduces GUI and other overhead...(

Yeah KDE requires dbus. I didn't have a problem with dbus when it came out, but over time I've realised it's a nutty idea. You're still tied to an ABI when you use it, irrespective of whether the underlying protocol can handle it, so all it does is act as an inappropriate bottleneck.

Strategically, it allows RedHat to sell its customers an opt-out from the GPL, while still effectively linking to GPL codebases. That hasn't been tested in Court of course, and I for one wouldn't believe any lawyer nor snake-oil salesman that it would stand up to inspection.

If anything, I'd fire the lawyer who dreamt it up or okayed it, as he's a liability.

Localising RPC doesn't stop it being a function-call; that's the whole point of RPC. All they're doing is exactly that, and labelling it IPC.

Indeed when I ran the above analysis of the motivation, past an embedded developer, his immediate response was "Yeah, that's exactly why we [his company] love dbus: because we can ignore the GPL."

That conversation also confirmed to me that another practitioner doesn't see any difference between calling a function via an API, and via an API wrapping an RPC call; from the code perspective it's exactly the same. Again, that's the whole point of RPC, so it would be very strange for anyone to argue otherwise.

Nor are any of those embedded companies anything other than practitioners, since they employ software developers to do this work.

So if I were them, I'd seriously start pulling myself out of that game, as they know full well they're breaking the law. There is no excuse of ignorance even feasible.

Technically speaking it's a terrible idea to think you can multiplex better than the kernel, when that is most of what the kernel does.

It is thus a liability in terms of efficiency, robustness and overall performance.

IPC should be left to the kernel to manage, since it has so many implications. By all means provide domain-specific convenience abstractions, where domain is data-related (ie user context); rather than desktop vs anything else.

Just don't be a muppet and buy into the emperor's "new clothes for old rope".
...[snip]...


Let me now repeat the point that, along with the encryptedness of the dbus, I base my conclusions on:

steveL wrote:

Strategically, it [the dbus] allows RedHat to sell its customers an opt-out from the GPL, while still effectively linking to GPL codebases. That hasn't been tested in Court of course, and I for one wouldn't believe any lawyer nor snake-oil salesman that it would stand up to inspection.


So, your fine FOSS Linux dear machine of yours, dear brother in *nix, your user-enpowering Operationg System you pin your hopes on, believing you can control it, if it has dbus, and if it is not a non-poetterized distro, then some of those private companies that RedHat can, having that dbus and other ingredients (look up my signature to understand what the linux capabilities and the SELinux are for), [then some of those private companies that RedHat can] sell to, can surely play nasty things on it, that your beloved FOSS Linux box!

They surely can play nasty things on your dear FOSS Linux machine, as long as you're online, because they can play/plant/other-action-here binaries close to as they like it, and do all kinds of things without you ever knowing about it! It's all hidden to you in that freaking encrypted communication just like in the Firefox browser in the two case studies near the top of this post of mine!

And I insist I don't want dbus in my system. It's only me who am allowed to decide what is and when, and for what reason and under what terms it should be, encrypted in my system. This is my turf. My privacy.

But how costly it has become to attain freedom with your FOSS Linux, dear *nixers!

And surely, I'm not yet there...

To finish this post, just the link to the term poetterize, poetterizing, as used in the Devuan mailing list,

And it is called so by its principal developer Lennart Poettering. We do not call it so for reason of disparaging or some other mean reason but because it's the team around the guy that that *!@~ware originated from.

First how those packages would want to call in dbus into my system.

---
[*] One remaining terrible obstacle in the eyes of the one-ring-to-rule-them-all cravers (or go for the referred to article: `With One Ring to rule them all') remains FOSS Linux in the whole of computing, and don't think for a second that they're not very busy trying to conquer our sacred ground as well (sacred in the eyes of still many of us).


Last edited by miroR on Tue Mar 10, 2015 3:25 pm; edited 2 times in total
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Thu Mar 05, 2015 9:54 am    Post subject: Reply with quote

This is my current /etc/portage/package.mask:
Code:

media-video/libav
gnome-base/gconf
>=app-crypt/gnupg-2.0.22
app-accessibility/at-spi2-atk
app-accessibility/at-spi2-core
sys-apps/dbus
#unmask else no wireshark
#x11-libs/gtk+:3
#=x11-libs/gtk+-3.14.8
#=x11-libs/gtk+-3.14.9
>=x11-libs/gtk+-3.12.2-r2
sys-auth/polkit
sys-auth/consolekit
media-sound/pulseaudio
sys-apps/systemd
sys-fs/udev
sys-fs/udev-init-scripts
x11-drivers/xf86-input-evdev
>=sys-apps/hwids-20140509
=app-admin/syslog-ng-3.5.6
=net-misc/openssh-6.6.1_p1-r4
=app-admin/syslog-ng-3.6.1
=app-admin/syslog-ng-3.6.2
=sys-apps/man-db-2.7.1

While every single one of the entries has its reason to be there, and for some the reason can be gleaned from my previous topic to which this is a follow-up (see top of the previous post), I'll point you to just syslog-ng behavior in my grsecurity-hardened Gentoo:

Syslog-ng from Delay Logging to BrokenPipe/no Logging
https://forums.gentoo.org/viewtopic-t-1001994.html

and:

app-admin/syslog-ng-3.6.2: scary time stamp jumps
https://bugs.gentoo.org/show_bug.cgi?id=533328

and give a short report right here as to why I also masked sys-apps/man-db-2.7.1. While running

emerge man-db
Code:

...[snip]...
[ebuild     U  ] sys-apps/man-db-2.7.1::gentoo [2.6.7.1::gentoo] USE="berkdb gdbm nls zlib (-selinux) -static-libs" 0 KiB

Total: 1 package (1 upgrade), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/man-db-2.7.1::gentoo
 * man-db-2.7.1.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...              [ ok ]
 * Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings
>>> Unpacking source...
>>> Unpacking man-db-2.7.1.tar.xz to /var/tmp/portage/sys-apps/man-db-2.7.1/work

...[snip]...
checking whether fdopendir is declared... (cached) yes
checking whether fdopendir works... yes
checking whether conversion from 'int' to 'long double' works... yes
checking for working GNU fnmatch... yes
checking whether fstatat (..., 0) works... yes
checking whether futimens works... needs runtime check
checking whether getcwd handles long file names properly...

And there I get a hang, during which if I fire up:
Code:

# top

it shows that one of my 4 core processor is engaged in some loop (close to 100 %CPU by COMMAND conftest), and this is what grsec reports in the /var/log/messages:

Code:

Mar  5 06:05:00 g0n kernel: [247120.221793] grsec: (admin:S:/) denied resource overstep by requesting 1000000 for RLIMIT_NOFILE against limit 1024 for /var/tmp/portage/sys-apps/man-db-2.7.1/work/man-db-2.7.1/conftest[conftest:3844] uid/euid:250/250 gid/egid:250/250, parent /var/tmp/portage/sys-apps/man-db-2.7.1/work/man-db-2.7.1/configure[configure:3843] uid/euid:250/250 gid/egid:250/250
Mar  5 06:05:00 g0n kernel: [247120.221838] grsec: (admin:S:/) denied resource overstep by requesting 4294967295 for RLIMIT_NOFILE against limit 1024 for /var/tmp/portage/sys-apps/man-db-2.7.1/work/man-db-2.7.1/conftest[conftest:3844] uid/euid:250/250 gid/egid:250/250, parent /var/tmp/portage/sys-apps/man-db-2.7.1/work/man-db-2.7.1/configure[configure:3843] uid/euid:250/250 gid/egid:250/250
Mar  5 06:05:00 g0n kernel: [247120.461296] grsec: (admin:S:/) denied resource overstep by requesting 4294967295 for RLIMIT_NOFILE against limit 1024 for /var/tmp/portage/sys-apps/man-db-2.7.1/work/man-db-2.7.1/conftest[conftest:3865] uid/euid:250/250 gid/egid:250/250, parent /var/tmp/portage/sys-apps/man-db-2.7.1/work/man-db-2.7.1/configure[configure:3864] uid/euid:250/250 gid/egid:250/250

If this doesn't vanish with new version, I'll have to open a topic for it.

From the /etc/portage/package.mask above, part of this entry has been discussed:
Code:

#unmask else no wireshark
#x11-libs/gtk+:3
#=x11-libs/gtk+-3.14.8
#=x11-libs/gtk+-3.14.9
>=x11-libs/gtk+-3.12.2-r2

But let me add that wireshark now works with the current, as reported in the post above, where you can find the line:
Code:

*  x11-libs/gtk+
      Latest version available: 3.14.9
      Latest version installed: 3.4.4


And now let's see what would be pulled in, and if I was right to say it would pull dbus (and pull it indirectly).

In the above /etc/portage/package.mask I'll temporarily comment out:

Code:

#app-accessibility/at-spi2-atk


Code:

g0n ~ # emerge -tuDN midori |& tee emerge-tuDN_midori_`date +%s`

These are the packages that would be merged, in reverse order:

Calculating dependencies  . .... done!

!!! All ebuilds that could satisfy ">=app-accessibility/at-spi2-core-2.11.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]"
have been masked.
!!! One of the following masked packages is required to complete your request:
- app-accessibility/at-spi2-core-2.14.1::gentoo (masked by: package.mask)
/etc/portage/package.mask:
#app-accessibility/at-spi2-atk

- app-accessibility/at-spi2-core-2.12.0-r1::gentoo (masked by: package.mask)
- app-accessibility/at-spi2-core-2.12.0::gentoo (masked by: package.mask)

(dependency required by "app-accessibility/at-spi2-atk-2.14.1::gentoo" [ebuild])
(dependency required by "x11-libs/gtk+-3.12.2::gentoo[X]" [ebuild])
(dependency required by "www-client/midori-0.5.8-r1::gentoo[-deprecated]" [ebuild])
(dependency required by "midori" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

g0n ~ #


Well, I'll comment out that one too:
Code:

#app-accessibility/at-spi2-core


And, sure enough, the star of the show wants to be allowed to enter my box:

Code:

g0n ~ # emerge -tuDN midori |& tee emerge-tuDN_midori_`date +%s`

These are the packages that would be merged, in reverse order:

Calculating dependencies  . .... done!

!!! All ebuilds that could satisfy ">=sys-apps/dbus-1.5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]"
have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.8.16::gentoo (masked by: package.mask)
/etc/portage/package.mask:
#app-accessibility/at-spi2-atk
#app-accessibility/at-spi2-core


(dependency required by "app-accessibility/at-spi2-atk-2.14.1::gentoo" [ebuild])
(dependency required by "x11-libs/gtk+-3.12.2::gentoo[X]" [ebuild])
(dependency required by "www-client/midori-0.5.8-r1::gentoo[-deprecated]" [ebuild])
(dependency required by "midori" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

g0n ~ #


And all that on the back of the care for the disabled (which `accessibility' stands for, such as poor eyesight and other handicap that call for special aid in using your computer).

Get the *!@~ out of here you =$]$% !!

Excuse my anger, kind readers, please!

This is very probably introduced without a reason, for the sake of introducing dbus, those dependecies are not rational (unless you warrant mass surveillance on everybody for data harvesting and all the control).

I can't learn to write ebuilds without significant input of time.

However, if our devs don't sort this (as they have sorted out the need for such `accessibility' and I was able to install wireshark with

Code:

*  x11-libs/gtk+
      Latest version available: 3.14.9
      Latest version installed: 3.4.4


and I installed it without those `accessibility' packages in question,

for which a big thanks to them!...

However, if our devs don't sort this, the problem will likely remain.

So much for now. Whether midori can be installed without dbus is an issue to figure out yet.

And pls. do tell me if neither netsurf nor midori have Javascript.

I'm almost fine with dillo and lynx otherwise, but I don't want to be logging in anywhere with Firefox anymore,

I'm seeking a browser that wouldn't be so Google-and-others-intrusion-ready as Firefox and which would have a working Javascript for where I need it.

I'm aware of this topic:

tiny browser suggest
https://forums.gentoo.org/viewtopic-t-952478.html

I guess some of those people will understand my despise of Firefox. Just, if they didn't say it there more openly, I will. I will post my reasons for looking for a safe and not bloated and nasty browser. I'll post it there.

And I'll post how my netsurf install fails. Because I looked up the bugs on http://bugs.netsurf-browser.org/ and I didn's see any install-related bugs, so it's best to ask about this failed netsurf install issue here on Gentoo Forums.

And then only can I move and try to do something that might ensue from this another revived topic (really old) over here:

Need help creating ebuild for "lurker"
https://forums.gentoo.org/viewtopic-t-228582.html

All this talk of browser is perfectly within the topic, because it seems to, as you can see from what I recounted, be a problem to get a non-poetterized browser (for me that includes non-dbus) in your system.

EDIT Tue 10 Mar 14:37:14 CET 2015: But, all this talk of browser (browser as a basic component of a Gentoo) is perfectly within the topic only as far as our pursuit of a non-poetterized Gentoo goes. Just as, since poetterization goes with the dbus-enabled FOSS Linux like a plug aims at its socket, dbus, IMO, being one of the indispensable requirements for the goals for which poetterization is deployed, [dbus] is pretty much completely within this topic of freeing ourselves, as users, from poetterization. Did anyone see a working poetterized Linux deployed without dbus?


Last edited by miroR on Tue Mar 10, 2015 3:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Mar 05, 2015 5:43 pm    Post subject: Reply with quote

... :roll:
Seriously, There are battles that need to be fought (like keeping Linux from getting systemd-borgified) and there's tinfoil hat territory (and no, Snowden is irrelevant in this case).
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7188
Location: Austria

PostPosted: Thu Mar 05, 2015 6:24 pm    Post subject: Reply with quote

Could we agree to stop the name-blame game?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44050
Location: 56N 3W

PostPosted: Thu Mar 05, 2015 9:12 pm    Post subject: Reply with quote

miroR,

This works for me.
Code:
roy@NeddySeagoon_Static ~ $ USE="-geoloc" emerge -pv midori

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libyaml-0.1.6::gentoo  USE="-doc -examples -static-libs {-test}" 0 KiB
[ebuild  N     ] app-admin/eselect-ruby-20141227::gentoo  2 KiB
[ebuild  N     ] sys-apps/paxctl-0.9::gentoo  0 KiB
[ebuild  N     ] dev-util/ragel-6.8::gentoo  USE="-vim-syntax" 0 KiB
[ebuild  N     ] media-libs/libwebp-0.4.2:0/5::gentoo  USE="gif jpeg opengl png tiff -experimental -static-libs -swap-16bit-csp" 955 KiB
[ebuild  N     ] dev-lang/ruby-2.0.0_p643:2.0::gentoo  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs" CPU_FLAGS_X86="sse2" 8127 KiB
[ebuild  N     ] dev-lang/ruby-1.9.3_p551:1.9::gentoo  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl yaml -debug -doc -examples -rubytests -socks5 -xemacs" 9816 KiB
[ebuild  N     ] dev-ruby/rubygems-2.4.6::gentoo  USE="-server {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 438 KiB
[ebuild  N     ] virtual/rubygems-10::gentoo  RUBY_TARGETS="ruby19 ruby20 -rbx -ruby21 -ruby22" 0 KiB
[ebuild  N     ] dev-ruby/rake-10.4.2::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 128 KiB
[ebuild  N     ] dev-ruby/json-1.8.2-r1::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 149 KiB
[ebuild  N     ] dev-ruby/racc-1.4.12::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 0 KiB
[ebuild  N     ] dev-ruby/rdoc-4.1.2-r1::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 0 KiB
[ebuild  N     ] net-libs/webkit-gtk-2.4.8:3/25::gentoo  USE="X egl gstreamer introspection jit opengl webgl (-aqua) -coverage -debug -geoloc -gles2 -libsecret -spell {-test} -wayland" 9598 KiB
[ebuild  N     ] www-client/midori-0.5.8-r1::gentoo  USE="jit webkit2 -deprecated -doc -granite -introspection -zeitgeist" 1245 KiB

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 768

PostPosted: Thu Mar 05, 2015 10:24 pm    Post subject: Reply with quote

Maybe we can talk about what exactly firefox does/allows and how to prevent it - unless it's a lost cause. Preferences, about:config, add-ons, plugins, search engines, tor/privoxy? And come up with a generally usable template for private browsing, if that is the issue here.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Fri Mar 06, 2015 12:39 am    Post subject: Reply with quote

NeddySeagoon and others, I need more time to reply to you. Pls. allow!

Princess Nell wrote:
Maybe we can talk about what exactly firefox does/allows and how to prevent it - unless it's a lost cause. Preferences, about:config, add-ons, plugins, search engines, tor/privoxy? And come up with a generally usable template for private browsing, if that is the issue here.

I'd like to! However, I'd prefer giving packet capture presentation, and I'd need time for that.

What I know, and don't like in the least, actually despise, is the first thing Firefox does is it hauls over all the data about you into the cloud. The first time it connects. And, sure, updates the cloud every next time. Data harvesting. I've seen it in all packet captures.

And it facilitates Google spying to the utmost. None of that when browsing with dillo and lynx.

I couldn't believe the relief I experienced when I decided to try dillo and lynx, and it dawned on me to full extent that that was the case.

Sorry if you like Firefox. So did I like my Samsung Galaxy II, till the regime showed how it owns it, and not I. I can't really use anything Google since, believe me, The regime started even placing video calls from it without me ever touching it... Just giving that as an example of how far the Big Brotherly control goes nowadays.

Mozilla has sold out too. Sorry!

But I may try and call you to teach us to degooglize Firefox, if that is at all feasible anymore, and if the old Firefox still can be gotten somwehow, out of the sources, but for that I'd need time, and it is lacking for me currently.

Just have a look at here, where other folks have tried to make something out of Firefox:

Google - can not open any link - malware ??
https://forums.gentoo.org/viewtopic-t-912056.html

But I'm busy over here currently:

The Devuan Mailing List
https://lists.dyne.org/lurker/message/20150305.175104.c6924211.en.html

Cheers!
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3257
Location: Illinois, USA

PostPosted: Fri Mar 06, 2015 2:14 am    Post subject: Reply with quote

Successfully removed dbus and udisks and the system is none the worse. I had been led to believe that these were necessary for mate-sensors-applet to work, but they are working fine without them.

Also interested in Firefox , what is wrong and how to fix it. For about twenty years my choice has been between Firefox/Mozilla and Internet Explorer. Firefox wins that fight hands down, including security.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Fri Mar 06, 2015 6:07 am    Post subject: Reply with quote

Tony0945 wrote:
Successfully removed dbus and udisks and the system is none the worse. I had been led to believe that these were necessary for mate-sensors-applet to work, but they are working fine without them.

Always glad to see folks going the real Unix way...

Tony0945 wrote:
Also interested in Firefox , what is wrong and how to fix it.

I just looked up Princess Nell's profile and posts. No, not much about Firefox, to expect that she be into it deep enough, it appears to me.
Packet capturing, brother in *nix. And see whether my claim about data harvesting and Google sitting in there is true or not!
Tony0945 wrote:
For about twenty years my choice has been between Firefox/Mozilla and Internet Explorer. Firefox wins that fight hands down, including security.

That's old fame they live off, I'm afraid.

But I owe a reply to NeddySeagoon, my teacher ;-) (he taught me here:
Recover partly overwritten luks volume?
https://forums.gentoo.org/viewtopic-t-1004014.html
and I haven't done the work yet because no money for 4TB disk still... )


Last edited by miroR on Tue Mar 10, 2015 3:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Fri Mar 06, 2015 9:31 am    Post subject: Reply with quote

NeddySeagoon wrote:
miroR,

This works for me.
Code:
roy@NeddySeagoon_Static ~ $ USE="-geoloc" emerge -pv midori
...[snip]...
[ebuild  N     ] net-libs/webkit-gtk-2.4.8:3/25::gentoo  USE="X egl gstreamer introspection jit opengl webgl (-aqua) -coverage -debug -geoloc -gles2 -libsecret -spell {-test} -wayland" 9598 KiB
[ebuild  N     ] www-client/midori-0.5.8-r1::gentoo  USE="jit webkit2 -deprecated -doc -granite -introspection -zeitgeist" 1245 KiB


It might be because of the old webkit-gtk-2.4.8 . It looks to me, but pls correct me, that maybe you have less the the newest gtk+, and not like me.

I looked up the difference btwn the dependencies in the ebuilds of

Code:

(from the probably still latest portage tree)
ls -l /usr/portage/x11-libs/gtk+/
...
-rw-r--r-- 1 portage portage  9942 2015-02-18 13:05 gtk+-2.24.26.ebuild
...
-rw-r--r-- 1 portage portage  7262 2015-02-26 21:15 gtk+-3.14.9.ebuild


The older one gtk+-2.24.26 works without the *!~@ `accessibility' to force dbus onto user trick, and the new one gtk+-3.14.9 forces it onto user,

Do coorect me if I'm wrong.

Maybe I can solve it by masking again the gtk+-3

Code:

x11-libs/gtk+:3

in /etc/portage/package.mask

Will report back.
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Fri Mar 06, 2015 2:08 pm    Post subject: Reply with quote

Here's what I have in my package.mask, miroR:
Code:
# over my dead body
sys-apps/systemd
>=gnome-base/gnome-control-center-3
# pulls in gdbus
>=x11-libs/gtk+-3.10.0
# gtk-3
x11-libs/libwnck
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Fri Mar 06, 2015 3:26 pm    Post subject: Reply with quote

steveL wrote:
Here's what I have in my package.mask, miroR:
Code:
# over my dead body
sys-apps/systemd
>=gnome-base/gnome-control-center-3
# pulls in gdbus
>=x11-libs/gtk+-3.10.0
# gtk-3
x11-libs/libwnck

Yeah, that'll help! Thanks, teacher steveL!

Updated my local mirror. Updating, currently, my Gentoo master, later will be updating this online cloned Gentoo of mine (I think I gave the link how to clone systems for newbies above... it's the "Postfix... Bkp/Cloning ..." titled).

Also. I wanted to point out that teacher NeedySeagoon is using grsecurity-hardened kernel (I see:
Code:

[ebuild  N     ] sys-apps/paxctl-0.9::gentoo  0 KiB

in his paste.)

Gentoo like that is very likely the most secure system in all of the FOSS-Linuxdom!
(Just for the visiting newbies.)

And another note for the visiting newbies. We can only live without dbus and poetterware because our devs have the spite to provide it for us. Thank you!

And I really hope to influence the nascent Devuan the new sun (as a friend of mine from Debian Forums, edbarx, calls it), so they pick up some of the spite for freedom from our developers. Because for the masses not advanced enough, which Debian served well before committing suicide with systemd, Devuan the Debian non-systemd fork will be much less learning than Gentoo, and if they get from Gentoo this security/privacy/freedom, then the world, yes!, will be that much freeer, in this Big Brotherly age...


Last edited by miroR on Tue Mar 10, 2015 3:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44050
Location: 56N 3W

PostPosted: Fri Mar 06, 2015 9:31 pm    Post subject: Reply with quote

miroR,

I do use gentoo-hardened most places but no on the box I pasted from.

I have an up to date ~amd86 /no-multilib/ install - all except two packages that will not build no my static /dev system.
mese I can fix, its a three line patch to the ebuild.
sys-apps/usbutils-008 is probably a lost cause as most of its functionality hase been taken over by udev.
sys-apps/usbutils-007 still works.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Spanik
Guru
Guru


Joined: 12 Dec 2003
Posts: 463
Location: Belgium

PostPosted: Sat Mar 07, 2015 11:49 am    Post subject: Reply with quote

What about pulseaudio?
_________________
Expert in non-working solutions
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 2:29 pm    Post subject: Reply with quote

NeddySeagoon wrote:
miroR,

I do use gentoo-hardened most places but no on the box I pasted from.

I have an up to date ~amd86 /no-multilib/ install - all except two packages that will not build no my static /dev system.

So it's probably an:
Olde Fashioned Gentooee
https://dev.gentoo.org/~neddyseagoon/Old_Fashioned_Gentoo_3.xml
(I found it easily, I recommended it in the Uninstalling dbus and *kits (to Unfacilitate Remote Seats), which is linked at the start of this topic.

NeddySeagoon wrote:
mese I can fix, its a three line patch to the ebuild.
sys-apps/usbutils-008 is probably a lost cause as most of its functionality hase been taken over by udev.
sys-apps/usbutils-007 still works.

`emerge -s "%^mese"' gave me nothing back. You mean "mesa"?

And what then does `emerge midori' updates paxctl for you for, if that box is not grsec-hardened? That evades my understanding (which is not so very ample, OK).

Spanik wrote:
What about pulseaudio?

Read the topic linked at the start of this topic, and mentioned in this topic in my reply to Neddy. pulseaudio is poetterware. I didn't know it was back then, Tractor Girl told me.
Oh, while you, if you're around still, [while you] are at viewing that previous topic on poetterware, pls. tell me if the first page is hard to read for a 1024x768 monitor (the standard that a page in a browser should be displayed in complete, and not part of, in its breadth), or is it without that breadth? In my dillo it is almost three times the 1024 breadth of my monitor, hard to read. In Firefox, I used to be able to always view it fine. (Or anyone other, if you care to tell me; better use Private Message for that, not to digress here, pls. Thanks! EDIT Tue 10 Mar 14:50:34 CET 2015: Wow, that was too much to ask! Received no message about it so far... If only I remember next time I use Firefox, I'll report back. It may not be sson, because I hate data harvesting...)

BTW, I've haven't had any success yet. dbus is called in by too many programs. I'm preparing a complete and detailed and reliable, as best I can, report of my tentatives. Working only on that now.


Last edited by miroR on Tue Mar 10, 2015 3:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44050
Location: 56N 3W

PostPosted: Sat Mar 07, 2015 3:00 pm    Post subject: Reply with quote

miroR,

Yes, I use Olde Fashioned Gentooee. There is now a version 4 of that guide that shows how to start with an offcial stage3.
You were correct about mesa. That was a typo. I'm still learning the dvorak-uk keyboard layout.

I don't have pulseaudio. So far USE=-pulseaudio has been enough to keep it at bay.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 4:30 pm    Post subject: Reply with quote

Thanks, Neddy!

I currently use what I was suggested by khayyam, jonathan183 and Tractor Girl in the Uninstalling dbus and *kits (to Unfacilitate Remote Seats), which is eudev and Slashbeast's mdev-like-a-boss.

That's just good *nix programs and methods. I didn't need to touch any of these booting/init/rc/other-initialization/devices-management programs (if I'm using the right words), almost ever, or maybe really not at all (can't remember an instance of a problem there), since then.

And I'm sure your Oldee is too!

---
I had done a lot of trying during some of the time since I last posted and up to last post. But I did it somewhat too hastily... You'll see better presentation next.

Maybe try and resolve this query first.

I made this note previously, that was the case maybe 7-8 hours ago, and maybe previously a few attempts at tweaking
/etc/portage/package.{use,mask,unmask,{,accept_,}keywords,license} (not many).

Code:

ukrainian # emerge -s gtk+

[ Results for search key : gtk+ ]
Searching...

*  x11-libs/gtk+
      Latest version available: 2.24.26
      Latest version installed: 3.4.4
      Size of files: 13,017 KiB
      Homepage:      http://www.gtk.org/
      Description:   Gimp ToolKit +
      License:       LGPL-2+


which is unusual. Latest version installed 3.4, latest version available 2.24
(while 2.24 is smaller than 3.4).

But I'll downgrade.

Or will I? Look at this, it does look like reinstall, not either downgrade nor
upgrade:

Code:

ukrainian # emerge gtk+ |& tee /Cmn/BAK_/emerge.d/emerge_-tuDNf_gtk+_`date +%s`

These are the packages that would be merged, in order:

Calculating dependencies  .... done!
[ebuild   R    ] x1g-libs/gtk+-2.24.26:2::gentoo  USE="vim-syntax (-aqua)
-cups -debug -examples -introspection {-test} -xinerama" ABI_X86="(64) -32
(-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Never mind. Accepted. It's churning on.

And it installed. But, regardless of, in the few tries afterwards, during some of the time past since (only some of the time; I'm only now fully at this), [in the few tries afterwards] that I attempted after studying both NeddySeagoon's and steveL's input and even more of my attempts at understanding the ebuilds in the /usr/portage/ involved, this is what I get:

Code:

ukrainian # emerge -s gtk+
[ Results for search key : gtk+ ]
Searching...

*o x11-libs/gtk+
      Latest version installed: 3.4.4
      Homepage:      http://www.gtk.org/
      Description:   Gimp ToolKit +
      License:       LGPL-2+

*  x11-libs/gtk+extra
      Latest version available: 3.0.5
      Latest version installed: [ Not Installed ]
...[snip]...

And I know I didn't install gtk+ afterwards. What it said, see the top of this post you're reading, was that it installed gtk+-2.24.26.

Could be that one is the rename of the other. Don't really understand this.

So I'll start afresh, but this time I'll post the /etc/portage/package.{use,mask,unmask,{,accept_,}keywords,license} and keep strict notes at what changes I try in which of these, and in the /etc/portage/make.conf, and with what results.

It looks to me this is where the battle will be at for a while, as lots of package maintainers have been including mandatory dbus dependencies (and I'm afraid while some of it is poor naїvety, some of it could be worse, but you judge for yourself:
BSD developer Poul-Heening Kamp on NSA Operation Orchestra
http://video.fosdem.org/2014/Janson/Sunday/NSA_operation_ORCHESTRA_Annual_Status_Report.webm
)

And for that reason, it might turn out we have an ongoing work, this getting rid of dbus.

So, the starting point, for all of my portage confs.

I've gone through, well summarily, and, as best as I could figure out or often just guess, I cleaned some from a little of old fluff, esp. package.use. Just, the content of the first one, the Freemail in /etc/portage/package.accept_keywords is my spiteful aspiration, not there yet.

/etc/portage/package.accept_keywords:
Code:

net-mail/Freemail **


/etc/portage/package.keywords:
Code:

=net-misc/openssh-6.6.1_p1-r3
=app-admin/syslog-ng-3.4.8
=sys-apps/man-db-2.6.7.1
=x11-libs/gtk+-2.24.26
#=www-client/midori-0.5.5


/etc/portage/package.license:
Code:

>=media-libs/faac-1.28-r4 MPEG-4
>=media-fonts/corefonts-1-r6 MSttfEULA


/etc/portage/package.mask:
Code:

media-video/libav
gnome-base/gconf
>=app-crypt/gnupg-2.0.22
app-accessibility/at-spi2-atk
app-accessibility/at-spi2-core
sys-apps/dbus
sys-auth/polkit
sys-auth/consolekit
media-sound/pulseaudio
sys-apps/systemd
sys-fs/udev
sys-fs/udev-init-scripts
x11-drivers/xf86-input-evdev
>=sys-apps/hwids-20140509
=app-admin/syslog-ng-3.5.6
=net-misc/openssh-6.6.1_p1-r4
=app-admin/syslog-ng-3.6.1
=app-admin/syslog-ng-3.6.2
=sys-apps/man-db-2.7.1
# (steveL) pulls in gdbus
>=x11-libs/gtk+-3.10.0


/etc/portage/package.unmask:
Code:

#...[EMPTY]...


/etc/portage/package.use
Code:

x11-base/xorg-server -udev
sys-kernel/linux-firmware savedconfig
x11-wm/openbox xdg imlib
x11-drivers/xf86-video-ati -glamor
x11-libs/libXfont truetype
dev-libs/libxml2 python
# required by x11-libs/glamor-0.6.0-r1
>=media-libs/mesa-10.1.0 gbm
x11-terms/rxvt-unicode pixbuf
>=app-text/ghostscript-gpl-9.14 cups
virtual/ffmpeg threads sdl jpeg2k mp3 x264 X theora vdpau
media-libs/mlt xml ffmpeg python gtk melt frei0r sdl kde qt4
media-sound/audacity alsa ffmpeg flac id3tag jack ladspa libsamplerate midi mp3 soundtouch twolame vamp vorbis
media-plugins/gst-plugins-meta ogg vorbis X a52 aac alsa dts dv dvb dvd esd ffmpeg flac lame mms mp3 mpeg musepack mythtv oss taglib theora v4l vcd vpx wavpack xv
media-video/vlc dvd ffmpeg mpeg mad wxwindows aac dts a52 ogg flac theora oggvorbis matroska freetype postproc xv svga gnutls stream vlm
sys-libs/zlib minizip
media-video/ffmpeg X aac alsa amr aviocat avx bzip2 cpudetection cws2fws dirac encode faac ffeval frei0r graph2dot hardcoded-tables ieee1394 ismindex jpeg2k mmx mp3 oss pic pktdumper qt-faststart schroedinger sdl theora threads trasher truetype v4l v4l2 vdpau vorbis vpx x264 xvid zlib 3dnow 3dnowext aacplus ass rtmp speex cdio gnutls gsm jack libass mmxext modplug network openssl sse sse2 vaapi fontconfig libcaca libsoxr twolame
media-video/gpac sdl ssl a52 aac alsa ffmpeg jack jpeg jpeg2k mad opengl png theora truetype vorbis xml xvi
media-libs/swfdec  gtk alsa ffmpeg gstreamer
media-gfx/imagemagick X jpeg lcms png svg tiff truetype xml corefonts djvu fftw fontconfig fpx graphviz hdri jbig jpeg2k lqr openexr pango perl postscript webp wmf
media-libs/alsa-lib python
dev-vcs/git cgi doc gtk highlight tk
# required by firefox
media-libs/libpng apng
www-servers/apache doc suexec
dev-lang/tk truetype
www-apps/cgit vhosts
www-client/firefox -dbus
x11-libs/gtk+ -dbus -introspection
app-portage/layman gpg
>=media-libs/gst-plugins-base-1.2.4-r1 theora
media-libs/harfbuzz icu
app-doc/pms html
>=dev-vcs/subversion-1.8.9 -dso perl
dev-libs/cyrus-sasl pam
mail-mta/postfix pam doc
net-analyzer/wireshark caps crypt doc filecaps ipv6 netlink pcap qt4 ssl zlib lua
media-video/mplayer dts doc faac libmpeg2 md5sum mp3 toolame twolame
mail-client/mutt doc imap mbox pop smime gpg smtp ssl -gnutls
net-mail/dovecot doc imapc pam
sys-apps/portage doc
net-misc/stunnel -ipv6
dev-vcs/mercurial gpg tk
net-analyzer/nmap ncat ndig nping
app-admin/ulogd doc pcap -nfacct -sqlite
net-dns/bind-tools doc
app-text/poppler qt4
net-firewall/conntrack-tools doc
app-emulation/wine -gstreamer -udisks xcomposite mp3
# required by net-analyzer/sslscan-1.8.2
net-libs/libnftnl examples
>=sys-process/lsof-4.88 rpc examples
app-editors/vim lua python perl
virtual/rubygems ruby_targets_ruby21
net-fs/nfs-utils ipv6 libmount nfsidmap nfsv4 -tcpd -uuid
#net-libs/webkit-gtk X egl gstreamer introspection jit opengl webgl -coverage -debug -geoloc -gles2 -libsecret -spell -wayland
#www-client/midori jit webkit2 deprecated -doc -granite -introspection -geoloc -zeitgeist
#>=net-libs/libsoup-2.48.1 introspection

And the last three lines were my attempts that I rushed through hoping to finish effortlessly, but it didn't happen.

The emerge --info takes more space. I'll put it in a post of its own. I know it's a little risk posting your confs, but it's much more benefits you get, because your problem gets solved for you and hopefully for others.

And, I used this command to prepare the confs for posting:

Code:

for i in `ls -1 /etc/portage/package.{use,mask,unmask,{,accept_,}keywords,license}` ; do echo "==== This is TOP marker so I can work it out in vim or you in nano" >> This_post_you_are_reading.txt ;  echo $i >> This_post_you_are_reading.txt ; cat $i >> This_post_you_are_reading.txt ;  echo "==== This is BOTTOM marker so I can work it out in vim or you in nano" >> This_post_you_are_reading.txt ; echo >> This_post_you_are_reading.txt ; done ;

and then worked it a little in vim to get what you've just viewed.


Last edited by miroR on Tue Mar 10, 2015 3:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 5:11 pm    Post subject: Reply with quote

emerge --info:
Code:

Portage 2.2.18 (python 2.7.9-final-0, hardened/linux/amd64, gcc-4.8.4, glibc-2.20-r2, 3.18.8-hardened-150302-05 x86_64)
=================================================================
System uname: Linux-3.18.8-hardened-150302-05-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:    16405372 total,   3267048 free
KiB Swap:   20971516 total,  20955028 free
Timestamp of repository gentoo: Fri, 06 Mar 2015 00:45:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.25 p1.0) 2.25
app-shells/bash:          4.3_p33-r2::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r2::gentoo, 3.3.5-r1::gentoo
dev-util/cmake:           3.1.0::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.11::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25::gentoo
sys-devel/gcc:            4.8.4::gentoo, 4.9.2::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

ukrainian
    location: /var/lib/layman
    masters: gentoo
    priority: 0

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

ABI="amd64"
ABI_X86="64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"

ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x
ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3
trident usb-audio via82xx via82xx-modem ymfpci hda-intel"

ANT_HOME="/usr/share/ant"

APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias
auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user autoindex
cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires
ext_filter file_cache filter headers include info log_config logio mem_cache
mime mime_magic negotiation rewrite setenvif speling status unique_id userdir
usertrack vhost_alias"

ARCH="amd64"

AUTOCLEAN="yes"

BOOTSTRAP_USE="cxx unicode internal-glib python_targets_python3_3
python_targets_python2_7 multilib hardened pax_kernel pic xtpax -jit -orc"

CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author"
CAMERAS="ptp2"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CFLAGS_amd64="-m64"
CFLAGS_x32="-mx32"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x32="x86_64-pc-linux-gnux32"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
COLLISION_IGNORE="/lib/modules/* *.py[co] *$py.class */dropin.cache"
COLORTERM="rxvt-xpm"

CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc"

CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d
/etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild
/etc/sandbox.d /etc/terminfo"

CPU_FLAGS_X86="mmx mmxext sse sse2 sse3"
CVS_RSH="ssh"
CXXFLAGS="-march=native -O2 -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vi"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--keep-going --with-bdeps=y --autounmask-keep-masks --ask --verbose"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FCFLAGS="-O2 -pipe"

FEATURES="assume-digests binpkg-logs candy config-protect-if-modified
distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs
protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs
unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"

FETCHCOMMAND="wget -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}"
-a /var/log/portage_logs/wget-fetch.log"

FETCHCOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""

FETCHCOMMAND_SFTP="bash -c "x=\${2#sftp://} ; host=\${x%%/*} ;
port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ;
eval \"declare -a ssh_opts=(\${3})\" ; exec sftp -P \${port}
\"\${ssh_opts[@]}\" \"\${host}:/\${x#*/}\" \"\$1\"" sftp "${DISTDIR}/${FILE}"
"${URI}" "${PORTAGE_SSH_OPTS}""

FETCHCOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:}
; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync
--rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync
"${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""

FFLAGS="-O2 -pipe"

FLTK_DOCDIR="/usr/share/doc/fltk-1.3.3-r3/html"

GCC_SPECS=""

GENTOO_MIRRORS="http://192.168.3.2/gentoo/"

GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt
gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2
rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx"

GRUB_PLATFORMS="pc multiboot"

GUILE_LOAD_PATH="/usr/share/guile/1.8"

HOME="/root"

INFOPATH="/usr/share/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.8.4/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.25/info"

INPUT_DEVICES="mouse keyboard"
INSTALL_MASK=" /usr/lib/systemd"
IUSE_IMPLICIT="abi_x86_64 prefix prefix-guest"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KERNEL="linux"
LADSPA_PATH="/usr/lib64/ladspa"
LANG="en_GB.utf8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_MESSAGES="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LDFLAGS_amd64="-m elf_x86_64"
LDFLAGS_x32="-m elf32_x86_64"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_arm="lib"
LIBDIR_arm64="lib64"
LIBDIR_n32="lib32"
LIBDIR_n64="lib64"
LIBDIR_o32="lib"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_s390="lib32"
LIBDIR_s390x="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x32="libx32"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32" LIBREOFFICE_EXTENSIONS="presenter-console
presenter-minimizer" LOGNAME="root"

LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;
41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;
31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;
31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;
31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;
31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;
35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;
35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;
35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;
35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;
32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;
36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"

MAIL="/var/mail/root"

MAKEOPTS="-j7"

MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.8.4/man:
/usr/share/binutils-data/x86_64-pc-linux-gnu/2.25/man:/etc/java-config-2/current-system-vm/man/"

MULTILIB_ABIS="amd64 x86"

MULTILIB_STRICT_DENY="64-bit.*shared object"

MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32
/usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"

MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage|udev|systemd|clang|python-exec)"

NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb
php profiler soa visualweb webcommon websvccommon xml"

NOCOLOR="true"

OFFICE_IMPLEMENTATION="libreoffice"

OLDPWD="/home/ukrainian"

OPENGL_PROFILE="xorg-x11"

PAGER="/usr/bin/less"

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.8.4"

PAX_MARKINGS="XT"

PHP_TARGETS="php5-5"

PKGDIR="/usr/portage/packages"

PORTAGE_ARCHLIST="alpha amd64 amd64-fbsd amd64-linux arm arm-linux arm64 hppa
hppa-hpux ia64 ia64-hpux ia64-linux m68k m68k-mint mips ppc ppc-aix ppc-macos
ppc-openbsd ppc64 ppc64-linux s390 sh sparc sparc-fbsd sparc-solaris
sparc64-freebsd sparc64-solaris x64-freebsd x64-macos x64-openbsd x64-solaris
x86 x86-cygwin x86-fbsd x86-freebsd x86-interix x86-linux x86-macos x86-netbsd
x86-openbsd x86-solaris x86-winnt"

PORTAGE_BIN_PATH="/usr/lib/portage/python2.7"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="info warn error log qa"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_GPG_DIR="/etc/portage/gpg"

PORTAGE_GPG_SIGNING_COMMAND="gpg --sign --digest-algo SHA256 --clearsign --yes
--default-key "${PORTAGE_GPG_KEY}" --homedir "${PORTAGE_GPG_DIR}" "${FILE}""

PORTAGE_INST_GID="0"

PORTAGE_INST_UID="0"

PORTAGE_INTERNAL_CALLER="1"

PORTAGE_OVERRIDE_EPREFIX=""

PORTAGE_PYM_PATH="/usr/lib64/python2.7/site-packages"

PORTAGE_PYTHONPATH="/usr/lib64/python2.7/site-packages"

PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
--omit-dir-times --compress --force --whole-file --delete --stats
--human-readable --timeout=180 --exclude=/distfiles --exclude=/local
--exclude=/packages"

PORTAGE_RSYNC_RETRIES="-1"

PORTAGE_SYNC_STALE="30"

PORTAGE_TMPDIR="/var/tmp"

PORTAGE_VERBOSE="1"

PORTAGE_WORKDIR_MODE="0700"

PORTAGE_XATTR_EXCLUDE="btrfs.* security.* system.nfs4_acl"

PORT_LOGDIR="/var/log/portage_logs"

PORT_LOGDIR_CLEAN="find /var/log/portage_logs -type f ! -name summary.log*
-mtime +90 -delete"

PRELINK_PATH_MASK="/usr/lib64/libfreebl3.so:/usr/lib64/libnssdbm3.so:/usr/lib64/libsoftokn3.so"

PROFILE_IS_HARDENED="1"

PROFILE_ONLY_VARIABLES="ARCH ELIBC IUSE_IMPLICIT KERNEL USERLAND
USE_EXPAND_IMPLICIT USE_EXPAND_UNPREFIXED USE_EXPAND_VALUES_ARCH
USE_EXPAND_VALUES_ELIBC USE_EXPAND_VALUES_KERNEL USE_EXPAND_VALUES_USERLAND"

PWD="/root"

PYTHONDONTWRITEBYTECODE="1"

PYTHON_SINGLE_TARGET="python2_7"

PYTHON_TARGETS="python2_7 python3_3"

QT_GRAPHICSSYSTEM="raster"

RESUMECOMMAND="wget -c -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}"
"${URI}" -a /var/log/portage_logs/wget-fetch.log"

RESUMECOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""

RESUMECOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ;
port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ;
exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\""
rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""

ROOT="/"

ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.8.4"

RPMDIR="/usr/portage/rpm"

RUBY_TARGETS="ruby19 ruby20"

SHELL="/bin/bash"

SHLVL="1"

SUDO_COMMAND="/bin/bash"

SUDO_GID="1000"

SUDO_UID="1000"

SUDO_USER="ukrainian"

SYMLINK_LIB="yes"

TERM="rxvt-unicode"

TIME_STYLE="posix-long-iso"

UNINSTALL_IGNORE="/lib/modules/* /var/run /var/lock"

USE="X a52 acl alsa amd64 apache2 audit bash-completion berkdb bzip2 caps cdr
cli cracklib crypt cscope css cxx dri dvb dvdr fam ffmpeg fontconfig gdbm gif
git gnutls gpm gstreamer gzip hardened iconv imagemagick ipv6 jack jpeg jpeg2k
justify lame libcaca mad maildir mhash mmx mng modules mplayer multilib
ncurses nls nptl ogg opengl openmp pax_kernel pcre png readline sasl sdl
session smp sound sox sqlite sqlite3 sse sse2 ssl subversion svg sysvipc tcpd
tiff truetype unicode urandom v4l vim-syntax vorbis x264 xattr xine xtpax xv
xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x
ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0
intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci hda-intel"
APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias
auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user autoindex
cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires
ext_filter file_cache filter headers include info log_config logio mem_cache
mime mime_magic negotiation rewrite setenvif speling status unique_id userdir
usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage
tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df
interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse
sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18
garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle
oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx"
GRUB_PLATFORMS="pc multiboot" INPUT_DEVICES="mouse keyboard" KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses
text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer"
OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5"
PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3"
RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon vesa"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface
geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac
delude chaos account"

USER="root"

USERLAND="GNU"

USERNAME="root"

USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES
APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CPU_FLAGS_X86
CROSSCOMPILE_OPTS CURL_SSL DRACUT_MODULES DVB_CARDS ELIBC
ENLIGHTENMENT_MODULES FCDSL_CARDS FFTOOLS FOO2ZJS_DEVICES FRITZCAPI_CARDS
GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL LCD_DEVICES
LIBREOFFICE_EXTENSIONS LINGUAS LIRC_DEVICES MONKEYD_PLUGINS NETBEANS_MODULES
NGINX_MODULES_HTTP NGINX_MODULES_MAIL OFED_DRIVERS OFFICE_IMPLEMENTATION
OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS
PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS
RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS
VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"

USE_EXPAND_HIDDEN="ABI_MIPS ABI_PPC ABI_S390 CROSSCOMPILE_OPTS ELIBC KERNEL
USERLAND"

USE_EXPAND_IMPLICIT="ARCH ELIBC KERNEL USERLAND"

USE_EXPAND_UNPREFIXED="ARCH"

USE_EXPAND_VALUES_ARCH="alpha amd64 amd64-fbsd amd64-linux arm arm-linux arm64
hppa hppa-hpux ia64 ia64-hpux ia64-linux m68k m68k-mint mips ppc ppc64
ppc64-linux ppc-aix ppc-macos ppc-openbsd s390 sh sparc sparc64-freebsd
sparc64-solaris sparc-fbsd sparc-solaris x64-freebsd x64-macos x64-openbsd
x64-solaris x86 x86-cygwin x86-fbsd x86-freebsd x86-interix x86-linux
x86-macos x86-netbsd x86-openbsd x86-solaris x86-winnt"

USE_EXPAND_VALUES_ELIBC="AIX Cygwin Darwin DragonFly FreeBSD glibc HPUX
Interix mintlib musl NetBSD OpenBSD SunOS uclibc Winnt"

USE_EXPAND_VALUES_KERNEL="AIX Cygwin Darwin FreeBSD freemint HPUX Interix
linux NetBSD OpenBSD SunOS Winnt" USE_EXPAND_VALUES_USERLAND="BSD GNU"
USE_ORDER="env:pkg:conf:defaults:pkginternal:repo:env.d" VIDEO_CARDS="radeon
vesa" XAUTHORITY="/home/ukrainian/.Xauthority" XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq
steal rawnat logmark ipmark dhcpmac delude chaos account"
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 5:20 pm    Post subject: Reply with quote

And, oh kay, in these exact circumstances the crime ;-) of indirect imposition of the dbus is being committed, like so:

Code:

ukrainian #  emerge -tuDN midori |& tee /Cmn/BAK_/emerge.d/emerge-tuDN_midori_`date +%s`

These are the packages that would be merged, in reverse order:

Calculating dependencies  .... done!

!!! The ebuild selected to satisfy ">=net-libs/webkit-gtk-1.11.91:3[jit=]" has unmet requirements.
- net-libs/webkit-gtk-2.4.8::gentoo USE="X egl geoloc gstreamer opengl webgl (-aqua) -coverage -debug -gles2 -introspection -jit -libsecret -spell -test -wayland" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    geoloc? ( introspection )

  The above constraints are a subset of the following complete expression:
    geoloc? ( introspection ) introspection? ( gstreamer ) gles2? ( egl ) webgl? ( exactly-one-of ( gles2 opengl ) ) !webgl? ( at-most-one-of ( gles2 opengl ) ) any-of ( aqua wayland X )

(dependency required by "www-client/midori-0.5.8-r1::gentoo" [ebuild])
(dependency required by "midori" [argument])
ukrainian #

I sure have to play with these geoloc, introspection and other flags, and surely I have already seen them in NeddySeagoon's paste further above, amd played already (and didn't keep good notice of the circumstances during different tries), but in my not too few hasty attempts previously, I hadn't made it...

Will report the exact circumstances and if the whether has changed and dispelled the criminal behavior :-) .


Last edited by miroR on Tue Mar 10, 2015 3:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 5:52 pm    Post subject: Reply with quote

Previously to changing anything in the confs:
Code:

ukrainian #  emerge -p webkit-gtk |& tee /Cmn/BAK_/emerge.d/emerge-p_webkit-gtk_`date +%s`

These are the packages that would be merged, in order:

Calculating dependencies  .

!!! Problem resolving dependencies for net-libs/webkit-gtk
... done!

!!! The ebuild selected to satisfy "webkit-gtk" has unmet requirements.
- net-libs/webkit-gtk-2.6.5::gentoo USE="egl geoloc gstreamer opengl webgl -coverage -doc -introspection -jit -libsecret -spell -test" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    geoloc? ( introspection )

  The above constraints are a subset of the following complete expression:
    geoloc? ( introspection ) introspection? ( gstreamer )

ukrainian #

this is simpler than before.

Just to say that the commented out bottom three lines in the package.use were some of my previous hastily tries. I left them so to use them to easier make changes.

Trying to change just, adding:
Code:

net-libs/webkit-gtk -geoloc

everything else as posted a little while ago.

Wow! This could now work!

Code:

ukrainian #  emerge -p webkit-gtk

These are the packages that would be merged, in order:

Calculating dependencies  .. ..... done!
[ebuild  N     ] net-libs/libproxy-0.4.11-r2::gentoo  USE="-gnome -kde -mono -networkmanager -perl -python -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 92 KiB
[ebuild  N     ] net-libs/glib-networking-2.42.1::gentoo  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="(64) -32 (-x32)" 366 KiB
[ebuild  N     ] net-libs/libsoup-2.48.1:2.4::gentoo  USE="ssl -debug -introspection -samba {-test}" ABI_X86="(64) -32 (-x32)" 1,668 KiB
[ebuild  N     ] net-libs/webkit-gtk-2.4.8-r200:2::gentoo  USE="X egl gstreamer opengl webgl (-aqua) -coverage -debug -geoloc -gles2 -introspection -jit -libsecret -spell {-test}" 9,598 KiB

Total: 4 packages (4 new), Size of downloads: 11,723 KiB
ukrainian #


Would the installation of midori now work?

Code:

ukrainian #  emerge midori |& tee /Cmn/BAK_/emerge.d/emerge_midori_`date +%s`

These are the packages that would be merged, in order:

Calculating dependencies  ..... done!

!!! All ebuilds that could satisfy ">=sys-apps/dbus-1" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.8.16::gentoo (masked by: package.mask)

(dependency required by "app-crypt/gcr-3.14.0::gentoo" [ebuild])
(dependency required by "www-client/midori-0.5.8-r1::gentoo[-deprecated]" [ebuild])
(dependency required by "midori" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

ukrainian #


Nope! Not yet! And I seen those gcr before (in my hastily attempts), and I start fear those dddbbbuuusss ...

However, I want to think a little about what to try next, and while I decide (and I may decide by some Elder's advice, if any comes in the meantime), I want to look up what this gcr is, and why is it needed here...
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 6:16 pm    Post subject: Reply with quote

Just the start of the ebuild:

Code:

# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.14.0.ebuild,v 1.3 2015/03/03 05:42:24 dlan Exp $

EAPI="5"
GCONF_DEBUG="no"
VALA_USE_DEPEND="vapigen"
PYTHON_COMPAT=( python2_7 )

inherit autotools eutils gnome2 python-any-r1 vala virtualx

DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
HOMEPAGE="https://developer.gnome.org/gcr/"

LICENSE="GPL-2+ LGPL-2+"
SLOT="0/1" # subslot = suffix of libgcr-3
IUSE="debug gtk +introspection vala"
REQUIRED_USE="vala? ( introspection )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"

COMMON_DEPEND="
   >=app-crypt/gnupg-2
   >=app-crypt/p11-kit-0.19
   >=dev-libs/glib-2.34:2
   >=dev-libs/libgcrypt-1.2.2:0=
   >=dev-libs/libtasn1-1:=
   >=sys-apps/dbus-1
   gtk? ( >=x11-libs/gtk+-3:3[introspection?] )
   introspection? ( >=dev-libs/gobject-introspection-1.34 )
"
RDEPEND="${COMMON_DEPEND}
   !<gnome-base/gnome-keyring-3.3
"
...


A Gnome package, a bit of bloat on top of the minimum user cryptography that I need (such as I used in my demonstration of Google's brute mess-up of my connection 10 months ago), and which [bloated cryptography] surely dbus would need for its third parties... Thanks a lot, but, please, no!

But what puzzles me, is how come Neddy demonstration (this same page of this topic) would get him the same midori without forcing gcr and dbus onto him, and my attempt would only get me that same midori (www-client/midori-0.5.8-r1) only with gcr and dbus.

What do I have wrong, or, just, different, what makes in my case, for that different behavior.


Last edited by miroR on Tue Mar 10, 2015 3:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 7:29 pm    Post subject: Reply with quote

This tells so much:
Code:

ukrainian # grep introspect /usr/portage/profiles/use.desc
introspection - Add support for GObject based introspection
ukrainian #

It tells all, like telling to somebody who doesn't know what one word means, a whole explanation with, basically, another word which he doesn't know what it means...

What is GObject?

But I'll try and add that use flag, again in packege.use.

So the line that I already added to packege.use I now change to:

Code:

net-libs/webkit-gtk -geoloc introspection


And I try:

emerge midori:
Code:

... was same output ...


What is jit?

Code:

ukrainian # grep jit /usr/portage/profiles/use.desc
jit - Enable just-in-time compilation for improved performance. May prevent use of some PaX memory protection features in Gentoo Hardened.
ukrainian #


I don't want to leave any stones unturned, so I'll try it, but revert back if it doesn't work.

Change to:

Code:

net-libs/webkit-gtk -geoloc introspection jit


Nope:

Code:

ukrainian #  emerge midori |& tee /Cmn/BAK_/emerge.d/emerge_midori_`date +%s`

These are the packages that would be merged, in order:

Calculating dependencies  .. .... done!

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by www-client/midori-0.5.8-r1::gentoo[-deprecated,webkit2]
# required by midori (argument)
>=net-libs/webkit-gtk-2.4.8:3 -jit
^Cukrainian #

Cancelled. It can't be enabled. Not that it were clear to me why. But reverting, I need PaX.

What I know sometimes happens, is, if something won't get installed right away such as midori won't, maybe if will after I install some of the packages that it needs.

I'll try (since no advice from any Elders), and install the webkit-gtk, and see if midori will be more condescending then.

And, with this `introspection' flag there (and `-jit' reverted to), now it wants to install it this way:

Code:

ukrainian #  emerge webkit-gtk |& tee /Cmn/BAK_/emerge.d/emerge_webkit-gtk_`date +%s`

These are the packages that would be merged, in order:

Calculating dependencies  ..... done!
[ebuild  N     ] dev-libs/gobject-introspection-1.42.0-r1::gentoo  USE="-cairo -doctool {-test}" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ] net-libs/libproxy-0.4.11-r2::gentoo  USE="-gnome -kde -mono -networkmanager -perl -python -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 92 KiB
[ebuild  N     ] net-libs/glib-networking-2.42.1::gentoo  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="(64) -32 (-x32)" 366 KiB
[ebuild  N     ] net-libs/libsoup-2.48.1:2.4::gentoo  USE="introspection ssl -debug -samba {-test}" ABI_X86="(64) -32 (-x32)" 1,668 KiB
[ebuild  N     ] net-libs/webkit-gtk-2.4.8-r200:2::gentoo  USE="X egl gstreamer introspection opengl webgl (-aqua) -coverage -debug -geoloc -gles2 -jit -libsecret -spell {-test}" 9,598 KiB

Total: 5 packages (5 new), Size of downloads: 11,723 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-libs/webkit-gtk-2.4.8-r200::gentoo
# required by webkit-gtk (argument)
>=net-libs/libsoup-2.48.1 introspection
^Cukrainian #

Canceled.

And I can finally understand better what introspection stands for, from the:
/usr/portage/dev-libs/gobject-introspection/gobject-introspection-1.42.0-r1.ebuild:
Code:

...
DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
...


Also you can see that I've been here, with my hasty tries earlier, and so I'll now uncomment the commented out line in package.use, so that it reads:
Code:

>=net-libs/libsoup-2.48.1 introspection


And I wonder if this one is pulling dbus, maybe,

/usr/portage/net-libs/glib-networking/glib-networking-2.42.1.ebuild:
Code:

# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/glib-networking-2.42.1.ebuild,v 1.2 2015/01/11 12:11:08 eva Exp $

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"

inherit autotools eutils gnome2 multilib-minimal virtualx

DESCRIPTION="Network-related giomodules for glib"
HOMEPAGE="http://git.gnome.org/browse/glib-networking/"

LICENSE="LGPL-2+"
SLOT="0"
IUSE="+gnome +libproxy smartcard +ssl test"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"

RDEPEND="
    >=dev-libs/glib-2.42:2[${MULTILIB_USEDEP}]
    gnome? ( gnome-base/gsettings-desktop-schemas )
    libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
    smartcard? (
        >=app-crypt/p11-kit-0.18.4[${MULTILIB_USEDEP}]
        >=net-libs/gnutls-3:=[pkcs11,${MULTILIB_USEDEP}] )
    ssl? (
        app-misc/ca-certificates
        >=net-libs/gnutls-3:=[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
    >=dev-util/intltool-0.35.0
    sys-devel/gettext
    >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
    test? ( sys-apps/dbus[X] )
"

dbus only on just two lines above here:
Code:

    test? ( sys-apps/dbus[X] )

and I got `-test' flag, so it should not pull dbus in.

I also looked up net-libs/glib-networking, and it doesn't look fishy.

So trying (but not repeating the same output as above, for:
Code:

ukrainian #  emerge webkit-gtk
...

Just this time I didn't cancel it. but accepted it. There wouldn't be any
Code:

^Cukrainian #
in bottom of the output (the paste) as it was then. I'm not pasting it, because that would be the sole difference from the canceled paste above.

It's churning on. It already is at the 5th package, the webkit-gtk. I'll post this while I wait.


Last edited by miroR on Tue Mar 10, 2015 3:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sat Mar 07, 2015 9:12 pm    Post subject: Reply with quote

emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`
was no different from the emerge --info given above.

emerge -pqv '=net-libs/webkit-gtk-2.4.8-r200::gentoo'
Code:

[ebuild  N    ] net-libs/webkit-gtk-2.4.8-r200  USE="X egl gstreamer introspection opengl webgl (-aqua) -coverage -debug -geoloc -gles2 -jit -libsecret -spell {-test}"


And from the
/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log, I left
those lines that contain the string `gir', and a few lines around them:
Code:

 * Package:    net-libs/webkit-gtk-2.4.8-r200
...[268 lines skipped]...
config.status: creating GNUmakefile
config.status: creating Source/WebCore/platform/gtk/po/POTFILES
config.status: creating Source/JavaScriptCore/javascriptcoregtk-1.0.pc
config.status: creating JavaScriptCore-1.0.gir
config.status: creating Source/WebKit/gtk/webkit/webkitversion.h
config.status: creating Source/WebKit/gtk/webkit-1.0.pc
config.status: creating autotoolsconfig.h
..[5827 lines skipped]...
...[1 really long lind skipped]...
libtool: link: x86_64-pc-linux-gnu-ranlib .libs/libWebCorePlatform.a
libtool: link: ( cd ".libs" && rm -f "libWebCorePlatform.la" && ln -s "../libWebCorePlatform.la" "libWebCorePlatform.la" )
/usr/bin/g-ir-compiler --includedir ./Source/WebKit/gtk --includedir . JavaScriptCore-1.0.gir -o JavaScriptCore-1.0.typelib
test ! -d ./Source/WebCore/platform/gtk/po || \
 mkdir -p ./Source/WebCore/platform/gtk/po
test ! -f ./Source/WebCore/platform/gtk/po/WebKitGTK-2.0.pot || \
...[1 really long lind skipped]...
make[2]: Entering directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
libtool: link: x86_64-pc-linux-gnu-ar cruT .libs/libGObjectDOMBindings.a Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-ConvertToUTF8String.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-DOMObjectCache.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-GObjectEventListener.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-WebKitDOMCustom.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-WebKitDOMDeprecated.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-WebKitDOMEventTarget.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLPrivate.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-WebKitDOMObject.o Source/WebCore/bindings/gobject/.libs/libGObjectDOMBindings_la-WebKitDOMPrivate.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMAttr.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMBarProp.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMBatteryManager.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMBlob.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMCDATASection.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMCharacterData.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMComment.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMConsole.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMCSSRule.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMCSSRuleList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMCSSStyleDeclaration.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMCSSStyleSheet.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMCSSValue.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDatabase.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDocument.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDocumentFragment.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDocumentType.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMApplicationCache.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMImplementation.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMMimeTypeArray.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMMimeType.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMNamedFlowCollection.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMPluginArray.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMPlugin.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMSecurityPolicy.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMSelection.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMStringList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMStringMap.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMSettableTokenList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMTokenList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMWindow.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMDOMWindowCSS.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMEntityReference.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMEvent.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMFile.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMFileList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMGamepad.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMGamepadList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMGeolocation.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHistory.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLAnchorElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLAppletElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLAreaElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLBaseElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLBaseFontElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLBodyElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLBRElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLButtonElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLCanvasElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLCollection.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLDetailsElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLDirectoryElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLDivElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLDListElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLDocument.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLEmbedElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLFieldSetElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLFontElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLFormElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLFrameElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLFrameSetElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLHeadElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLHeadingElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLHRElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLHtmlElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLIFrameElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLImageElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLInputElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLKeygenElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLLabelElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLLegendElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLLIElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLLinkElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLMapElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLMarqueeElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLMediaElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLMenuElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLMetaElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLModElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLObjectElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLOListElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLOptGroupElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLOptionElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLOptionsCollection.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLParagraphElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLParamElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLPreElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLQuoteElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLScriptElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLSelectElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLStyleElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTableCaptionElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTableCellElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTableColElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTableElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTableRowElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTableSectionElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTextAreaElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLTitleElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLUListElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMKeyboardEvent.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMLocation.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMMediaController.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMMediaError.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMMediaList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMMediaQueryList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMMessagePort.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMMouseEvent.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMNamedNodeMap.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMNavigator.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMNode.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMNodeFilter.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMNodeIterator.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMNodeList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMPerformance.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMPerformanceEntry.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMPerformanceEntryList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMPerformanceNavigation.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMPerformanceTiming.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMProcessingInstruction.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMRange.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMScreen.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMShadowRoot.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMStorage.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMStorageInfo.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMStorageQuota.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMStyleMedia.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMStyleSheet.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMStyleSheetList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMText.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTouch.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTimeRanges.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTreeWalker.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMUIEvent.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMValidityState.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMWebKitPoint.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMWebKitNamedFlow.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMWheelEvent.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMXPathExpression.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMXPathNSResolver.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMXPathResult.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLAudioElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMHTMLVideoElement.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMAudioTrack.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMAudioTrackList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTextTrack.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTextTrackList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTextTrackCue.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTextTrackCueList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMVideoPlaybackQuality.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMVideoTrack.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMVideoTrackList.o DerivedSources/webkitdom/.libs/libGObjectDOMBindings_la-WebKitDOMTrackEvent.o
...[6389 lines skipped]...
libtool: link: x86_64-pc-linux-gnu-g++ -fno-strict-aliasing -fno-rtti -I/usr/include -march=native -O2 -pipe -pthread -std=c++11 -Wno-c++11-compat -Wl,-O1 -Wl,--as-needed -Wl,--no-keep-memory -Wl,--reduce-memory-overheads -Wl,--no-demangle -o Programs/.libs/jsc-1 Source/JavaScriptCore/Programs_jsc_1-jsc.o  ./.libs/libjavascriptcoregtk-1.0.so -lpthread -lz -lgmodule-2.0 -lgthread-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -licui18n -licuuc -licudata -pthread
cp -f Programs/jsc-1 Programs/jsc
libtool: link: x86_64-pc-linux-gnu-g++  -fPIC -DPIC -shared -nostdlib /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/../../../../lib64/crti.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/crtbeginS.o  Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-AcceleratedCompositingContextGL.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-AssertMatchingEnums.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-BatteryClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-ChromeClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-ContextMenuClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-DeviceMotionClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-DeviceOrientationClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-DocumentLoaderGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-DragClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-DumpRenderTreeSupportGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-EditorClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-FrameLoaderClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-FrameNetworkingContextGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-GeolocationClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-GtkAdjustmentWatcher.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-InspectorClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-NavigatorContentUtilsClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-PlatformStrategiesGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-ProgressTrackerClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-UserMediaClientGtk.o Source/WebKit/gtk/WebCoreSupport/.libs/libwebkitgtk_1_0_la-WebViewInputMethodFilter.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitapplicationcache.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitauthenticationdialog.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitdownload.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkiterror.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitfavicondatabase.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitfilechooserrequest.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitgeolocationpolicydecision.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitglobals.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkithittestresult.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkiticondatabase.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitnetworkrequest.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitnetworkresponse.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitsecurityorigin.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitsoupauthdialog.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitspellchecker.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitspellcheckerenchant.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitversion.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitviewportattributes.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebbackforwardlist.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebdatabase.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebdatasource.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebframe.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebhistoryitem.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebinspector.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebnavigationaction.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebpolicydecision.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebresource.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebplugin.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebplugindatabase.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebsettings.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebview.o Source/WebKit/gtk/webkit/.libs/libwebkitgtk_1_0_la-webkitwebwindowfeatures.o DerivedSources/webkit/.libs/libwebkitgtk_1_0_la-webkitenumtypes.o DerivedSources/webkit/.libs/libwebkitgtk_1_0_la-webkitmarshal.o  -Wl,--whole-archive ./.libs/libPlatform.a ./.libs/libPlatformGtk.a ./.libs/libWebCore.a ./.libs/libWebCorePlatform.a ./.libs/libWebCoreModules.a ./.libs/libGObjectDOMBindings.a ./.libs/libWebCoreGtk.a ./.libs/libANGLE.a ./.libs/libWebCoreSVG.a -Wl,--no-whole-archive  -Wl,-rpath -Wl,/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8/.libs ./.libs/libjavascriptcoregtk-1.0.so -lpthread -lharfbuzz-icu -lharfbuzz -lgmodule-2.0 -lgthread-2.0 -lgstapp-1.0 -lgstaudio-1.0 -lgstfft-1.0 -lgstpbutils-1.0 -lgstvideo-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -ljpeg -lsoup-2.4 -lgio-2.0 -lxslt -lxml2 -lGL -lEGL -ldl -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype -lpng16 -lsqlite3 -licui18n -licuuc -licudata -lwebp -lXcomposite -lXdamage -lXfixes -lXrender -lXt -lX11 -lz -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/../../../../x86_64-pc-linux-gnu/lib -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/crtendS.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/../../../../lib64/crtn.o  -march=native -O2 -pthread -Wl,--version-script -Wl,./Source/autotools/symbols.filter -Wl,-O1 -Wl,--as-needed -Wl,--no-keep-memory -Wl,--reduce-memory-overheads -Wl,--no-demangle -Wl,--export-dynamic -pthread -pthread   -pthread -Wl,-soname -Wl,libwebkitgtk-1.0.so.0 -o .libs/libwebkitgtk-1.0.so.0.22.14
libtool: link: (cd ".libs" && rm -f "libwebkitgtk-1.0.so.0" && ln -s "libwebkitgtk-1.0.so.0.22.14" "libwebkitgtk-1.0.so.0")
libtool: link: (cd ".libs" && rm -f "libwebkitgtk-1.0.so" && ln -s "libwebkitgtk-1.0.so.0.22.14" "libwebkitgtk-1.0.so")
libtool: link: ( cd ".libs" && rm -f "libwebkitgtk-1.0.la" && ln -s "../libwebkitgtk-1.0.la" "libwebkitgtk-1.0.la" )
\
     CC="x86_64-pc-linux-gnu-gcc" \
     CFLAGS="-march=native -O2 -pipe -pthread -std=c99   -Wno-deprecated-declarations" \
     /usr/bin/g-ir-scanner \
     --quiet \
     --warn-all \
     --symbol-prefix=webkit \
     --identifier-prefix=WebKit \
     --namespace=WebKit \
     --nsversion=1.0 \
     --include=GObject-2.0 \
     --include=Gtk-2.0 \
     --include=JavaScriptCore-1.0 \
     --include=Soup-2.4 \
     --library=webkitgtk-1.0 \
     --library=javascriptcoregtk-1.0 \
     --libtool="/bin/sh ./libtool" \
     --pkg=gobject-2.0 \
     --pkg=gtk+-2.0 \
     --pkg=libsoup-2.4 \
     --pkg-export=webkitgtk-1.0 \
     --output=WebKit-1.0.gir \
     --add-include-path=./Source/WebKit/gtk \
     --add-include-path=. \
     --c-include="webkit/webkit.h" \
     -DBUILDING_WEBKIT \
     -I./Source \
     -I./Source/WebKit/gtk \
     -I./DerivedSources \
     -I./DerivedSources/webkitdom \
     -I./DerivedSources/webkit \
     -I./Source/WebKit/gtk \
     -I./Source/JavaScriptCore/ForwardingHeaders \
     -I. \
     ./DerivedSources/webkit/webkitenumtypes.h \
     Source/WebKit/gtk/webkit/webkitversion.h ./Source/WebKit/gtk/webkit/webkit.h ./Source/WebKit/gtk/webkit/webkitapplicationcache.h ./Source/WebKit/gtk/webkit/webkitdefines.h ./Source/WebKit/gtk/webkit/webkitdom.h ./Source/WebKit/gtk/webkit/webkitdownload.h ./Source/WebKit/gtk/webkit/webkiterror.h ./Source/WebKit/gtk/webkit/webkitfavicondatabase.h ./Source/WebKit/gtk/webkit/webkitfilechooserrequest.h ./Source/WebKit/gtk/webkit/webkitgeolocationpolicydecision.h ./Source/WebKit/gtk/webkit/webkitglobals.h ./Source/WebKit/gtk/webkit/webkithittestresult.h ./Source/WebKit/gtk/webkit/webkiticondatabase.h ./Source/WebKit/gtk/webkit/webkitnetworkrequest.h ./Source/WebKit/gtk/webkit/webkitnetworkresponse.h ./Source/WebKit/gtk/webkit/webkitsecurityorigin.h ./Source/WebKit/gtk/webkit/webkitsoupauthdialog.h ./Source/WebKit/gtk/webkit/webkitspellchecker.h ./Source/WebKit/gtk/webkit/webkitviewportattributes.h ./Source/WebKit/gtk/webkit/webkitwebbackforwardlist.h ./Source/WebKit/gtk/webkit/webkitwebdatabase.h ./Source/WebKit/gtk/webkit/webkitwebdatasource.h ./Source/WebKit/gtk/webkit/webkitwebframe.h ./Source/WebKit/gtk/webkit/webkitwebhistoryitem.h ./Source/WebKit/gtk/webkit/webkitwebinspector.h ./Source/WebKit/gtk/webkit/webkitwebnavigationaction.h ./Source/WebKit/gtk/webkit/webkitwebplugin.h ./Source/WebKit/gtk/webkit/webkitwebplugindatabase.h ./Source/WebKit/gtk/webkit/webkitwebpolicydecision.h ./Source/WebKit/gtk/webkit/webkitwebresource.h ./Source/WebKit/gtk/webkit/webkitwebsettings.h ./Source/WebKit/gtk/webkit/webkitwebwindowfeatures.h ./Source/WebKit/gtk/webkit/webkitwebview.h \
     DerivedSources/webkitdom/WebKitDOMBatteryManager.h DerivedSources/webkitdom/WebKitDOMCSSRule.h DerivedSources/webkitdom/WebKitDOMCSSRuleList.h DerivedSources/webkitdom/WebKitDOMCSSStyleDeclaration.h DerivedSources/webkitdom/WebKitDOMCSSStyleSheet.h DerivedSources/webkitdom/WebKitDOMCSSValue.h DerivedSources/webkitdom/WebKitDOMMediaController.h DerivedSources/webkitdom/WebKitDOMMediaList.h DerivedSources/webkitdom/WebKitDOMMediaQueryList.h DerivedSources/webkitdom/WebKitDOMStyleMedia.h DerivedSources/webkitdom/WebKitDOMStyleSheet.h DerivedSources/webkitdom/WebKitDOMStyleSheetList.h DerivedSources/webkitdom/WebKitDOMAttr.h DerivedSources/webkitdom/WebKitDOMCDATASection.h DerivedSources/webkitdom/WebKitDOMCharacterData.h DerivedSources/webkitdom/WebKitDOMComment.h DerivedSources/webkitdom/WebKitDOMDocument.h DerivedSources/webkitdom/WebKitDOMDocumentFragment.h DerivedSources/webkitdom/WebKitDOMDocumentType.h DerivedSources/webkitdom/WebKitDOMDOMImplementation.h DerivedSources/webkitdom/WebKitDOMDOMNamedFlowCollection.h DerivedSources/webkitdom/WebKitDOMDOMSettableTokenList.h DerivedSources/webkitdom/WebKitDOMDOMSecurityPolicy.h DerivedSources/webkitdom/WebKitDOMDOMStringList.h DerivedSources/webkitdom/WebKitDOMDOMStringMap.h DerivedSources/webkitdom/WebKitDOMDOMTokenList.h DerivedSources/webkitdom/WebKitDOMElement.h DerivedSources/webkitdom/WebKitDOMEntityReference.h DerivedSources/webkitdom/WebKitDOMEvent.h DerivedSources/webkitdom/WebKitDOMKeyboardEvent.h DerivedSources/webkitdom/WebKitDOMMessagePort.h DerivedSources/webkitdom/WebKitDOMMouseEvent.h DerivedSources/webkitdom/WebKitDOMNamedNodeMap.h DerivedSources/webkitdom/WebKitDOMNode.h DerivedSources/webkitdom/WebKitDOMNodeFilter.h DerivedSources/webkitdom/WebKitDOMNodeIterator.h DerivedSources/webkitdom/WebKitDOMNodeList.h DerivedSources/webkitdom/WebKitDOMProcessingInstruction.h DerivedSources/webkitdom/WebKitDOMRange.h DerivedSources/webkitdom/WebKitDOMText.h DerivedSources/webkitdom/WebKitDOMTouch.h DerivedSources/webkitdom/WebKitDOMTreeWalker.h DerivedSources/webkitdom/WebKitDOMUIEvent.h DerivedSources/webkitdom/WebKitDOMBlob.h DerivedSources/webkitdom/WebKitDOMFile.h DerivedSources/webkitdom/WebKitDOMFileList.h DerivedSources/webkitdom/WebKitDOMGamepad.h DerivedSources/webkitdom/WebKitDOMGamepadList.h DerivedSources/webkitdom/WebKitDOMGeolocation.h DerivedSources/webkitdom/WebKitDOMHTMLAnchorElement.h DerivedSources/webkitdom/WebKitDOMHTMLAppletElement.h DerivedSources/webkitdom/WebKitDOMHTMLAreaElement.h DerivedSources/webkitdom/WebKitDOMHTMLBaseElement.h DerivedSources/webkitdom/WebKitDOMHTMLBaseFontElement.h DerivedSources/webkitdom/WebKitDOMHTMLBodyElement.h DerivedSources/webkitdom/WebKitDOMHTMLBRElement.h DerivedSources/webkitdom/WebKitDOMHTMLButtonElement.h DerivedSources/webkitdom/WebKitDOMHTMLCanvasElement.h DerivedSources/webkitdom/WebKitDOMHTMLCollection.h DerivedSources/webkitdom/WebKitDOMHTMLDirectoryElement.h DerivedSources/webkitdom/WebKitDOMHTMLDivElement.h DerivedSources/webkitdom/WebKitDOMHTMLDListElement.h DerivedSources/webkitdom/WebKitDOMHTMLDocument.h DerivedSources/webkitdom/WebKitDOMHTMLDetailsElement.h DerivedSources/webkitdom/WebKitDOMHTMLElement.h DerivedSources/webkitdom/WebKitDOMHTMLEmbedElement.h DerivedSources/webkitdom/WebKitDOMHTMLFieldSetElement.h DerivedSources/webkitdom/WebKitDOMHTMLFontElement.h DerivedSources/webkitdom/WebKitDOMHTMLFormElement.h DerivedSources/webkitdom/WebKitDOMHTMLFrameElement.h DerivedSources/webkitdom/WebKitDOMHTMLFrameSetElement.h DerivedSources/webkitdom/WebKitDOMHTMLHeadElement.h DerivedSources/webkitdom/WebKitDOMHTMLHeadingElement.h DerivedSources/webkitdom/WebKitDOMHTMLHRElement.h DerivedSources/webkitdom/WebKitDOMHTMLHtmlElement.h DerivedSources/webkitdom/WebKitDOMHTMLIFrameElement.h DerivedSources/webkitdom/WebKitDOMHTMLImageElement.h DerivedSources/webkitdom/WebKitDOMHTMLInputElement.h DerivedSources/webkitdom/WebKitDOMHTMLKeygenElement.h DerivedSources/webkitdom/WebKitDOMHTMLLabelElement.h DerivedSources/webkitdom/WebKitDOMHTMLLegendElement.h DerivedSources/webkitdom/WebKitDOMHTMLLIElement.h DerivedSources/webkitdom/WebKitDOMHTMLLinkElement.h DerivedSources/webkitdom/WebKitDOMHTMLMapElement.h DerivedSources/webkitdom/WebKitDOMHTMLMarqueeElement.h DerivedSources/webkitdom/WebKitDOMHTMLMediaElement.h DerivedSources/webkitdom/WebKitDOMHTMLMenuElement.h DerivedSources/webkitdom/WebKitDOMHTMLMetaElement.h DerivedSources/webkitdom/WebKitDOMHTMLModElement.h DerivedSources/webkitdom/WebKitDOMHTMLObjectElement.h DerivedSources/webkitdom/WebKitDOMHTMLOListElement.h DerivedSources/webkitdom/WebKitDOMHTMLOptGroupElement.h DerivedSources/webkitdom/WebKitDOMHTMLOptionElement.h DerivedSources/webkitdom/WebKitDOMHTMLOptionsCollection.h DerivedSources/webkitdom/WebKitDOMHTMLParagraphElement.h DerivedSources/webkitdom/WebKitDOMHTMLParamElement.h DerivedSources/webkitdom/WebKitDOMHTMLPreElement.h DerivedSources/webkitdom/WebKitDOMHTMLQuoteElement.h DerivedSources/webkitdom/WebKitDOMHTMLScriptElement.h DerivedSources/webkitdom/WebKitDOMHTMLSelectElement.h DerivedSources/webkitdom/WebKitDOMHTMLStyleElement.h DerivedSources/webkitdom/WebKitDOMHTMLTableElement.h DerivedSources/webkitdom/WebKitDOMHTMLTableCaptionElement.h DerivedSources/webkitdom/WebKitDOMHTMLTableColElement.h DerivedSources/webkitdom/WebKitDOMHTMLTableSectionElement.h DerivedSources/webkitdom/WebKitDOMHTMLTableCellElement.h DerivedSources/webkitdom/WebKitDOMHTMLTextAreaElement.h DerivedSources/webkitdom/WebKitDOMHTMLTitleElement.h DerivedSources/webkitdom/WebKitDOMHTMLTableRowElement.h DerivedSources/webkitdom/WebKitDOMHTMLUListElement.h DerivedSources/webkitdom/WebKitDOMMediaError.h DerivedSources/webkitdom/WebKitDOMTimeRanges.h DerivedSources/webkitdom/WebKitDOMValidityState.h DerivedSources/webkitdom/WebKitDOMDOMApplicationCache.h DerivedSources/webkitdom/WebKitDOMBarProp.h DerivedSources/webkitdom/WebKitDOMConsole.h DerivedSources/webkitdom/WebKitDOMCustom.h DerivedSources/webkitdom/WebKitDOMDeprecated.h DerivedSources/webkitdom/WebKitDOMDOMWindowCSS.h DerivedSources/webkitdom/WebKitDOMDOMWindow.h DerivedSources/webkitdom/WebKitDOMDOMSelection.h DerivedSources/webkitdom/WebKitDOMEventTarget.h DerivedSources/webkitdom/WebKitDOMHistory.h DerivedSources/webkitdom/WebKitDOMLocation.h DerivedSources/webkitdom/WebKitDOMObject.h DerivedSources/webkitdom/WebKitDOMNavigator.h DerivedSources/webkitdom/WebKitDOMScreen.h DerivedSources/webkitdom/WebKitDOMShadowRoot.h DerivedSources/webkitdom/WebKitDOMWebKitPoint.h DerivedSources/webkitdom/WebKitDOMWebKitNamedFlow.h DerivedSources/webkitdom/WebKitDOMDOMMimeType.h DerivedSources/webkitdom/WebKitDOMDOMMimeTypeArray.h DerivedSources/webkitdom/WebKitDOMDOMPlugin.h DerivedSources/webkitdom/WebKitDOMDOMPluginArray.h DerivedSources/webkitdom/WebKitDOMDatabase.h DerivedSources/webkitdom/WebKitDOMStorage.h DerivedSources/webkitdom/WebKitDOMStorageInfo.h DerivedSources/webkitdom/WebKitDOMStorageQuota.h DerivedSources/webkitdom/WebKitDOMXPathExpression.h DerivedSources/webkitdom/WebKitDOMXPathNSResolver.h DerivedSources/webkitdom/WebKitDOMXPathResult.h DerivedSources/webkitdom/WebKitDOMPerformance.h DerivedSources/webkitdom/WebKitDOMPerformanceEntry.h DerivedSources/webkitdom/WebKitDOMPerformanceEntryList.h DerivedSources/webkitdom/WebKitDOMPerformanceNavigation.h DerivedSources/webkitdom/WebKitDOMPerformanceTiming.h DerivedSources/webkitdom/WebKitDOMWheelEvent.h DerivedSources/webkitdom/webkitdom.h DerivedSources/webkitdom/webkitdomdefines.h DerivedSources/webkitdom/WebKitDOMAudioTrack.h DerivedSources/webkitdom/WebKitDOMAudioTrackList.h DerivedSources/webkitdom/WebKitDOMHTMLAudioElement.h DerivedSources/webkitdom/WebKitDOMHTMLVideoElement.h DerivedSources/webkitdom/WebKitDOMTextTrack.h DerivedSources/webkitdom/WebKitDOMTextTrackList.h DerivedSources/webkitdom/WebKitDOMTextTrackCue.h DerivedSources/webkitdom/WebKitDOMTextTrackCueList.h DerivedSources/webkitdom/WebKitDOMTrackEvent.h DerivedSources/webkitdom/WebKitDOMVideoPlaybackQuality.h DerivedSources/webkitdom/WebKitDOMVideoTrack.h DerivedSources/webkitdom/WebKitDOMVideoTrackList.h \
     ./Source/WebKit/gtk/webkit/*.cpp
/bin/sh ./libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -ansi -fno-strict-aliasing  -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz  -I/usr/include/harfbuzz  -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2  -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -march=native -O2 -pipe -pthread -std=c99   -no-install -Wl,-O1 -Wl,--as-needed -Wl,--no-keep-memory -Wl,--reduce-memory-overheads -Wl,--no-demangle -o Programs/GtkLauncher Tools/GtkLauncher/Programs_GtkLauncher-LauncherInspectorWindow.o Tools/GtkLauncher/Programs_GtkLauncher-main.o libwebkitgtk-1.0.la libjavascriptcoregtk-1.0.la -lcairo -lfontconfig -lfreetype -lharfbuzz  -lharfbuzz-icu -lharfbuzz  -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype  -Wl,--export-dynamic -lgmodule-2.0 -pthread -lgthread-2.0 -pthread -lgio-2.0 -lgobject-2.0 -lglib-2.0  -lsoup-2.4 -lgio-2.0 -lgobject-2.0 -lglib-2.0   -lgstapp-1.0 -lgstaudio-1.0 -lgstfft-1.0 -lm -lgstpbutils-1.0 -lgstvideo-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 
Couldn't find include 'Gtk-2.0.gir' (search path: ['./Source/WebKit/gtk', '.', '/usr/local/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0'])
GNUmakefile:82212: recipe for target 'WebKit-1.0.gir' failed
make[1]: *** [WebKit-1.0.gir] Error 1
make[1]: *** Waiting for unfinished jobs....
libtool: link: x86_64-pc-linux-gnu-gcc -ansi -fno-strict-aliasing -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/harfbuzz -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -march=native -O2 -pipe -pthread -std=c99 -Wl,-O1 -Wl,--as-needed -Wl,--no-keep-memory -Wl,--reduce-memory-overheads -Wl,--no-demangle -o Programs/GtkLauncher Tools/GtkLauncher/Programs_GtkLauncher-LauncherInspectorWindow.o Tools/GtkLauncher/Programs_GtkLauncher-main.o -Wl,--export-dynamic -pthread -pthread  ./.libs/libwebkitgtk-1.0.so /var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8/.libs/libjavascriptcoregtk-1.0.so -ljpeg -lxslt -lxml2 -lGL -lEGL -ldl -lpng16 -lsqlite3 -lwebp -lXcomposite -lXdamage -lXfixes -lXrender -lXt -lX11 ./.libs/libjavascriptcoregtk-1.0.so -lpthread -lz -licui18n -licuuc -licudata -lharfbuzz-icu -lharfbuzz -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lpango-1.0 -lfontconfig -lfreetype -lgmodule-2.0 -lgthread-2.0 -lsoup-2.4 -lgio-2.0 -lgstapp-1.0 -lgstaudio-1.0 -lgstfft-1.0 -lm -lgstpbutils-1.0 -lgstvideo-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -pthread -Wl,-rpath -Wl,/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8/.libs
make[1]: Leaving directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
GNUmakefile:25594: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: net-libs/webkit-gtk-2.4.8-r200::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`.
 * The complete build log is located at '/var/log/portage_logs/net-libs:webkit-gtk-2.4.8-r200:20150307-191806.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'


Also, but only now, this report will, and I think I'll do so from now on, when I need help, contain the changes in /etc/portage/package.* when I make them. So, for some next try, if I don't abandon the midori compilation attempts, the change is in make.conf:

Code:

introspection

in the USE= flags, instead of `-introspection' which was the case up unto now.

In absence of better suggestion, I'll next try an `emerge -tuDN world', and try installing webkit-gtk again afterwards.
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 768

PostPosted: Sat Mar 07, 2015 9:37 pm    Post subject: Reply with quote

What do your packet traces say about a firefox instance where e.g. "safe browsing" is disabled completely, and the resp. about:config URLs have been emptied? What if OCSP is disabled?

The next step is going through about:config, look for https?://, check what those entries are about, and if necessary empty them as well. How much behind-your-back-tracffic is left then?

Yeah, I'm probably just dabbling. Until recently, most of my privacy needs were taken care of by ff add-ons, and it was a slow process realizing what modern browsers are up to in the background. Creeping featuritis and "market pressures" are taking their toll on FOSS, and some entities, companies and other, act as if they've lost the effing plot (yes, I'm looking at you, major commercial Linux vendor).
Back to top
View user's profile Send private message
jonathan183
Guru
Guru


Joined: 13 Dec 2011
Posts: 309

PostPosted: Sun Mar 08, 2015 12:48 am    Post subject: Reply with quote

I use links most of the time ... I use firefox for sites where I need to. When I do use firefox I use noscript and only enable the minimum to get things working. I tend to disable the reporting stuff as well.
One of the banks I use with links ... which is great, the other I use needs scripts so it's back to firefox for me ...
I tried qupzilla, midori, netsurf and a few others - but for me links in a framebuffer display works best if scripts are not needed otherwise firefox. I use separate users for general surfing, emails (mutt or claws-mail), online bank, accessing documents etc.
For me the need to enable scripts is the main problem ... ymmv
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum