Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED: Openrc blocking kmod in recent update!
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
shisbosd
n00b
n00b


Joined: 16 Jun 2014
Posts: 27

PostPosted: Sat Jan 17, 2015 5:53 am    Post subject: SOLVED: Openrc blocking kmod in recent update! Reply with quote

Anyone else have this problem, or is it just me? My most recent update attempt got stuck with this block. I don't know what to do. It seems like I need both of these packages. I certainly need some of the packages which sys-apps/kmod is required by. And I don't feel like writing my own init script. If anyone could suggest something safe to do, I'd be grateful. I'm guessing I should just mask kmod and see if anything breaks.


Code:

 # !emer
emerge -avuDq --with-bdeps=y @world
[ebuild     U ] sys-apps/kmod-19 [18-r1] USE="tools zlib -debug -doc -lzma -python -static-libs" PYTHON_TARGETS="python2_7 python3_3 -python3_4"
[ebuild     U ] sys-apps/busybox-1.23.0 [1.21.0] USE="ipv6 pam static -debug% -livecd -make-symlinks -math -mdev -savedconfig (-selinux) -sep-usr -syslog -systemd"
[ebuild     U ] dev-db/sqlite-3.8.7.4 [3.8.6] USE="readline -debug -doc -icu -secure-delete -static-libs -tcl {-test}" ABI_X86="(64) (-32) (-x32)"
[blocks B     ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-apps/kmod-19)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/kmod-19:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >sys-apps/kmod-5[tools] required by (sys-kernel/dracut-038-r2:0/0::gentoo, installed)
    >=sys-apps/kmod-16 required by (sys-fs/eudev-1.10-r2:0/0::gentoo, installed)
    sys-apps/kmod[tools] required by (virtual/modutils-0:0/0::gentoo, installed)
    sys-apps/kmod required by (sys-apps/pciutils-3.2.0:0/0::gentoo, installed)

  (sys-apps/openrc-0.12.4:0/0::gentoo, installed) pulled in by
    sys-apps/openrc required by @system
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2:0/0::gentoo, installed)
    sys-apps/openrc required by (virtual/service-manager-0:0/0::gentoo, installed)



Last edited by shisbosd on Sat Jan 17, 2015 4:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1699

PostPosted: Sat Jan 17, 2015 6:48 am    Post subject: Reply with quote

try updating openrc to openrc-0.13.7
Code:
emerge -ua openrc


That should update openrc to version 0.13 which will clear this block. According to my system, openrc-0.13 has been marked stable so do be sure you run sync first to ensure you have a updated tree.
Back to top
View user's profile Send private message
kvada
n00b
n00b


Joined: 11 Nov 2014
Posts: 9

PostPosted: Sat Jan 17, 2015 6:57 am    Post subject: Reply with quote

Same problem:
Code:
# emerge -uDNv --with-bdeps=y  --newuse world     

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/busybox-1.23.0 [1.21.0] USE="pam static -debug% -ipv6 -livecd -make-symlinks -math -mdev -savedconfig (-selinux) -sep-usr -syslog -systemd" 2 201 KiB
[ebuild     U  ] sys-apps/kmod-19 [18-r1] USE="tools zlib -debug -doc -lzma -python -static-libs" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 1 440 KiB
[ebuild     U  ] net-libs/libssh-0.6.4:0/4 [0.6.3-r1:0/4] USE="sftp zlib -debug -doc -examples -gcrypt -gssapi -pcap -server -ssh1 -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 375 KiB
[ebuild     U  ] sys-apps/openrc-0.13.7 [0.12.4] USE="ncurses netifrc pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools" 148 KiB
[blocks b      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-apps/kmod-19)
[blocks B      ] <sys-fs/udev-init-scripts-27 ("<sys-fs/udev-init-scripts-27" is blocking sys-apps/openrc-0.13.7)

Total: 4 packages (4 upgrades), Size of downloads: 4 162 KiB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/openrc-0.13.7:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by (virtual/service-manager-0:0/0::gentoo, installed)
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2:0/0::gentoo, installed)
    sys-apps/openrc required by @system

  (sys-fs/udev-init-scripts-26-r2:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/eudev-1.10-r2:0/0::gentoo, installed)

Anybody can help?
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2586

PostPosted: Sat Jan 17, 2015 7:11 am    Post subject: Reply with quote

:roll:

Try what ct85711 suggested or add --backtrack=42
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
kvada
n00b
n00b


Joined: 11 Nov 2014
Posts: 9

PostPosted: Sat Jan 17, 2015 7:25 am    Post subject: Reply with quote

Code:
# emerge -ua openrc --backtrack=42

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/openrc-0.13.7 [0.12.4]
[blocks B      ] <sys-fs/udev-init-scripts-27 ("<sys-fs/udev-init-scripts-27" is blocking sys-apps/openrc-0.13.7)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-init-scripts-26-r2:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/eudev-1.10-r2:0/0::gentoo, installed)

  (sys-apps/openrc-0.13.7:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by @system
    sys-apps/openrc required by (virtual/service-manager-0:0/0::gentoo, installed)
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2:0/0::gentoo, installed)
    openrc

What am I doing wrong?
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2586

PostPosted: Sat Jan 17, 2015 7:29 am    Post subject: Reply with quote

try emerge -auv openrc udev-init-scripts if that still fails you can try ading udev to the list.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
Ftroop
n00b
n00b


Joined: 17 Jan 2015
Posts: 4

PostPosted: Sat Jan 17, 2015 7:35 am    Post subject: Reply with quote

having the same problem tried that Doctor with same results at least im not alone :)
Back to top
View user's profile Send private message
kvada
n00b
n00b


Joined: 11 Nov 2014
Posts: 9

PostPosted: Sat Jan 17, 2015 7:39 am    Post subject: Reply with quote

The Doctor wrote:
try emerge -auv openrc udev-init-scripts if that still fails you can try ading udev to the list.

It did not help. Exactly the same blocks.

I can't understand which package required sys-fs/udev-init-scripts-27, which is unstable and blocked by sys-apps/openrc-0.13.7.
Back to top
View user's profile Send private message
Ftroop
n00b
n00b


Joined: 17 Jan 2015
Posts: 4

PostPosted: Sat Jan 17, 2015 7:44 am    Post subject: Reply with quote

I've checked all my package.use make.conf and accept and cant see whats happening??
Back to top
View user's profile Send private message
olegon
n00b
n00b


Joined: 09 Jul 2012
Posts: 4

PostPosted: Sat Jan 17, 2015 7:57 am    Post subject: Reply with quote

The same problem... Suppose, that latest update of openrc-13, changed quickly to 13.7 is broken. Still waiting...
Back to top
View user's profile Send private message
mhex
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2005
Posts: 143
Location: Germany/Berlin

PostPosted: Sat Jan 17, 2015 7:57 am    Post subject: Reply with quote

Same here. Btw. what about a descriptive topic?

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/busybox-1.23.0 [1.21.0] USE="-debug%"
[ebuild     U  ] sys-apps/kmod-19 [18-r1]
[ebuild     U  ] net-libs/libssh-0.6.4 [0.6.3-r1]
[ebuild     U  ] sys-apps/openrc-0.13.7 [0.12.4]
[blocks b      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-apps/kmod-19)
[blocks B      ] <sys-fs/udev-init-scripts-27 ("<sys-fs/udev-init-scripts-27" is blocking sys-apps/openrc-0.13.7)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/openrc-0.13.7:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by @system
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2:0/0::gentoo, installed)
    sys-apps/openrc required by (virtual/service-manager-0:0/0::gentoo, installed)

  (sys-fs/udev-init-scripts-26-r2:0/0::gentoo, installed) pulled in by
    sys-fs/udev-init-scripts required by @selected
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/udev-216:0/0::gentoo, installed)
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Jan 17, 2015 8:03 am    Post subject: Reply with quote

1. Add "=sys-fs/udev-init-scripts-27" to package.keywords
2. Continue with update world.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2586

PostPosted: Sat Jan 17, 2015 8:07 am    Post subject: Reply with quote

Looks to me like this might have simply been poor coordination on package stabilization. I'd wait 12-24 hours, sync and try again.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
kvada
n00b
n00b


Joined: 11 Nov 2014
Posts: 9

PostPosted: Sat Jan 17, 2015 8:13 am    Post subject: Reply with quote

ppurka wrote:
1. Add "=sys-fs/udev-init-scripts-27" to package.keywords
2. Continue with update world.

Thanks. It's helped.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Jan 17, 2015 8:21 am    Post subject: Reply with quote

The Doctor wrote:
Looks to me like this might have simply been poor coordination on package stabilization. I'd wait 12-24 hours, sync and try again.
Yes. It has not been coordinated well. FYI: https://bugs.gentoo.org/show_bug.cgi?id=531602
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
olegon
n00b
n00b


Joined: 09 Jul 2012
Posts: 4

PostPosted: Sat Jan 17, 2015 8:43 am    Post subject: Reply with quote

Fixed :)
Back to top
View user's profile Send private message
shisbosd
n00b
n00b


Joined: 16 Jun 2014
Posts: 27

PostPosted: Sat Jan 17, 2015 4:33 pm    Post subject: Reply with quote

mhex wrote:
Same here. Btw. what about a descriptive topic?


Done. It looks like more people are having this problem than just me.

Although I synced last night, openrc 0.13.7 was masked this morning... Anyway, I synced again and continued with my updates with ppurka's advice. Everything worked itself out.
Back to top
View user's profile Send private message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 136

PostPosted: Sat Jan 17, 2015 6:58 pm    Post subject: Reply with quote

kvada wrote:
ppurka wrote:
1. Add "=sys-fs/udev-init-scripts-27" to package.keywords
2. Continue with update world.

Thanks. It's helped.


you mean package.accept_keywords?
if yes, i did it but the problem still exist.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Jan 17, 2015 11:27 pm    Post subject: Reply with quote

papandreoos wrote:
kvada wrote:
ppurka wrote:
1. Add "=sys-fs/udev-init-scripts-27" to package.keywords
2. Continue with update world.

Thanks. It's helped.


you mean package.accept_keywords?
if yes, i did it but the problem still exist.
From when did package.keywords become package.accept_keywords? Anyway, package.keywords still works for me.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2586

PostPosted: Sat Jan 17, 2015 11:36 pm    Post subject: Reply with quote

ppurka wrote:
From when did package.keywords become package.accept_keywords? Anyway, package.keywords still works for me.
It has been quite a while, but portage still accepts both. However, you should only have one :wink:
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
mhex
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2005
Posts: 143
Location: Germany/Berlin

PostPosted: Sun Jan 18, 2015 7:49 am    Post subject: Reply with quote

Thanks for changing the topic.

Yesterday a new version of udev-init-scripts showed up in portage and solved everything.

Like ppurka said, it was this bug https://bugs.gentoo.org/show_bug.cgi?id=531602
Back to top
View user's profile Send private message
divined
Apprentice
Apprentice


Joined: 23 Jul 2004
Posts: 165

PostPosted: Sun Jan 18, 2015 9:44 am    Post subject: Reply with quote

Still unresolved here. Synced ten minutes ago.

Code:

[blocks B      ] <sys-fs/udev-init-scripts-27 ("<sys-fs/udev-init-scripts-27" is blocking sys-apps/openrc-0.13.7)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/openrc-0.13.7:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by @system
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2:0/0::gentoo, installed)
    sys-apps/openrc required by (virtual/service-manager-0:0/0::gentoo, installed)

  (sys-fs/udev-init-scripts-26-r2:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/udev-216:0/0::gentoo, installed)



Could it be that my mirror has not yet caught up?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2643

PostPosted: Sun Jan 18, 2015 10:22 am    Post subject: Reply with quote

divined wrote:
Could it be that my mirror has not yet caught up?
Possible. But maybe did you happen to forget to run eix-sync before?
Back to top
View user's profile Send private message
divined
Apprentice
Apprentice


Joined: 23 Jul 2004
Posts: 165

PostPosted: Sun Jan 18, 2015 12:33 pm    Post subject: Reply with quote

eix-sync

Been using Gentoo for over 5 years now. Never had to do that before!!
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Jan 18, 2015 12:54 pm    Post subject: Reply with quote

divined wrote:
eix-sync. Been using Gentoo for over 5 years now. Never had to do that before!!

divined ... you don't ... its just a substitute for 'emerge --sync, layman --sync (if '*' is in /etc/eix-sync.conf), eix-update, and eix-diff' (and egencache can also be called if so configured).

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum