Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Not able to run grub2-install /dev/sda
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 461
Location: India

PostPosted: Thu Nov 20, 2014 7:51 pm    Post subject: [SOLVED] Not able to run grub2-install /dev/sda Reply with quote

Hi Expert, I am totally stuck at a point and not able to figure out how to fix the below error message. I am doing a fresh install on a Server and while running the command ' grub2-install /dev/sda' , I am getting the below error message :-

Code:
livecd ~ # grub2-install /dev/sda
Installing for i386-pc platform.
grub2-install: warning: Attempting to install GRUB to a disk with multiple partition labels.  This is not supported yet..
grub2-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub2-install: error: will not proceed with blocklists.


I am not sure why is it says -
Code:
installing for the i386-pc platform


Code:
uname -a
Linux livecd 3.16.5-gentoo #1 SMP Thu Nov 13 06:29:04 UTC 2014 x86_64 Intel(R) Xeon(R) CPU X7560 @ 2.27GHz GenuineIntel GNU/Linux




Appreciate all your help in advance.


Last edited by manu_leo on Wed Nov 26, 2014 11:45 am; edited 1 time in total
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1773
Location: United Kingdom

PostPosted: Thu Nov 20, 2014 9:47 pm    Post subject: Reply with quote

manu_leo wrote:
I am not sure why is it says -
Code:
installing for the i386-pc platform


Code:
uname -a
Linux livecd 3.16.5-gentoo #1 SMP Thu Nov 13 06:29:04 UTC 2014 x86_64 Intel(R) Xeon(R) CPU X7560 @ 2.27GHz GenuineIntel GNU/Linux

That should be OK if the CPU architecture is x86_64 and the machine uses PC BIOS. See http://wiki.gentoo.org/wiki/GRUB2_Quick_Start

GRUB2 Quick Start wrote:
grub2-install accepts a --target option to specify which CPU/Platform to install. If unspecified, grub2-install will make a guess; on amd64/x86 it will use "i386-pc" by default.

See also http://wiki.gentoo.org/wiki/GRUB2

In my Gentoo ~amd64 PC BIOS installation:

Code:
# ls /boot/grub/
fonts     grub.cfg.20130603  grub.cfg.20140108  grub.cfg.20140401  grubenv  locale            themes
grub.cfg  grub.cfg.20131102  grub.cfg.20140226  grub.cfg.20140402  i386-pc  mybackground.png
# uname -a
Linux meshedgedx 3.17.1-gentoo-r1 #1 SMP Wed Nov 5 16:41:59 GMT 2014 x86_64 Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz GenuineIntel GNU/Linux

Notice the directory /boot/grub/i386-pc/
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 461
Location: India

PostPosted: Wed Nov 26, 2014 4:07 am    Post subject: Reply with quote

Thanks for looking into this.

Actually, what happened is that the total HDD size is 16Tb in my server and I used fdisk to create partitions tables -boot, swap and so on. Because fdisk does not support partitioning more than 2 Tb, that is what caused the below error :-

Code:
livecd ~ # grub2-install /dev/sda
Installing for i386-pc platform.
grub2-install: warning: Attempting to install GRUB to a disk with multiple partition labels.  This is not supported yet..
grub2-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub2-install: error: will not proceed with blocklists.


I used parted command to do the partition and the grub2-install /dev/sda comes without any error message.

Appreciate all your help.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 461
Location: India

PostPosted: Wed Nov 26, 2014 11:45 am    Post subject: [SOLVED] Re: Not able to run grub2-install /dev/sda Reply with quote

manu_leo wrote:
Hi Expert, I am totally stuck at a point and not able to figure out how to fix the below error message. I am doing a fresh install on a Server and while running the command ' grub2-install /dev/sda' , I am getting the below error message :-

Code:
livecd ~ # grub2-install /dev/sda
Installing for i386-pc platform.
grub2-install: warning: Attempting to install GRUB to a disk with multiple partition labels.  This is not supported yet..
grub2-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub2-install: error: will not proceed with blocklists.


I am not sure why is it says -
Code:
installing for the i386-pc platform


Code:
uname -a
Linux livecd 3.16.5-gentoo #1 SMP Thu Nov 13 06:29:04 UTC 2014 x86_64 Intel(R) Xeon(R) CPU X7560 @ 2.27GHz GenuineIntel GNU/Linux




Appreciate all your help in advance.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2744

PostPosted: Wed Nov 26, 2014 12:03 pm    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/GRUB2#Embedding_area_is_unusually_small
Back to top
View user's profile Send private message
mistreated
n00b
n00b


Joined: 03 Dec 2006
Posts: 26
Location: Riga, Latvia

PostPosted: Fri Oct 20, 2017 9:39 am    Post subject: Reply with quote

Just want to post my solution to the above problem, since someone will probably find this thread searching by error message.

Symptoms were the same:
Code:

# grub-install /dev/sda
Installing for i386-pc platform.
grub-install: warning: Attempting to install GRUB to a disk with multiple partition labels.  This is not supported yet..
grub-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.


The reason was different. Once I accidentally dd iso imange to my /dev/sda instead of USB flash drive... Yes, such things happen occasionally. :D
Despite I recreated all partitions some signatures were left on the drive. Similar thing might happen when there used to be a DOS partitioning and you are migrating to GPT.
Utility wipefs can help to view and remove these old signatures.

Code:

# wipefs /dev/sda
offset               type
----------------------------------------------------------------
0x200                gpt   [partition table]

0x8001               iso9660   [filesystem]
                     LABEL: Fedora-KDE-Live-26-1-5
                     UUID:  2017-07-05-22-12-15-00


Above you can see which image I was intending to writer to the flash drive. :) There should be gpt only, so here's the solution:
Code:

# wipefs -o 0x8001 /dev/sda
/dev/sda: 5 bytes were erased at offset 0x00008001 (iso9660): 43 44 30 30 31

# wipefs /dev/sda
offset               type
----------------------------------------------------------------
0x200                gpt   [partition table]


P.S.
wipefs won't run on the drive which has mounted partitions, so all /dev/sda* have to be unmounted in prior.
If you are booted from the livecd and running the Gentoo installation from chrooted shell, then you can refer to the Handbook (Installation/Bootloader) on how to correctly unmount /dev/sda* partitions and then go back to the Handbook (Installation/Base) if you have forgotten how to chroot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum