Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mumble does not get any input
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
guido-pe
n00b
n00b


Joined: 10 May 2004
Posts: 52

PostPosted: Thu Aug 21, 2014 6:29 pm    Post subject: Mumble does not get any input Reply with quote

Hi,

I am having trouble using mumble under Gentoo. I can start the program, but no matter what I set as "Device" or "System" (Pulseaudio or ALSA) under Settings->Audio Input, mumble never gets input. The input indicator bar doesn't move

I can use alsamixer to enable capture on the capture device, but this will directly forward all microphone input to the headphones, which I don't want. Mumble does get input in this case, though, if I configure it to use ALSA and the default ALSA card.

I have a CreativeLab X-Fi Titanium PCI-Express sound card with a connected headset. The basic hardware setup works fine under Windows. (So it cannot be the hardware's fault.)

These are the useflags I used when emerging mumble:

Code:
 $ sudo emerge -vp mumble

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-sound/mumble-1.2.6  USE="alsa dbus pulseaudio -debug -g15 -oss -pch -portaudio -speech -zeroconf" 0 kB


Can anyone help me with this problem?
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2928
Location: UK

PostPosted: Sat Aug 23, 2014 1:01 am    Post subject: Reply with quote

Check the "Recording" tab in the pavucontrol GUI, does it show input happening there?
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 207
Location: Estonia, Tallinn

PostPosted: Tue Sep 02, 2014 7:54 am    Post subject: Reply with quote

For me pulseaudio doesn't seem to save my microphone level across reboots (same problem was with output, but that seems to have been saved by now at some level), so indeed, check it in your volume control; maybe the volume is all the way down (muted), so it is too silent to send anything (I move it up to some 75% to not overboost it). In GNOME3 when microphone is attached, it should just be one of the sliders in the top-right menu or under Sound in system settings
_________________
GNOME team lead; GStreamer
Back to top
View user's profile Send private message
mf2
n00b
n00b


Joined: 14 Jun 2007
Posts: 31

PostPosted: Sat Sep 06, 2014 3:13 pm    Post subject: Re: Mumble does not get any input Reply with quote

guido-pe wrote:

I can use alsamixer to enable capture on the capture device, but this will directly forward all microphone input to the headphones, which I don't want. Mumble does get input in this case, though, if I configure it to use ALSA and the default ALSA card.

Try the following:

  • Open alsamixer
  • Press F4 to get into capture mode
  • Activate your capture device and set - if needed - the capture volume
  • Press F3 to go in playback mode
  • Select your capture device and mute it using the M key.

The last step should avoid that your microphone input is forwarded to your headphones.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum