Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
screencasting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Adel Ahmed
l33t
l33t


Joined: 21 Sep 2012
Posts: 738

PostPosted: Sat Aug 02, 2014 8:33 pm    Post subject: screencasting Reply with quote

I'm planning to record my gaming/work sessions.
gtk-record mydeskop works fine except for 2 things:
- switching resolution during recording crashes the recorder(not critical, I can start recording after the game starts running)
- output is huge in size(100 MB for 5 minutes of recording) this is critical, I will be recording and archiving many things, I need compact size without compromising quality
- voice and video are out of sync

I'm open to other screencasting software, I'm also willing to convert the videos instead(I'll need help with that though)

if the second option is more viable, what containers and codecs are good for both size and quality(I'm clueless)


thanks
Back to top
View user's profile Send private message
swathe
n00b
n00b


Joined: 04 Jul 2011
Posts: 69

PostPosted: Sat Aug 02, 2014 9:13 pm    Post subject: Reply with quote

Simple Screen recorder seems pretty popular with people on youtube.
Back to top
View user's profile Send private message
Adel Ahmed
l33t
l33t


Joined: 21 Sep 2012
Posts: 738

PostPosted: Sat Aug 02, 2014 10:03 pm    Post subject: Reply with quote

[PageOutput::PageOutput] Error: Could not find any suitable video codec in libavcodec!

I can't install libavcodec because it conflicts with ffmpeg, and ffmpeg is essential for some scripts on my laptop
Back to top
View user's profile Send private message
creaker
l33t
l33t


Joined: 14 Jul 2012
Posts: 651

PostPosted: Sun Aug 03, 2014 12:40 am    Post subject: Reply with quote

blakdeath wrote:

I can't install libavcodec because it conflicts with ffmpeg, and ffmpeg is essential for some scripts on my laptop


Since you have ffmpeg installed, why would not use it for screencasting? ffmpeg records screen just fine.
And doesn't conflict himself :D
Back to top
View user's profile Send private message
Chiitoo
Veteran
Veteran


Joined: 28 Feb 2010
Posts: 1007
Location: Here and Away Again

PostPosted: Sun Aug 03, 2014 3:37 pm    Post subject: ><)))°€ Reply with quote

To expand upon the above a little bit, check for example the topic: screencasting software recommendation?

There's even an example included! ^^
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Adel Ahmed
l33t
l33t


Joined: 21 Sep 2012
Posts: 738

PostPosted: Wed Aug 06, 2014 5:18 pm    Post subject: Reply with quote

I tried running ffmpeg screencasting:
ffmpeg -f x11grab -s cif -r 25 -i :0.0 /tmp/out.mpg
and got:
Encoder (codec none) not found for output stream #0:0
Back to top
View user's profile Send private message
Adel Ahmed
l33t
l33t


Joined: 21 Sep 2012
Posts: 738

PostPosted: Wed Aug 06, 2014 5:27 pm    Post subject: Reply with quote

I trid runnig the script mentioned in the topic but I get:
[NULL @ 0x14eae10] Unable to find a suitable output format for 'AUDIO_CODEC'
AUDIO_CODEC: Invalid argument

here are my use flags:
media-video/ffmpeg-1.2.6 USE="X alsa mmx mmxext theora threads truetype vaapi vpx x264 -3dnow -3dnowext -aac -aacplus (-altivec) -amr -avx -bindist -bluray -bzip2 -cdio (-celt) -cpudetection -debug -doc -encode -examples -faac -fdk -flite -fontconfig -frei0r -gnutls -gsm -hardcoded-tables -iconv -iec61883 -ieee1394 -jack -jpeg2k -libass -libcaca -libsoxr -libv4l -modplug -mp3 (-neon) -network -openal -openssl -opus -oss -pic -pulseaudio -rtmp -schroedinger -sdl -speex -ssse3 -static-libs {-test} -twolame -v4l -vdpau (-vis) -vorbis -xvid -zlib" FFTOOLS="-aviocat -cws2fws -ffescape -ffeval -fourcc2pixfmt -graph2dot -ismindex -pktdumper -qt-faststart -trasher" 0 kB
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2954
Location: UK

PostPosted: Thu Aug 07, 2014 9:30 pm    Post subject: Reply with quote

Can you show us the script you're running and how you're trying to run it
Back to top
View user's profile Send private message
creaker
l33t
l33t


Joined: 14 Jul 2012
Posts: 651

PostPosted: Thu Aug 07, 2014 11:15 pm    Post subject: Reply with quote

Possibly you have specified codec that missed on your system.

The very first example I've found on google records my screen:
Code:
ffmpeg -f x11grab -r 25 -s 1024x768 -i :0.0 -vcodec huffyuv screencast.avi


You can check for availible codecs with
Quote:
ffmpeg -formats



As for me, I have ffmpeg built with these flags:
Code:
media-video/ffmpeg-1.2.6-r1 was built with the following:
USE="X aac alsa bzip2 encode hardcoded-tables iconv mmx mp3 network sdl truetype vorbis x264 xvid zlib -3dnow -3dnowext -aacplus (-altivec) -amr -avx -bindist -bluray -cdio (-celt) -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -libass -libcaca -libsoxr -libv4l -mmxext -modplug (-neon) -openal -openssl -opus -oss -pic -pulseaudio -rtmp -schroedinger -speex -ssse3 -static-libs -test -theora -threads -twolame -v4l -vaapi -vdpau (-vis) -vpx" ABI_X86="64 -32 -x32" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
Back to top
View user's profile Send private message
Adel Ahmed
l33t
l33t


Joined: 21 Sep 2012
Posts: 738

PostPosted: Sat Aug 09, 2014 4:50 am    Post subject: Reply with quote

for some reason, I have no encoders on my system, I found out by running ffmpeg -codecs, I have x264 compiled with encode support sp this is a bit weird. I'll start trying to resolve this problem
Back to top
View user's profile Send private message
Adel Ahmed
l33t
l33t


Joined: 21 Sep 2012
Posts: 738

PostPosted: Thu Aug 14, 2014 4:15 pm    Post subject: Reply with quote

I got nothing so far
any help?
Back to top
View user's profile Send private message
Chiitoo
Veteran
Veteran


Joined: 28 Feb 2010
Posts: 1007
Location: Here and Away Again

PostPosted: Thu Aug 21, 2014 12:36 pm    Post subject: Reply with quote

blakdeath wrote:
here are my use flags:
media-video/ffmpeg-1.2.6 USE="X alsa mmx mmxext theora threads truetype vaapi vpx x264 -3dnow -3dnowext -aac -aacplus (-altivec) -amr -avx -bindist -bluray -bzip2 -cdio (-celt) -cpudetection -debug -doc -encode -examples -faac -fdk -flite -fontconfig -frei0r -gnutls -gsm -hardcoded-tables -iconv -iec61883 -ieee1394 -jack -jpeg2k -libass -libcaca -libsoxr -libv4l -modplug -mp3 (-neon) -network -openal -openssl -opus -oss -pic -pulseaudio -rtmp -schroedinger -sdl -speex -ssse3 -static-libs {-test} -twolame -v4l -vdpau (-vis) -vorbis -xvid -zlib" FFTOOLS="-aviocat -cws2fws -ffescape -ffeval -fourcc2pixfmt -graph2dot -ismindex -pktdumper -qt-faststart -trasher" 0 kB

You might want to try enabling some more flags (encode for example might be important!).

Here are my (current) flags for it (note that the version I'm using is 'unstable', and even hard-masked right now):

Code:
media-video/ffmpeg-2.3.1 was built with the following:
USE="3dnow 3dnowext X aac alsa bzip2 encode faac hardcoded-tables iconv jpeg2k mmx mmxext mp3 network openal opengl rtmp sdl sse sse2 sse3 threads truetype v4l vdpau vorbis x264 xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -avx -avx2 -bindist -bluray -bs2b -cdio -celt -cpudetection -debug -doc -examples -fdk -flite -fma3 -fma4 -fontconfig -frei0r -fribidi -gme -gnutls -gsm -iec61883 -ieee1394 -jack -ladspa -libass -libcaca -libsoxr -libv4l (-mips32r2) (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openssl -opus -oss -pic -pulseaudio -quvi -samba -schroedinger -speex -sse4 -sse4_2 -ssh -ssse3 -static-libs -test -theora -twolame -vaapi -vpx -wavpack -webp -x265 -xop -zvbi" ABI_X86="32 64 -x32" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"

_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Adel Ahmed
l33t
l33t


Joined: 21 Sep 2012
Posts: 738

PostPosted: Thu Aug 21, 2014 4:33 pm    Post subject: Reply with quote

thanks it's all good now
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum