Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Flash keep restarting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
new_fish
n00b
n00b


Joined: 18 Jul 2014
Posts: 18

PostPosted: Tue Aug 12, 2014 2:52 pm    Post subject: [SOLVED] Flash keep restarting Reply with quote

Hello everybody, i have a little problem with my flash player...

I have firefox installed (version 24.6.0), and i also have adobe flash installed:

Code:
*  www-plugins/adobe-flash
      Latest version available: 11.2.202.394
      Latest version installed: 11.2.202.394
      Size of files: 6,763 kB
      Homepage:      http://www.adobe.com/products/flashplayer.html http://get.adobe.com/flashplayer/
      Description:   Adobe Flash Player
      License:       AdobeFlash-11.x


Also my about:plugins shows that Shockwave Flash is enabled:

Code:
File: libflashplayer.so
Path: /usr/lib/nsbrowser/plugins/libflashplayer.so
Version: 11,2,202,394
State: Enabled
Shockwave Flash 11.2 r202


The problem is that when i go to youtube to watch a video it start but then after a couple of seconds it restarts from the beginning and then again... it keeps restarting for about 4-5 times then flash player crashes and i have to reload the page to try again...
Firefox doesn't freeze, i can still scroll the page and use the browser.

Do you have any clue on what is happening and how to solve this issue?


Last edited by new_fish on Wed Aug 20, 2014 11:16 am; edited 1 time in total
Back to top
View user's profile Send private message
neonl
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 100
Location: Portugal

PostPosted: Thu Aug 14, 2014 11:57 pm    Post subject: Reply with quote

I have no idea what it is, but I have the exact same problem.
_________________
Core i5 760 | Gentoo x86-64 | Xfce 4.10
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 865
Location: Montréal

PostPosted: Fri Aug 15, 2014 12:11 am    Post subject: Reply with quote

Clic right on a flash video, choose Setup or Options. Uncheck Hardware acceleration. See if it work better.
_________________
Paul
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2455
Location: Silver City, NM

PostPosted: Fri Aug 15, 2014 7:24 am    Post subject: Reply with quote

You NEED to upgrade to >= 11.2.202.400. See here. I just went through this earlier today.
Back to top
View user's profile Send private message
neonl
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 100
Location: Portugal

PostPosted: Fri Aug 15, 2014 12:17 pm    Post subject: Reply with quote

Logicien wrote:
Clic right on a flash video, choose Setup or Options. Uncheck Hardware acceleration. See if it work better.

I tried it. Didn't work.

BitJam wrote:
You NEED to upgrade to >= 11.2.202.400. See here. I just went through this earlier today.

Updated and the problem persists...
_________________
Core i5 760 | Gentoo x86-64 | Xfce 4.10
Back to top
View user's profile Send private message
mir3x
Apprentice
Apprentice


Joined: 02 Jun 2012
Posts: 151

PostPosted: Sat Aug 16, 2014 9:15 pm    Post subject: Reply with quote

Disable flash/uninstall ? Check how it works under HTML5 ?
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2455
Location: Silver City, NM

PostPosted: Sat Aug 16, 2014 10:11 pm    Post subject: Reply with quote

IT'S ALIVE! IT'S ALIVE!

Chrome has never worked for this stuff. I'm able to watch Amazon Prime videos in Firfox-24.7.0 using Pipelight. You have to disable flash so pipelight can get in edgewise. Yuu need to disable https-everywhere, and noscript, (at least to get started) and you need to use User Agent Overrider and say you are Firefox runnig on windows. I tried enabling/disabling silverlight and silverlight5.1. (via pipelight-plugin on the command line) The most recent one I used was 5.1

In /usr/share/pipelight/config/pipelight-silverligh5.1 I edited it (perhaps bringing it back it it original state setting:
Code:
wineArch            = win32
enableGPUAcceleration=false

But the thing that finally got it to work was to run /usr/share/pipelight/scripts./configure-silverlight (as a normal user) and first enter "disable" and then "enter "abort". I reloaded the amazon video page and I had video and audio. I have not tried netflix yet and the video only ran for a few seconds but this seems like a step in the right direction.

I imagine this technique could be greatly improved. The key thing is getting it to start to work.

Edit: Neftlix also works with Firefox and pipelight + silverlight. The only problem right now is there is no graphics acceleration. I'll try that next.

Edit-2: I get this best results with win32 set, not win64. I can either enable or disable acceleration and it doesn't seem to matter. On Amazon, I'm denied HD (720p) because I don't have HDMI. ***sigh***.

I hate the assumption that we are a bunch of immoral thieves who would steal anything not tied down. For goodness sake, we let them use our software for free. Maybe someday we will all see the insanity of people expecting to be paid for providing a dis-service just because they have an illegal monopolistic hold on a certain market.
Back to top
View user's profile Send private message
new_fish
n00b
n00b


Joined: 18 Jul 2014
Posts: 18

PostPosted: Wed Aug 20, 2014 8:42 am    Post subject: Reply with quote

There i am, unfortunately i started this post but then i got some hardware issues that prevented me to work on my computer.

Anyway...

BitJam wrote:
You NEED to upgrade to >= 11.2.202.400. See here. I just went through this earlier today.


Thanks for pointing me to this, i'm updating right now... i'm also updating firefox to see if something change, i'll let you know.
Back to top
View user's profile Send private message
new_fish
n00b
n00b


Joined: 18 Jul 2014
Posts: 18

PostPosted: Wed Aug 20, 2014 9:50 am    Post subject: Reply with quote

I updated flash and firefox and now i have the latest version available but the problem still remains.

However updating flash due to security issues was a must do...
Back to top
View user's profile Send private message
new_fish
n00b
n00b


Joined: 18 Jul 2014
Posts: 18

PostPosted: Wed Aug 20, 2014 11:16 am    Post subject: Reply with quote

Ok, i finally found what was the problem with my firefox and solved it.

Actually the problem is that i am running firefox as another user, in fact for security reasons i created another user from which i run firefox via sudo command (sudo -u ffuser -H firefox %U).
When i use firefox like that i can browse the pages like a charm but apparently videos fails, but the thing that led me to the solution was that even sound was not working correctly, i mean no sound at all... and i know my ALSA sound service is perfectly configured.
Well, i'm kinda embarrassed to say that i forgot to add firefox user to 'audio' and 'video' groups :oops:

After setting proper group settings for that particular user everything is working fine and i also noticed a slight improvement on speed at loading pages.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum