Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error while emerging media-libs/mlt-0.8.2/ on amd64 system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
atemv
n00b
n00b


Joined: 09 Aug 2014
Posts: 28

PostPosted: Sat Aug 16, 2014 4:51 pm    Post subject: Error while emerging media-libs/mlt-0.8.2/ on amd64 system Reply with quote

Hello everybody!

I got the following error when I tried to emerge MLT.:

Code:
filter_avresample.c: In function ‘resample_get_audio’:
filter_avresample.c:86:4: warning: ‘av_audio_resample_init’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4109) [-Wdeprecated-declarations]
filter_avresample.c:93:4: warning: ‘audio_resample_close’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4126) [-Wdeprecated-declarations]
filter_avresample.c:102:3: warning: ‘audio_resample’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4117) [-Wdeprecated-declarations]
filter_avcolour_space.c: In function ‘filter_avcolour_space_init’:
filter_avcolour_space.c:324:15: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
filter_swscale.c: In function ‘filter_swscale_init’:
filter_swscale.c:194:15: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
factory.c: In function ‘add_parameters’:
factory.c:133:54: error: ‘FF_OPT_TYPE_BINARY’ undeclared (first use in this function)
factory.c:133:54: note: each undeclared identifier is reported only once for each function it appears in
factory.c:137:30: error: ‘FF_OPT_TYPE_CONST’ undeclared (first use in this function)
factory.c:182:8: error: ‘FF_OPT_TYPE_FLAGS’ undeclared (first use in this function)
factory.c:186:8: error: ‘FF_OPT_TYPE_INT’ undeclared (first use in this function)
factory.c:204:8: error: ‘FF_OPT_TYPE_INT64’ undeclared (first use in this function)
factory.c:215:8: error: ‘FF_OPT_TYPE_FLOAT’ undeclared (first use in this function)
factory.c:225:8: error: ‘FF_OPT_TYPE_DOUBLE’ undeclared (first use in this function)
factory.c:236:8: error: ‘FF_OPT_TYPE_STRING’ undeclared (first use in this function)
factory.c:242:8: error: ‘FF_OPT_TYPE_RATIONAL’ undeclared (first use in this function)
make[2]: *** [factory.o] Error 1
make[2]: *** Waiting for unfinished jobs....
consumer_avformat.c: In function ‘write_transmitter’:
consumer_avformat.c:1079:48: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
producer_avformat.c: In function ‘producer_get_image’:
producer_avformat.c:1490:14: warning: unused variable ‘interp’ [-Wunused-variable]
producer_avformat.c: In function ‘decode_audio’:
producer_avformat.c:2147:3: warning: ‘avcodec_decode_audio3’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3608) [-Wdeprecated-declarations]
producer_avformat.c:2180:5: warning: ‘audio_resample’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4117) [-Wdeprecated-declarations]
producer_avformat.c: In function ‘producer_get_audio’:
producer_avformat.c:2298:5: warning: ‘av_audio_resample_init’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4109) [-Wdeprecated-declarations]
consumer_avformat.c: In function ‘consumer_thread’:
consumer_avformat.c:1604:8: warning: ‘avcodec_encode_audio’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3968) [-Wdeprecated-declarations]
consumer_avformat.c:1671:8: warning: ‘avcodec_encode_audio’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3968) [-Wdeprecated-declarations]
consumer_avformat.c:1811:8: warning: ‘avcodec_encode_video’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4030) [-Wdeprecated-declarations]
consumer_avformat.c:1897:5: warning: ‘avcodec_encode_audio’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3968) [-Wdeprecated-declarations]
consumer_avformat.c:1900:5: warning: ‘avcodec_encode_audio’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3968) [-Wdeprecated-declarations]
consumer_avformat.c:1927:4: warning: ‘avcodec_encode_video’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4030) [-Wdeprecated-declarations]
producer_avformat.c: In function ‘producer_avformat_close’:
producer_avformat.c:2691:4: warning: ‘audio_resample_close’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4126) [-Wdeprecated-declarations]
make[2]: Leaving directory `/var/tmp/portage/media-libs/mlt-0.8.2/work/mlt-0.8.2/src/modules/avformat'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/mlt-0.8.2/work/mlt-0.8.2/src/modules'
make: *** [all] Error 1
 * ERROR: media-libs/mlt-0.8.2::gentoo failed (compile phase):
 *   emake failed


I managed to solve this problem, so I write down what have I done. I am really new in Gentoo (2 weeks), so I apologize beforehand If my explanation is inexact for the experienced users. In this case, please correct me.

From the error log above I had the assumption, that the problems come form MLT-ffmpeg version incompatibility, because mlt try to call deprecated functions. So I installed the newer, but non tested 0.9.0 version of MLT. For this one has to add the following line to the /etc/portage/package.accept_keywords file:

Code:
>=media-libs/mlt-0.9.0 ~amd64


Well this solved it, and Kdenlive worked with my short test (some effects, transitions, rendering to ogg, mp4 and avi), but perhaps the unmasked MLT-0.9.0 will give me some run time errors in the future.

If you use x86 gentoo, the MLT-0.9.0 is already stable for you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum