Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
content of /etc/mtab: number for root?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
freifunk_connewitz
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2006
Posts: 131

PostPosted: Mon Aug 11, 2014 7:47 am    Post subject: content of /etc/mtab: number for root? Reply with quote

Hi,
it's been a while since this occurs: when issueing "mount" or "cat /etc/mtab" to see the actually mounted filesystems, it prints as the first two lines:

Quote:

rootfs on / type rootfs (rw)
812 on / type ext3 (rw,noatime,nodiratime,commit=0)


what's with this "812"? shouldnt it say something like "/dev/sdaX"?

I found nothing bout it in the mount or fstab documentation...

Cheers,
FFCW
Back to top
View user's profile Send private message
Demonking
n00b
n00b


Joined: 12 Mar 2007
Posts: 38

PostPosted: Mon Aug 11, 2014 1:14 pm    Post subject: Reply with quote

Hello freifunk_connewitz,

the first value could also be a virtual Filesystem from the Kernel like proc,cgroup_root or something like that.
This would look like this :

Code:

proc on /proc type proc (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,size=817364k,mode=755)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)


But the 812 is strange, have you checked your fstab?

Maybe look what this command returns :

Code:
cat /proc/filesystems


Greetz

Demonking
_________________
I finally understand why Java's security model is so torturous:
It's to protect everyone else against people who write code like this.

The Answer to Life, the Universe, and Everything = 42
Back to top
View user's profile Send private message
freifunk_connewitz
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2006
Posts: 131

PostPosted: Mon Aug 11, 2014 2:09 pm    Post subject: Reply with quote

Hi Demonking,

thanks for your answer.

Demonking wrote:

the first value could also be a virtual Filesystem from the Kernel like proc,cgroup_root or something like that.


Yeah, I do have all those mounted, too.

Quote:
But the 812 is strange, have you checked your fstab?


Most def. There, everything looks like it should.

Quote:
Maybe look what this command returns :
Code:
cat /proc/filesystems



- a long list of possible filesystems.
By the way, I have the same thing on a laptop with a quite similar installation on it. Except that the number isn't 812 but something else.

What I first thought was that it could be some new feature of OpenRC or LVM or dm-crypt. But on both machines, not root, but only the home dir is encrypted, and I do not use use logical volumes.

LVM had to be installed anyway, because lilo, cryptsetup and some others depend on it. For whatever reason.

So, nobody has ever seen such a mtab?

Cheers,
freifunk connewitz
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4704

PostPosted: Mon Aug 11, 2014 7:00 pm    Post subject: Reply with quote

Hi, victim #2 :)
Look here, you'll get some explain about what is the number...
https://forums.gentoo.org/viewtopic-t-996732.html

Nobody have the solve to get back a saner naming. Waiting to see if more users get affected.
Back to top
View user's profile Send private message
freifunk_connewitz
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2006
Posts: 131

PostPosted: Tue Aug 12, 2014 10:19 am    Post subject: Reply with quote

krinn,

thanks for the hint. that's the thread I was looking for.
fortunately for me, my good old LILO indeed does complain about "812 not found", too, when updating the bootsector, but still continues its job and succeeds.

so, should there be a bug filed against udev?

cheers,
ffcw
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4704

PostPosted: Tue Aug 12, 2014 10:35 am    Post subject: Reply with quote

Without really knowing my feelings are more a kernel problem than udev (because /proc is not handle by udev but kernel)
But as you and the other user didn't expose any udev or kernel version. Things get hard to debug without info.

You indeed should filebug that (as i'm sure victim #3 exists but didn't notice it yet)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33266
Location: 56N 3W

PostPosted: Tue Aug 12, 2014 4:31 pm    Post subject: Reply with quote

krinn,

... behind you :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum