Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Java-WebStart not working anymore (IcedTea)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Greeny
n00b
n00b


Joined: 27 Dec 2007
Posts: 19

PostPosted: Sun Aug 10, 2014 12:28 pm    Post subject: [Solved] Java-WebStart not working anymore (IcedTea) Reply with quote

Nowaday's my javaws is not working anmyore with the comment:
Quote:
* javaws is not available for icedtea-bin-6 on x86_64
* IMPORTANT: some Java tools are not available on some VMs on some architectures


Till now, i only found out that the icedtea-vm don't supports javaws but i don't know why my Gentoo don't uses the icedtea-web.

I've installed dev-java/icedtea-bin-6.1.13.3-r3 and dev-java/icedtea-web-1.4.2.
I can't remember, that i changed anything. But in early times it worked without any problem. But since a few weeks (or maybe some months) it's not working anmore.

Can anyone tell me, thy gentoo alwys try to open javaws with the icedtea-6 java-vm and not with the icedtea-web-1.4?


Last edited by Greeny on Sun Aug 17, 2014 1:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
Demonking
n00b
n00b


Joined: 12 Mar 2007
Posts: 39

PostPosted: Sun Aug 10, 2014 12:36 pm    Post subject: Reply with quote

Hello Greeny,

what is the output of

Code:
eselect java-nsplugin list


and

Code:
eselect java-vm list



And maybe

Quote:
java-config --list-available-vms




Greetz

Demonking
_________________
I finally understand why Java's security model is so torturous:
It's to protect everyone else against people who write code like this.

The Answer to Life, the Universe, and Everything = 42
Back to top
View user's profile Send private message
Greeny
n00b
n00b


Joined: 27 Dec 2007
Posts: 19

PostPosted: Sun Aug 10, 2014 4:05 pm    Post subject: Reply with quote

Code:
#eselect java-nsplugin list
Available 32-bit Java browser plugins
Available 64-bit Java browser plugins
  [1]   icedtea-web@icedtea-bin-6  current


Code:
#eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-bin-6  system-vm


Code:
#java-config --list-available-vms
The following VMs are available for generation-2:
*)   IcedTea JDK 6.1.13.3 [icedtea-bin-6]


For package dev-java/icedtea-web only slot (0) is installed (because the other ones are masked as testing):
Quote:
# eix icedtea-web
[I] dev-java/icedtea-web
Available versions:
(6) ~1.3.2
(7) ~1.3.2-r7
(0) ~1.4.1 1.4.2 ~1.4.2-r1
{build doc +icedtea7 javascript +nsplugin test ELIBC="FreeBSD"}
Installed versions: 1.4.2(10:59:15 2014-08-10)(javascript nsplugin -doc -test ELIBC="-FreeBSD")
Homepage: http://icedtea.classpath.org
Description: FOSS Java browser plugin and Web Start implementation

Should i install therefore also the 1.3.2 version for slot (6)?
Back to top
View user's profile Send private message
dustfinger
Guru
Guru


Joined: 15 Aug 2004
Posts: 427

PostPosted: Sun Aug 17, 2014 7:06 am    Post subject: Reply with quote

Hi,

I had the same problem. I added the following to package.accept_keywords
Code:
# The following keyword changes are necessary to proceed:
#  (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-java/icedtea-web-1.4.2
# required by dev-java/icedtea-bin-6.1.13.3-r3[nsplugin]
# required by @selected
# required by @world (argument)
=dev-java/icedtea-7.2.4.7 ~amd64
# required by dev-java/icedtea-7.2.4.7[webstart]
# required by dev-java/icedtea (argument)
=dev-java/icedtea-web-1.3.2-r7 ~amd64


Then I un-installed icedtea-bin (This is not a necessary step though. You may skip it. See next step for explanation):
# emerge -aC icedtea-bin

I installed icedtea (this pulls icedtea-bin back in if you un-installed it because it is required to compile icedtea).
# emerge -autDN dev-java/icedtea

Make sure that icedtea has the webstart and nsplugin use flags set.
Make sure that icedtea-web has the nsplugin use flag set.
Code:

$ sudo emerge -pv dev-java/icedtea

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] dev-java/icedtea-7.2.4.7:7  USE="X alsa cups jbootstrap nsplugin nss source webstart -cacao -cjk -debug -doc -examples -jamvm -javascript -kerberos -pax_kernel -pulseaudio (-selinux) {-test} -zero" 0 kB

$ sudo emerge -pv dev-java/icedtea-web

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-java/icedtea-web-1.4.2  USE="nsplugin -doc -javascript {-test}" 0 kB



After dev-java/icedtea has finished installing you will need to change the system java-vm and the current nsplugin:

Code:

$ sudo eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-7
  [2]   icedtea-bin-6  system-vm
$ sudo eselect java-vm set system 1
$ sudo eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-7  system-vm
  [2]   icedtea-bin-6


Now change the java-nsplugin:
Code:

$ eselect java-nsplugin list
Available 32-bit Java browser plugins
Available 64-bit Java browser plugins
  [1]   icedtea-7
  [2]   icedtea-web@icedtea-7
  [3]   icedtea-web@icedtea-bin-6  current
$ sudo eselect java-nsplugin set 64bit 2
$ sudo eselect java-nsplugin list
Available 32-bit Java browser plugins
Available 64-bit Java browser plugins
  [1]   icedtea-7
  [2]   icedtea-web@icedtea-7  current
  [3]   icedtea-web@icedtea-bin-6


Now restart your browser so that your java plugin is reloaded and try to open a jnlp applet.

Sincerely,

dustfinger
_________________
Unanswered Post Initiative:
https://forums.gentoo.org/viewtopic.php?t=119906
Back to top
View user's profile Send private message
Greeny
n00b
n00b


Joined: 27 Dec 2007
Posts: 19

PostPosted: Sun Aug 17, 2014 1:40 pm    Post subject: Reply with quote

You're right - works correctly with IcedTea 7 (non-binary version).
Formerly it worked without unmasking some packages. I only hoped i can avoid this.

But anyhow, thanks for your instructions - everything works fine now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum