Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
FLASH videos don't work in FIREFOX
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Fri Jul 25, 2014 11:17 pm    Post subject: FLASH videos don't work in FIREFOX Reply with quote

Hi,

I have the newest firefox and adobe-flash, done all that stuff with package.license and in installed ok.

Code:
fuji ~ # emerge -pv www-plugins/adobe-flash

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] www-plugins/adobe-flash-11.2.202.394  USE="sse2 -debug -kde (-selinux)" 0 kB

Code:
[ebuild   R    ] www-client/firefox-24.6.0  USE="alsa dbus jit minimal -bindist -custom-cflags -custom-optimization -debug -gstreamer -libnotify (-pgo) -pulseaudio (-selinux) -startup-notification -system-cairo -system-icu -system-jpeg -system-sqlite {-test} -wifi" LINGUAS="fi -af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW -zu" 0 kB



No problem. But no videos in firefox? In youtube or any other place. Just a blank space.

Having this problem for a really long time.. help!
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5029
Location: Saint Amant, Acadiana

PostPosted: Sat Jul 26, 2014 12:03 am    Post subject: Reply with quote

Does it show up in about:plugins ?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Sat Jul 26, 2014 7:46 am    Post subject: Reply with quote

Code:
Installed plugins
Find updates for installed plugins at mozilla.com/plugincheck
Shockwave Flash

    File: libflashplayer.so
    Path: /usr/lib/nsbrowser/plugins/libflashplayer.so
    Version: 11,2,202,394
    State: Enabled
    Shockwave Flash 11.2 r202

MIME Type   Description   Suffixes
application/x-shockwave-flash   Shockwave Flash   swf
application/futuresplash   FutureSplash Player   spl
Shockwave Flash

    File: libswfdecmozilla.so
    Path: /usr/lib/nsbrowser/plugins/libswfdecmozilla.so
    Version:
    State: Enabled
    Shockwave Flash 9.0 r999

MIME Type   Description   Suffixes
application/x-shockwave-flash   Adobe Flash movie   swf
application/futuresplash   FutureSplash movie   spl
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5825

PostPosted: Sat Jul 26, 2014 5:59 pm    Post subject: Reply with quote

Well, ATM I see two possibilities:
- a trivial one: what does 'uname -p' print ?
- the second one is more tricky: there might be a subtle upstream bug in handling blocklists, if more than one plugin of the same name is installed; it might be that libswfdecmozilla makes libflashplayer blocked too
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Sun Jul 27, 2014 10:56 am    Post subject: Reply with quote

Code:
uname -p
AMD Sempron(tm) 3000+


yea, it's old but it's used to show youtube videos some time atleast ;)


emerge gives me this kind of stuff, i don't know if it has anything to do with anything:

Code:
!!! existing preserved libs:
>>> package: app-text/poppler-0.24.5
 *  - /usr/lib/libpoppler.so.43
 *  - /usr/lib/libpoppler.so.43.0.0
 *      used by /usr/lib/libreoffice/program/libpdfimportlo.so (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libreoffice/program/xpdfimport (app-office/libreoffice-4.1.2.3)
>>> package: media-libs/libjpeg-turbo-1.3.1
 *  - /usr/lib/libjpeg.so.8
 *  - /usr/lib/libjpeg.so.8.0.2
 *      used by /usr/lib/libreoffice/program/libmergedlo.so (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libwebkitgtk-3.0.so.0.13.4 (net-libs/webkit-gtk-1.8.3-r300)
>>> package: dev-libs/icu-52.1
 *  - /usr/lib/libicudata.so.51
 *  - /usr/lib/libicudata.so.51.2
 *      used by /usr/lib/libreoffice/program/libwpftdrawlo.so (app-office/libreoffice-4.1.2.3)
 *  - /usr/lib/libicule.so.51
 *  - /usr/lib/libicule.so.51.2
 *      used by /usr/lib/libreoffice/program/libmergedlo.so (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libreoffice/program/libvclplug_genlo.so (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libreoffice/program/libvclplug_gtklo.so (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libreoffice/program/libvclplug_svplo.so (app-office/libreoffice-4.1.2.3)
 *  - /usr/lib/libicui18n.so.51
 *  - /usr/lib/libicui18n.so.51.2
 *      used by /usr/lib/libjavascriptcoregtk-3.0.so.0.13.4 (net-libs/webkit-gtk-1.8.3-r300)
 *      used by /usr/lib/libreoffice/program/libfrmlo.so (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libreoffice/program/libi18nsearchlo.so (app-office/libreoffice-4.1.2.3)
 *      used by 4 other files
 *  - /usr/lib/libicuuc.so.51
 *  - /usr/lib/libicuuc.so.51.2
 *      used by /usr/lib/libjavascriptcoregtk-3.0.so.0.13.4 (net-libs/webkit-gtk-1.8.3-r300)
 *      used by /usr/lib/libreoffice/program/libcomphelper.so (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libreoffice/program/libcuilo.so (app-office/libreoffice-4.1.2.3)
app-arch/rar
app-arch/unzip
app-editors/gvim
app-editors/vim
app-emulation/wine
app-misc/screen
app-office/abiword
app-office/libreoffice
app-portage/udept
 *      used by 13 other files
>>> package: app-text/libmwaw-0.2.0
 *  - /usr/lib/libmwaw-0.1.so.1
 *  - /usr/lib/libmwaw-0.1.so.1.0.10
 *      used by /usr/lib/libreoffice/program/libwpftwriterlo.so (app-office/libreoffice-4.1.2.3)
>>> package: media-libs/libpng-1.6.10
 *  - /usr/lib/libpng15.so.15
 *  - /usr/lib/libpng15.so.15.17.0
 *      used by /usr/lib/libreoffice/program/oosplash (app-office/libreoffice-4.1.2.3)
 *      used by /usr/lib/libwebkitgtk-3.0.so.0.13.4 (net-libs/webkit-gtk-1.8.3-r300)
>>> package: x11-drivers/nvidia-drivers-331.20
 *  - /usr/lib/OpenCL/vendors/nvidia/libOpenCL.so.1
 *  - /usr/lib/OpenCL/vendors/nvidia/libOpenCL.so.1.0.0
 *      used by /opt/bin/clinfo (x11-drivers/ati-drivers-14.4_p1)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



and, hmm, I tried to move libswfdecmozilla.so to another location, but it had no effect. I was thinking, is the path correct:
Code:


fuji ~ # ls /usr/lib/nsbrowser/plugins/
libflashplayer.so  libswfdecmozilla.la  libswfdecmozilla.so


should it be
Code:
/usr/lib/firefox/plugins
or something?
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Fri Aug 01, 2014 8:18 am    Post subject: Reply with quote

Promblem still exists, noticed that epiphany crashes when trying to open a flash video page like youtube or any other.

Code:
unhandled event 19
unhandled event 19
unhandled event 19
** Message: console message: http://s.brkmd.com/combres.axd/layoutTopCdpJs/073014_015249/ @1: ReferenceError: Can't find variable: ga

** Message: console message: http://lockerdome.com/embed/6257701483190337/6736687040709914?pubid=ld-853-3924&pubo=http%3A%2F%2Fwww.break.com&width=300 @11: Viewport argument key "minimal-ui" not recognized and ignored.
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Fri Aug 01, 2014 9:10 am    Post subject: Reply with quote

opera seems to show me videos, thanks for the help!
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 292
Location: S.O. France

PostPosted: Fri Aug 01, 2014 10:17 am    Post subject: Reply with quote

Do you have swfdec and swfdec-mozilla installed?
If yes remove then.
Then do
Code:
mv /usr/lib/nsbrowser/plugins /usr/lib/nsbrowser/plugins.back

Emerge adobe-flash and try with firefox.
Like VoidMage said, "it might be that libswfdecmozilla makes libflashplayer blocked too"

EDIT: run emerge @preserved-rebuild to rebuild broken libraries
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Fri Aug 01, 2014 10:53 am    Post subject: Reply with quote

Well, did those things, it didn't help that much, see the blank screen anyhow.. now there is only one add-on in the settings, guess it's good. Opera seems to show videos on youtube. Some webpages not, soundcloud tells me to install flash player. Yea and soundcloud on firefox says "It looks like you have a Flash blocker browser setting or extension. Please enable Flash to hear this track." I actually have adblocker, but disabled now, so it can't be that..
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 292
Location: S.O. France

PostPosted: Fri Aug 01, 2014 11:11 am    Post subject: Reply with quote

What does ls /usr/lib/nsbrowser/plugins/ say now?
Did you try with a clean firefox profile?
In your home directory
Code:
mv .mozilla .mozilla.back
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Fri Aug 01, 2014 1:38 pm    Post subject: Reply with quote

Code:
ls /usr/lib/nsbrowser/plugins
libflashplayer.so


moving the .mozilla had only the effect that my bookmarks dissapeared. Youtube video plugin is just a white screen.
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 292
Location: S.O. France

PostPosted: Fri Aug 01, 2014 2:19 pm    Post subject: Reply with quote

Did you run ?
Code:
emerge @preserved-rebuild
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Fri Aug 01, 2014 4:21 pm    Post subject: Reply with quote

Code:
fuji ~ # emerge @preserved-rebuild

 * IMPORTANT: 17 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] dev-libs/glib-2.40.0-r1 [2.38.2-r1]
[ebuild     U  ] gnome-base/dconf-0.20.0 [0.12.1] USE="{-test%}"
[ebuild  N     ] media-sound/audacious-3.4.1  USE="nls -chardet"
[ebuild     U  ] media-plugins/audacious-plugins-3.4.1 [3.2.2-r1] USE="-lirc%"
[ebuild  N     ] media-libs/swfdec-0.8.4  USE="alsa gtk -doc -ffmpeg -gstreamer -pulseaudio"
[ebuild     U  ] app-misc/geoclue-2.1.9 [2.0.0] USE="modemmanager%*"
[ebuild     U  ] net-libs/webkit-gtk-2.4.4 [1.8.3-r300] USE="X%* egl%* opengl%* -gles2% -libsecret% -wayland%"
[ebuild   R    ] gnome-extra/swfdec-gnome-2.30.1
[ebuild     U  ] app-office/libreoffice-4.2.5.2 [4.1.2.3] USE="(-firebird) -vlc%" PYTHON_SINGLE_TARGET="(-python3_4)" PYTHON_TARGETS="python3_3* (-python3_4)"
[ebuild  NS    ] gnome-base/gnome-menus-3.10.1-r1 [2.30.5-r1] USE="introspection -debug {-test}"
[uninstall     ] gnome-base/gnome-menus-2.30.5-r1
[blocks b      ] <gnome-base/gnome-menus-3.0.1-r1:0 ("<gnome-base/gnome-menus-3.0.1-r1:0" is blocking gnome-base/gnome-menus-3.10.1-r1)
[ebuild     U  ] gnome-base/gnome-panel-3.8.0-r1 [2.32.1-r3]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.40.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.39.1:2 required by (gnome-base/dconf-0.20.0::gentoo, ebuild scheduled for merge)

  (dev-libs/glib-2.38.2-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

fuji ~ #


i have done that command many times, it seems allways has something to complain about
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 292
Location: S.O. France

PostPosted: Fri Aug 01, 2014 8:57 pm    Post subject: Reply with quote

Unmerge swfdec-gnome
What does emerge -1u dev-libs/glib:2 say?
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Sat Aug 02, 2014 10:13 am    Post subject: Reply with quote

Code:
fuji ~ # emerge -1u dev-libs/glib:2

 * IMPORTANT: 17 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] dev-libs/glib-2.40.0-r1 [2.38.2-r1]
[uninstall     ] dev-util/gdbus-codegen-2.38.2
[blocks b      ] <dev-util/gdbus-codegen-2.40.0 ("<dev-util/gdbus-codegen-2.40.0" is blocking dev-libs/glib-2.40.0-r1)
[blocks B      ] <dev-libs/gobject-introspection-1.40 ("<dev-libs/gobject-introspection-1.40" is blocking dev-libs/glib-2.40.0-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/glib-2.40.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.34:2 required by (sci-geosciences/geocode-glib-3.10.0::gentoo, installed)
    >=dev-libs/glib-2.37.7:2 required by (gnome-base/gnome-settings-daemon-3.10.2::gentoo, installed)
    dev-libs/glib:2 required by (dev-dotnet/glib-sharp-2.12.10::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (gnome-base/libgnomeui-2.24.5::gentoo, installed)
    >=dev-libs/glib-2.13:2 required by (net-libs/libnice-0.1.4::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/notification-daemon-0.5.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-flac-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.4:2 required by (dev-libs/libIDL-0.8.14::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (x11-misc/colord-1.0.3::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-ugly-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfconf-4.10.0::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (media-libs/gegl-0.2.0-r2::gentoo, installed)
    >=dev-libs/glib-2.35.1:2 required by (dev-libs/libgweather-3.10.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-vorbis-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (www-client/opera-12.16_p1860-r1::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (x11-libs/gtk+-2.24.23::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (app-office/abiword-3.0.0-r1::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.10.0::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (net-libs/gupnp-0.20.10::gentoo, installed)
    >=dev-libs/glib-2.16 required by (net-im/pidgin-2.10.9-r1::gentoo, installed)
    >=dev-libs/glib-2.9.3 required by (gnome-base/gnome-vfs-2.24.4-r1::gentoo, installed)
    >=dev-libs/glib-2.38.2-r1:2 required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.37.6:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.37.6:2[abi_x86_32(-)]) required by (x11-libs/gdk-pixbuf-2.30.7-r1::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-24.6.0::gentoo, installed)
    >=dev-libs/glib-2.22:2 required by (dev-dotnet/gio-sharp-0.3::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-good-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_32(-)]) required by (dev-libs/dbus-glib-0.100.2-r1::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtgui-4.8.5-r3::gentoo, installed)
    dev-libs/glib:2 required by (x11-misc/tint2-0.11-r1::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112-r1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-accessibility/at-spi2-atk-2.10.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-lame-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-ugly-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (media-libs/swfdec-0.8.4::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4ui-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-misc/modemmanager-1.2.0-r1::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.44.2::gentoo, installed)
    dev-libs/glib:2 required by (x11-wm/openbox-3.5.2-r1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-alsa-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-xvid-0.10.23::gentoo, installed)
    dev-libs/glib:2 required by (net-ftp/gftp-2.0.19-r1::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-bad-0.10.23-r1::gentoo, installed)
    >=dev-libs/glib-2 required by (dev-perl/glib-perl-1.280.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-cdparanoia-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (app-text/evince-3.10.3::gentoo, installed)
    >=dev-libs/glib-2.34.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3[abi_x86_32(-)]) required by (dev-util/pkgconfig-0.28-r1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/libcanberra-0.30-r1::gentoo, installed)
    >=dev-libs/glib-2.6.0:2 required by (gnome-base/libbonoboui-2.24.5::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/thunar-1.6.3::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-mad-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (gnome-base/libgnome-2.32.1-r1::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (x11-libs/goffice-0.10.14::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-plugins/gst-plugins-gio-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/liboil-0.3.17::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (gnome-extra/libgsf-1.14.30::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-base-1.2.3::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-1.2.3::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-taglib-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.10.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/exo-0.10.2::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.16::gentoo, installed)
    >=dev-libs/glib-2 required by (gnome-base/libgnomeprint-2.18.8::gentoo, installed)
    >=dev-libs/glib-2 required by (dev-libs/fribidi-0.19.5-r1::gentoo, installed)
    >=dev-libs/glib-2.35:2 required by (gnome-base/gnome-desktop-3.10.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-bad-0.10.23-r1::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libcroco-0.6.8::gentoo, installed)
    dev-libs/glib:2 required by (media-gfx/pornview-0.2.2::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-power/upower-pm-utils-0.9.23-r2::gentoo, installed)
    >=dev-libs/glib-2.37.5:2 required by (x11-libs/gtk+-3.10.8::gentoo, installed)
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (gnome-base/librsvg-2.40.2::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (dev-libs/libgusb-0.1.4::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4-r1::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (net-libs/gupnp-0.20.10::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.5-r2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-gconf-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-gio-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-faad-0.10.23::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (net-libs/gupnp-igd-0.2.2-r1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gstreamer-1.2.3::gentoo, installed)
    dev-libs/glib:2 required by (x11-libs/wxGTK-2.8.12.1-r1::gentoo, installed)
    >=dev-libs/glib-2 required by (app-text/wv-1.2.9-r1::gentoo, installed)
    >=dev-libs/glib-2.32 required by (net-libs/libqmi-1.8.0::gentoo, installed)
    >=dev-libs/glib-2.38:2 required by (net-libs/glib-networking-2.38.2::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (app-misc/geoclue-2.1.9::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/gssdp-0.14.7::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gconf-3.2.6-r2::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (gnome-base/orbit-2.14.19-r3::gentoo, installed)
    >=dev-libs/glib-2.18:2 required by (dev-lang/vala-0.22.1::gentoo, installed)
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.36.3::gentoo, installed)
    >=dev-libs/glib-2.14 required by (xfce-base/garcon-0.2.0::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libgnomecanvas-2.30.3::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (app-i18n/ibus-1.4.99.20121006::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-crypt/gcr-3.10.1::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (dev-dotnet/libgdiplus-2.10.9-r1::gentoo, installed)
    dev-libs/glib required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-good-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.6.0 required by (net-irc/irssi-0.8.15-r1::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/webkit-gtk-2.2.6-r200::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.37:2 required by (gnome-base/gvfs-1.18.3-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-panel-4.10.0-r1::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (gnome-base/gnome-keyring-3.10.1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-soundtouch-0.10.23::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (x11-libs/pangox-compat-0.0.2::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-java/icedtea-bin-6.1.13.3-r3::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.10.1::gentoo, installed)
    >=dev-libs/glib-2.4.0 required by (media-sound/pulseaudio-2.1-r1::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (net-libs/libproxy-0.4.11-r1::gentoo, installed)
    >=dev-libs/glib-2.34.3:2/2=[abi_x86_32(-)] required by (sys-apps/systemd-215-r1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-x-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.30 required by (net-misc/networkmanager-0.9.8.8::gentoo, installed)
    dev-libs/glib:2
    >=dev-libs/glib-2.14:2 required by (gnome-base/libbonobo-2.24.3::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-ogg-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (rox-base/rox-2.10::gentoo, installed)
    dev-libs/glib:2 required by (www-plugins/adobe-flash-11.2.202.394::gentoo, installed)
    dev-libs/glib:2 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4util-4.10.1::gentoo, installed)
    >=dev-libs/glib-2:2 required by (x11-libs/gtkglext-1.2.0-r1::gentoo, installed)
    >=dev-libs/glib-2.30.2:2 required by (media-gfx/gimp-2.8.10-r1::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.1.3::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/gobject-introspection-1.38.0::gentoo, installed)

  (dev-libs/gobject-introspection-1.38.0::gentoo, installed) pulled in by
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.36.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/libgweather-3.10.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (dev-libs/libgusb-0.1.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1:0/0= required by (x11-libs/goffice-0.10.14::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (app-i18n/ibus-1.4.99.20121006::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (net-misc/modemmanager-1.2.0-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.44.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-1.0.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.10.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.10.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (gnome-extra/libgsf-1.14.30::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-3.2.6-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-pm-utils-0.9.23-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.10.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.3 required by (net-misc/networkmanager-0.9.8.8::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.10.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.2.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.10.8::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-3.2.6-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.14.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.30.7-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.20.10::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.10.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.0 required by (net-libs/webkit-gtk-2.2.6-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.10.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.40.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.2.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (sci-geosciences/geocode-glib-3.10.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.23::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.10.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.0.0 required by (app-office/abiword-3.0.0-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.44.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1:= required by (x11-libs/goffice-0.10.14::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5825

PostPosted: Sat Aug 02, 2014 1:22 pm    Post subject: Reply with quote

Sorry for ignoring your thread for this long.
If I google correctly, 'AMD Sempron(tm) 3000+' is the complete reason of your problem.

The problem is that Adobe upstream are being asshats.

You see, from what I've googled, this processor does not support SSE2 set and while this is one of the more recent and complete reports, the actual problem goes back at least here, so is over two years old, with Adobe doing shit all about it.
One of the more aggravating parts is that 32bit Windows version last time I was able to check (less than 3 months ago) still didn't have such requirement.
Back to top
View user's profile Send private message
ct85711
Guru
Guru


Joined: 27 Sep 2005
Posts: 357

PostPosted: Sat Aug 02, 2014 8:22 pm    Post subject: Reply with quote

I thought I should also mention, in that the adobe stopped providing updates for flash on firefox on linux( a couple years ago, and soon coming up where they'll be stopping support in general, or what little they provide now). So what it means, is that even if you get the adobe-flash working on firefox; it is way out of date (hence the message to update your flash and since they won't give any more updates, you can't do that). Some site, like I know youtube for sure, you can watch the videos using html5 and not deal with flash at all. You will need gstreamer installed for that. Otherwise, you will be forced to use google-chrome/chromium to use the flash that adobe is giving them. Sadly, the flash plugin chrome is using is not compatible to firefox in any way, and last I saw firefox is still refusing to even consider adding support for that type of plugins in general.

I will say there is a couple projects out there, 2 main ones (can't think the names right off hand, and you can easily find the threads for that information) that is trying to make a replacment for flash. However, every time I've tried using them; they haven't worked on most sites I visit and few they did was marginal at best. Right now, from what I've seen, your best bet would be use google-chrome for any site that requires flash; as none of the sites are going to get better (and more of then will stop working with adobe-flash due to being too old, they demand newer versions). I couldn't say on Opera, but I doubt it's going to fair much better than firefox. Mostly due to adobe's licensing and everything. I don't follow Opera to say on if they are going to support papi (google's new plugin format that flash now only supports) or not. Now if if someone knows on if Opera is going to support papi, please let me know as I'd gladly switch from gogole-chrome to Opera for my flash support.
Back to top
View user's profile Send private message
charles17
l33t
l33t


Joined: 02 Mar 2008
Posts: 801

PostPosted: Sun Aug 03, 2014 9:49 am    Post subject: Reply with quote

ct85711 wrote:
(...) Some site, like I know youtube for sure, you can watch the videos using html5 and not deal with flash at all. You will need gstreamer installed for that. Otherwise, (...)
I don't have gstreamer an firefoxing the Youtube stuff works well. Why should one need gstreamer?
Back to top
View user's profile Send private message
ct85711
Guru
Guru


Joined: 27 Sep 2005
Posts: 357

PostPosted: Mon Aug 04, 2014 6:20 pm    Post subject: Reply with quote

There's other plugins besides gstreamer for videos, I don't know all of the various plugins for videos. I was just mentioning one that works fairly well for me. Like I know vlc's plugin works too (not sure how well for html5, but I haven't looked on that much).
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 292
Location: S.O. France

PostPosted: Tue Aug 05, 2014 8:50 am    Post subject: Reply with quote

@ Pulie
Unmerge dev-util/gdbus-codegen and dev-libs/gobject-introspection
Then
Code:
emerge -1u dev-libs/glib:2 && emerge @preserved-rebuild


VoidMage wrote:
this processor does not support SSE2

Pulie, Can you post cat /proc/cpuinfo
Back to top
View user's profile Send private message
charles17
l33t
l33t


Joined: 02 Mar 2008
Posts: 801

PostPosted: Tue Aug 05, 2014 9:59 am    Post subject: Reply with quote

ct85711 wrote:
There's other plugins besides gstreamer for videos, I don't know all of the various plugins for videos. I was just mentioning one that works fairly well for me. Like I know vlc's plugin works too (not sure how well for html5, but I haven't looked on that much).
I have firefox without any plugins, even unmerged gnash, and the Youtube stuff runs well. No pulseaudio no gstreamer needed to run html5 in firefox. But regarding the alternatives, even ffplay works well, without firefox.
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Tue Aug 05, 2014 1:37 pm    Post subject: Reply with quote

thnaks for the help!

here is the cpuinfo

Code:
cat /proc/cpuinfo
processor   : 0
vendor_id   : AuthenticAMD
cpu family   : 6
model      : 10
model name   : AMD Sempron(tm)  3000+
stepping   : 0
cpu MHz      : 1991.181
cache size   : 512 KB
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 1
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow
bogomips   : 3982.36
clflush size   : 32
cache_alignment   : 32
address sizes   : 34 bits physical, 32 bits virtual
power management: ts
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 866
Location: Massachusetts USA

PostPosted: Tue Aug 05, 2014 6:16 pm    Post subject: Reply with quote

See https://github.com/klemens/ff-youtube-all-html5/issues/26

Firefox changed the API that youtube is using to display the video. Other sites, www,cnn.com, can show flash videos.
Back to top
View user's profile Send private message
Pulie
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 95
Location: Finland

PostPosted: Thu Aug 07, 2014 10:25 am    Post subject: Reply with quote

yea, well, it's sad they don't support my cpu better.

By the way webkit-gtk failed to install while doing the emerge @preserved-rebuild

Code:
i686-pc-linux-gnu-g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
make[1]: *** [DerivedSources/WebKit2/libwebkit2gtk_3_0_la-WebPageProxyMessageReceiver.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
mv -f DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebPageMessageReceiver.Tpo DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebPageMessageReceiver.Plo
make[1]: Leaving directory `/var/tmp/portage/net-libs/webkit-gtk-2.4.4/work/webkitgtk-2.4.4'
make: *** [all] Error 2
 * ERROR: net-libs/webkit-gtk-2.4.4::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/work/webkitgtk-2.4.4'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/work/webkitgtk-2.4.4'

>>> Failed to emerge net-libs/webkit-gtk-2.4.4, Log file:

>>>  '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/temp/build.log'

 * Messages for package net-libs/webkit-gtk-2.4.4:

 * ERROR: net-libs/webkit-gtk-2.4.4::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/work/webkitgtk-2.4.4'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.4/work/webkitgtk-2.4.4'


info:


Code:
Portage 2.2.8-r1 (default/linux/x86/13.0, gcc-4.7.3, glibc-2.17, 3.8.13-ck i686)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.8.13-ck-i686-AMD_Sempron-tm-_3000+-with-gentoo-2.2
KiB Mem:     1029784 total,    387732 free
KiB Swap:     524284 total,    388612 free
Timestamp of tree: Fri, 01 Aug 2014 08:30:01 +0000
ld GNU ld-versio (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.2.5-r3, 3.3.3
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.5.4, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -funroll-loops -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -funroll-loops -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LANG="fi_FI.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="3dnow X aac acl alsa apache2 avi berkdb bzip2 cli cracklib crypt cxx dhcp dri firefox flac fortran gd gdbm gif gnome gtk iconv ipv6 java joystick jpeg matroska mmx modules mozilla mp3 music mysql ncurses networkmanager nls nptl ogg opengl openmp pam pcre perl php ppp python readline session sse2 ssl tcpd truetype udev unicode usb vorbis x86 xvid zlib" ABI_X86="32" ALSA_CARDS="ac97" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fi" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3 php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5029
Location: Saint Amant, Acadiana

PostPosted: Thu Aug 07, 2014 11:47 am    Post subject: Reply with quote

This is most likely OOM killer in action, try with MAKEOPTS="-j1".
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum