Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualGL - finally got it working!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1532

PostPosted: Thu Aug 07, 2014 8:46 am    Post subject: VirtualGL - finally got it working! Reply with quote

After banging my head against a wall for the last 5 days, I finally got VirtualGL to work! Hurrah!

Things worth knowing:

If you use xdm, it defaults to the 7th virtual terminal. I had 8. You need to edit /etc/conf.d/xdm and change the VT it uses to 9 or more.
But you don't need this as you can just run /usr/bin/X

This one is the kicker that has wasted 3 days of research: VirtualGL _*REQUIRES*_ VNCserver to be running in 24-bit mode; I had $depth=16; in the vncserver file. This yields the in-hindsight understandable, but at the time expletively, unhelpful "Error: couldn't get an RGB, Double-buffered visual" error message.

Thank you Paul McIntosh on the VGL mailing list! You were the SINGLE person on the whole Internet who discovered this and mentioned it!


For my next task, I need to try and get OpenCL working! It only works on the CPU and not the GPU, and running test programs yields unhelpful messages like "ERROR: clBuildProgram(-11)"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum