Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solucionado] Problema al actualizar perl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 461
Location: Tultitlan, México

PostPosted: Tue Aug 05, 2014 12:33 am    Post subject: [Solucionado] Problema al actualizar perl Reply with quote

Pues con este problemilla que ha salido al tratar de actualizar mi gentoo, traté de hacer un perl-cleaner pero no lo ejecuta por problemas de dependencias también. Haber si me ayudan con alguna sugerencia.

Code:
These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Algorithm-Diff-1.190.200-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-File-Spec-3.400.0-r2::gentoo, installed)
    (and 4 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.


Last edited by edgar_uriel84 on Thu Aug 07, 2014 4:45 am; edited 1 time in total
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 348

PostPosted: Tue Aug 05, 2014 1:23 pm    Post subject: Reply with quote

Hola:

Dale un tiempo a portage para que se acomode. Vuelve a correr "emerge --sync" en unos días.

https://forums.gentoo.org/viewtopic-t-996494.html
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3757

PostPosted: Tue Aug 05, 2014 2:43 pm    Post subject: Reply with quote

que pasa si ejecutas :

Code:
emerge -av1 =dev-lang/perl-5.18.2-r1


?

en caso de que puedas actualizar a 5.18.* acuérdate de ejecutar perl-cleaner despues.

saluetes
Back to top
View user's profile Send private message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 461
Location: Tultitlan, México

PostPosted: Tue Aug 05, 2014 8:13 pm    Post subject: Reply with quote

Pues así tratando de instalar algo de perl "a la brava" no me sirvió todas las salidas eran lo mismo, buscandole un poquito, parece que el problema esta casi solucionado, hice:

Quote:
# emerge -auvDN -1 =dev-lang/perl-5.18* $(eix '-I#' virtual/perl-*)

# perl-cleaner --reallyall


ahora al tratar de actualizar, me ha dicho que git y un par de cosas mas (no anote lo siento) aun piden perl-5.16 las he reinstalado de desinstalado de forma individual, ahora estoy actualizando todo el sistema han salido muchas actualizaciones así que toca esperar para detectar errores y esas cosas.

Por cierto, este post me ha ayudado bastante: https://forums.gentoo.org/viewtopic-p-7593682.html
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.
Back to top
View user's profile Send private message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 461
Location: Tultitlan, México

PostPosted: Thu Aug 07, 2014 4:45 am    Post subject: Reply with quote

Cierro el tema porque básicamente el comando mágico es emerge -auvDN -1 =dev-lang/perl-5.18* $(eix '-I#' virtual/perl-*)

Luego de eso, hay problemas de dependencias, pero luego de un rato siguiendo instrucciones normales de portage, se soluciona.

Gracias, a todos por la ayuda
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum