Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ALSA] Problème de carte son
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
makillo
n00b
n00b


Joined: 24 Nov 2012
Posts: 22
Location: Paris

PostPosted: Sun Aug 03, 2014 11:05 pm    Post subject: [ALSA] Problème de carte son Reply with quote

Bonjour,
je viens de refaire une install de gentoo et impossible de faire fonctionner la carte son :
Quand j'avais pulseaudio je n'avais que la chaine dummy output, maintenant désinstallé, alsamixer me répond
Code:
le mixeur ne peut pas être ouvert: Aucun fichier ou dossier de ce type
et quand je lance relance le service alsa, ca donne ca :
Code:
genkillo makillo # /etc/init.d/alsasound start
 * Starting udev ...
 * start-stop-daemon: /lib/systemd/systemd-udevd is already running
 * Failed to start udev                                                                 [ !! ]
 * ERROR: udev failed to start
 * Restoring Mixer Levels ...     
pourtant j'ai vérifié 10 fois mon kernel et j'ai activé tout ce qu'il fallait que ce soit pour udev ou alsa et mes autorisation sont ok (j’appartiens bien au groupe audio...
Bref j'ai l'impression de tourner en rond depuis ce matin.
Merci pour votre aide
_________________
- Pourquoi ce déguisement de lapin ridicule ?
- Pourquoi ce déguisement d’homme ridicule ?
Donnie Darko
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 423
Location: La Louviere (Belgique)

PostPosted: Mon Aug 04, 2014 5:31 am    Post subject: Reply with quote

Bonjour,

Peux-tu, s'il te plait, poster le résultat de ; lspci -kk
si carte son sous usb : lsusb -kk

Ton problème ne s'explique que par cela, pas de modules kernel pour la carte son
lspci : liste les périph pci
-kk : affiche le module kernel utilisé par le périphérique, pour la carte son cela devrait être vide.
Back to top
View user's profile Send private message
makillo
n00b
n00b


Joined: 24 Nov 2012
Posts: 22
Location: Paris

PostPosted: Tue Aug 05, 2014 9:06 am    Post subject: Reply with quote

Voila :
Code:
genkillo makillo # lspci -kk
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: i915
        Kernel modules: i915
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: mei_me
        Kernel modules: mei_me
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: lpc_ich
        Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel modules: i2c_i801
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev a1)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: nouveau
        Kernel modules: nouveau
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
        Subsystem: Intel Corporation Centrino Advanced-N 6235 AGN
        Kernel modules: iwlwifi
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
        Subsystem: Samsung Electronics Co Ltd Device c0d1
        Kernel driver in use: r8169
        Kernel modules: r8169
genkillo makillo #

_________________
- Pourquoi ce déguisement de lapin ridicule ?
- Pourquoi ce déguisement d’homme ridicule ?
Donnie Darko
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5877
Location: ~Brussels - Belgique

PostPosted: Tue Aug 05, 2014 9:12 am    Post subject: Reply with quote

Code:
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device c0d1


Il n'y a pas de module noyau associé. As-tu bien compilé les pilotes Intel HD Audio ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4704

PostPosted: Mon Aug 11, 2014 9:35 pm    Post subject: Reply with quote

XavierMiller wrote:
As-tu bien compilé les pilotes Intel HD Audio ?

Pourquoi tu poses la question ? :D
Back to top
View user's profile Send private message
Cincinnatus
n00b
n00b


Joined: 18 Jul 2014
Posts: 9

PostPosted: Thu Oct 02, 2014 12:41 pm    Post subject: Reply with quote

Bonjour, j'ai presque exactement le même problème à ceci près que je n'ai jamais installé pulseaudio.

lspci -kk me donne ceci :
Code:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
   Subsystem: Lenovo Device 20f2
   Kernel driver in use: snd_hda_intel


Ce qui me laisse penser que j'ai bien un pilote pour ma carte

Mais quand je rentre
mplayer -ao alsa Gallois.mp4
j'ai la vidéo mais aucun son, et mplayer me renvoi ceci :
Code:

==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[aac @ 0x7f1b1227f640]Warning: not compiled with thread support, using thread emulation
AUDIO: 44100 Hz, 2 ch, floatle, 95.8 kbit/3.40% (ratio: 11980->352800)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO_ALSA] alsa-lib: /var/tmp/portage/media-libs/alsa-lib-1.0.27.2/work/alsa-lib-1.0.27.2/src/pcm/pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa'
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 960x540 => 960x540 Planar YV12
V:  42.2   0/  0 14%  2%  0.0% 0 0

Exiting... (Quit)


De plus quand je lance alsamixer je peux choisir une carte son :

Code:
-  (par défaut)
0  HDA Intel
entrez le nom du périphérique...

(Périphérique que je retrouve bien dans la séquence de démarrage)
mais par contre je ne peux rien toucher :
Code:

┌────────────────────────────────── AlsaMixer v1.0.27.2 ───────────────────────────────────┐
│    Carte: HDA Intel                                            F1:  Aide                 │
│     Puce:                                                      F2:  Informations Système │
│      Vue: F3: Lecture  F4: Capture  F5: Tout                   F6:  Choisir la carte son │
│ Contrôle:                                                      Esc: Quitter              │
│                          Ce périphérique n'a pas de commandes.                           │
└──────────────────────────────────────────────────────────────────────────────────────────┘


Voila, j'ai suivi le tuto, j'ai fais les test de speaker qui n'ont bien entendu pas aboutis, j'ai cherché d'autres tutos, et j'en suis arrivé là.
C'est assez handicapant pour le moment... Si quelqu'un a une solution je lui en serait un pot de grès.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4704

PostPosted: Fri Oct 03, 2014 7:59 am    Post subject: Reply with quote

Vérifie dans ton kernel si tu as bien le codec pour ta carte.

genre:
Code:
grep HDA_CODEC /usr/src/linux/.config


Et pour la carte son
Code:
head -1 /proc/asound/card0/codec#0
Back to top
View user's profile Send private message
Cincinnatus
n00b
n00b


Joined: 18 Jul 2014
Posts: 9

PostPosted: Fri Oct 03, 2014 7:42 pm    Post subject: Reply with quote

C'était exactement ça, il me manquait le codec.
Vu que je n'avais jamais eu ce problème de son sur mes autres ordinateurs ça ne m'était pas venu à l'esprit.
Merci pour ton aide.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum