Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Samba issue
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1483
Location: Oranienburg/Germany

PostPosted: Fri Jun 13, 2014 10:11 am    Post subject: Reply with quote

I rechecked a lot of forums and a bugzilla report as well. I hope you still have:

Code:

rc_depend_strict="NO"


set in /etc/rc.conf

This should work around the issue, when you have a net.XXX script in the default runlevel (see: http://dev.gentoo.org/~vapier/openrc/projects/openrc/ticket/33.html )

bb
_________________
1st: i5-4440 3.1GHz, 16GB, 900GB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 256GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB + 3TB + 4TB BACKUP
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 4GB SD + NFS
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2113

PostPosted: Fri Jun 13, 2014 10:21 am    Post subject: Reply with quote

OK, sorry. That line was turned off.
After turning it on, I am getting a new error:

Code:

IgorReinCloud igor # smbclient -L localhost
WARNING: The security=share option is deprecated
Enter root's password:
Domain=[MSHOME] OS=[Unix] Server=[Samba 3.6.23]
Server requested LANMAN password (share-level security) but 'client lanman auth = no' or 'client ntlmv2 auth = yes'
tree connect failed: NT_STATUS_ACCESS_DENIED


This is a new page, so I will push samba config for reference. ;-)

Code:

IgorReinCloud igor # /usr/bin/testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[public]"
WARNING: The security=share option is deprecated
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
   workgroup = MSHOME
   server string = Samba Server %v
   security = SHARE
   log file = /var/log/samba/log.%m
   max log size = 50
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   local master = No
   dns proxy = No
   idmap config * : backend = tdb
   hosts allow = 192.168.1.9, 127.0.0.1
   hosts deny = 0.0.0.0/0

[homes]
   comment = Home Directories
   read only = No
   browseable = No

[printers]
   comment = All Printers
   path = /var/spool/samba
   printable = Yes
   print ok = Yes
   browseable = No

[public]
   comment = Public Stuff
   path = /home/samba/public
   write list = @staff
   read only = No
   create mask = 0766
   guest ok = Yes


Need to go to sleep. Will talk to you in the morning.

Thank you.
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1483
Location: Oranienburg/Germany

PostPosted: Fri Jun 13, 2014 10:25 am    Post subject: Reply with quote

OK, good night but we have samba running now. Problem with NT_STATUS_ACCESS_DENIED is, you need to set a samba password for accessing the shares. You should not (and maybe cannot) do this with root. Use a normal user for this. If you dont have a user, create one and use "smbpasswd" to set a samba password for this user. Then try again with the following command:

Code:

smbclient -L localhost -U <username>


It should look similiar like this:

Code:

smbclient -L localhost -U <username>
Enter <username>'s password:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

        Sharename       Type      Comment
        ---------       ----      -------
        IPC$            IPC       IPC Service (raspi server (Samba, Debian 7.1))
        Virtual_PDF_Printer Printer   Virtual PDF Printer
        HP_DeskJet_1050A Printer   HP_DeskJet_1050A
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

        Server               Comment
        ---------            -------
        RASPI                raspi server (Samba, Debian 7.1)
        ZEUS                 zeus server (Samba, Ubuntu)

        Workgroup            Master
        ---------            -------
        WORKGROUP            ZEUS


greets and good night bb
_________________
1st: i5-4440 3.1GHz, 16GB, 900GB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 256GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB + 3TB + 4TB BACKUP
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 4GB SD + NFS
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2113

PostPosted: Fri Jun 13, 2014 5:45 pm    Post subject: Reply with quote

bbgermany,
1. Yes, wicd works. I just added it and it is now running with no problems.
2. Setting the password for the user fails:

Code:

igor@IgorReinCloud ~ $ smbpasswd
Old SMB password:
New SMB password:
Retype new SMB password:
machine 127.0.0.1 rejected the password change: Error was : NT_STATUS_RPC_PROTOCOL_ERROR.


I still have samba-3 installed on my machine.

Thank you.
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1483
Location: Oranienburg/Germany

PostPosted: Sun Jun 15, 2014 6:11 pm    Post subject: Reply with quote

Hi,

please run as root:

Code:

smbpasswd -a igor


If this was running without issues run the following as root:

Code:

smbpasswd -e igor


AFAIK you have to enable a special option in smb.conf for allowing changing the password via smbpasswd as user. Oh and btw, did you check, that samba is running correctly as process via ps. There must be at least on smbd and one nmbd process running.

greets bb
_________________
1st: i5-4440 3.1GHz, 16GB, 900GB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 256GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB + 3TB + 4TB BACKUP
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 4GB SD + NFS
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2113

PostPosted: Mon Jul 14, 2014 10:16 pm    Post subject: Reply with quote

bbgermany,
Code:

igor@IgorReinCloud ~/wxWidgets $ smbclient -L localhost -U igor
WARNING: The security=share option is deprecated
Enter igor's password:
Domain=[MSHOME] OS=[Unix] Server=[Samba 3.6.23]
Server requested LANMAN password (share-level security) but 'client lanman auth = no' or 'client ntlmv2 auth = yes'
tree connect failed: NT_STATUS_ACCESS_DENIED


Looks like we are making progress. ;-)
Is this error because I have "security=share" or something else?

Thank you.
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1483
Location: Oranienburg/Germany

PostPosted: Tue Jul 15, 2014 8:50 am    Post subject: Reply with quote

Hi,

i dont have set "security" in my smb.conf. Remove or disable the line and try again.

bb
_________________
1st: i5-4440 3.1GHz, 16GB, 900GB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 256GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB + 3TB + 4TB BACKUP
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 4GB SD + NFS
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2113

PostPosted: Wed Jul 16, 2014 2:33 am    Post subject: Reply with quote

OK, that did it.
Now about "security=" line: why did you remove it? What are the consequences of such removal?

Thank you.
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1483
Location: Oranienburg/Germany

PostPosted: Wed Jul 16, 2014 6:20 am    Post subject: Reply with quote

Hi,

I used a default config for the basics and "security" wasnt set in this case. This is my basic file for shared homdirs:

Code:

[global]
        server string = %h server (Samba)
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        usershare allow guests = Yes
        load printers = no
        printing = bsd
        cups options = raw
        printcap name = /dev/null
        disable spoolss = Yes
        print command = lpr -r -P'%p' %s
        lpq command = lpq -P'%p'
        lprm command = lprm -P'%p' %j


[homes]
        comment = Homedirectories
        read only = No
        browseable = No
        browsable = No


bb
_________________
1st: i5-4440 3.1GHz, 16GB, 900GB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 256GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB + 3TB + 4TB BACKUP
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 4GB SD + NFS
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2113

PostPosted: Fri Jul 25, 2014 6:19 pm    Post subject: Reply with quote

Thank you for the help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum