Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201406-27 ] polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege escalation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1650

PostPosted: Fri Jun 27, 2014 12:26 am    Post subject: [ GLSA 201406-27 ] polkit, Spice-Gtk, systemd, HPLIP, libvir Reply with quote

Gentoo Linux Security Advisory

Title: polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege escalation (GLSA 201406-27)
Severity: high
Exploitable: local
Date: June 26, 2014
Bug(s): #484486, #484488, #485420, #485546, #485904
ID: 201406-27

Synopsis

A race condition in polkit could allow a local attacker to gain
escalated privileges.


Background

polkit is a toolkit for managing policies relating to unprivileged
processes communicating with privileged processes.


Affected Packages

Package: net-print/hplip
Vulnerable: < 3.14.1
Unaffected: >= 3.14.1
Architectures: All supported architectures

Package: net-misc/spice-gtk
Vulnerable: < 0.21
Unaffected: >= 0.21
Architectures: All supported architectures

Package: sys-apps/systemd
Vulnerable: < 204-r1
Unaffected: >= 204-r1
Architectures: All supported architectures

Package: app-emulation/libvirt
Vulnerable: < 1.1.2-r3
Unaffected: >= 1.1.2-r3
Architectures: All supported architectures

Package: sys-auth/polkit
Vulnerable: < 0.112
Unaffected: >= 0.112
Architectures: All supported architectures


Description

polkit has a race condition which potentially allows a process to change
its UID/EUID via suid or pkexec before authentication is completed.


Impact

A local attacker could start a suid or pkexec process through a
polkit-enabled application, which could result in privilege escalation or
bypass of polkit restrictions.


Workaround

There is no known workaround at this time.

Resolution

All polkit users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-auth/polkit-0.112"
   
All HPLIP users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-print/hplip-3.14.1"
   
All Spice-Gtk users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/spice-gtk-0.21"
   
All systemd users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-apps/systemd-204-r1"
   
All libvirt users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-emulation/libvirt-1.1.2-r3"
   


References

CVE-2013-4288
CVE-2013-4311
CVE-2013-4324
CVE-2013-4325
CVE-2013-4327
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum