Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The Xorg make me crazy!!!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lhw828
n00b
n00b


Joined: 05 Sep 2013
Posts: 27

PostPosted: Wed Jun 25, 2014 11:44 am    Post subject: The Xorg make me crazy!!!! Reply with quote

Code:
[  2367.982]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
[  2367.982]
X.Org X Server 1.15.99.903 (1.16.0 RC 3)
Release Date: 2014-06-04
[  2367.984] X Protocol Version 11, Revision 0
[  2367.984] Build Operating System: Linux 3.15.1-gentoo x86_64 Gentoo
[  2367.984] Current Operating System: Linux lhw 3.15.1-gentoo #1 SMP Wed Jun 25 08:11:18 CST 2014 x86_64
[  2367.984] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.15.1-gentoo root=UUID=56b2d440-b5b9-4d91-a910-f6afc0d0e9b4
[  2367.984] Build Date: 26 June 2014  03:26:05AM
[  2367.985] 
[  2367.985] Current version of pixman: 0.32.4
[  2367.985]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  2367.985] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2367.986] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 26 03:35:39 2014
[  2367.986] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2367.986] (==) No Layout section.  Using the first Screen section.
[  2367.986] (==) No screen section available. Using defaults.
[  2367.986] (**) |-->Screen "Default Screen Section" (0)
[  2367.986] (**) |   |-->Monitor "<default monitor>"
[  2367.986] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  2367.986] (==) Automatically adding devices
[  2367.986] (==) Automatically enabling devices
[  2367.986] (==) Automatically adding GPU devices
[  2367.986] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  2367.986] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  2367.986] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2367.986] (II) Loader magic: 0x806c60
[  2367.986] (II) Module ABI versions:
[  2367.986]    X.Org ANSI C Emulation: 0.4
[  2367.986]    X.Org Video Driver: 18.0
[  2367.986]    X.Org XInput driver : 21.0
[  2367.986]    X.Org Server Extension : 8.0
[  2367.988] (--) PCI:*(0:0:2:0) 8086:0166:17aa:21fa rev 9, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00006000/64
[  2367.988] (II) LoadModule: "glx"
[  2367.988] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  2367.988] (II) Module glx: vendor="X.Org Foundation"
[  2367.988]    compiled for 1.15.99.903, module version = 1.0.0
[  2367.988]    ABI class: X.Org Server Extension, version 8.0
[  2367.988] (==) AIGLX enabled
[  2367.988] (==) Matched intel as autoconfigured driver 0
[  2367.988] (==) Matched modesetting as autoconfigured driver 1
[  2367.988] (==) Matched fbdev as autoconfigured driver 2
[  2367.988] (==) Matched vesa as autoconfigured driver 3
[  2367.988] (==) Assigned the driver to the xf86ConfigLayout
[  2367.988] (II) LoadModule: "intel"
[  2367.989] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  2367.989] (II) Module intel: vendor="X.Org Foundation"
[  2367.989]    compiled for 1.15.99.903, module version = 2.99.912
[  2367.989]    Module class: X.Org Video Driver
[  2367.989]    ABI class: X.Org Video Driver, version 18.0
[  2367.989] (II) LoadModule: "modesetting"
[  2367.989] (WW) Warning, couldn't open module modesetting
[  2367.989] (II) UnloadModule: "modesetting"
[  2367.989] (II) Unloading modesetting
[  2367.989] (EE) Failed to load module "modesetting" (module does not exist, 0)
[  2367.989] (II) LoadModule: "fbdev"
[  2367.989] (WW) Warning, couldn't open module fbdev
[  2367.989] (II) UnloadModule: "fbdev"
[  2367.989] (II) Unloading fbdev
[  2367.989] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2367.989] (II) LoadModule: "vesa"
[  2367.989] (WW) Warning, couldn't open module vesa
[  2367.989] (II) UnloadModule: "vesa"
[  2367.989] (II) Unloading vesa
[  2367.989] (EE) Failed to load module "vesa" (module does not exist, 0)
[  2367.989] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  2367.989] (II) intel: Driver for Intel(R) HD Graphics: 2000-5000
[  2367.989] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100
[  2367.989] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200
[  2367.989] (--) using VT number 7

[  2367.993] (EE) No devices detected.
[  2367.993] (EE)
Fatal server error:
[  2367.993] (EE) no screens found(EE)
[  2367.993] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  2367.993] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2367.993] (EE)
Back to top
View user's profile Send private message
russK
Apprentice
Apprentice


Joined: 27 Jun 2006
Posts: 272

PostPosted: Wed Jun 25, 2014 12:39 pm    Post subject: Re: The Xorg make me crazy!!!! Reply with quote

Can you post the xorg.conf file and output from 'lspci' ?
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1801
Location: Berlin, Germany

PostPosted: Wed Jun 25, 2014 12:39 pm    Post subject: Reply with quote

Looks like you don't have CONFIG_DRM_I915_KMS enabled in your kernel.
Back to top
View user's profile Send private message
lhw828
n00b
n00b


Joined: 05 Sep 2013
Posts: 27

PostPosted: Thu Jun 26, 2014 9:17 am    Post subject: Reply with quote

chithanh wrote:
Looks like you don't have CONFIG_DRM_I915_KMS enabled in your kernel.


Code:
[    59.102]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
[    59.102]
X.Org X Server 1.15.99.903 (1.16.0 RC 3)
Release Date: 2014-06-04
[    59.103] X Protocol Version 11, Revision 0
[    59.103] Build Operating System: Linux 3.15.1-gentoo x86_64 Gentoo
[    59.103] Current Operating System: Linux lhw 3.15.1-gentoo #1 SMP Fri Jun 27 00:54:48 CST 2014 x86_64
[    59.103] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.15.1-gentoo root=UUID=56b2d440-b5b9-4d91-a910-f6afc0d0e9b4
[    59.103] Build Date: 26 June 2014  03:26:05AM
[    59.103] 
[    59.103] Current version of pixman: 0.32.4
[    59.104]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    59.104] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    59.105] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 27 01:09:08 2014
[    59.159] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    59.179] (==) No Layout section.  Using the first Screen section.
[    59.179] (==) No screen section available. Using defaults.
[    59.179] (**) |-->Screen "Default Screen Section" (0)
[    59.179] (**) |   |-->Monitor "<default monitor>"
[    59.187] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    59.187] (==) Automatically adding devices
[    59.187] (==) Automatically enabling devices
[    59.187] (==) Automatically adding GPU devices
[    59.264] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[    59.264] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    59.264] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    59.264] (II) Loader magic: 0x806c60
[    59.264] (II) Module ABI versions:
[    59.264]    X.Org ANSI C Emulation: 0.4
[    59.264]    X.Org Video Driver: 18.0
[    59.264]    X.Org XInput driver : 21.0
[    59.264]    X.Org Server Extension : 8.0
[    59.265] (--) PCI:*(0:0:2:0) 8086:0166:17aa:21fa rev 9, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00006000/64
[    59.272] (II) LoadModule: "glx"
[    59.291] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    59.465] (II) Module glx: vendor="X.Org Foundation"
[    59.465]    compiled for 1.15.99.903, module version = 1.0.0
[    59.465]    ABI class: X.Org Server Extension, version 8.0
[    59.465] (==) AIGLX enabled
[    59.465] (==) Matched intel as autoconfigured driver 0
[    59.465] (==) Matched modesetting as autoconfigured driver 1
[    59.465] (==) Matched fbdev as autoconfigured driver 2
[    59.465] (==) Matched vesa as autoconfigured driver 3
[    59.465] (==) Assigned the driver to the xf86ConfigLayout
[    59.465] (II) LoadModule: "intel"
[    59.465] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    59.499] (II) Module intel: vendor="X.Org Foundation"
[    59.499]    compiled for 1.15.99.903, module version = 2.99.912
[    59.499]    Module class: X.Org Video Driver
[    59.499]    ABI class: X.Org Video Driver, version 18.0
[    59.499] (II) LoadModule: "modesetting"
[    59.513] (WW) Warning, couldn't open module modesetting
[    59.513] (II) UnloadModule: "modesetting"
[    59.513] (II) Unloading modesetting
[    59.513] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    59.513] (II) LoadModule: "fbdev"
[    59.513] (WW) Warning, couldn't open module fbdev
[    59.513] (II) UnloadModule: "fbdev"
[    59.513] (II) Unloading fbdev
[    59.513] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    59.513] (II) LoadModule: "vesa"
[    59.513] (WW) Warning, couldn't open module vesa
[    59.513] (II) UnloadModule: "vesa"
[    59.514] (II) Unloading vesa
[    59.514] (EE) Failed to load module "vesa" (module does not exist, 0)
[    59.514] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    59.514] (II) intel: Driver for Intel(R) HD Graphics: 2000-5000
[    59.514] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100
[    59.514] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200
[    59.514] (--) using VT number 7

[    59.518] (EE) No devices detected.
[    59.518] (EE)
Fatal server error:
[    59.518] (EE) no screens found(EE)
[    59.518] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    59.518] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    59.518] (EE)
Back to top
View user's profile Send private message
lhw828
n00b
n00b


Joined: 05 Sep 2013
Posts: 27

PostPosted: Thu Jun 26, 2014 9:18 am    Post subject: Re: The Xorg make me crazy!!!! Reply with quote

russK wrote:
Can you post the xorg.conf file and output from 'lspci' ?


Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "Present"               # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "VSync"                 # [<bool>]
        #Option     "PageFlip"              # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"        # [<bool>]
        #Option     "DeleteUnusedDP12Displays"    # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "VirtualHeads"          # <i>
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1805

PostPosted: Thu Jun 26, 2014 12:05 pm    Post subject: Reply with quote

It's many years since I needed an xorg.conf file; are you sure it's necessary?
(Though it might well still be needed for advanced configuration).

Will
Back to top
View user's profile Send private message
russK
Apprentice
Apprentice


Joined: 27 Jun 2006
Posts: 272

PostPosted: Thu Jun 26, 2014 12:13 pm    Post subject: Reply with quote

cwr wrote:
It's many years since I needed an xorg.conf file; are you sure it's necessary?
(Though it might well still be needed for advanced configuration).

Will


Very good point.

lhw828, did you do what chithanh suggested? Have you tried without the xorg.conf file ? Also the output of 'lspci' and 'emerge --info' might help us find an answer for you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum