Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]The EDID read for display device DFP-1 is invalid
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 167

PostPosted: Mon Jun 23, 2014 9:33 pm    Post subject: [gelöst]The EDID read for display device DFP-1 is invalid Reply with quote

Moin Moin,
der HDMI-Monitor wird unter Gentoo nicht mehr erkannt und fällt in eine Minimalauflösung von 800*600 Punkten zurück:
Code:
xrandr
Screen 0: minimum 8 x 8, current 2080 x 1024, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0 
   1280x960       60.0 
   1152x864       75.0 
   1024x768       75.0     70.1     60.0 
   800x600        75.0     72.2     60.3     56.2 
   640x480        75.0     72.8     59.9 
HDMI-0 connected primary 800x600+1280+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600

Unter Ubuntu funktioniert die Erkennung:
Code:
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
.....
HDMI-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 475mm x 267mm
   1920x1080      60.0 +   50.0     59.9 
   1920x1080i     60.1     50.0     60.0 
   1680x1050      59.9 
   1280x1024      75.0     60.0*
   1440x900       59.9 
   1280x960       60.0 
   1280x800       59.9 
   1152x864       75.0 
   1280x720       60.0     50.0     59.9 
   1440x576       50.0 
   1024x768       75.1     70.1     60.0 
   1440x480       60.0     59.9 
   832x624        74.6 
   800x600        72.2     75.0     60.3     56.2 
   720x576        50.0 
   720x480        60.0     59.9 
   640x480        75.0     66.7     60.0     59.9 
   720x400        70.1 

In der /var/log/X.log.0 finde ich folgende Fehlermeldung:
Code:
[  3841.486] (WW) NVIDIA(GPU-0): The EDID read for display device DFP-1 is invalid: the
[  3841.486] (WW) NVIDIA(GPU-0):     checksum for EDID version 1 extension is invalid.

Der Versuch einen neuen Mode zu kreieren scheitert:
Code:
~ % cvt 1920 1080 60
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

~ % xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120

~ % xrandr --addmode HDMI-0 "1920x1080_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  31
  Current serial number in output stream:  32
~ % xrandr --output HDMI-0 --mode "1920x1080_60.00"
xrandr: cannot find mode 1920x1080_60.00
kai@kais_quad ~ % xrandr
Screen 0: minimum 8 x 8, current 2080 x 1024, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0 
   1280x960       60.0 
   1152x864       75.0 
   1024x768       75.0     70.1     60.0 
   800x600        75.0     72.2     60.3     56.2 
   640x480        75.0     72.8     59.9 
HDMI-0 connected primary 800x600+1280+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600        60.3*+
  1920x1080_60.00 (0x2a9)  173.0MHz
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock   67.2KHz
        v: height 1080 start 1083 end 1088 total 1120           clock   60.0Hz

Da die Erkennung früher funktioniert hat, wäre es schön, wenn ich sie wieder in Gang bekäme...
Doch zum Anfang wäre eine funktionierende Modeline auch nicht schlecht.
Kann jemand helfen?
_________________
Linux-User seit 1999


Last edited by wuesti on Wed Jun 25, 2014 6:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 167

PostPosted: Wed Jun 25, 2014 6:34 pm    Post subject: Reply with quote

Nach diversen Stunden mit unserem Freund G. aus USA habe ich die die Lösung gefunden:
Code:
cat /etc/X11/xorg.conf.d/20-nvidia.conf
Section "ServerLayout"
    Identifier     "ASUS-an-HDMI"
    Screen       0 "Screen0"
EndSection

#######################-HDMI-###########
Section "Device"
    Identifier    "Device-HDMI"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName     "GeForce GT 610"
    BusID         "PCI:1:0:0"
    Screen        0
    Option        "UseEDIDFreqs"   "False"
    Option        "UseEDIDDpi"     "False"
    Option        "IgnoreEDID"     "True"
    #Option        "UseEDID"        "false"
    Option        "ModeValidation" "NoVesaModes,NoXServerModes,NoEDIDModes"
EndSection

Section "Monitor"
    Identifier     "ASUS-HDMI"
    VendorName     "Unknown"
    ModelName      "ASUS VS229"
    HorizSync      30.0 - 82.0
    VertRefresh    56.0 - 76.0
    Modeline       "1920x1080"  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync
    Option         "Preferred Mode" "1920x1080"
    Option         "ExactModeTimingsDVI" "True"
    Option         "DPI" "104x104"
    Option         "DPMS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device-HDMI"
    Monitor        "ASUS-HDMI"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "HDMI-0: 1920x1080"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
        Modes      "1920x1080"
    EndSubSection
EndSection

Quellen:
http://askubuntu.com/questions/188060/force-video-mode-without-edid-information
https://wiki.archlinux.org/index.php/NVIDIA#Multiple_monitors
_________________
Linux-User seit 1999
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum