Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nach Festplatte einrichten kontinuierliche Schreibvorgänge!?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
SarahS93
Apprentice
Apprentice


Joined: 21 Nov 2013
Posts: 260

PostPosted: Fri Jun 20, 2014 11:05 pm    Post subject: Nach Festplatte einrichten kontinuierliche Schreibvorgänge!? Reply with quote

Code:
CONFIG_EFI_PARTITION=y

emerge -av sys-apps/gptfdisk

gdisk /dev/sd[buchstabe]

mkdir /root/crypt

dd if=/dev/urandom of=/root/crypt/hdd036.key bs=1k count=4
dd if=/dev/urandom of=/root/crypt/hdd037.key bs=1k count=4
dd if=/dev/urandom of=/root/crypt/hdd038.key bs=1k count=4

cryptsetup -v -c aes-cbc-essiv:sha256 -h sha1 -s 256 luksFormat /dev/sdc1 --key-file /root/crypt/hdd036.key
cryptsetup -v -c aes-cbc-essiv:sha256 -h sha1 -s 256 luksFormat /dev/sdd1 --key-file /root/crypt/hdd037.key
cryptsetup -v -c aes-cbc-essiv:sha256 -h sha1 -s 256 luksFormat /dev/sde1 --key-file /root/crypt/hdd038.key

cryptsetup luksOpen /dev/sdc1 verschluesseltefestplatte-hdd036 --key-file /root/crypt/hdd036.key
cryptsetup luksOpen /dev/sdd1 verschluesseltefestplatte-hdd037 --key-file /root/crypt/hdd037.key
cryptsetup luksOpen /dev/sde1 verschluesseltefestplatte-hdd038 --key-file /root/crypt/hdd038.key

mkfs.ext4 -j /dev/mapper/verschluesseltefestplatte-hdd036
mkfs.ext4 -j /dev/mapper/verschluesseltefestplatte-hdd037
mkfs.ext4 -j /dev/mapper/verschluesseltefestplatte-hdd038

tune2fs -m 0.05 /dev/mapper/verschluesseltefestplatte-hdd036
tune2fs -m 0.05 /dev/mapper/verschluesseltefestplatte-hdd037
tune2fs -m 0.05 /dev/mapper/verschluesseltefestplatte-hdd038

mount /dev/mapper/verschluesseltefestplatte-hdd036 /mnt/hdd036
mount /dev/mapper/verschluesseltefestplatte-hdd037 /mnt/hdd037
mount /dev/mapper/verschluesseltefestplatte-hdd038 /mnt/hdd038
Das habe ich gemacht.

Im KDE bei dem Anzeigenprogramm Gkrellm sehe ich das auf allen 3 Festplatten kontinuierlich mit 4 bis 8 MB/s geschrieben wird.
Ein lsof |grep sdc z.B. bringt keine Erklärung. Weiss nicht so recht weiter, und mir kommt das etwas seltsam vor.
Warum wird da auf den Festplatten so langsam und ständig irgendwas geschrieben?
An dem verfügbaren Speicherplatz auf den Festplatten ändert sich überhauptnichts.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5435
Location: Langen (Hessen), Germany

PostPosted: Sat Jun 21, 2014 5:39 am    Post subject: Reply with quote

Soweit ich mich erinnere, schreibt ext4 zunächst noch viele Metadaten.
Das dauert, je nach Größe einige Stunden.
Da das ein Kernelmodul ist, wirst du es mit sdc nicht finden.

Hier auf die Schnelle ein link: http://askubuntu.com/questions/119742/ext4-jbd2-journaling-active-even-on-empty-filesystem
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2803
Location: de

PostPosted: Sat Jun 21, 2014 7:30 am    Post subject: Reply with quote

Ist korrekt. Ext4 schreibt erst mal stundenlang. Das ist aber eine einmalige Initilialisierungsaktion.

Sehr nützlich, um Übeltäter für unnötige Schreibzugriffe rauszufinden, ist übrigens iotop.
Back to top
View user's profile Send private message
SarahS93
Apprentice
Apprentice


Joined: 21 Nov 2013
Posts: 260

PostPosted: Sat Jun 21, 2014 10:03 am    Post subject: Reply with quote

Danke für die Infos Jungs, dann brauch ich mir keine sorgen zu machen was da los war ... .
Back to top
View user's profile Send private message
SarahS93
Apprentice
Apprentice


Joined: 21 Nov 2013
Posts: 260

PostPosted: Mon Jun 23, 2014 9:11 am    Post subject: Reply with quote

cat /var/log/messages |grep "Jun 23"
Übereinstimmungen in Binärdatei (Standardeingabe).
Funktioniert das nicht mehr so? Früher war das immer möglich.

Code:
Jun 23 00:16:53 sarah93 kernel: [   15.231818] ata1.00: configured for UDMA/100
Jun 23 00:16:53 sarah93 kernel: [   15.231821] ata1: EH complete
Jun 23 00:16:53 sarah93 udisksd[4907]: udisks daemon version 2.1.0 starting
Jun 23 00:16:53 sarah93 kernel: [   15.333983] ata2.00: configured for UDMA/133
Jun 23 00:16:53 sarah93 kernel: [   15.333987] ata2: EH complete
Jun 23 00:16:53 sarah93 kernel: [   15.337039] ata4.00: configured for UDMA/133
Jun 23 00:16:53 sarah93 kernel: [   15.337042] ata4: EH complete
Jun 23 00:16:53 sarah93 dbus[4267]: [system] Successfully activated service 'org.freedesktop.UDisks2'
Jun 23 00:16:53 sarah93 udisksd[4907]: Acquired the name org.freedesktop.UDisks2 on the system message bus
Jun 23 00:16:54 sarah93 kernel: [   16.036261] ata5.00: configured for UDMA/133
Jun 23 00:16:54 sarah93 kernel: [   16.036264] ata5: EH complete
Jun 23 00:16:54 sarah93 dbus[4267]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jun 23 00:16:54 sarah93 dbus[4267]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jun 23 00:16:54 sarah93 kernel: [   16.197931] ata6.00: configured for UDMA/133
Jun 23 00:16:54 sarah93 kernel: [   16.197934] ata6: EH complete


Am Sataport1 hängt ein SSD Laufwerk das Sata3 kann.
Am Sataport2 hängt eine HDD mit 2TB.
Und an den Sataports 4 bis 6 hägen die 3 neuen 4TB Laufwerke.
Warum sehe ich beim booten UDMA/100 und UDMA/133 ?
Back to top
View user's profile Send private message
SarahS93
Apprentice
Apprentice


Joined: 21 Nov 2013
Posts: 260

PostPosted: Tue Jun 24, 2014 8:42 pm    Post subject: Reply with quote

Warum UDMA100 und 133 ?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2803
Location: de

PostPosted: Wed Jun 25, 2014 5:59 am    Post subject: Reply with quote

Welchen Kerneltreiber hast du gewählt? SATA braucht AHCI. Und SCSI-disc sollte auch aktiviert werden.

Ich würde grob vermuten, dass du stattdessen die alten PATA-Treiber aktiviert hast.
Back to top
View user's profile Send private message
SarahS93
Apprentice
Apprentice


Joined: 21 Nov 2013
Posts: 260

PostPosted: Wed Jun 25, 2014 9:29 am    Post subject: Reply with quote

OHJE
Ein "cat /usr/src/linux/.config |grep AHCI" sagt: "CONFIG_SATA_AHCI=y"
Die Laufwerke sind bei mir im System unter /dev/sda bis sdf zufinden.
Frueher, zu IDE-Zeiten waren das hda, hdb usw...
Nach welchen Kernel Optionen sollte ich noch nachsehen ob alles richtig ist?
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1620
Location: St. Wendel

PostPosted: Wed Jun 25, 2014 9:37 am    Post subject: Reply with quote

Uh, das mit dem UDMA hat nichts zu sagen, schau einfach mit smartctl -a nach, da sollte dann sowas auftauchen:

Code:
SATA Version is:  SATA 2.6, 3.0 Gb/s (current: 3.0 Gb/s)


Current ist das wichtige.

Bye
Py
Back to top
View user's profile Send private message
SarahS93
Apprentice
Apprentice


Joined: 21 Nov 2013
Posts: 260

PostPosted: Wed Jun 25, 2014 9:59 am    Post subject: Reply with quote

smartctl -a /dev/sdc
Code:
...
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)
...

Habe ich hier stehen.
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1620
Location: St. Wendel

PostPosted: Wed Jun 25, 2014 10:09 am    Post subject: Reply with quote

Sieht gut aus.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5435
Location: Langen (Hessen), Germany

PostPosted: Wed Jun 25, 2014 1:16 pm    Post subject: Reply with quote

Sorry, dass ich mich so dran hänge, aber mein SDD zeigt nur:
Code:
smartctl -a /dev/sda|grep -i current
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS


Wohingegen die normale Festplatte:
Code:
smartctl -a /dev/sdb|grep -i current
SATA Version is:  SATA 2.6, 3.0 Gb/s (current: 3.0 Gb/s)
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       0
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS


Warum zeigt meine SDD nix an?
Hdparm gibt:
Code:
/dev/sda:
 Timing cached reads:   13518 MB in  2.00 seconds = 6764.50 MB/sec
 Timing buffered disk reads: 724 MB in  3.00 seconds = 241.09 MB/se

/dev/sdb:
 Timing cached reads:   13742 MB in  2.00 seconds = 6876.16 MB/sec
 Timing buffered disk reads: 342 MB in  3.01 seconds = 113.71 MB/sec


Danke!
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1620
Location: St. Wendel

PostPosted: Wed Jun 25, 2014 1:19 pm    Post subject: Reply with quote

Deine SSD ist vermutlich nicht in der Geräte Datenbank, müsste bei der komplett Ausgabe aber auch dann relativ weit oben stehen.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5435
Location: Langen (Hessen), Germany

PostPosted: Wed Jun 25, 2014 1:40 pm    Post subject: Reply with quote

Leider (?) nein:
Code:

=== START OF INFORMATION SECTION ===
Model Family:     Intel 320 Series SSDs
Device Model:     INTEL SSDSA2CW120G3
Serial Number:    CVPR135003TM120LGN
LU WWN Device Id: 5 001517 9596703f7
Firmware Version: 4PC10362
User Capacity:    120,034,123,776 bytes [120 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 2.6, 3.0 Gb/s
Local Time is:    Wed Jun 25 15:38:35 2014 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled


Code:
Drive found in smartmontools Database.  Drive identity strings:
MODEL:              INTEL SSDSA2CW120G3
FIRMWARE:           4PC10362
match smartmontools Drive Database entry:
MODEL REGEXP:       INTEL SSDSA[12][BC][WT](040|080|120|160|300|600)G3
FIRMWARE REGEXP:    .*
MODEL FAMILY:       Intel 320 Series SSDs
ATTRIBUTE OPTIONS:  170 Reserve_Block_Count
                    171 Program_Fail_Count
                    172 Erase_Fail_Count
                    192 Unsafe_Shutdown_Count
                    225 Host_Writes_32MiB
                    226 Workld_Media_Wear_Indic
                    227 Workld_Host_Reads_Perc
                    228 Workload_Minutes
                    241 Host_Writes_32MiB
                    242 Host_Reads_32MiB
OTHER PRESETS:      Avoids reading GP/SMART Log Directories (same as -F nologdir)


Sind 240MB/s schnell genug? Oder ist das zu langsam, sodass ich mich mehr damit beschäftigen sollte?

Danke!
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1620
Location: St. Wendel

PostPosted: Wed Jun 25, 2014 1:46 pm    Post subject: Reply with quote

Ist anscheinend nur SATA2, da geht nicht wirklich mehr.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2520
Location: Germany

PostPosted: Wed Jun 25, 2014 1:51 pm    Post subject: Reply with quote

@Finswimmer
sollte auch im dmesg unter "link up ..." ersichtlich sein.

Beispiel: (hier von einem Uralt-Rechner dessen Controller-Treiber hier (wegen nicht kompatiblem BIOS) leider nur "Serial ATA 1.5 Gbit/s" unterstützt)
Code:
[    1.943358] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    1.950178] ata2.00: ATA-9: Samsung SSD 840 PRO Series, DXM05B0Q, max UDMA/133
[    1.950180] ata2.00: 250069680 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    2.013672] ata2.00: configured for UDMA/133
Code:
smartctl -a /dev/sdb | grep current
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 1.5 Gb/s)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum