Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Verschlüsselte Partition entschlüsseln und mounten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1142
Location: Buchholz/GER

PostPosted: Sun Jun 22, 2014 7:26 am    Post subject: Verschlüsselte Partition entschlüsseln und mounten Reply with quote

Moin,
ich habe ein recht triviales Problem, für das mir irgendwie der richtige Weg fehlt.

Ich habe ein vollverschlüsseltes System mit lvm, das sich auch wunderbar verhält. Jetzt möchte ich nachträglich eine verschlüsselte Partition einhängen, was manuell auch ganz gut funktioniert.

Ich habe dazu /etc/conf.d/dmcrypt konfiguriert, sodass er die Partition automatisch mit einem in /root gelegenen Keyfile aufschließt. Klappt auch wunderbar. Und ich mounte das ganze dann via /etc/fstab, was - theoretisch - auch ganz gut funktioniert.

Das Problem: Er versucht den Mount via fstab BEVOR er die Partition via dmcrypt aufschließt. Und das schlägt natürlich fehl. Andersrum wärs schöner. :D

Ich habe allerdings an der Bootreihenfolge der Dienste nichts geändert, sodass ich vermute, dass es da noch einen besseren Weg gibt, denn so muss es ja zwangsläufig fehlschlagen. Welche Option habe ich übersehen, um das in die richtige Reihenfolge zu bringen? Oder werden verschlüsselte Partitionen gar auf einem anderen Weg gemounted?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5919
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Jun 22, 2014 10:04 am    Post subject: Reply with quote

hilft Folgendes ?

http://wiki.gentoo.org/wiki/OpenRC#Dependency_behaviour


irgendwie scheint das aber veraltete Info zu sein und alles sollte zentral in /etc/rc.conf konfiguriert werden


oder läuft auf dem System systemd ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.5.2

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1142
Location: Buchholz/GER

PostPosted: Sun Jun 22, 2014 10:12 am    Post subject: Reply with quote

Nein, systemd läuft hier nicht, ist alles noch auf OpenRC. Ich würde allerdings vermuten, dass schon per default alle Aktionen auf luks-Devices VOR dem Mounten stattfinden sollten und ich kann mir gerade keine Konstellation vorstellen, in der es anders herum sein sollte.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5919
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Jun 22, 2014 10:20 am    Post subject: Reply with quote

ist nicht so :wink:

bei mir will der, glaub ich, zuerst die ZFS Partitionen einbinden (oder anderes) und dann luks [bin gerade unter Windows, kann also nicht nachschauen, was es genau war]

bzw. es gibt Abhängigkeitsprobleme mit keymaps & luks, etc.


es funktioniert also nicht alles so reibungslos und logisch wie es sollte


alternativ hilft evtl. rc_depend_strict="yes"
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.5.2

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1142
Location: Buchholz/GER

PostPosted: Sun Jun 22, 2014 5:38 pm    Post subject: Reply with quote

kernelOfTruth wrote:
alternativ hilft evtl. rc_depend_strict="yes"

Das hat nichts gebracht. Mittlerweile habe ich allerdings (m)einen Designfehler erkannt.

dmcrypt war bei mir im runlevel default und wird da wohl nach dem Mounten der lokalen Verzeichnisse ausgeführt. Also habe ich es in den Runlevel boot verschoben, wo es dann auch vor dem Mounten der lokalen Verzeichnisse ausgeführt wird. Das notwendige Keyfile für meine Problempartition liegt allerdings im vollverschlüsselten lvm, worauf ich natürlich noch nicht zugreifen kann, bevor die übrigen (im lvm befindlichen) Verzeichnisse gemounted wurden.

Wie man es auch dreht und wendet ... irgendwas fehlt also immer.

Ich werde mir daher wohl entweder ganz stumpf und einfach mit /etc/local.d behelfen oder - wenn's aufwendiger werden soll - mit pam-mount.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum