Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PBM: connection errors with Yahoo and Pidgin [WORKAROUND]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4739
Location: Dark side of the mood

PostPosted: Wed May 07, 2014 8:57 pm    Post subject: PBM: connection errors with Yahoo and Pidgin [WORKAROUND] Reply with quote

Hi all.

Some time ago I got connection issues to my Yahoo account with Pidgin on my Gentoo machine. It failed to connect with the error message "Input/output error". I gave up and ended up living without my Yahoo account on my Gentoo machine after I tried to investigate... in vain. Now it suddenly errs again with my Jabber account, which I *do* use every day. The error message now is "SSL connection failure"!

Thing is I have the very same version of Pidgin (2.10.7) on my Linux Mint laptop and everything is absolutely, perfectly fine! Well, except the count of unread messages never ceases to increase (now it's above 700) although Yahoo reports me no unread message but that's another, meaningless annoyance I might deal later. Or not.

Well, in short, only my MSN account (which I use only casually) and my Xfire account (which I almost never use) work fine and I'm now puzzled as to what's going to fail next time :-( .

Can anybody help diagnose and fix this issue?

I've just tested Pidgin on my laptop at home and my Yahoo account connects just fine. However My jabber account times out. I'm using im.apinc.org with my Jabber account. Does it have anything to do with it? Can I safely change Jabber servers and will my account still be able to connect?

Thanks in advance.

EDIT: Running Pidgin in debug mode tells me this amongst other things:
Code:
gnutls: receive failed: A TLS packet of an incorrect length was received

This is what I've been getting with my Yahoo account from my Gentoo machine for a couple of weeks now.

There was also an update to my DSL router and I applied it. Curiously enough my Jabber account works now. But it's still a no-go with Yahoo :( .
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”


Last edited by VinzC on Tue May 13, 2014 6:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4739
Location: Dark side of the mood

PostPosted: Tue May 13, 2014 6:31 pm    Post subject: Reply with quote

This turned out to be due to a buggy behaviour of some sort with Yahoo IM servers and the fact that GnuTLS ensures TLS connections end with close_notify . GnuTLS enforces this rule and seems to return an error while NSS doesn't. Compiling Pidgin without gnutls does the trick but then makes Pidgin vulnerable to MitM attacks. When paid companies aren't following the standards they work for... I've really had my time with Yahoo. *sighs*
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
jagdpanther
Apprentice
Apprentice


Joined: 22 Nov 2003
Posts: 280

PostPosted: Fri Jun 20, 2014 2:50 pm    Post subject: Reply with quote

Not using GnuTLS does 'fix' the failure to connect to Yahoo issue for me. Unfortunately, if you also use an IM server that Requires TLS then you can't use that IM server.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4739
Location: Dark side of the mood

PostPosted: Tue Jun 24, 2014 8:19 am    Post subject: Reply with quote

jagdpanther wrote:
Not using GnuTLS does 'fix' the failure to connect to Yahoo issue for me. Unfortunately, if you also use an IM server that Requires TLS then you can't use that IM server.

Yup, this is why I didn't mark this topic solved, it's not really a solution alas.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum