Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
waiting for uevents to be processed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
brummbaer
n00b
n00b


Joined: 08 Jun 2014
Posts: 14

PostPosted: Tue Jun 10, 2014 6:00 am    Post subject: waiting for uevents to be processed Reply with quote

Hallo Leute,

nachdem mein selbst konfigurierter Kernel sofort nach der Auswahl einen schwarzen Bildschirm erzeugt hat, so dass der Rechner sich nur durch Ausschalten wieder beleben ließ, habe ich nun noch einen Kernel mit genkernel erstellt.
Dieser lässt sich auch zunächst starten, und gibt mir einige Meldungen aus. Dann folgt als vorletzte etwas wie
Code:
populating /dev through uevents
oder in diesem Sinne, und dann folgt die letzte Zeile
Code:
 waiting for uevents to be processed
wonach der Rechner sich nicht mehr rührt. Allerdings hilft nun ein Strg+Alt+Entf um den Rechner neu zu starten.

Ich habe ein EFI-System und auch grub-efi auf dem Rechner installiert. genkernel hat mir ein initramfs erstellt, welches ich auch starte:

Code:
menuentry 'Gentoo GNU/Linux' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-deaad932-9b4e-4365-ac21-8a3d36cad531' {
        load_video
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  deaad932-9b4e-4365-ac21-8a3d36cad531
        else
          search --no-floppy --fs-uuid --set=root deaad932-9b4e-4365-ac21-8a3d36cad531
        fi
        echo    'Linux 3.12.21 wird geladen …'
        linux   /boot/kernel-genkernel-x86_64-3.12.21-gentoo-r1Auto root=/dev/sda4 ro
        initrd /boot/initramfs-genkernel-x86_64-3.12.21-gentoo-r1Auto
}


Ich hatte meine /etc/fstab mit UUID-Einträgen statt /dev/sdaX erstellt. Das habe ich zwar nun geändert, aber könnte es sein, dass das initrd noch eine fstab mit uuid-Einträgen hat, und damit nichts anfangen kann?

Oder woran kann es liegen, dass nicht weiter gebootet wird, bzw. was kann ich jetzt machen?

Bin für Vorschläge dankbar.
Back to top
View user's profile Send private message
brummbaer
n00b
n00b


Joined: 08 Jun 2014
Posts: 14

PostPosted: Tue Jun 10, 2014 3:32 pm    Post subject: Reply with quote

Okay, ich bin jetzt schon mal soweit vorgedrungen, dass ich mit der Bootoption nomodeset zur Anmeldung gelange. Wo kann ich denn schrauben, dass ich auch ohne Bootoption zum Zuge komme?

Hier ein paar Angaben zum System:
Code:
sudo dmidecode -t0 -t1
[sudo] password for stepfahn:
# dmidecode 2.12
# SMBIOS entry point at 0xdecf4000
SMBIOS 2.7 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: LENOVO
        Version: HMET90WW (2.50 )
        Release Date: 12/26/2012
        Address: 0xE0000
        Runtime Size: 128 kB
        ROM Size: 4096 kB
        Characteristics:
                PCI is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                EDD is supported
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                CGA/mono video services are supported (int 10h)
                NEC PC-98
                ACPI is supported
                USB legacy is supported
                BIOS boot specification is supported
                Function key-initiated network boot is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 2.50
        Firmware Revision: 2.0

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: LENOVO
        Product Name: 33597FG
        Version: ThinkPad Edge E135
        Serial Number: LRR0T5D
        UUID: 5243EB81-5144-11CB-97FF-A84FE0247497
        Wake-up Type: Power Switch
        SKU Number: LENOVO_MT_3359
        Family: ThinkPad Edge E135


System.xml

Code:
 lspci -nnk | grep -i VGA -A2
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 7340] [1002:9808]
        Subsystem: Lenovo Device [17aa:5105]
        Kernel driver in use: fglrx_pci


Ich muss also eigentlich irgendwo im Kernel einstellen, dass ich eine Radeon HD 7340 habe, aber wo? Unter Ubuntu läuft diese auch sehr fein mit dem X-Org AMD/ATI- Treiber - auch wenn ich den fglrx-Treiber installiert habe.

Kann mich da jemand beraten?
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1163

PostPosted: Sat Jun 14, 2014 2:36 pm    Post subject: Reply with quote

Versuche es mal mit:

Setzen der frame-buffer vga-16 und VESA
Wenn dein Kernel kleiner 3.8 ist setze USE flag "firmware-loader"
Kernel größer 3.8 den inkernel firmloader.

grz
_________________
Test H.265
VP9 | VP8 | H.265 | x264 encoder test
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum