Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NetworkManager has started, but is inactive
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
windex
n00b
n00b


Joined: 09 Dec 2012
Posts: 70

PostPosted: Fri Jun 06, 2014 4:53 pm    Post subject: NetworkManager has started, but is inactive Reply with quote

Wasn't having any luck with wicd so I switched to NetworkManager.

Here is the wicd log

Code:

2014/06/03 13:10:58 :: ---------------------------
2014/06/03 13:10:58 :: wicd initializing...
2014/06/03 13:10:58 :: ---------------------------
2014/06/03 13:10:58 :: wicd is version 1.7.2.4 768
2014/06/03 13:10:58 :: Traceback (most recent call last):
2014/06/03 13:10:58 ::   File "/usr/share/wicd/daemon/wicd-daemon.py", line 1849, in <module>
2014/06/03 13:10:58 ::     main(sys.argv)
2014/06/03 13:10:58 ::   File "/usr/share/wicd/daemon/wicd-daemon.py", line 1810, in main
2014/06/03 13:10:58 ::     bus = dbus.SystemBus()
2014/06/03 13:10:58 ::   File "/usr/lib64/python2.7/site-packages/dbus/_dbus.py", line 194, in __new__
2014/06/03 13:10:58 ::     private=private)
2014/06/03 13:10:58 ::   File "/usr/lib64/python2.7/site-packages/dbus/_dbus.py", line 100, in __new__
2014/06/03 13:10:58 ::     bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
2014/06/03 13:10:58 ::   File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 122, in __new__
2014/06/03 13:10:58 ::     bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
2014/06/03 13:10:58 :: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory


Seems like a dbus problem? Hopefully network-manager will go a little bit better.

Let's confirm wireless is working:
iw wlo1 scan completely successfully

Now onto network manager?

Code:

* Starting NetworkManager ...                                                                                                                                    [ ok ]
Connecting...............    1s
 * Marking NetworkManager as inactive. It will automatically be marked
 * as started after a network connection has been established.
* WARNING: NetworkManager has started, but is inactive


That doesn't seem good, right? Unfortunately it immediately starts lousing up my dhcp lease on my ethernet connection, which as you can imagine pretty quickly terminates any network connections. Urgh.

What does the log have to say about this?

http://codepad.org/VSuDupz0

I suppose the first problem, NetworkManager is unable to find /etc/conf.d/net ?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7241
Location: almost Mile High in the USA

PostPosted: Fri Jun 06, 2014 6:14 pm    Post subject: Reply with quote

Your wicd problem looks like your system dbus isn't running, perhaps /etc/init.d/dbus start will help?

The networkmanager problem - networkmanager was intended to be an alternative to the standard wired/wireless config and the openrc method should be disabled - /etc/conf.d/net should only have a skeleton (the default should be fine) and there shouldn't be /etc/init.d/net.* (other than net.lo) . The nm-applet gui can then be used to configure your network devices.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jun 10, 2014 2:20 pm    Post subject: Reply with quote

*subscribed*

also been experiencing this NetworkManager "inactive" issue,

pinging IPs directly works but DNS doesn't (my specific configuration might have some intricate additional issues but in essence it's the same issue)

http://wiki.gentoo.org/wiki/Udev/upgrade

seems to be partly at fault


at least I know now where to look :?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7241
Location: almost Mile High in the USA

PostPosted: Tue Jun 10, 2014 5:52 pm    Post subject: Reply with quote

I just checked one of my working machines (virtual machine, VM) and it also says "started but inactive"... I think it may mostly be for systemd or maybe even openrc to trigger other network dependencies but not until it sets up a network connection. And it won't unless there's a profile for your network connection....

For my VM it started up just fine, sshd came up and I was able to remotely login without console intervention.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
windex
n00b
n00b


Joined: 09 Dec 2012
Posts: 70

PostPosted: Mon Jun 16, 2014 8:40 pm    Post subject: Reply with quote

FYI, I think I may have met my match in network manager. I'm switching over to wicd.



EDIT: Sorry for the delayed reply but I was in jail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum