Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]imlib2 emake fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Tue May 27, 2014 10:58 pm    Post subject: [solved]imlib2 emake fails Reply with quote

Trying to emerge media-libs/imlib2-1.4.6-r2 I get

Code:

ERROR: media-libs/imlib2-1.4.6-r2::gentoo failed (compile phase):
    emake failed


How do I fix this?

I've tried installing libstdc++ and running

Code:

fix_libtool_files.sh 3.13.1


(also tried 3.3.4 as suggested in the thread where I found it)

Neither solved the issue for me.

I'm not in the best situation to post the entire error from start to finish, but it starts at:

Code:

...
CC    imlib2_grab.o
/var/tmp/portage/media-libs/imlib2-1.4.6-r2/work/imlib2-1.4.6/src/bin/imlib2_test.c:5:20: fatal error: Imlib2.h: No such file or directory
compilation terminated.

_________________
This picture was my biggest reason for ever trying Gentoo <3


Last edited by rabcor on Wed Jun 11, 2014 7:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 918

PostPosted: Wed May 28, 2014 12:12 am    Post subject: Reply with quote

Probably Imlib2.h belongs to media-libs/imlib2. Try emerge it:
Code:
emerge -pv --oneshot media-libs/imlib2
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Wed May 28, 2014 2:09 am    Post subject: Reply with quote

that is exactly the package i was trying to emerge.. (dependency for enlightenment)
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 918

PostPosted: Wed May 28, 2014 2:25 pm    Post subject: Reply with quote

I'm sorry the mistake.

Maybe that's the last error message and there are some other prior.
Back to top
View user's profile Send private message
shouya
n00b
n00b


Joined: 28 May 2014
Posts: 6

PostPosted: Wed May 28, 2014 5:42 pm    Post subject: Reply with quote

here it seems to be a working patch.

https://bugs.gentoo.org/show_bug.cgi?id=510522
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Wed May 28, 2014 7:36 pm    Post subject: Reply with quote

Thanks! but how do I apply that patch? I really need to know how! (Not just that, there are other packages I'll need to apply patches to)
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8114

PostPosted: Fri May 30, 2014 3:53 am    Post subject: Reply with quote

Give a man a fish and he eats for a day.
Teach a man to fish and he eats for life.
Give a man a pass to the fishing library and he will ask how to work the card catalog.

Given the above, a few selections from the library to help you on your way (you can figure out the card catalog later):
https://wiki.gentoo.org/index.php?title=/etc/portage/patches (note that this approach does not appear to apply to the ebuilds in question)
https://wiki.gentoo.org/wiki//etc/portage/env
https://wiki.gentoo.org/wiki//etc/portage/bashrc
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sat May 31, 2014 11:01 am    Post subject: Reply with quote

Heh you are right :)

Fortunately though inbetween the time I posted that and now i have found out how to apply these patches (but it actually took quite a bit of digging to find out about "/etc/portage/patches" somoene actually had to point it out to me in another thread where I asked specifically for it (older than this one)

But as you said sadly that does not work for the ebuilds in question :( I'm learning about overlays now maybe that can be of use.

Still ebuilds that do support patching on emerge, that has just got to be the best feature there is in portage 8) and luckily for me nvidia proprietary drivers and kernel support it!
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
morten.dynamite
n00b
n00b


Joined: 11 Nov 2007
Posts: 4
Location: Charlottenberg, Sweden

PostPosted: Fri Jun 06, 2014 4:12 pm    Post subject: Reply with quote

I solved it by emerging imlib2-1.4.5-r1 first then i could emerge imlib2-1.4.6-r2.
Back to top
View user's profile Send private message
calvinx
n00b
n00b


Joined: 14 May 2014
Posts: 2

PostPosted: Fri Jun 06, 2014 4:30 pm    Post subject: fix for the time Reply with quote

Code:
# cat /etc/portage/package.mask
=media-libs/imlib2-1.4.6-r2
=media-libs/imlib2-1.4.6-r1

imlib2 1.4.5. compiling successful
Code:
emerge imlib2 -a
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Wed Jun 11, 2014 7:11 pm    Post subject: Reply with quote

Thanks guys, I'll remember that next time I hop on gentoo (I need to finish an arch installation first)
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum