Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wine update fails[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
gentoorockerfr
Tux's lil' helper
Tux's lil' helper


Joined: 25 May 2012
Posts: 92

PostPosted: Sat May 03, 2014 2:01 pm    Post subject: Wine update fails[SOLVED] Reply with quote

Here is the log -> http://pastebin.com/mfeKf3h7


Quote:
configure: error: libjpeg development files not found, JPEG won't be supported.
This is an error since --with-jpeg was requested.
yes
checking for snd_pcm_hw_params_get_access_mask in -lasound...
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-emulation/wine-1.6.1/work/wine-1.6.1-x86/config.log
* ERROR: app-emulation/wine-1.6.1::gentoo failed (configure phase):
* econf failed
yes
*
* Call stack:
* ebuild.sh, line 93: Called src_configure
* environment, line 4995: Called multilib_parallel_foreach_abi 'do_configure'
* environment, line 4300: Called multibuild_parallel_foreach_variant '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3913: Called multibuild_foreach_variant '_multibuild_parallel' '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3856: Called _multibuild_run '_multibuild_parallel' '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3854: Called _multibuild_parallel '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3904: Called _multilib_multibuild_wrapper 'do_configure'
* environment, line 1331: Called do_configure
* environment, line 1792: Called autotools-utils_src_configure
* environment, line 1499: Called econf '--docdir=/usr/share/doc/wine-1.6.1' '--sysconfdir=/etc/wine' '--with-alsa' '--without-capi' '--with-cms' '--with-cups' '--with-curses' '--with-dbus' '--with-fontconfig' '--with-gnutls' '--with-gphoto' '--without-gsm' '--without-gstreamer' '--without-hal' '--with-jpeg' '--with-ldap' '--with-mpg123' '--with-gettext' '--without-openal' '--without-opencl' '--with-opengl' '--without-osmesa' '--without-oss' '--with-png' '--with-pthread' '--with-sane' '--disable-tests' '--with-freetype' '--without-v4l' '--with-x' '--with-xcomposite' '--with-xinerama' '--with-xml' '--with-xslt' '--disable-win64'
checking cups/cups.h usability... * phase-helpers.sh, line 584: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of `emerge --info '=app-emulation/wine-1.6.1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=app-emulation/wine-1.6.1::gentoo'`.
/usr/lib64/portage/bin/isolated-functions.sh: line 195: wait: `econf failed': not a pid or valid job spec
* The complete build log is located at '/var/tmp/portage/app-emulation/wine-1.6.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-emulation/wine-1.6.1/temp/environment'.
* Working directory: '/var/tmp/portage/app-emulation/wine-1.6.1/work/wine-1.6.1-x86'
* S: '/var/tmp/portage/app-emulation/wine-1.6.1/work/wine-1.6.1'



Quote:
configure: Finished. Do 'make' to compile Wine.


>>> Failed to emerge app-emulation/wine-1.6.1, Log file:

>>> '/var/tmp/portage/app-emulation/wine-1.6.1/temp/build.log'

* Messages for package app-emulation/wine-1.6.1:

* ERROR: app-emulation/wine-1.6.1::gentoo failed (configure phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 93: Called src_configure
* environment, line 4995: Called multilib_parallel_foreach_abi 'do_configure'
* environment, line 4300: Called multibuild_parallel_foreach_variant '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3913: Called multibuild_foreach_variant '_multibuild_parallel' '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3856: Called _multibuild_run '_multibuild_parallel' '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3854: Called _multibuild_parallel '_multilib_multibuild_wrapper' 'do_configure'
* environment, line 3904: Called _multilib_multibuild_wrapper 'do_configure'
* environment, line 1331: Called do_configure
* environment, line 1792: Called autotools-utils_src_configure
* environment, line 1499: Called econf '--docdir=/usr/share/doc/wine-1.6.1' '--sysconfdir=/etc/wine' '--with-alsa' '--without-capi' '--with-cms' '--with-cups' '--with-curses' '--with-dbus' '--with-fontconfig' '--with-gnutls' '--with-gphoto' '--without-gsm' '--without-gstreamer' '--without-hal' '--with-jpeg' '--with-ldap' '--with-mpg123' '--with-gettext' '--without-openal' '--without-opencl' '--with-opengl' '--without-osmesa' '--without-oss' '--with-png' '--with-pthread' '--with-sane' '--disable-tests' '--with-freetype' '--without-v4l' '--with-x' '--with-xcomposite' '--with-xinerama' '--with-xml' '--with-xslt' '--disable-win64'
* phase-helpers.sh, line 584: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of `emerge --info '=app-emulation/wine-1.6.1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=app-emulation/wine-1.6.1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/app-emulation/wine-1.6.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-emulation/wine-1.6.1/temp/environment'.
* Working directory: '/var/tmp/portage/app-emulation/wine-1.6.1/work/wine-1.6.1-x86'
* S: '/var/tmp/portage/app-emulation/wine-1.6.1/work/wine-1.6.1'

* GNU info directory index is up-to-date.
* After world updates, it is important to remove obsolete packages with
* emerge --depclean. Refer to `man emerge` for more information.


any help please?
Thank you


Last edited by gentoorockerfr on Fri Jun 06, 2014 10:43 am; edited 1 time in total
Back to top
View user's profile Send private message
nephron
n00b
n00b


Joined: 18 Oct 2007
Posts: 66

PostPosted: Sat May 03, 2014 2:33 pm    Post subject: Reply with quote

Code:

configure: error: libjpeg development files not found, JPEG won't be supported.
This is an error since --with-jpeg was requested.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9268

PostPosted: Sat May 03, 2014 2:52 pm    Post subject: Reply with quote

You forgot to post emerge --info like the error message told you to do, but based on the build log, it looks like you are using ARCH=amd64 and the build failed building a 32-bit Wine. Do you have the right 32-bit compatibility libraries and headers installed? If not, then either install them or build only the 64-bit Wine.
Back to top
View user's profile Send private message
gentoorockerfr
Tux's lil' helper
Tux's lil' helper


Joined: 25 May 2012
Posts: 92

PostPosted: Sat May 03, 2014 2:57 pm    Post subject: Reply with quote

emerge --info

http://pastebin.com/60h4gVAv

i have already wine 1.6 installed so the libraries was here!
but totally emerge update world fails.ALso fails depclean
emerge --ask --depclean
Quote:

* Always study the list of packages to be cleaned for any obvious
* mistakes. Packages that are part of the world set will always
* be kept. They can be manually added to this set with
* `emerge --noreplace <atom>`. Packages that are listed in
* package.provided (see portage(5)) will be removed by
* depclean, even if they are part of the world set.
*
* As a safety measure, depclean will not remove any packages
* unless *all* required dependencies have been resolved. As a
* consequence, it is often necessary to run `emerge --update
* --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
* Dependencies could not be completely resolved due to
* the following required packages not being installed:
*
* media-libs/libpng:0/0= pulled in by:
* app-emulation/wine-1.6
*
* Have you forgotten to do a complete update prior to depclean? The
* most comprehensive command for this purpose is as follows:
*
* emerge --update --newuse --deep --with-bdeps=y @world
*
* Note that the --with-bdeps=y option is not required in many
* situations. Refer to the emerge manual page (run `man emerge`)
* for more information about --with-bdeps.
*
* Also, note that it may be necessary to manually uninstall
* packages that no longer exist in the portage tree, since it may
* not be possible to satisfy their dependencies.


ps i think that error with jpeg is not fatal...
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 172
Location: Northern California

PostPosted: Mon May 05, 2014 4:05 pm    Post subject: Reply with quote

I ran into this yesterday. It appears the multi-lib issue is starting to trickle down to us stable users:

https://forums.gentoo.org/viewtopic-p-7509542.html#7509542

Follow the links in that forum posting for details.

In any case, I got wine to compile on my system by removing the gphoto2, scanner and v4l USE flags. You might want to try playing with the wine USE flags to see if you can get it to compile. It seems to still work, near as I can tell.

At this point in time it looks like going to multi-lib is an ugly excursion for stable users with some unstable packages, so I chose to disable some wine functionality rather than go down that road. Hopefully not too much else will pop up between now and when the devs complete the transition.
Back to top
View user's profile Send private message
xenon
Guru
Guru


Joined: 25 Dec 2002
Posts: 432
Location: Europe

PostPosted: Tue May 20, 2014 11:59 am    Post subject: Reply with quote

I have the same problem: wine (with ABI_X86_32) emerge fails because it can't find jpeglib.h. The last time I successfully emerged Wine was in February, so apparently something has changed, and not for the best. :)

Taking a look at Wine's ebuild, jpeg support for ABI_X86_32 requires either emul-linux-baselibs with the development USE flag enabled or virtual/jpeg:0 with ABI_X86_32, which are mutually exclusive portage-wise.

I have and always had the former installed (currently the latest unstable non-hardmasked, 20140508), but - as of now at least - it doesn't seem to provide the JPEG headers:

Code:
arcadia ~ # equery f emul-linux-x86-baselibs | grep jp
/usr/lib32/libjpeg.so
/usr/lib32/libjpeg.so.62
/usr/lib32/libjpeg.so.62.1.0
/usr/lib32/libturbojpeg.so
/usr/lib32/libturbojpeg.so.0
/usr/lib32/libturbojpeg.so.0.0.0


Is it just a problem with emul-linux-baselibs or am I missing something? Thanks!
Back to top
View user's profile Send private message
xenon
Guru
Guru


Joined: 25 Dec 2002
Posts: 432
Location: Europe

PostPosted: Wed May 21, 2014 12:15 am    Post subject: Reply with quote

I fixed the my issue by rebuilding libjpeg-turbo (which provides virtual/jpeg), as suggested here. It's not entirely clear to me how a headers issue can be fixed by rebuilding the same package and portage didn't tell me the package needed to be rebuilt, but alas, it worked.
Back to top
View user's profile Send private message
gentoorockerfr
Tux's lil' helper
Tux's lil' helper


Joined: 25 May 2012
Posts: 92

PostPosted: Fri Jun 06, 2014 10:42 am    Post subject: Reply with quote

Finally after last eix-sync wine builds ok!
so strange..
thank you
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum