Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas con layman [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 319

PostPosted: Mon Jun 02, 2014 1:31 pm    Post subject: Problemas con layman [SOLVED] Reply with quote

Hola a todos!!
Emergí layman pero cuando quiero actualizar la lista me salta este error:

Code:
# layman -L

 * Fetching remote list,...
 * Warning: an installed db file was not found at: ['/var/lib/layman/cache_ac494f50f5736be7871962c0dec7b3bb.xml']
 * RemoteDB.cache(); Failed to update the overlay list from: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * IOError was:<urlopen error unknown url type: https>
 *


 * CLI: Errors occurred processing action list
 * RemoteDB.cache(); Failed to update the overlay list from: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * IOError was:<urlopen error unknown url type: https>
 *


Alguna idea de que puede ser?
Gracias!


Last edited by natrix on Sat Jun 07, 2014 5:30 am; edited 1 time in total
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1561

PostPosted: Mon Jun 02, 2014 5:32 pm    Post subject: Reply with quote

Echa un vistazo a esta dirección por si se te ha olvidado algo:
http://www.gentoo.org/proj/es/overlays/userguide.xml?style=printable
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 319

PostPosted: Mon Jun 02, 2014 6:44 pm    Post subject: Reply with quote

Hola esteban_conde; gracias por responder.

Esa link fue la guía que use para emerger layman, le eche otra leída pero no encontré nada llamativo. Por las dudas agregue las USEs recomendadas pero nada

NOTA: mi PC no está conectada directamente a internet sino a un servidor. Puede tener algo que ver? De este tema no entiendo nada :(
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1561

PostPosted: Mon Jun 02, 2014 7:13 pm    Post subject: Reply with quote

Quote:
IOError was:<urlopen error unknown url type: https

Me llama la atención ese error que te da, deberia cambiar de http:// a https:// sin problemas, leete el make.conf de /etc/portage y el de /var/lib/layman y prueba a cambiar la dirección por si fuera eso.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 319

PostPosted: Mon Jun 02, 2014 7:21 pm    Post subject: Reply with quote

Revise los dos make.conf y ninguno tiene ningún http para modificar.

Encontré una solución temporal, baje manualmente el archivo xml que pide (el link de la salida funciona bien), y lo copie con el nombre y en el lugar en que lo buscar y funciona. Pero se queja de que no puede actualizar la lista. Con esto ya pude instalar lo que necesitaba, pero fue algo muy improvisado.

Alguna idea? gracias!!!
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 924

PostPosted: Mon Jun 02, 2014 10:07 pm    Post subject: Reply with quote

Compueba que la versión o versiones que tengas de python estén construidas con la use ssl.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 319

PostPosted: Mon Jun 02, 2014 11:19 pm    Post subject: Reply with quote

Si, tiene SSL:

Code:

emerge --info  dev-lang/python
=================================================================
                        Package Settings
=================================================================

dev-lang/python-2.7.6 was built with the following:
USE="gdbm ipv6 ncurses (policykit) readline sqlite ssl threads (wide-unicode) xml -berkdb -build -doc -examples -hardened -tk -wininst" ABI_X86="64"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fwrapv"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fwrapv"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -L."


dev-lang/python-3.3.3 was built with the following:
USE="gdbm ipv6 ncurses (policykit) readline sqlite ssl threads xml -build -doc -examples -hardened -tk -wininst" ABI_X86="64"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fwrapv"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fwrapv"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -L."

Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 319

PostPosted: Tue Jun 03, 2014 3:04 pm    Post subject: Reply with quote

Hola quilosaq!!!! Tenías razón, era el SSL!!!

Agregue el SSL para python en el package.use y cuando actualice el sistema me recompilo python 2.7 y anduvo layman.

Ahora tengo esta duda. ¿que es exactamente SSL? lei el manual pero no entendí suficiente.

En el USE del make.conf lo tengo como "-ssl" pensando que no lo necesitaba. ¿que me conviene?

Gracias maestro!!!
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 924

PostPosted: Tue Jun 03, 2014 11:44 pm    Post subject: Reply with quote

Hay mucha documentación en internet que explica lo que es la SSL; por ejemplo wikipedia. Sólo te puedo decir que sirve para que dos equipos en red puedan comunicarse de forma segura (cifrada).

Sobre la use ssl y sobre las uses en general, no hay que sentirse obligado a elegir una opción (¿la necesito o no la necesito?). Muchas de ellas no sabemos para que sirven. En esto estamos ayudados por el perfil (profile) que hemos elegido. En el perfil hay un conjunto razonable (razonable para el creador del perfil) de uses definidas. Si dudamos en una use, la mejor opción es no ponerla.

La use ssl es muy necesaria. Tanto es así que está definida en el perfil default/linux. ¿Debes ponerla en make.conf? Mi consejo es que no. Si ya está en el perfil, ¿para que lo vas a duplicar?
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 319

PostPosted: Tue Jun 03, 2014 11:59 pm    Post subject: Reply with quote

Muy interesante tu comentario

Ya lo saque del make.conf y que cada paquete decida lo que necesita!!!

Muchas veces tuve dudas sobre los USEs del make.conf (https://forums.gentoo.org/viewtopic-t-988486.html). Más allá de que hay mucha información sobre cada USE y le dedico su tiempo (en la medida de lo posible), no siempre llego a ver su influencia y/o sus implicancias "hasta que algo anda mejor o deja de andar".

Gracias nuevamente, quilosaq!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum