Joined: 12 May 2004
|Posted: Sat May 17, 2014 2:26 pm Post subject: [ GLSA 201405-09 ] ImageMagick: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: ImageMagick: Multiple vulnerabilities (GLSA 201405-09)
Date: May 17, 2014
Bug(s): #409431, #483032, #500988, #506562
Multiple vulnerabilities have been discovered in ImageMagick, the
worst of which could lead to arbitrary code execution.
ImageMagick is a collection of tools and libraries for manipulating
various image formats.
Vulnerable: < 184.108.40.206
Unaffected: >= 220.127.116.11
Architectures: All supported architectures
Multiple vulnerabilities have been discovered in ImageMagick. Please
review the CVE identifiers referenced below for details.
Note that CVE-2012-1185 and CVE-2012-1186 were issued due to incomplete
fixes for CVE-2012-0247 and CVE-2012-0248, respectively. The earlier CVEs
were addressed in GLSA 201203-09.
A remote attacker can utilize multiple vectors to execute arbitrary code
or cause a Denial of Service condition.
There is no known workaround at this time.
All ImageMagick users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/imagemagick-18.104.22.168"