Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Libav (Avconv) Imposition on Users who want FFmpeg
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Mon Apr 21, 2014 8:54 pm    Post subject: Libav (Avconv) Imposition on Users who want FFmpeg Reply with quote

EDIT START 2014-11-02
The results of my quest are what counts. Anyway, a comprehensive previous topic, worth much more of reader's time than this topic, is in those results:

libav vs ffmpeg
https://forums.gentoo.org/viewtopic-t-870175-start-50.html#7225660
ssuominen wrote:
...[snip]...
The switch in the virtual/ffmpeg to prefer libav was indeed done in secret. Other members of the team didn't know about it. I'm also committed in keeping my packages working with ffmpeg, not libav.
...[snip]...

[ and, recommended: stay with that topic to learn the whole saga ]

and in the results is my take (that I could only arrive through research like this one here) on the current related events, find it in today's update:

https://forums.gentoo.org/viewtopic-t-989196.html#7643904
Quote:
...[snip]... you can install MPlayer just fine, and really, really it is _not_ buggy. And neither is a bug (sorry, that is really a political bug, not a real bug), that MPlayer can not support Libav, because the Libav Team have deleted the code to make it impossible to be supported by MPlayer ...[snip]...

EDIT END
---

A critique, as well as enquiry of mine is, beginning of it, here:
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021022.html

EDIT START 2014-11-02
If someone reaches here from the FFmpeg Users Archive, pls. cosider what I posted over in another topic of mine (cutting my typing time, pls. allow):
Quote:
Have a look at these events:

The Gentoo servers went down (and generally I sooo rarely see them down, ever, actually I remember them down only at that precise time):
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021025.html
almost immediately explained by some server man:
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021027.html

and there were lots of temporary addresses for same pages:

https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021065.html
(look in there where you see a stack of http:// forums.gentoo.org preceded by my explanation how:

me wrote:
At some point in the past, all of these opened exactly the same page

Well, now (Sun 2 Nov 08:09:47 CET 2014) they all do open, but not the same page...

That might be the reason if wrong pages open to an FFmpeg Users Archives reader... Do not have another hour or two to check all that I wrote to that list in that thread... Not claiming anything here either.
EDIT END

I'm now waiting for Gentoo Mods Admins and Devs to give me gree lite to openly expose the problem, technically, in terms of what can be found on emerge install's statndard inputs, and some other portage things.

I can't wait for long, because I have completely interrupted my building of my Gentoo box, as is available here:

Air-Gapped Gentoo Install, Tentative
https://forums.gentoo.org/viewtopic-t-987268.html

to see.

It is early A.M in the U.S. where most of the deciders, and the Gentoo Foundation, reside.

An hour or two I have to wait.
After that, I'll simply try and post my text here (the technical arguments, things that happened on my Gentoo box) , so there be no cross-posting, but an attempt at transparent collaboration in giving information with both the FFmpeg team and Gentoo team,
links nowadays work just fine, unless there is censorship, and it would be great all the documents so far in this matter, and the documents that I intend to post, be freely available for time to come.

Thank you,


Last edited by miroR on Sun Nov 02, 2014 4:34 pm; edited 3 times in total
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Apr 22, 2014 3:05 am    Post subject: Reply with quote

##################################
EDIT START Tue Apr 22 13:52:50 BST 2014
Pls. go straight to:
https://forums.gentoo.org/viewtopic-p-7539792.html#7539792
which is the complete version of this post.
This one was done in a real hurry and is neither formatted nor complete.
But I stilll regard it as document, so I won't delete it.
Thank you.
EDIT END
##################################
=======================================
=======================================
Just like I just wrote on:
[FFmpeg-user] Libav (Avconv) Imposition on Users who want FFmpeg
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021029.html
(pasting) I'm very tired, here is morning, no sleep yet, so no correcting of text
below.(pasted)
Pls. allow me to after some rest, revisit what I wrote.
Thank you!
=======================================
=======================================

I installed openbox, some of (only some of, not all the bloat) LDXE, and I
wanted to watch some videos. So I went for my favorite mplayer program.

Code:
gbn ~ # emerge -qtuDN mplayer
[ebuild  N    ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[nomerge      ]  media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-plugins/alsa-plugins-1.0.27-r1  USE="ffmpeg jack pulseaudio -debug -libsamplerate -speex"
[ebuild  N    ]    virtual/ffmpeg-9  USE="X encode jpeg2k sdl x264 -gsm -mp3 -opus -speex -theora -threads -truetype -vaapi -vdpau"
[ebuild  N    ]     media-video/libav-9.12  USE="X bindist bzip2 encode gpl hardcoded-tables jack jpeg2k mmx network pulseaudio sdl ssl v4l vorbis x264 xvid zlib -3dnow -3dnowext -aac -alsa (-altivec) -amr -avx -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -ieee1394 -mmxext -mp3 (-neon) -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -tools -truetype -vaapi -vdpau (-vis) -vpx"
[ebuild  N    ]      media-libs/libsdl-1.2.15-r4  USE="X audio joystick libcaca opengl pulseaudio video xv -aalib -alsa -custom-cflags -dga -directfb -fbcon -ggi -nas -oss (-ps3) -static-libs (-svga) -tslib -xinerama"
[ebuild  N    ]       media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]       media-libs/libcaca-0.99_beta18-r1  USE="X cxx ncurses opengl -doc -imlib -java -mono -python (-ruby) -slang -static-libs {-test} -truetype" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild  N    ]  media-libs/libass-0.10.2  USE="enca fontconfig harfbuzz -static-libs"
[ebuild  NS   ]  media-libs/openjpeg-1.5.1-r1 [2.0.0] USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-sound/jack-audio-connection-kit-0.121.3-r1  USE="mmx pam sse -3dnow -alsa (-altivec) (-coreaudio) -cpudetection -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-libs/libsndfile-1.0.25-r1  USE="sqlite -alsa -minimal -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/flac-1.3.0  USE="cxx ogg sse -3dnow (-altivec) -debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  app-i18n/enca-1.14-r1  USE="recode -doc" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   app-text/recode-3.6_p20-r1  USE="nls -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  NS   ]    sys-devel/automake-1.11.6 [1.13.4, 1.14.1]
[ebuild  N    ]  dev-libs/libcdio-0.92  USE="cxx -cddb -minimal -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/xvid-1.3.2-r1  USE="threads -examples -pic" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/x264-0.0.20140308  USE="interlaced sse threads -10bit -opencl -pic -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   dev-lang/yasm-1.2.0-r1  USE="nls -python" PYTHON_TARGETS="python2_7 -python2_6"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[nomerge      ]  media-video/libav-9.12  USE="X bindist bzip2 encode gpl hardcoded-tables jack jpeg2k mmx network pulseaudio sdl ssl v4l vorbis x264 xvid zlib -3dnow -3dnowext -aac -alsa (-altivec) -amr -avx -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -ieee1394 -mmxext -mp3 (-neon) -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -tools -truetype -vaapi -vdpau (-vis) -vpx"
[nomerge      ]   media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/speex-1.2_rc1-r2  USE="ogg sse -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    dev-libs/json-c-0.12  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    net-libs/libasyncns-0.8-r3  USE="-debug -doc" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    x11-libs/libXtst-1.2.2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/webrtc-audio-processing-0.1-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[nomerge      ]  media-libs/libsdl-1.2.15-r4  USE="X audio joystick libcaca opengl pulseaudio video xv -aalib -alsa -custom-cflags -dga -directfb -fbcon -ggi -nas -oss (-ps3) -static-libs (-svga) -tslib -xinerama"
[ebuild  N    ]   media-libs/audiofile-0.3.6-r1  USE="-flac -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-plugins/alsa-plugins-1.0.27-r1  USE="ffmpeg jack pulseaudio -debug -libsamplerate -speex"
[nomerge      ]  media-sound/jack-audio-connection-kit-0.121.3-r1  USE="mmx pam sse -3dnow -alsa (-altivec) (-coreaudio) -cpudetection -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-libs/libsamplerate-0.1.8-r1  USE="-sndfile -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-libs/libass-0.10.2  USE="enca fontconfig harfbuzz -static-libs"
[ebuild  N    ]  dev-libs/fribidi-0.19.5-r2  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[ebuild  N    ]  media-libs/libdvdnav-4.2.1  ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-libs/libdvdread-4.9.9  USE="css" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/libdvdcss-1.2.13-r1  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  x11-libs/libXv-1.0.10  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  x11-libs/libXScrnSaver-1.2.2-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libmng-2.0.2-r1  USE="-lcms -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/a52dec-0.7.4-r7  USE="-djbfft -oss -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libvorbis-1.3.4  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/alsa-lib-1.0.27.2  USE="-alisp -debug -doc -python" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[nomerge      ] media-libs/speex-1.2_rc1-r2  USE="ogg sse -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libogg-1.3.1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-plugins/alsa-plugins-1.0.27-r1  USE="ffmpeg jack pulseaudio -debug -libsamplerate -speex"
[nomerge      ]  media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[nomerge      ]   media-sound/jack-audio-connection-kit-0.121.3-r1  USE="mmx pam sse -3dnow -alsa (-altivec) (-coreaudio) -cpudetection -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    sys-auth/realtime-base-0.1
[ebuild  N    ]   dev-libs/libatomic_ops-7.4.0
[ebuild  N    ]   gnome-extra/gnome-audio-2.22.2  USE="-debug"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[ebuild  N    ]  virtual/linuxtv-dvb-headers-5.8

Would you like to merge these packages? [Yes/No]       
>>> Verifying ebuild manifests
>>> Running pre-merge checks for media-sound/pulseaudio-5.0
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.13.9-hardened-140420-00
 * Checking for suitable kernel configuration options...                                               [ ok ]
 * A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!
 * CONFIG_SND_HDA_PREALLOC_SIZE=64
>>> Emerging (1 of 42) virtual/linuxtv-dvb-headers-5.8::gentoo
>>> Installing (1 of 42) virtual/linuxtv-dvb-headers-5.8
>>> Emerging (2 of 42) gnome-extra/gnome-audio-2.22.2::gentoo
>>> Installing (2 of 42) gnome-extra/gnome-audio-2.22.2
>>> Emerging (3 of 42) dev-libs/libatomic_ops-7.4.0::gentoo
>>> Installing (3 of 42) dev-libs/libatomic_ops-7.4.0
>>> Emerging (4 of 42) sys-auth/realtime-base-0.1::gentoo
>>> Installing (4 of 42) sys-auth/realtime-base-0.1
>>> Emerging (5 of 42) media-libs/libogg-1.3.1::gentoo
>>> Installing (5 of 42) media-libs/libogg-1.3.1
>>> Emerging (6 of 42) media-libs/alsa-lib-1.0.27.2::gentoo
>>> Installing (6 of 42) media-libs/alsa-lib-1.0.27.2
>>> Emerging (7 of 42) media-libs/libvorbis-1.3.4::gentoo
>>> Installing (7 of 42) media-libs/libvorbis-1.3.4
>>> Emerging (8 of 42) media-libs/a52dec-0.7.4-r7::gentoo
>>> Installing (8 of 42) media-libs/a52dec-0.7.4-r7
>>> Emerging (9 of 42) media-libs/libmng-2.0.2-r1::gentoo
>>> Installing (9 of 42) media-libs/libmng-2.0.2-r1
>>> Emerging (10 of 42) x11-libs/libXScrnSaver-1.2.2-r1::gentoo
>>> Jobs: 9 of 42 complete, 1 running               Load avg: 1.36, 1.02, 0.62^[[6~^[[6~^[[6~^[[6~^[[6~^[[6~^[>>> Installing (10 of 42) x11-libs/libXScrnSaver-1.2.2-r1
>>> Emerging (11 of 42) media-libs/libmad-0.15.1b-r8::gentoo
>>> Installing (11 of 42) media-libs/libmad-0.15.1b-r8
>>> Emerging (12 of 42) x11-libs/libXv-1.0.10::gentoo
>>> Installing (12 of 42) x11-libs/libXv-1.0.10
>>> Emerging (13 of 42) media-libs/libdvdcss-1.2.13-r1::gentoo
>>> Installing (13 of 42) media-libs/libdvdcss-1.2.13-r1
>>> Emerging (14 of 42) media-libs/libdvdread-4.9.9::gentoo
>>> Installing (14 of 42) media-libs/libdvdread-4.9.9
>>> Emerging (15 of 42) media-libs/libdvdnav-4.2.1::gentoo
>>> Installing (15 of 42) media-libs/libdvdnav-4.2.1
>>> Emerging (16 of 42) dev-libs/fribidi-0.19.5-r2::gentoo
>>> Installing (16 of 42) dev-libs/fribidi-0.19.5-r2
>>> Emerging (17 of 42) media-libs/libsamplerate-0.1.8-r1::gentoo
>>> Installing (17 of 42) media-libs/libsamplerate-0.1.8-r1
>>> Emerging (18 of 42) media-libs/audiofile-0.3.6-r1::gentoo
>>> Installing (18 of 42) media-libs/audiofile-0.3.6-r1
>>> Emerging (19 of 42) media-libs/webrtc-audio-processing-0.1-r1::gentoo
>>> Installing (19 of 42) media-libs/webrtc-audio-processing-0.1-r1
>>> Emerging (20 of 42) x11-libs/libXtst-1.2.2::gentoo
>>> Installing (20 of 42) x11-libs/libXtst-1.2.2
>>> Emerging (21 of 42) net-libs/libasyncns-0.8-r3::gentoo
>>> Installing (21 of 42) net-libs/libasyncns-0.8-r3
>>> Emerging (22 of 42) dev-libs/json-c-0.12::gentoo
>>> Installing (22 of 42) dev-libs/json-c-0.12
>>> Emerging (23 of 42) media-libs/speex-1.2_rc1-r2::gentoo
>>> Installing (23 of 42) media-libs/speex-1.2_rc1-r2
>>> Emerging (24 of 42) dev-lang/yasm-1.2.0-r1::gentoo
>>> Installing (24 of 42) dev-lang/yasm-1.2.0-r1
>>> Emerging (25 of 42) media-libs/x264-0.0.20140308::gentoo
>>> Installing (25 of 42) media-libs/x264-0.0.20140308
>>> Emerging (26 of 42) media-libs/xvid-1.3.2-r1::gentoo
>>> Installing (26 of 42) media-libs/xvid-1.3.2-r1
>>> Emerging (27 of 42) dev-libs/libcdio-0.92::gentoo
>>> Installing (27 of 42) dev-libs/libcdio-0.92
>>> Emerging (28 of 42) sys-devel/automake-1.11.6::gentoo
>>> Installing (28 of 42) sys-devel/automake-1.11.6
>>> Emerging (29 of 42) app-text/recode-3.6_p20-r1::gentoo
>>> Installing (29 of 42) app-text/recode-3.6_p20-r1
>>> Emerging (30 of 42) app-i18n/enca-1.14-r1::gentoo
>>> Installing (30 of 42) app-i18n/enca-1.14-r1
>>> Emerging (31 of 42) media-libs/flac-1.3.0::gentoo
>>> Installing (31 of 42) media-libs/flac-1.3.0
>>> Emerging (32 of 42) media-libs/libsndfile-1.0.25-r1::gentoo
>>> Installing (32 of 42) media-libs/libsndfile-1.0.25-r1
>>> Emerging (33 of 42) media-sound/jack-audio-connection-kit-0.121.3-r1::gentoo
>>> Installing (33 of 42) media-sound/jack-audio-connection-kit-0.121.3-r1
>>> Emerging (34 of 42) media-libs/openjpeg-1.5.1-r1::gentoo
>>> Installing (34 of 42) media-libs/openjpeg-1.5.1-r1
>>> Emerging (35 of 42) media-libs/libass-0.10.2::gentoo
>>> Installing (35 of 42) media-libs/libass-0.10.2
>>> Emerging (36 of 42) media-libs/libcaca-0.99_beta18-r1::gentoo
>>> Installing (36 of 42) media-libs/libcaca-0.99_beta18-r1
>>> Emerging (37 of 42) media-sound/pulseaudio-5.0::gentoo
>>> Installing (37 of 42) media-sound/pulseaudio-5.0
>>> Emerging (38 of 42) media-libs/libsdl-1.2.15-r4::gentoo
>>> Installing (38 of 42) media-libs/libsdl-1.2.15-r4
>>> Emerging (39 of 42) media-video/libav-9.12::gentoo
>>> Installing (39 of 42) media-video/libav-9.12
>>> Emerging (40 of 42) virtual/ffmpeg-9::gentoo
>>> Installing (40 of 42) virtual/ffmpeg-9
>>> Emerging (41 of 42) media-plugins/alsa-plugins-1.0.27-r1::gentoo
>>> Installing (41 of 42) media-plugins/alsa-plugins-1.0.27-r1
>>> Emerging (42 of 42) media-video/mplayer-1.2_pre20130729::gentoo
>>> Installing (42 of 42) media-video/mplayer-1.2_pre20130729
>>> Recording media-video/mplayer in "world" favorites file...
>>> Jobs: 42 of 42 complete                         Load avg: 2.36, 2.39, 1.74
gbn ~ #


Even though I saw that the libav was the default for kaffeine installation
(why?), and wanted to rearrange my use flags, as I mentioned here:

LXDE replacement question

LINK HERE

I, being non-expert (it's obvious from my setting up some flags and then
opting for the opposite once I figure out reliably), this time thought, well
this must be just some general library, since anyway, there existed such
general library that was called something to that effect...

But, man, was I wrong!

And what the mimicry! And how high these people aim!

They're the av for the world! Not just an option, but the Audio-Video library
and for all the programs of all the desktops of the GNU (sorry, they wouldn't
say GNU) of the (just) Linux world!

That's their aim!

(Patiently, please, and someone correct me if I'm wrong, but correct me for
where I am really wrong only, don't invent mistakes), but have a look:

Code:
gbn ~ # emerge -qtuDN ffmpeg


 * virtual/ffmpeg

Would you like to add these packages to your world favorites? [Yes/No] yes
>>> Recording virtual/ffmpeg in "world" favorites file...
gbn ~ #


What's this now? If I want to install the real ffmpeg, from www.ffmpeg.org
(unless these guys physically killed them, their hatred towards them is
obvious), I now can't anymore!

Because there is this virtual that the renegade ffmpeg, the fork of ffmpeg,
very aggressive fork, and I will now take time to show that it did behave
aggressively in the past already:

LINK HERE

Because there is this virtual that the renegade ffmpeg installed so I couldn't
anymore even see that there still exist the Ffmpeg from www.ffmpeg.org (unless
these guys killed or imprisoned all the Ffmpeg team).

These are obstacles that are very hard to overcome for beginners.

So you're feeding this ugly fork to the majority of users without giving them
a choice at all?!

This tantamount to criminal behavior in GNU/Linux terms. This should be
brought into plain daylight which I am trying to do now, and this should be
immediately stopped, and this should also be punished in some way!

Have a closer look to see if I am exaggerating:

Code:
gbn ~ # etc-update
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)
gbn ~ # emerge -qt ffmpeg
[ebuild   R   ] virtual/ffmpeg-9  USE="X encode jpeg2k sdl x264 -gsm -mp3 -opus -speex -theora -threads -truetype -vaapi -vdpau"

Would you like to merge these packages? [Yes/No] n     

Quitting.


gbn ~ # emerge -qtuDN media-video/ffmpeg
[ebuild  N    ] media-video/ffmpeg-1.2.6  USE="X bindist bzip2 encode fontconfig gnutls hardcoded-tables iconv jack jpeg2k libcaca mmx network pulseaudio sdl v4l vorbis x264 xvid zlib -3dnow -3dnowext -aac -aacplus -alsa (-altivec) -amr -avx -bluray -cdio (-celt) -cpudetection -debug -doc -examples -faac -fdk -flite -frei0r -gsm -iec61883 -ieee1394 -libass -libsoxr -libv4l -mmxext -modplug -mp3 (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -truetype -twolame -vaapi -vdpau (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
[blocks B     ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-video/libav-9.12)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/ffmpeg-1.2.6:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-1.0:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/ffmpeg-1.0:0[X,encode,jpeg2k,sdl,x264]) required by (virtual/ffmpeg-9:0/0::gentoo, installed)
    >=media-video/ffmpeg-1.2.1:0= required by (media-video/mplayer-1.2_pre20130729:0/0::gentoo, installed)
    media-video/ffmpeg

  (media-video/libav-9.12:0/9::gentoo, installed) pulled in by
    >=media-video/libav-9.8:0/9= required by (media-video/mplayer-1.2_pre20130729:0/0::gentoo, installed)

gbn ~ # equery d libav
 * These packages depend on libav:
media-video/mplayer-1.2_pre20130729 (>=media-video/libav-9.8)
virtual/ffmpeg-9 (>=media-video/libav-9[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?])
gbn ~ #


gbn ~ # emerge -s ffmpeg
...[snip]...
...[[three so much less important packages]]..
...[snip]...

*  media-video/ffmpeg
      Latest version available: 1.2.6
      Latest version installed: [ Not Installed ]
      Size of files: 5,830 kB
      Homepage:      http://ffmpeg.org/
      Description:   Complete solution to record, convert and stream audio and video. Includes libavcodec.
      License:       GPL-2 amr? ( GPL-3 ) encode? ( aac? ( GPL-3 ) )

...[snip]...
...[[three so much less important packages]]..
...[snip]...

*  virtual/ffmpeg
     Latest version available: 9
     Latest version installed: 9
     Size of files: 0 kB
     Homepage:     
     Description:   Virtual package for FFmpeg
     implementation
     License:       

gbn ~ #


There, the virtual that has the main task and duty to prevent users to see
that there is the real Ffmpeg.

I'm sick of this behavior. I didn't want to write about this.

But I had to.

Because there is a clear violation of some principles that must be enshrined
in the Gentoo Foundation Statute (still haven't found time to read it).

Namely, the ffmpeg from www.ffmpeg.org (unless those team is banned from the
wolrd by, say Google, the Surveillance Engine that makes people disappear,
don't laugh, the Shmoogle all of a suddan declared all my 500 (five hundred)
videos to be in breach of copyright laws, and all of my videos were posted
last one some maybe six months, others many in the span of some 5 (five)
years), the copyright excuse for terminating my Youtube account being a lie
biggeer than Zhoogle itself; so Shoogle, and others, can disappear people!)...

Namely, the ffmpeg from www.ffmpeg.org is still what everybody has the right
to expect to see under:

ffmpeg

isn't that so?

And if I choose the ffmpeg flag, do Gentoo developers by that flag mean
something other than the Ffmpeg, maybe?

I think not.

So why are my useflags not being respected?

I already published them (unless I get censored again, for stupid reasons, and
I really don't know if I will be, never mind the First Amendment of the
Constitution of the United States of America, the free speech amendment, which
Gentoo Foundation deciders I hope won't breach this time, but I don't know),
and also I mentioned in various places such as here:

LINK here

and here:

LINK here

the changes to my make.conf and the use flags, but ffmpeg I never removed from
there. this is my current emerge --info:

Code:
Portage 2.2.10 (hardened/linux/amd64, gcc-4.7.3, glibc-2.19, 3.13.9-hardened-140420-00 x86_64)
=================================================================
System uname: Linux-3.13.9-hardened-140420-00-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:    16343020 total,  12756272 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Thu, 17 Apr 2014 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p47
dev-lang/python:          2.7.6, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.11.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: /portage-prev/
    priority: 9999

ABI="amd64"
ABI_X86="64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="amd64"
AUTOCLEAN="yes"
BOOTSTRAP_USE="cxx unicode python_targets_python3_3 python_targets_python2_7 multilib hardened pax_kernel pic xtpax -jit -orc"
CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author"
CAMERAS="ptp2"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CFLAGS_amd64="-m64"
CFLAGS_x32="-mx32"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x32="x86_64-pc-linux-gnux32"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
COLLISION_IGNORE="/lib/modules/* *.py[co] *$py.class */dropin.cache"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-march=native -O2 -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--keep-going --with-bdeps=y --autounmask-write --ask --verbose"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FETCHCOMMAND="wget -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}" -a /var/log/portage_logs/wget-fetch.log"
FETCHCOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
FETCHCOMMAND_SFTP="bash -c "x=\${2#sftp://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; eval \"declare -a ssh_opts=(\${3})\" ; exec sftp -P \${port} \"\${ssh_opts[@]}\" \"\${host}:/\${x#*/}\" \"\$1\"" sftp "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FETCHCOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FFLAGS="-O2 -pipe"
GCC_SPECS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx"
GRUB_PLATFORMS="pc multiboot"
GUILE_LOAD_PATH="/usr/share/guile/1.8"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.24/info:/usr/share/info/emacs-24"
INPUT_DEVICES="evdev"
IUSE_IMPLICIT="prefix"
KERNEL="linux"
LANG="en_US.utf8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_MESSAGES="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LDFLAGS_amd64="-m elf_x86_64"
LDFLAGS_x32="-m elf32_x86_64"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_arm="lib"
LIBDIR_arm64="lib64"
LIBDIR_n32="lib32"
LIBDIR_n64="lib64"
LIBDIR_o32="lib"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_s390="lib32"
LIBDIR_s390x="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x32="libx32"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32"
LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01; 05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01; 31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01; 31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01; 31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01; 31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01; 35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01; 35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01; 35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01; 35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01; 35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01; 35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00; 36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00; 36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"
MAIL="/var/mail/root"
MAKEOPTS="-j7"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.24/man"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage|udev|systemd|clang|python-exec)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
NOCOLOR="true"
OFFICE_IMPLEMENTATION="libreoffice"
OLDPWD="/home/miro"
OPENGL_PROFILE="xorg-x11"
PATH="/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin"
PHP_TARGETS="php5-5"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc sparc64-freebsd ppc-openbsd x86-openbsd ppc64 x86-winnt x86-fbsd ppc-aix alpha arm x86-freebsd s390 amd64 arm-linux x86-macos x64-openbsd ia64-hpux hppa x86-netbsd ppc64-linux x86-cygwin amd64-linux ia64-linux x86 sparc-solaris x64-freebsd sparc64-solaris x86-linux x64-macos sparc m68k-mint ia64 mips ppc-macos x86-interix hppa-hpux amd64-fbsd x64-solaris m68k sh arm64 x86-solaris sparc-fbsd"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="info warn error log qa"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_GPG_DIR="/etc/portage/gpg"
PORTAGE_GPG_SIGNING_COMMAND="gpg --sign --digest-algo SHA256 --clearsign --yes --default-key "${PORTAGE_GPG_KEY}" --homedir "${PORTAGE_GPG_DIR}" "${FILE}""
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_INTERNAL_CALLER="1"
PORTAGE_OVERRIDE_EPREFIX=""
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_PYTHONPATH="/usr/lib64/portage/pym"
PORTAGE_REPOSITORIES="[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
masters =
priority = 9999
sync-type = rsync
sync-uri = /portage-prev/
"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="-1"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTAGE_XATTR_EXCLUDE="security.* system.nfs4_acl"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
PORT_LOGDIR="/var/log/portage_logs"
PORT_LOGDIR_CLEAN="find /var/log/portage_logs -type f ! -name summary.log* -mtime +90 -delete"
PROFILE_ONLY_VARIABLES="ARCH ELIBC IUSE_IMPLICIT KERNEL USERLAND USE_EXPAND_IMPLICIT USE_EXPAND_UNPREFIXED USE_EXPAND_VALUES_ARCH USE_EXPAND_VALUES_ELIBC USE_EXPAND_VALUES_KERNEL USE_EXPAND_VALUES_USERLAND"
PWD="/root"
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python2_7"
PYTHON_TARGETS="python2_7 python3_3"
RESUMECOMMAND="wget -c -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}" -a /var/log/portage_logs/wget-fetch.log"
RESUMECOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
RESUMECOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.7.3"
RPMDIR="/usr/portage/rpm"
RUBY_TARGETS="ruby19 ruby20"
SHELL="/bin/bash"
SHLVL="1"
SUDO_COMMAND="/bin/bash"
SUDO_GID="1000"
SUDO_UID="1000"
SUDO_USER="miro"
SYMLINK_LIB="yes"
SYNC=""
SYSTEMD_LESS="FRSM --shift 5"
TERM="xterm"
UNINSTALL_IGNORE="/lib/modules/*"
USE="X a52 acl amd64 apache2 audit bash-completion berkdb bindist bzip2 caps cdr cli cracklib crypt cscope css cxx dri dvb dvdr fam ffmpeg fontconfig gdbm gif git gnutls gpm gstreamer gzip hardened iconv imagemagick introspection ipv6 jack jpeg jpeg2k justify lame libcaca mad maildir mhash mmx mng modules mplayer multilib ncurses nls nptl ogg opengl openmp pam pax_kernel pcre png pulseaudio readline sasl sdl session smp sound sox sqlite sqlite3 sse sse2 ssl ssse svg tcpd tiff udev unicode urandom v4l vim-syntax vorbis x264 xattr xine xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc multiboot" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USER="root"
USERLAND="GNU"
USERNAME="root"
USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CROSSCOMPILE_OPTS CURL_SSL DRACUT_MODULES DVB_CARDS ELIBC ENLIGHTENMENT_MODULES FCDSL_CARDS FFTOOLS FOO2ZJS_DEVICES FRITZCAPI_CARDS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL LCD_DEVICES LIBREOFFICE_EXTENSIONS LINGUAS LIRC_DEVICES MONKEYD_PLUGINS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="ABI_MIPS ABI_PPC ABI_S390 CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_EXPAND_IMPLICIT="ARCH ELIBC KERNEL USERLAND"
USE_EXPAND_UNPREFIXED="ARCH"
USE_EXPAND_VALUES_ARCH="alpha amd64 amd64-fbsd amd64-linux arm arm-linux arm64 hppa hppa-hpux ia64 ia64-hpux ia64-linux m68k m68k-mint mips ppc ppc64 ppc64-linux ppc-aix ppc-macos ppc-openbsd s390 sh sparc sparc64-freebsd sparc64-solaris sparc-fbsd sparc-solaris x64-freebsd x64-macos x64-openbsd x64-solaris x86 x86-cygwin x86-fbsd x86-freebsd x86-interix x86-linux x86-macos x86-netbsd x86-openbsd x86-solaris x86-winnt"
USE_EXPAND_VALUES_ELIBC="AIX Cygwin Darwin FreeBSD glibc HPUX Interix mintlib musl NetBSD OpenBSD SunOS uclibc Winnt"
USE_EXPAND_VALUES_KERNEL="AIX Cygwin Darwin FreeBSD freemint HPUX Interix linux NetBSD OpenBSD SunOS Winnt"
USE_EXPAND_VALUES_USERLAND="BSD GNU"
USE_ORDER="env:pkg:conf:defaults:pkginternal:repo:env.d"
VIDEO_CARDS="radeon vesa"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
_="/usr/bin/emerge"


Why is the only logical assumption that ffmpeg means ffmpeg not respected
here?

And why such hatred, and whence such might at those devs that make what the
now call libav, and I don't know if the program is still called avconc, as
this Ffmpeg fork was named for at least a while.

Why don't you people give us instead, a use flag such as:

libav

along with keeping the ffmpeg use flag, but don't name the virtual whose only
duty is to mask the existence of the real Ffmpeg named ffmpeg, because that is
misleading and in the GNU terms criminal.

Pls. give us the flag:

libav

and keep the flag:

ffmpeg

in it's true meaning.

And pls. don't impose that ugly ffmpeg fork that aims at becoming the sole
Audio-Video converting set of programs for the world, onto us users. Please!

Allow people to choose any set of combinations, such and I would certainly
always (well if the Ffmpeg team is allowed to live and work, and program the
Ffmpeg) opt for:

ffmpeg

and if you give us the libav flag (but actually they should stick to the
avconv name they initially chose), then I would gladly give them:

-libav

(pls. notice the "-")

and stay away from having to engage in discussions like this.


Thank you!

Miroslav Rovis
Zagreb, Croatia
www.CroatiaFidelis.hr


Last edited by miroR on Tue Apr 22, 2014 12:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
Nicias
Guru
Guru


Joined: 06 Dec 2005
Posts: 444

PostPosted: Tue Apr 22, 2014 10:39 am    Post subject: Reply with quote

Code:
$ emerge -C libav
$ emerge media-video/ffmpeg
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Apr 22, 2014 12:40 pm    Post subject: Reply with quote

Morning is now in the U.S., where Gentoo Foundation is home and donates its distribution of free programs, GNU licensed (almost all), to the world.

I will now format and complete the document that I posted some twelve hours ago.

I installed openbox, some of (only some of, not all the bloat) LDXE, and I
wanted to watch some videos. So I went for my favorite mplayer program.

Code:

gbn ~ # emerge -qtuDN mplayer
[ebuild  N    ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[nomerge      ]  media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-plugins/alsa-plugins-1.0.27-r1  USE="ffmpeg jack pulseaudio -debug -libsamplerate -speex"
[ebuild  N    ]    virtual/ffmpeg-9  USE="X encode jpeg2k sdl x264 -gsm -mp3 -opus -speex -theora -threads -truetype -vaapi -vdpau"
[ebuild  N    ]     media-video/libav-9.12  USE="X bindist bzip2 encode gpl hardcoded-tables jack jpeg2k mmx network pulseaudio sdl ssl v4l vorbis x264 xvid zlib -3dnow -3dnowext -aac -alsa (-altivec) -amr -avx -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -ieee1394 -mmxext -mp3 (-neon) -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -tools -truetype -vaapi -vdpau (-vis) -vpx"
[ebuild  N    ]      media-libs/libsdl-1.2.15-r4  USE="X audio joystick libcaca opengl pulseaudio video xv -aalib -alsa -custom-cflags -dga -directfb -fbcon -ggi -nas -oss (-ps3) -static-libs (-svga) -tslib -xinerama"
[ebuild  N    ]       media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]       media-libs/libcaca-0.99_beta18-r1  USE="X cxx ncurses opengl -doc -imlib -java -mono -python (-ruby) -slang -static-libs {-test} -truetype" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild  N    ]  media-libs/libass-0.10.2  USE="enca fontconfig harfbuzz -static-libs"
[ebuild  NS   ]  media-libs/openjpeg-1.5.1-r1 [2.0.0] USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-sound/jack-audio-connection-kit-0.121.3-r1  USE="mmx pam sse -3dnow -alsa (-altivec) (-coreaudio) -cpudetection -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-libs/libsndfile-1.0.25-r1  USE="sqlite -alsa -minimal -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/flac-1.3.0  USE="cxx ogg sse -3dnow (-altivec) -debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  app-i18n/enca-1.14-r1  USE="recode -doc" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   app-text/recode-3.6_p20-r1  USE="nls -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  NS   ]    sys-devel/automake-1.11.6 [1.13.4, 1.14.1]
[ebuild  N    ]  dev-libs/libcdio-0.92  USE="cxx -cddb -minimal -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/xvid-1.3.2-r1  USE="threads -examples -pic" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/x264-0.0.20140308  USE="interlaced sse threads -10bit -opencl -pic -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   dev-lang/yasm-1.2.0-r1  USE="nls -python" PYTHON_TARGETS="python2_7 -python2_6"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[nomerge      ]  media-video/libav-9.12  USE="X bindist bzip2 encode gpl hardcoded-tables jack jpeg2k mmx network pulseaudio sdl ssl v4l vorbis x264 xvid zlib -3dnow -3dnowext -aac -alsa (-altivec) -amr -avx -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -ieee1394 -mmxext -mp3 (-neon) -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -tools -truetype -vaapi -vdpau (-vis) -vpx"
[nomerge      ]   media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/speex-1.2_rc1-r2  USE="ogg sse -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    dev-libs/json-c-0.12  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    net-libs/libasyncns-0.8-r3  USE="-debug -doc" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    x11-libs/libXtst-1.2.2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/webrtc-audio-processing-0.1-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[nomerge      ]  media-libs/libsdl-1.2.15-r4  USE="X audio joystick libcaca opengl pulseaudio video xv -aalib -alsa -custom-cflags -dga -directfb -fbcon -ggi -nas -oss (-ps3) -static-libs (-svga) -tslib -xinerama"
[ebuild  N    ]   media-libs/audiofile-0.3.6-r1  USE="-flac -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-plugins/alsa-plugins-1.0.27-r1  USE="ffmpeg jack pulseaudio -debug -libsamplerate -speex"
[nomerge      ]  media-sound/jack-audio-connection-kit-0.121.3-r1  USE="mmx pam sse -3dnow -alsa (-altivec) (-coreaudio) -cpudetection -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-libs/libsamplerate-0.1.8-r1  USE="-sndfile -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-libs/libass-0.10.2  USE="enca fontconfig harfbuzz -static-libs"
[ebuild  N    ]  dev-libs/fribidi-0.19.5-r2  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[ebuild  N    ]  media-libs/libdvdnav-4.2.1  ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]   media-libs/libdvdread-4.9.9  USE="css" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    media-libs/libdvdcss-1.2.13-r1  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  x11-libs/libXv-1.0.10  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  x11-libs/libXScrnSaver-1.2.2-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libmng-2.0.2-r1  USE="-lcms -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/a52dec-0.7.4-r7  USE="-djbfft -oss -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libvorbis-1.3.4  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/alsa-lib-1.0.27.2  USE="-alisp -debug -doc -python" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[nomerge      ] media-libs/speex-1.2_rc1-r2  USE="ogg sse -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]  media-libs/libogg-1.3.1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge      ] media-plugins/alsa-plugins-1.0.27-r1  USE="ffmpeg jack pulseaudio -debug -libsamplerate -speex"
[nomerge      ]  media-sound/pulseaudio-5.0  USE="X alsa asyncns caps gdbm glib ipv6 jack ssl tcpd udev webrtc-aec -avahi -bluetooth -dbus -doc -equalizer -gnome -gtk -libsamplerate -lirc (-neon) -orc (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen" ABI_X86="(64) -32 (-x32)"
[nomerge      ]   media-sound/jack-audio-connection-kit-0.121.3-r1  USE="mmx pam sse -3dnow -alsa (-altivec) (-coreaudio) -cpudetection -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ]    sys-auth/realtime-base-0.1
[ebuild  N    ]   dev-libs/libatomic_ops-7.4.0
[ebuild  N    ]   gnome-extra/gnome-audio-2.22.2  USE="-debug"
[nomerge      ] media-video/mplayer-1.2_pre20130729  USE="X a52 alsa bindist cdio dvb dvd dvdnav enca encode gif iconv ipv6 jack jpeg jpeg2k libass libcaca mad mmx mng network opengl osdmenu png pulseaudio sdl shm sse sse2 truetype unicode v4l vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dts -dv -dxr3 -faac -faad -fbcon -ftp -ggi -gsm -joystick -ladspa -libmpeg2 -lirc -live -lzo -md5sum -mmxext -mp3 -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -rtmp -samba -speex -ssse3 -tga -theora -toolame -tremor -twolame -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[ebuild  N    ]  virtual/linuxtv-dvb-headers-5.8

Would you like to merge these packages? [Yes/No]       
>>> Verifying ebuild manifests
>>> Running pre-merge checks for media-sound/pulseaudio-5.0
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.13.9-hardened-140420-00
 * Checking for suitable kernel configuration options...                                               [ ok ]
 * A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!
 * CONFIG_SND_HDA_PREALLOC_SIZE=64
>>> Emerging (1 of 42) virtual/linuxtv-dvb-headers-5.8::gentoo
>>> Installing (1 of 42) virtual/linuxtv-dvb-headers-5.8
>>> Emerging (2 of 42) gnome-extra/gnome-audio-2.22.2::gentoo
>>> Installing (2 of 42) gnome-extra/gnome-audio-2.22.2
>>> Emerging (3 of 42) dev-libs/libatomic_ops-7.4.0::gentoo
>>> Installing (3 of 42) dev-libs/libatomic_ops-7.4.0
>>> Emerging (4 of 42) sys-auth/realtime-base-0.1::gentoo
>>> Installing (4 of 42) sys-auth/realtime-base-0.1
>>> Emerging (5 of 42) media-libs/libogg-1.3.1::gentoo
>>> Installing (5 of 42) media-libs/libogg-1.3.1
>>> Emerging (6 of 42) media-libs/alsa-lib-1.0.27.2::gentoo
>>> Installing (6 of 42) media-libs/alsa-lib-1.0.27.2
>>> Emerging (7 of 42) media-libs/libvorbis-1.3.4::gentoo
>>> Installing (7 of 42) media-libs/libvorbis-1.3.4
>>> Emerging (8 of 42) media-libs/a52dec-0.7.4-r7::gentoo
>>> Installing (8 of 42) media-libs/a52dec-0.7.4-r7
>>> Emerging (9 of 42) media-libs/libmng-2.0.2-r1::gentoo
>>> Installing (9 of 42) media-libs/libmng-2.0.2-r1
>>> Emerging (10 of 42) x11-libs/libXScrnSaver-1.2.2-r1::gentoo
>>> Jobs: 9 of 42 complete, 1 running               Load avg: 1.36, 1.02, 0.62^[[6~^[[6~^[[6~^[[6~^[[6~^[[6~^[>>> Installing (10 of 42) x11-libs/libXScrnSaver-1.2.2-r1
>>> Emerging (11 of 42) media-libs/libmad-0.15.1b-r8::gentoo
>>> Installing (11 of 42) media-libs/libmad-0.15.1b-r8
>>> Emerging (12 of 42) x11-libs/libXv-1.0.10::gentoo
>>> Installing (12 of 42) x11-libs/libXv-1.0.10
>>> Emerging (13 of 42) media-libs/libdvdcss-1.2.13-r1::gentoo
>>> Installing (13 of 42) media-libs/libdvdcss-1.2.13-r1
>>> Emerging (14 of 42) media-libs/libdvdread-4.9.9::gentoo
>>> Installing (14 of 42) media-libs/libdvdread-4.9.9
>>> Emerging (15 of 42) media-libs/libdvdnav-4.2.1::gentoo
>>> Installing (15 of 42) media-libs/libdvdnav-4.2.1
>>> Emerging (16 of 42) dev-libs/fribidi-0.19.5-r2::gentoo
>>> Installing (16 of 42) dev-libs/fribidi-0.19.5-r2
>>> Emerging (17 of 42) media-libs/libsamplerate-0.1.8-r1::gentoo
>>> Installing (17 of 42) media-libs/libsamplerate-0.1.8-r1
>>> Emerging (18 of 42) media-libs/audiofile-0.3.6-r1::gentoo
>>> Installing (18 of 42) media-libs/audiofile-0.3.6-r1
>>> Emerging (19 of 42) media-libs/webrtc-audio-processing-0.1-r1::gentoo
>>> Installing (19 of 42) media-libs/webrtc-audio-processing-0.1-r1
>>> Emerging (20 of 42) x11-libs/libXtst-1.2.2::gentoo
>>> Installing (20 of 42) x11-libs/libXtst-1.2.2
>>> Emerging (21 of 42) net-libs/libasyncns-0.8-r3::gentoo
>>> Installing (21 of 42) net-libs/libasyncns-0.8-r3
>>> Emerging (22 of 42) dev-libs/json-c-0.12::gentoo
>>> Installing (22 of 42) dev-libs/json-c-0.12
>>> Emerging (23 of 42) media-libs/speex-1.2_rc1-r2::gentoo
>>> Installing (23 of 42) media-libs/speex-1.2_rc1-r2
>>> Emerging (24 of 42) dev-lang/yasm-1.2.0-r1::gentoo
>>> Installing (24 of 42) dev-lang/yasm-1.2.0-r1
>>> Emerging (25 of 42) media-libs/x264-0.0.20140308::gentoo
>>> Installing (25 of 42) media-libs/x264-0.0.20140308
>>> Emerging (26 of 42) media-libs/xvid-1.3.2-r1::gentoo
>>> Installing (26 of 42) media-libs/xvid-1.3.2-r1
>>> Emerging (27 of 42) dev-libs/libcdio-0.92::gentoo
>>> Installing (27 of 42) dev-libs/libcdio-0.92
>>> Emerging (28 of 42) sys-devel/automake-1.11.6::gentoo
>>> Installing (28 of 42) sys-devel/automake-1.11.6
>>> Emerging (29 of 42) app-text/recode-3.6_p20-r1::gentoo
>>> Installing (29 of 42) app-text/recode-3.6_p20-r1
>>> Emerging (30 of 42) app-i18n/enca-1.14-r1::gentoo
>>> Installing (30 of 42) app-i18n/enca-1.14-r1
>>> Emerging (31 of 42) media-libs/flac-1.3.0::gentoo
>>> Installing (31 of 42) media-libs/flac-1.3.0
>>> Emerging (32 of 42) media-libs/libsndfile-1.0.25-r1::gentoo
>>> Installing (32 of 42) media-libs/libsndfile-1.0.25-r1
>>> Emerging (33 of 42) media-sound/jack-audio-connection-kit-0.121.3-r1::gentoo
>>> Installing (33 of 42) media-sound/jack-audio-connection-kit-0.121.3-r1
>>> Emerging (34 of 42) media-libs/openjpeg-1.5.1-r1::gentoo
>>> Installing (34 of 42) media-libs/openjpeg-1.5.1-r1
>>> Emerging (35 of 42) media-libs/libass-0.10.2::gentoo
>>> Installing (35 of 42) media-libs/libass-0.10.2
>>> Emerging (36 of 42) media-libs/libcaca-0.99_beta18-r1::gentoo
>>> Installing (36 of 42) media-libs/libcaca-0.99_beta18-r1
>>> Emerging (37 of 42) media-sound/pulseaudio-5.0::gentoo
>>> Installing (37 of 42) media-sound/pulseaudio-5.0
>>> Emerging (38 of 42) media-libs/libsdl-1.2.15-r4::gentoo
>>> Installing (38 of 42) media-libs/libsdl-1.2.15-r4
>>> Emerging (39 of 42) media-video/libav-9.12::gentoo
>>> Installing (39 of 42) media-video/libav-9.12
>>> Emerging (40 of 42) virtual/ffmpeg-9::gentoo
>>> Installing (40 of 42) virtual/ffmpeg-9
>>> Emerging (41 of 42) media-plugins/alsa-plugins-1.0.27-r1::gentoo
>>> Installing (41 of 42) media-plugins/alsa-plugins-1.0.27-r1
>>> Emerging (42 of 42) media-video/mplayer-1.2_pre20130729::gentoo
>>> Installing (42 of 42) media-video/mplayer-1.2_pre20130729
>>> Recording media-video/mplayer in "world" favorites file...
>>> Jobs: 42 of 42 complete                         Load avg: 2.36, 2.39, 1.74
gbn ~ #


Even though I saw that the libav was the default for kaffeine installation
(why?), and wanted to rearrange my use flags, as I mentioned here:

LXDE replacement question
https://forums.gentoo.org/viewtopic-p-7538796.html#7538754
Quote:

Ran emerge -p kaffeine, and just found out that they want to
replace my ffmpeg for its fork


I, being non-expert (it's obvious from my setting up some flags and then
opting for the opposite once I figure out reliably), this time thought, well
this must be just some general library, since anyway, there existed such
general library that was called something to that effect...

But, man, was I wrong!

And what the mimicry! And how high these people aim!

They're the av for the world! Not just an option, but the Audio-Video library
and for all the programs of all the desktops of the GNU (sorry, they wouldn't
say GNU) of the (just) Linux world!

That's their aim!

(Patiently, please, and someone correct me if I'm wrong, but correct me for
where I am really wrong only, don't invent mistakes), but have a look:

Code:

gbn ~ # emerge -qtuDN ffmpeg


 * virtual/ffmpeg

Would you like to add these packages to your world favorites? [Yes/No] yes
>>> Recording virtual/ffmpeg in "world" favorites file...
gbn ~ #


What's this now? If I want to install the real ffmpeg, from www.ffmpeg.org
(unless these guys physically killed them, their hatred towards them is
obvious), I now can't anymore!

Because there is this virtual that the renegade ffmpeg, the fork of ffmpeg,
very aggressive fork, and I will now take time to show that it did behave
aggressively in the past already:

How to Use the Arguably Superior Deb-Multimedia Repository
http://forums.debian.net/viewtopic.php?f=16&t=111905
Quote:

Back in 2013 when I first installed Debian GNU/Linux, I tried and
installed ffmpeg, and soon discovered that it was "obsolete".

And Debian installs avconv instead.
So many people know that this is true. But I can't easily rummage through my
archives and prove now. Still, if there were need, we could open an Offtopic
question on Debian Forums asking people if that statement is true or not. But I
can't dedicate to that precise little issue more of my time now (unless I
recollect better where to search).

Because there is this virtual that the renegade ffmpeg installed so I couldn't
anymore even see that there still exist the FFmpeg from www.ffmpeg.org (unless
these guys killed or imprisoned all the FFmpeg team).

These are obstacles that are very hard to overcome for beginners.

So you're feeding this ugly fork to the majority of users without giving them a
choice at all?!

This tantamounts to criminal behavior in GNU/Linux terms. This should be
brought into plain daylight which I am trying to do now, and this should be
immediately stopped, and this should also be punished in some way!

Have a closer look to see if I am exaggerating:

Code:

gbn ~ # etc-update
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)
gbn ~ # emerge -qt ffmpeg
[ebuild   R   ] virtual/ffmpeg-9  USE="X encode jpeg2k sdl x264 -gsm -mp3 -opus -speex -theora -threads -truetype -vaapi -vdpau"

Would you like to merge these packages? [Yes/No] n     

Quitting.

gbn ~ # emerge -qtuDN media-video/ffmpeg
[ebuild  N    ] media-video/ffmpeg-1.2.6  USE="X bindist bzip2 encode fontconfig gnutls hardcoded-tables iconv jack jpeg2k libcaca mmx network pulseaudio sdl v4l vorbis x264 xvid zlib -3dnow -3dnowext -aac -aacplus -alsa (-altivec) -amr -avx -bluray -cdio (-celt) -cpudetection -debug -doc -examples -faac -fdk -flite -frei0r -gsm -iec61883 -ieee1394 -libass -libsoxr -libv4l -mmxext -modplug -mp3 (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -truetype -twolame -vaapi -vdpau (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
[blocks B     ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-video/libav-9.12)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/ffmpeg-1.2.6:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-1.0:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/ffmpeg-1.0:0[X,encode,jpeg2k,sdl,x264]) required by (virtual/ffmpeg-9:0/0::gentoo, installed)
    >=media-video/ffmpeg-1.2.1:0= required by (media-video/mplayer-1.2_pre20130729:0/0::gentoo, installed)
    media-video/ffmpeg

  (media-video/libav-9.12:0/9::gentoo, installed) pulled in by
    >=media-video/libav-9.8:0/9= required by (media-video/mplayer-1.2_pre20130729:0/0::gentoo, installed)

gbn ~ # equery d libav
 * These packages depend on libav:
media-video/mplayer-1.2_pre20130729 (>=media-video/libav-9.8)
virtual/ffmpeg-9 (>=media-video/libav-9[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?])
gbn ~ #


gbn ~ # emerge -s ffmpeg
...[snip]...
...[[three so much less important packages]]..
...[snip]...

*  media-video/ffmpeg
      Latest version available: 1.2.6
      Latest version installed: [ Not Installed ]
      Size of files: 5,830 kB
      Homepage:      http://ffmpeg.org/
      Description:   Complete solution to record, convert and stream audio and video. Includes libavcodec.
      License:       GPL-2 amr? ( GPL-3 ) encode? ( aac? ( GPL-3 ) )

...[snip]...
...[[three so much less important packages]]..
...[snip]...

*  virtual/ffmpeg
     Latest version available: 9
     Latest version installed: 9
     Size of files: 0 kB
     Homepage:     
     Description:   Virtual package for FFmpeg
     implementation
     License:       

gbn ~ #


There, the virtual that has the main task and duty to prevent users to see
that there is the real FFmpeg.

I'm sick of this behavior. I didn't want to write about this.

But I had to.

Because there is a clear violation of some principles that must be enshrined
in the Gentoo Foundation Statute (still haven't found time to read it).

Namely, the ffmpeg from www.ffmpeg.org (unless those team is banned from the
wolrd by, say Google, the Surveillance Engine that makes people disappear,
don't laugh, the Shmoogle all of a suddan declared all my 500 (five hundred)
videos to be in breach of copyright laws, and all of my videos were posted
last one some maybe six months, others many in the span of some 5 (five)
years), the copyright excuse for terminating my Youtube account being a lie
bigger than Zhoogle itself; so Shoogle, and others, can disappear people!)...
Let's have a look together it things by some miracle of compunction in Eric's Larry's or Sergey's heart made those hearts thow out the money for human blood to start running again through those poor hearts, and if my Youtube account is back:

http://www.youtube.com/user/miroR2

...

Namely, the ffmpeg from www.ffmpeg.org is still what everybody has the right
to expect to see under:

Code:

ffmpeg


isn't that so?

And if I choose the ffmpeg flag, do Gentoo developers by that flag mean
something other than the FFmpeg, maybe?

I think not.

So why are my useflags not being respected?

I already published them (unless I get censored again, for stupid reasons, and
I really don't know if I will be, never mind the First Amendment of the
Constitution of the United States of America, the free speech amendment, which
Gentoo Foundation deciders I hope won't breach this time, but I don't know), [I already published] my emerge --info :

Installing X; but X ... freezes
https://forums.gentoo.org/viewtopic-p-7538746.html#7537924

and also I mentioned in various places which changes I later made:

https://forums.gentoo.org/viewtopic-p-7538796.html#7538754
Quote:

thanks to
information in this thread I stopped in my tracks, backed everything up, and
removed

dbus policykit and cosolekit

which I had added thinking they were needed, while only INPUT_DEVICES="evdev"
was needed


the changes to my make.conf and the use flags, but ffmpeg I never removed from
there. this is my current emerge --info:

Code:

Portage 2.2.10 (hardened/linux/amd64, gcc-4.7.3, glibc-2.19, 3.13.9-hardened-140420-00 x86_64)
=================================================================
System uname: Linux-3.13.9-hardened-140420-00-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:    16343020 total,  12756272 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Thu, 17 Apr 2014 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p47
dev-lang/python:          2.7.6, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.11.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: /portage-prev/
    priority: 9999

ABI="amd64"
ABI_X86="64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="amd64"
AUTOCLEAN="yes"
BOOTSTRAP_USE="cxx unicode python_targets_python3_3 python_targets_python2_7 multilib hardened pax_kernel pic xtpax -jit -orc"
CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author"
CAMERAS="ptp2"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CFLAGS_amd64="-m64"
CFLAGS_x32="-mx32"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x32="x86_64-pc-linux-gnux32"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
COLLISION_IGNORE="/lib/modules/* *.py[co] *$py.class */dropin.cache"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-march=native -O2 -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--keep-going --with-bdeps=y --autounmask-write --ask --verbose"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FETCHCOMMAND="wget -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}" -a /var/log/portage_logs/wget-fetch.log"
FETCHCOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
FETCHCOMMAND_SFTP="bash -c "x=\${2#sftp://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; eval \"declare -a ssh_opts=(\${3})\" ; exec sftp -P \${port} \"\${ssh_opts[@]}\" \"\${host}:/\${x#*/}\" \"\$1\"" sftp "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FETCHCOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FFLAGS="-O2 -pipe"
GCC_SPECS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx"
GRUB_PLATFORMS="pc multiboot"
GUILE_LOAD_PATH="/usr/share/guile/1.8"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.24/info:/usr/share/info/emacs-24"
INPUT_DEVICES="evdev"
IUSE_IMPLICIT="prefix"
KERNEL="linux"
LANG="en_US.utf8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_MESSAGES="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LDFLAGS_amd64="-m elf_x86_64"
LDFLAGS_x32="-m elf32_x86_64"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_arm="lib"
LIBDIR_arm64="lib64"
LIBDIR_n32="lib32"
LIBDIR_n64="lib64"
LIBDIR_o32="lib"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_s390="lib32"
LIBDIR_s390x="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x32="libx32"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32"
LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;
05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;
31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;
31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;
31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;
31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;
35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;
35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;
35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;
35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;
35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;
35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;
36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;
36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"
MAIL="/var/mail/root"
MAKEOPTS="-j7"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.24/man"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage|udev|systemd|clang|python-exec)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
NOCOLOR="true"
OFFICE_IMPLEMENTATION="libreoffice"
OLDPWD="/home/miro"
OPENGL_PROFILE="xorg-x11"
PATH="/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin"
PHP_TARGETS="php5-5"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc sparc64-freebsd ppc-openbsd x86-openbsd ppc64 x86-winnt x86-fbsd ppc-aix alpha arm x86-freebsd s390 amd64 arm-linux x86-macos x64-openbsd ia64-hpux hppa x86-netbsd ppc64-linux x86-cygwin amd64-linux ia64-linux x86 sparc-solaris x64-freebsd sparc64-solaris x86-linux x64-macos sparc m68k-mint ia64 mips ppc-macos x86-interix hppa-hpux amd64-fbsd x64-solaris m68k sh arm64 x86-solaris sparc-fbsd"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="info warn error log qa"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_GPG_DIR="/etc/portage/gpg"
PORTAGE_GPG_SIGNING_COMMAND="gpg --sign --digest-algo SHA256 --clearsign --yes --default-key "${PORTAGE_GPG_KEY}" --homedir "${PORTAGE_GPG_DIR}" "${FILE}""
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_INTERNAL_CALLER="1"
PORTAGE_OVERRIDE_EPREFIX=""
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_PYTHONPATH="/usr/lib64/portage/pym"
PORTAGE_REPOSITORIES="[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
masters =
priority = 9999
sync-type = rsync
sync-uri = /portage-prev/
"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="-1"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTAGE_XATTR_EXCLUDE="security.* system.nfs4_acl"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
PORT_LOGDIR="/var/log/portage_logs"
PORT_LOGDIR_CLEAN="find /var/log/portage_logs -type f ! -name summary.log* -mtime +90 -delete"
PROFILE_ONLY_VARIABLES="ARCH ELIBC IUSE_IMPLICIT KERNEL USERLAND USE_EXPAND_IMPLICIT USE_EXPAND_UNPREFIXED USE_EXPAND_VALUES_ARCH USE_EXPAND_VALUES_ELIBC USE_EXPAND_VALUES_KERNEL USE_EXPAND_VALUES_USERLAND"
PWD="/root"
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python2_7"
PYTHON_TARGETS="python2_7 python3_3"
RESUMECOMMAND="wget -c -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}" -a /var/log/portage_logs/wget-fetch.log"
RESUMECOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
RESUMECOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.7.3"
RPMDIR="/usr/portage/rpm"
RUBY_TARGETS="ruby19 ruby20"
SHELL="/bin/bash"
SHLVL="1"
SUDO_COMMAND="/bin/bash"
SUDO_GID="1000"
SUDO_UID="1000"
SUDO_USER="miro"
SYMLINK_LIB="yes"
SYNC=""
SYSTEMD_LESS="FRSM --shift 5"
TERM="xterm"
UNINSTALL_IGNORE="/lib/modules/*"
USE="X a52 acl amd64 apache2 audit bash-completion berkdb bindist bzip2 caps cdr cli cracklib crypt cscope css cxx dri dvb dvdr fam ffmpeg fontconfig gdbm gif git gnutls gpm gstreamer gzip hardened iconv imagemagick introspection ipv6 jack jpeg jpeg2k justify lame libcaca mad maildir mhash mmx mng modules mplayer multilib ncurses nls nptl ogg opengl openmp pam pax_kernel pcre png pulseaudio readline sasl sdl session smp sound sox sqlite sqlite3 sse sse2 ssl ssse svg tcpd tiff udev unicode urandom v4l vim-syntax vorbis x264 xattr xine xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc multiboot" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USER="root"
USERLAND="GNU"
USERNAME="root"
USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CROSSCOMPILE_OPTS CURL_SSL DRACUT_MODULES DVB_CARDS ELIBC ENLIGHTENMENT_MODULES FCDSL_CARDS FFTOOLS FOO2ZJS_DEVICES FRITZCAPI_CARDS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL LCD_DEVICES LIBREOFFICE_EXTENSIONS LINGUAS LIRC_DEVICES MONKEYD_PLUGINS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="ABI_MIPS ABI_PPC ABI_S390 CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_EXPAND_IMPLICIT="ARCH ELIBC KERNEL USERLAND"
USE_EXPAND_UNPREFIXED="ARCH"
USE_EXPAND_VALUES_ARCH="alpha amd64 amd64-fbsd amd64-linux arm arm-linux arm64 hppa hppa-hpux ia64 ia64-hpux ia64-linux m68k m68k-mint mips ppc ppc64 ppc64-linux ppc-aix ppc-macos ppc-openbsd s390 sh sparc sparc64-freebsd sparc64-solaris sparc-fbsd sparc-solaris x64-freebsd x64-macos x64-openbsd x64-solaris x86 x86-cygwin x86-fbsd x86-freebsd x86-interix x86-linux x86-macos x86-netbsd x86-openbsd x86-solaris x86-winnt"
USE_EXPAND_VALUES_ELIBC="AIX Cygwin Darwin FreeBSD glibc HPUX Interix mintlib musl NetBSD OpenBSD SunOS uclibc Winnt"
USE_EXPAND_VALUES_KERNEL="AIX Cygwin Darwin FreeBSD freemint HPUX Interix linux NetBSD OpenBSD SunOS Winnt"
USE_EXPAND_VALUES_USERLAND="BSD GNU"
USE_ORDER="env:pkg:conf:defaults:pkginternal:repo:env.d"
VIDEO_CARDS="radeon vesa"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
_="/usr/bin/emerge"


##########################################################################
Why is the only logical assumption that ffmpeg means ffmpeg not respected
here?
##########################################################################

And why such hatred, and whence such might at those devs that make what they
now call libav, and I don't know if the program is still called avconv, as
this FFmpeg fork was named for at least a while.

Why don't you people give us instead, a use flag such as:

Code:

libav


along with keeping the ffmpeg use flag, but don't name so the virtual whose only
duty then is to mask the existence of the real FFmpeg named ffmpeg, because that is
misleading and in the GNU terms criminal.

Pls. give us the flag:

Code:

libav


and keep the flag:

Code:

ffmpeg


in it's true meaning.

And pls. don't impose that ugly ffmpeg fork that aims at becoming the sole
Audio-Video converting set of programs for the world, onto us users. Please!

Allow people to choose any set of combinations, such and I would certainly
always (well if the FFmpeg team is allowed to live and work, and program the
FFmpeg) opt for:

Code:

ffmpeg


and if you give us the libav flag (but actually they should stick to the
avconv name they initially chose), then I would gladly give them:

Code:

-libav


(pls. notice the "-")

and stay away from having to engage in discussions like this.


Thank you! Sincerely. Gentoo must remain free in the best sense
of the word, the GNU sense!

Miroslav Rovis
Zagreb, Croatia
www.CroatiaFidelis.hr

Some egregiously long lines in the "emerge --info" output split for forum formatting reasons. — JRG
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Tue Apr 22, 2014 12:48 pm    Post subject: Reply with quote

So you ignored the above post.

The virtual is called ffmpeg, because there were only ffmpeg and libav forked. So how to call it the right way? It is the same thing with mysql and mariadb. It does not interfer with your freedom of choice, it is just a naming thing.

So your rant is solely about the naming and the default selection.

Bye
Py
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Apr 22, 2014 1:12 pm    Post subject: Reply with quote

I had work that I announced that I would finish.
I don't think I need to jump around if someone invested a minute, before completing my work of more than ten hours.
Thank you botrh for your replies.
Pls see here:
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/thread.html#21023
the whole thread, and it has currently as my last post, probably for some time:
[FFmpeg-user] Libav (Avconv) Imposition on Users who want FFmpeg
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021032.html
Quote:
I am off this topic.
I gave a lot and I am tired now. And have to do other things.

It is up to others now, not me, to judge and decide on this issue.
I'm off.
Thank you.
Miroslav Rovis
Croatia
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5917

PostPosted: Tue Apr 22, 2014 4:35 pm    Post subject: Reply with quote

miroR wrote:
... already published them (unless I get censored again, for stupid reasons, and
I really don't know if I will be, never mind the First Amendment of the
Constitution of the United States of America, the free speech amendment, which
Gentoo Foundation deciders I hope won't br ...

https://xkcd.com/1357/
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Tue Apr 22, 2014 4:38 pm    Post subject: Reply with quote

Add media-video/libav to /etc/portage/package.mask and unmerge it with `emerge -C media-video/libav`, then do `emerge media-video/ffmpeg`; you should be all set without much force, unless you use a specific package that needs media-video/libav in specific.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Apr 22, 2014 8:55 pm    Post subject: Reply with quote

Quote:
Some egregiously long lines in the "emerge --info" output split for forum formatting reasons. — JRG
Thanks, JRG.
That's the_Admin, for those who don't recognize the initials.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Apr 22, 2014 9:01 pm    Post subject: Reply with quote

TomWij wrote:
Add media-video/libav to /etc/portage/package.mask and unmerge it with `emerge -C media-video/libav`, then do `emerge media-video/ffmpeg`; you should be all set without much force, unless you use a specific package that needs media-video/libav in specific.

Thanks, TomWij.
But I did already figured that out myself.
I would want it changed (or would have), so Libav don't take over users who are unable to find their way through this naming mess.
Well, it hurts me that ffmpeg is used for what is not ffmpeg (or what is renegade ffmpeg), but maybe the FFmpeg don't care, and then who am I to be more fussy about it than them?
( https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021035.html of the same title as here)
M.R.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Apr 22, 2014 9:13 pm    Post subject: Reply with quote

Ant P. wrote:
miroR wrote:
... already published them (unless I get censored again, for stupid reasons, and
I really don't know if I will be, never mind the First Amendment of the
Constitution of the United States of America, the free speech amendment, which
Gentoo Foundation deciders I hope won't br ...

https://xkcd.com/1357/


Hi, Ant P.!

I see, but still, you let people write, and it they are not read, they won't be writing
anymore, if they have integrity and selt-esteem.

And it you don't like it, don't read it. I don't what I don't like.

But don't remove it unless it really offends someone.

OTOH, why would topics that I often feel there is need to talk about, such as
surveillance (and anti-surveillance), be frowned upon, when proofs are, in this
post-Snowden age, abundant that we live in a globally surveilled society,
and there is need to protect oneself
(that was the reason fom my occasionally being censored in different ways)?

I respect you, but we look at the topic of the NSA with different eyes...

Miroslav Rovis,
Zagreb, Croaita,
www.CroatiaFidelis.hr
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9273

PostPosted: Wed Apr 23, 2014 3:21 am    Post subject: Reply with quote

miroR wrote:
Ant P. wrote:
miroR wrote:
... already published them (unless I get censored again, for stupid reasons, and
I really don't know if I will be, never mind the First Amendment of the
Constitution of the United States of America, the free speech amendment, which
Gentoo Foundation deciders I hope won't br ...

https://xkcd.com/1357/


Hi, Ant P.!

I see, but still, you let people write, and it they are not read, they won't be writing
anymore, if they have integrity and selt-esteem.

And it you don't like it, don't read it. I don't what I don't like.

But don't remove it unless it really offends someone.

OTOH, why would topics that I often feel there is need to talk about, such as
surveillance (and anti-surveillance), be frowned upon, when proofs are, in this
post-Snowden age, abundant that we live in a globally surveilled society,
and there is need to protect oneself
(that was the reason fom my occasionally being censored in different ways)?

I respect you, but we look at the topic of the NSA with different eyes...

Miroslav Rovis,
Zagreb, Croaita,
www.CroatiaFidelis.hr
If you want to select which package to use to satisfy virtual/ffmpeg, feel free to continue here. Conversely, if you want to discuss censorship, the NSA, the NRO, the NRA, the FBI, the CIA, the NSF, fashionable styles of tin foil headgear, eye transplants, or the plight of the modern banana; Off the Wall awaits.
Back to top
View user's profile Send private message
Akkara
Administrator
Administrator


Joined: 28 Mar 2006
Posts: 6702
Location: &akkara

PostPosted: Wed Apr 23, 2014 7:06 am    Post subject: Reply with quote

I had skimmed this thread a couple days ago. Had I not seen those kind soul's reply, I would never have guessed there was an actual question buried somewhere in that rant.

That first post sounds like the mother of all windups, preparing to unleash a heretofore unseen rhetorical assault directed toward major world-shaking political and societal flaws that you had singlehandedly uncovered and are bringing to light.

The ultimatum ever so generously gives the Gentoo management multiple *hours* in which to respond prior to opening the gates of blisteringly potent unilateral dialogue.

And when the screed finally arrives, it is discovered the cause of all this sea-roiling tempest: a misunderstood role of the ffmpeg virtual.

In the future, it would help immensely, both in getting your question answered, and for us trying to figure out what it is we're reading and whether we're dealing with yet another systemd level of rhetorical battle, if you would clearly state, in your opening post, what you are trying to emerge, and what emerge is doing that's not to your liking. Then the problem could have been solved sooner, and saved you much wear and tear on the keyboard.
_________________
Many think that Dilbert is a comic. Unfortunately it is a documentary.
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Wed Apr 23, 2014 8:18 am    Post subject: Reply with quote

miroR wrote:
I would want it changed (or would have), so Libav don't take over users who are unable to find their way through this naming mess.


Let us take a view of what is happening:

Code:
 $ grep --include=*.ebuild -r 'media-video/\(ffmpeg\|libav\)' /usr/portage/virtual/ffmpeg/
/usr/portage/virtual/ffmpeg/ffmpeg-0.10.3.ebuild:      >=media-video/ffmpeg-0.10.3:0[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
/usr/portage/virtual/ffmpeg/ffmpeg-0.10.3.ebuild:      >=media-video/libav-0.8.4[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
/usr/portage/virtual/ffmpeg/ffmpeg-9.ebuild:      >=media-video/libav-9[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
/usr/portage/virtual/ffmpeg/ffmpeg-9.ebuild:      >=media-video/ffmpeg-1.0:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]


In 0.10.3 media-video/ffmpeg was listed before media-video/libav, this meant that if you didn't have either you would get media-video/ffmpeg installed; in 9 media-video/libav comes first, this meant that if you didn't have either you would get media-video/libav installed. If you already have one of both installed; you would keep that choice, unless there is some other package only depending on one of both.

The reason that I think the order is changed is because media-video/ffmpeg 1 and higher were masked throughout 2013:

Code:
 $ grep '\(unmask\|update\) ffmpeg' /usr/portage/profiles/ChangeLog-2013
  unmask ffmpeg 1.2
  update ffmpeg 1.1 mask reason with more details
  unmask ffmpeg-1.0


If you now go look at the ChangeLog of the virtual; you'll notice that the virtual was made at the beginning of 2013, at that moment the new 1.x branch that would satisfy the virtual was still masked.

Quote:
# ChangeLog for virtual/ffmpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/virtual/ffmpeg/ChangeLog,v 1.53 2014/02/23 19:45:47 maekke Exp $

[...]

24 Jun 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9.ebuild:
take ffmpeg dep down to 1.0 as it is unmasked

[...]

*ffmpeg-9 (16 Jan 2013)

16 Jan 2013; Tomáš Chvátal <scarabeus@gentoo.org> +ffmpeg-9.ebuild,
-ffmpeg-0.10.2-r1.ebuild:
Add new virtual for 1.1/9 series. Masked. Also it has switched dep order as
will be announced upon unmasking.


The masked refers here to the virtual itself being masked.

Similar to back then, media-video/ffmpeg is experiencing this again nowadays; because its newest branch is again masked:

Code:
 $ awk -vRS= "/media-video\/ffmpeg/ { print \" \" FILENAME \":\", \"\n\" \"\n\" \$0 \"\n\" }" /usr/portage/profiles/package.mask
 /usr/portage/profiles/package.mask:

# Alexis Ballier <aballier@gentoo.org> (20 Jul 2013)
# New major release and lots of packages fail to build.
# Tracker bug is: https://bugs.gentoo.org/show_bug.cgi?id=476490
>=media-video/ffmpeg-2.0


If you look at the tracker bug you can see that it is almost done going through the bugs that it depends on. Being a ffmpeg user, I hope the mask will be soon gone; it is also blocking stabilization a bit for packages like media-video/vlc, which are experiencing security bugs that block other security bugs.

On a final note, there are some other interesting things regarding the virtual and the lack thereof that you need to be aware of when considering what the virtual and the default are:

1. The virtual doesn't accurately match the big API changes of both packages; due to that, a lot of packages list the packages themselves instead with certain more correct version restrictions.
2. As a lot of packages list the packages themselves, they on their own induce an order; that order often is media-video/ffmpeg media-video/libav.

When you have the order A B in one place and the order B A in another, it gets satisfied in a more random way. Not entirely random, Portage might still induce an order in which of A B and B A it tries to satisfy first but it's hard to tell in which order that happens; probably following the order of the world file, but it might differ as it progresses dependencies.

Sometimes this A B and B A listings across the Portage tree cause slot conflicts and/or blockers; because if you have multiple of these with multiple version restrictions, it can become though for the package manager.

To get an idea of how though, as well as see how often they are listed in A B or B A order:

Code:
grep --include=*.ebuild -r 'media-video/\(ffmpeg\|libav\)' /usr/portage/
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5689
Location: Removed by Neddy

PostPosted: Wed Apr 23, 2014 3:17 pm    Post subject: Reply with quote

stop giving gentoo users a bad name on other mailing lists...
support is provided for free, doesn't mean people have to jump when you want them to.

virtuals exist exactly for this...
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Wed Apr 23, 2014 7:58 pm    Post subject: Reply with quote

Akkara wrote:
I had skimmed this thread a couple days ago. Had I not seen those kind soul's reply, I would never have guessed there was an actual question buried somewhere in that rant.

That first post sounds like the mother of all windups, preparing to unleash a heretofore unseen rhetorical assault directed toward major world-shaking political and societal flaws that you had singlehandedly uncovered and are bringing to light.

The ultimatum ever so generously gives the Gentoo management multiple *hours* in which to respond prior to opening the gates of blisteringly potent unilateral dialogue.

And when the screed finally arrives, it is discovered the cause of all this sea-roiling tempest: a misunderstood role of the ffmpeg virtual.

In the future, it would help immensely, both in getting your question answered, and for us trying to figure out what it is we're reading and whether we're dealing with yet another systemd level of rhetorical battle, if you would clearly state, in your opening post, what you are trying to emerge, and what emerge is doing that's not to your liking. Then the problem could have been solved sooner, and saved you much wear and tear on the keyboard.

Thanks for your interest in the topic.
My views are like I wrote on the FFmpeg (meaning FFmpeg) list:
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021046.html
You're free to differ.
Miroslav Rovis
www.CroatiaFidelis.hr
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Wed Apr 23, 2014 8:01 pm    Post subject: Reply with quote

Naib wrote:
stop giving gentoo users a bad name on other mailing lists...
support is provided for free, doesn't mean people have to jump when you want them to.

virtuals exist exactly for this...

My reply here is same as to Akkara. Pls. see above (and on just one step, the link to FFmpeg exact post in the thread).
Thank you!
Miroslav Rovis
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Wed Apr 23, 2014 8:13 pm    Post subject: Reply with quote

TomWij wrote:
miroR wrote:
I would want it changed (or would have), so Libav don't take over users who are unable to find their way through this naming mess.


Let us take a view of what is happening:

Code:
 $ grep --include=*.ebuild -r 'media-video/\(ffmpeg\|libav\)' /usr/portage/virtual/ffmpeg/
/usr/portage/virtual/ffmpeg/ffmpeg-0.10.3.ebuild:      >=media-video/ffmpeg-0.10.3:0[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
/usr/portage/virtual/ffmpeg/ffmpeg-0.10.3.ebuild:      >=media-video/libav-0.8.4[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
/usr/portage/virtual/ffmpeg/ffmpeg-9.ebuild:      >=media-video/libav-9[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
/usr/portage/virtual/ffmpeg/ffmpeg-9.ebuild:      >=media-video/ffmpeg-1.0:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]


In 0.10.3 media-video/ffmpeg was listed before media-video/libav, this meant that if you didn't have either you would get media-video/ffmpeg installed; in 9 media-video/libav comes first, this meant that if you didn't have either you would get media-video/libav installed. If you already have one of both installed; you would keep that choice, unless there is some other package only depending on one of both.

The reason that I think the order is changed is because media-video/ffmpeg 1 and higher were masked throughout 2013:

Code:
 $ grep '\(unmask\|update\) ffmpeg' /usr/portage/profiles/ChangeLog-2013
  unmask ffmpeg 1.2
  update ffmpeg 1.1 mask reason with more details
  unmask ffmpeg-1.0


If you now go look at the ChangeLog of the virtual; you'll notice that the virtual was made at the beginning of 2013, at that moment the new 1.x branch that would satisfy the virtual was still masked.

Quote:
# ChangeLog for virtual/ffmpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/virtual/ffmpeg/ChangeLog,v 1.53 2014/02/23 19:45:47 maekke Exp $

[...]

24 Jun 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9.ebuild:
take ffmpeg dep down to 1.0 as it is unmasked

[...]

*ffmpeg-9 (16 Jan 2013)

16 Jan 2013; Tomáš Chvátal <scarabeus@gentoo.org> +ffmpeg-9.ebuild,
-ffmpeg-0.10.2-r1.ebuild:
Add new virtual for 1.1/9 series. Masked. Also it has switched dep order as
will be announced upon unmasking.


The masked refers here to the virtual itself being masked.

Similar to back then, media-video/ffmpeg is experiencing this again nowadays; because its newest branch is again masked:

Code:
 $ awk -vRS= "/media-video\/ffmpeg/ { print \" \" FILENAME \":\", \"\n\" \"\n\" \$0 \"\n\" }" /usr/portage/profiles/package.mask
 /usr/portage/profiles/package.mask:

# Alexis Ballier <aballier@gentoo.org> (20 Jul 2013)
# New major release and lots of packages fail to build.
# Tracker bug is: https://bugs.gentoo.org/show_bug.cgi?id=476490
>=media-video/ffmpeg-2.0


If you look at the tracker bug you can see that it is almost done going through the bugs that it depends on. Being a ffmpeg user, I hope the mask will be soon gone; it is also blocking stabilization a bit for packages like media-video/vlc, which are experiencing security bugs that block other security bugs.

On a final note, there are some other interesting things regarding the virtual and the lack thereof that you need to be aware of when considering what the virtual and the default are:

1. The virtual doesn't accurately match the big API changes of both packages; due to that, a lot of packages list the packages themselves instead with certain more correct version restrictions.
2. As a lot of packages list the packages themselves, they on their own induce an order; that order often is media-video/ffmpeg media-video/libav.

When you have the order A B in one place and the order B A in another, it gets satisfied in a more random way. Not entirely random, Portage might still induce an order in which of A B and B A it tries to satisfy first but it's hard to tell in which order that happens; probably following the order of the world file, but it might differ as it progresses dependencies.

Sometimes this A B and B A listings across the Portage tree cause slot conflicts and/or blockers; because if you have multiple of these with multiple version restrictions, it can become though for the package manager.

To get an idea of how though, as well as see how often they are listed in A B or B A order:

Code:
grep --include=*.ebuild -r 'media-video/\(ffmpeg\|libav\)' /usr/portage/

Hi, TomWij!
Actually when I read from you, I almost always feel I should start with: Thank you.
Because you not only care, but you also understand these things way higher then I will probably ever get.
But while I see the intricacies and complexities, I have to refer this for the insight of the busy FFmpeg devs, because this to some extent clears Gentoo's name (hope Naib is also reading this).
But only to some extent, as probably is, after that one step on from here into FFmpeg mailing list:
[FFmpeg-user] Libav (Avconv) Imposition on Users who want FFmpeg
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021046.html
easy to conclude that I believe still, but repeat that it is not for me to judge, that ffmpeg should mean FFmpeg and not Libav (Avconv).
I'll nudge them to take a close look, those busy developers making programs that are still masked in Gentoo, but which work so great when bugs are fixed!...
I'll nudge the FFmpeg developers to take a close look here, because I wouldn't understand it without a many hours work...
Pls. understand, TomWij, that I have been building my Gentoo for, i guess more than, one month by now, and am far from done with building of it, as can be seen from the page where you also helped me:
Air-Gapped Gentoo Install, Tentative
https://forums.gentoo.org/viewtopic-t-987268.html#7525358
This is a discussion for developers (and lawyers maybe), and I'm neither.
Miroslav Rovis
Zagreb, Croatia,
www.CroatiaFidelis.hr
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7167

PostPosted: Wed Apr 23, 2014 8:17 pm    Post subject: Reply with quote

Naib wrote:
stop giving gentoo users a bad name on other mailing lists...
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Wed Apr 23, 2014 8:39 pm    Post subject: Reply with quote

krinn wrote:
Naib wrote:
stop giving gentoo users a bad name on other mailing lists...

No, I'm not, krinn!
Pls. have a look what I wrote while I you were replying jhere.(as I see what you wrote while I was replying it):
[FFmpeg-user] Libav (Avconv) Imposition on Users who want FFmpeg
https://ffmpeg.org/pipermail/ffmpeg-user/2014-April/021048.html

And pls., TomWij, have a look, I did just what I said I would. and I mentioned you by name there and gave the exact link to your expertize. I called FFmpeg devs there to look into those reasons here, where I can't at this time understand things clearly, They and you can.

Thank you!

Miroslav Rovis
www.CroatiaFidelis.hr
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Wed Apr 23, 2014 8:49 pm    Post subject: Reply with quote

(As a disclaimer, for people reading this thread; I'd like to note that I am not involved with what has been demonstrated, I am not the distributor or maintainer of the FFmpeg or libav packages on Gentoo.)
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7167

PostPosted: Wed Apr 23, 2014 9:29 pm    Post subject: Reply with quote

miroR wrote:
No, I'm not, krinn!

Only few upstream can claim any power over a distro.
If upstream doesn't agree with a distro choice and try to battle a distro, upstream may suffer from been removed from the distro and problem solved.

So if you rant on ffmpeg to get better support in Gentoo, you're doing nothing and as usual, doing again a way too long post just showing bad manner, and quoting your already too long post to add some few lines worst it, just like reposting yourself in your own thread to up it.
Because at end, ffmpeg users will only remember one thing : it's a gentoo user.

Rant on Gentoo forum on how Gentoo handle this or that. And you can do it in correct manner : short message, no repost every X hours if nobody answer, and stop quoting yourself or limit it to the interesting part you must quote. This is why no one really wish to answer you. Do it the "good" way and you will get answers...

And i'm not angry against you, just disagreeing with you, did you even search the forum? Because there's a thread already that cover that problem, you think you're the only Gentoo user? https://forums.gentoo.org/viewtopic-t-870175-highlight-libav.html
Back to top
View user's profile Send private message
Nicias
Guru
Guru


Joined: 06 Dec 2005
Posts: 444

PostPosted: Wed Apr 23, 2014 11:10 pm    Post subject: Reply with quote

If you are unhappy with how Libav is behaving complain to them at libav.org. Your current complaint about gentoo is that if the user installs virtual/ffmpeg rather than media-video/ffmpeg or has virtual/ffmpeg pulled in as a depend they get libav, that is a very minor quibble and does not deserve that attention you are giving it.

In any case it has nothing to do with the kind people over at ffmpeg-user@ffmpeg.org. Please leave them alone.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Thu Apr 24, 2014 11:34 am    Post subject: Reply with quote

krinn wrote:
miroR wrote:
No, I'm not, krinn!

Only few upstream can claim any power over a distro.
If upstream doesn't agree with a distro choice and try to battle a distro, upstream may suffer from been removed from the distro and problem solved.

So if you rant on ffmpeg to get better support in Gentoo, you're doing nothing and as usual, doing again a way too long post just showing bad manner, and quoting your already too long post to add some few lines worst it, just like reposting yourself in your own thread to up it.
Because at end, ffmpeg users will only remember one thing : it's a gentoo user.

Rant on Gentoo forum on how Gentoo handle this or that. And you can do it in correct manner : short message, no repost every X hours if nobody answer, and stop quoting yourself or limit it to the interesting part you must quote. This is why no one really wish to answer you. Do it the "good" way and you will get answers...

And i'm not angry against you, just disagreeing with you, did you even search the forum? Because there's a thread already that cover that problem, you think you're the only Gentoo user? https://forums.gentoo.org/viewtopic-t-870175-highlight-libav.html

Krinn, you are right in some aspects, distribution decides.

But it's so unfair!

And also, as can be read (if only I knew -- I did search, but maybe not enough, and, sometimes when I tried inputing two words, either they are mangled into one, or search fails in other fashion, and didn't find, well and you don't look at 20 pages every time you search, do you?)-- if only I knew before of the link you gave me!

And also, as can be read in that thread you gave me above, the virtual/ffmpeg _was_ introduced secretly!

And ffmpeg should mean FFmpeg, but I repeat, I'm not the one to judge and
decide. That is my opinion.
I can't go into details, but I most certainly wouldn't like that somebody took
the name Flowstamp from my program of which the distant (imaginary- no source)
pre-release I have just made available:
http://www.croatiafidelis.hr/gnu/Flowstamp/

Nicholas, I tried to help those people. And cared for freedom and choice
in Gentoo. Had I been able to inform myself better, I would probably have been
able to do it in some better way. Sorry for the flawed way in which I did it.

Can't argue anymore. I think all is said here, and the link was long overdue,
and really thanks krinn for it.

I tried posting this before going to sleep, but at that time Gentoo Forums was
down.

Miroslav Rovis
Zagreb, Croatia
www.CroatiaFidelis.hr
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Sun Nov 02, 2014 3:24 pm    Post subject: Reply with quote

I wish I didn't need to revive this thread.

This is lengthy. However, I wouldn't arrive at enough arguments to be able to say that we have a a political bug on our hands here, without quite a lot of research (in my modest terms sure).

However, as far as astute imposition seems to still be continuing, so I think, out of gratitude for FFmpeg program (and MPlayer program, read on) given me/us, and grateful I am, just as a huge number of other users worldwide many of them are as well, an update is due.

It's mostly same Developers, IIUC, who work both FFmpeg and MPlayer, and this imposition is to try and render them and their programs obsolete. It is a crawling imposition IMO, and it is a political one, it has been happening for political reasons, surely with a façade of technicalities to camouflage the politics.

To hit those group of Devs, it is fine whether FFmpeg or MPlayer is somehow presented as, and users led to believe (that is the point!) that FFmpeg or MPlayer were faulty or lacking, and how the rival Libav and MPlayer2 programs were superior, and should be used instead.

Just to clear eventual suspicion: I have no affiliation with FFmpeg or MPlayer Devs. All I have is gratitude for them who give me such superb programs which I have used for at least a decade, and if I can, and sure I should be allowed, because I am not breaking any rules, I'll do what little I can, to defend them.

However, I don't intend to attack anyone ad hominem, just the reality and the events before us I have no wish to call what they are not, for any reason of any stupid considerateness.

See what happened recently, in Gentoo. This, and you can judge for yourself looking in your...

/usr/portage/media-video/mplayer:

The head -30 of Changelog:
Code:

# ChangeLog for media-video/mplayer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.928 2014/10/17 14:35:40 klausman Exp $

  17 Oct 2014; Tobias Klausmann <klausman@gentoo.org>
  mplayer-1.2_pre20130729.ebuild:
  Stable on alpha, bug 517692

  12 Oct 2014; Alexis Ballier <aballier@gentoo.org>
  mplayer-1.2_pre20141011.ebuild, mplayer-9999.ebuild:
  require ffmpeg on latest versions as it doesnt build with libav, bug #525070

*mplayer-1.2_pre20141011 (11 Oct 2014)

  11 Oct 2014; Alexis Ballier <aballier@gentoo.org>
  +mplayer-1.2_pre20141011.ebuild:
  bump a new snapshot, bug #524570

  11 Oct 2014; Alexis Ballier <aballier@gentoo.org> files/dump_ffmpeg.sh:
  dump_ffmpeg.sh: no need for x86_cpu.h nor lavf/internal.h anymore

  01 Sep 2014; Michał Górny <mgorny@gentoo.org> mplayer-1.2_pre20130729.ebuild,
  mplayer-9999.ebuild:
  Remove := subslot operator from || () block since it is meaningless and
  broken.

  31 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
  mplayer-1.2_pre20130729.ebuild:
  amd64/x86 stable wrt #517692

So, as anyone can see, the only not-last-year's MPlayer in Gentoo in almost the whole of 2014 (this is from my portage updated on 2014-10-30), was availble for not more than one (1) week, the *mplayer-1.2_pre20141011 (11 Oct 2014) as the reader can see above.

I was among the lucky people who installed that MPlayer from those kind Devs that I try to, as minimally that I can, speak in favor of, because my previous update of my Gentoo local mirror was around 2014-10-12.

That MPlayer works better than the last-year's which is again the sole non-masked MPlayer that a common Gentoo user can install, if (s)he does not know the tricks about masking/unmasking packages (which I believe is still a few people, and I happen to try and write for them as well, if I can).

In your portage, kind reader, you will, at around the time of my writing, find these MPlayer ebuilds:

Code:

/usr/portage/media-video/mplayer/:
total 242
-rw-r--r-- 1  53533 Oct 17 17:01 ChangeLog
-rw-r--r-- 1 107064 Jan  2  2012 ChangeLog-2008
drwxr-xr-x 2   2048 Oct 14 02:24 files
-rw-r--r-- 1   9954 Oct 17 17:01 Manifest
-rw-r--r-- 1   2825 Jul 28 03:31 metadata.xml
-rw-r--r-- 1  18277 Jul 28 03:31 mplayer-1.1.1-r1.ebuild
-rw-r--r-- 1  17336 Oct 17 17:01 mplayer-1.2_pre20130729.ebuild
-rw-r--r-- 1  17215 Oct 12 10:31 mplayer-1.2_pre20141011.ebuild
-rw-r--r-- 1  17224 Oct 12 10:31 mplayer-9999.ebuild

/usr/portage/media-video/mplayer/files:
total 40
-rwxr-xr-x 1  2455 Oct 11 13:01 dump_ffmpeg.sh
-rw-r--r-- 1  2751 Apr  5  2012 mplayer-1.0_rc4-pkg-config.patch
-rw-r--r-- 1   678 Jun 14  2013 mplayer-1.1.1-avcodecidsubrip.patch
-rw-r--r-- 1   686 Jun 14  2013 mplayer-1.1.1-codecidsubrip.patch
-rw-r--r-- 1   656 Aug 22  2012 mplayer-1.1-codecid.patch
-rw-r--r-- 1  1452 Jun 11  2012 mplayer-1.1-ffmpeg.patch
-rw-r--r-- 1   441 Jan 16  2013 mplayer-1.1-libav-0.8.patch
-rw-r--r-- 1 19609 Jun 14  2013 mplayer-1.1-libav-9.patch
-rw-r--r-- 1   767 Jan 17  2013 mplayer-1.1-missingbreak.patch
-rw-r--r-- 1  4832 Jan 17  2013 mplayer-1.1-planaraudio.patch
-rw-r--r-- 1  3005 Jul 29  2013 mplayer-1.2_pre20130729-compat.patch
-rw-r--r-- 1   757 Jul 29  2013 prepare_mplayer.sh

But the analysis (esp. for the new users) is not complete without:

/usr/portage/profiles/package.mask:

Code:

...[snip]...
# bug #525070
>=media-video/mplayer-1.2_pre20141011
...[snip]...


So, there is the reason in the shape of a bug for our new version of MPlayer being kind of banned from portage, as if it were dirt... The bug is #525070:

https://bugs.gentoo.org/show_bug.cgi?id=525070

and the talk there is comprehensible. I mean it is clear what they mean. Somebody correct me if my explanation is wrong. I want even people ending up here by chance, and maybe even without sufficient knowledge of Gentoo Portage, to still be able to understand this. Because somewhere in this event there is a lot of injustice, and I can, I believe, at least speak up that I see it.

Nobody touched MPlayer in Gentoo in quite long time. Undeniable. Obvious if you look up the Porage entries for category media-video package mplayer. I doubt that MPlayer is that rarely developed, so I have no time to confirm that it is much more often contributed and released, or the source revamped and snapshots offered, than that.

Some time in 2014, probably, in their quest towards world's domination and becoming the sole video converter program for the whole of FOSS Linux and wider, the Libav team (let's not forget that Libav is a fork of FFmpeg, and MPlayer2, by the same Libav Team, IIUC, is a fork of the real MPlayer) deletes all the code that makes it possible for MPlayer to support Libav where Libav, and not FFmpeg, is installed (like mine).

Then someone decides to update the last-year's MPlayer, because it's getting conspicuously old, and it will be easy to mask it, because the code will not be there anymore and it will be easy to declare it unsupportive of the now "dominant" program, and it will be easy to keep the dominance of Libav Team marching on toward their conquest of the entire FOSS Linux and wider.

Of course this is just what I suspect might have happened. I have no proof. All those kind people may have done it purely by chance, I most certainly can not claim anything here.

I know FFmpeg Team are poor. No finances. Probably just for a living, from donations or otherwise, from other work unrelated to FFmpeg. And I know that is not the case with some other groups involved with FOSS who work for their masters (like Lennart Poetteing who is not poor by any means), just I hate the programs and packages by those other poeple as much as dirt (I don't hate the people ever, just their work if it is disreputable and immoral.).

There is one quote from elsewhere that I want to paste here. It isn't exactly by a Dev whose work I regard as best around, because I was stuck with udev because of the direction of his,. ssuominem's, work (IIUC it was keeping udev with systemd instead of what blueness did, isolate udev from systemd in his eudev which I love and am thankful for), and it took me a while to find the right way in my Gentoo ( see

Uninstalling dbus and *kits (to Unfacilitate Remote Seats)
https://forums.gentoo.org/viewtopic-t-992146.html

), but I don't doubt that these words of his are correct:

libav vs ffmpeg
https://forums.gentoo.org/viewtopic-t-870175-start-50.html#7225660
ssuominen wrote:
...[snip]...
The switch in the virtual/ffmpeg to prefer libav was indeed done in secret. Other members of the team didn't know about it. I'm also committed in keeping my packages working with ffmpeg, not libav.
...[snip]...


So, this looks like just another steath move against FFmpeg and MPlayer Team (it's the same people). Political move, that is why I pronounce these few political words here. I hope things with support for real MPlayer and real (the so called "obsolete") FFmpeg, improve in the time ahead of us.

For the occasional newbie, do what TomWij suggested above (
< this same topic >
https://forums.gentoo.org/viewtopic-t-989196.html#7539888
), and now, on top of that, put this in your

/etc/portage/package.unmask:
Code:

=media-video/mplayer-1.2_pre20141011

Then you can install MPlayer just fine, and really, really it is _not_ buggy. And neither is a bug (sorry, that is really a political bug, not a real bug), that MPlayer can not support Libav, because the Libav Team have deleted the code to make it impossible to be supported by MPlayer (IIUC what is reported in the bug).


Last edited by miroR on Sun Nov 02, 2014 5:34 pm; edited 15 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum