Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HDMI output since boot?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Ginta
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2006
Posts: 112
Location: Spain

PostPosted: Fri Apr 18, 2014 5:34 pm    Post subject: HDMI output since boot? Reply with quote

I have a laptop with a broken screen, but it usually boots, and when KDM is started, then, HDMI is detected and used, so I can use it.

But my problem is that I am afraid that maybe one day, some update or bad config could have my system unbootable and I could not do much without an active screen.

That's why I thought on the posibility of booting directly to HDMI (like some framebuffer or something similar) in early kernel boot stage.

The problem: I don't have a clue if it is possible, which kernel config should I have, or which special option to kernel boot parameters should I use :(

Currently, I use grub2, with this lines on /etc/defaults/grub

GRUB_GFXPAYLOAD_LINUX=1920x1080x24
GRUB_DISTRIBUTOR="Gentoo"
GRUB_TIMEOUT=10
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DEFAULT=saved
GRUB_GFXMODE=1920x1080x24
GRUB_CMDLINE_LINUX_DEFAULT='root=/dev/sda2 video=uvesafb:1920x1080-32,mtrr:3,ywrap crashkernel=128M@16M resume=/dev/sda4 udev splash rw'
#GRUB_HIDDEN_TIMEOUT=0
GRUB_TERMINAL=console



Maybe changing video=uvesafb:1920x1080-32 to something else could work, but unfortunatelly I can't just test, because if it does not boot, it is very hard to repair it.

I will thank any comment on it :)

P.S. I use nvidia-driver if it is needed to know
_________________
Somebody should use emerge brain on theirselves...
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 867
Location: Montréal

PostPosted: Fri Apr 18, 2014 6:16 pm    Post subject: Reply with quote

If you want to boot only from your external Hdmi screen, you can tell Linux to do so. You do not need more than one video parameter, This should do the job:
Code:
GRUB_CMDLINE_LINUX_DEFAULT='root=/dev/sda2 video=LVDS-1:d crashkernel=128M@16M resume=/dev/sda4 udev splash rw'

You can add an other video= parameter if you want to precise the external display, but it should be use by the kernel at is native resolution. Your internal screen will be disabled for Linux and Xorg until you will reboot without the video=LVDS-1:d parameter. Xorg should use the Hdmi screen by default.
_________________
Paul
Back to top
View user's profile Send private message
Ginta
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2006
Posts: 112
Location: Spain

PostPosted: Fri Apr 18, 2014 11:09 pm    Post subject: Reply with quote

Logicien wrote:
If you want to boot only from your external Hdmi screen, you can tell Linux to do so. You do not need more than one video parameter, This should do the job:
Code:
GRUB_CMDLINE_LINUX_DEFAULT='root=/dev/sda2 video=LVDS-1:d crashkernel=128M@16M resume=/dev/sda4 udev splash rw'

You can add an other video= parameter if you want to precise the external display, but it should be use by the kernel at is native resolution. Your internal screen will be disabled for Linux and Xorg until you will reboot without the video=LVDS-1:d parameter. Xorg should use the Hdmi screen by default.


Thanks for your answer! Just for curiosity:

Shouldn't it be video=HDMI-1... ? Because, at least when I had the screen working, in nvidia-settings, I could see that my laptop screen was LVDS in its connection name (maybe I am wrong, but I am pretty sure)
_________________
Somebody should use emerge brain on theirselves...
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 867
Location: Montréal

PostPosted: Sat Apr 19, 2014 12:38 am    Post subject: Reply with quote

All videos output use to be enabled by default by the Linux kernel. Passing
Code:
video=HDMI-1:e

can be redundant because it is already enabled. What you want is to use only the Hdmi output.
Code:
video=LVDS-1:d

will force the Linux kernel to disable the integrated screen that is enabled by default, living only the Hdmi enabled.
Code:
d = disable
e = enable

_________________
Paul
Back to top
View user's profile Send private message
Ginta
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2006
Posts: 112
Location: Spain

PostPosted: Sun Apr 20, 2014 2:58 pm    Post subject: Reply with quote

Oh, that makes sense.

However, I've tried and the result is just the same, hdmi output is not enabled until KDE starts and I can't see the tty in my TV yet.

Maybe I miss some kernel options, or maybe my hardware is just unable to do it in boot phase?
_________________
Somebody should use emerge brain on theirselves...
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 867
Location: Montréal

PostPosted: Sun Apr 20, 2014 3:20 pm    Post subject: Reply with quote

Note that the kernel log will give you the exact port number for LVDS-? and HDMI-? Check with dmesg.
Try to boot with these kernel parameters
Code:
video=HDMI-1:e video=LVDS-1:d

and boot again if needed with those one
Code:
video=HDMI-1:D video=LVDS-1:d

_________________
Paul
Back to top
View user's profile Send private message
s4e8
Apprentice
Apprentice


Joined: 29 Jul 2006
Posts: 237

PostPosted: Mon Apr 21, 2014 7:40 am    Post subject: Reply with quote

You have no output control if you use the nvidia-driver, both VGA/VESA console output initialized by BIOS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum