Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.10 won't use 3d acceleration by default.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
owemeacent
n00b
n00b


Joined: 06 Apr 2014
Posts: 32

PostPosted: Sun Apr 13, 2014 11:41 pm    Post subject: Gnome 3.10 won't use 3d acceleration by default. Reply with quote

I recently did my first succesfiul Gentoo install. I installed Gentoo on an AMD/ATI machine. I want 3d acceleration so I got the radeon drivers. When I manually run
Code:
startx
and then
Code:
gnome-shell
it starts up gnome shell with acceleration but something is wrong with how it renders icons, something that doesn't happen when gdm is started at boot.

When I ran
Code:

omar@GenShady ~ $ sudo dmesg | grep radeon
[    1.308206] [drm] radeon kernel modesetting enabled.
[    1.309615] radeon 0000:01:05.0: VRAM: 256M 0x00000000C0000000 - 0x00000000CFFFFFFF (256M used)
[    1.309720] radeon 0000:01:05.0: GTT: 512M 0x00000000A0000000 - 0x00000000BFFFFFFF
[    1.310254] [drm] radeon: 256M of VRAM memory ready
[    1.310324] [drm] radeon: 512M of GTT memory ready.
[   61.563293] r600_cp: Failed to load firmware "radeon/R600_rlc.bin"
[   61.563440] radeon 0000:01:05.0: disabling GPU acceleration
[   61.564600] radeon 0000:01:05.0: ffff88011ab47400 unpin not necessary
[   61.565966] [drm] radeon: power management initialized
[   61.610395] fbcon: radeondrmfb (fb0) is primary device
[   61.653013] radeon 0000:01:05.0: fb0: radeondrmfb frame buffer device
[   61.653114] radeon 0000:01:05.0: registered panic notifier
[   61.653205] [drm] Initialized radeon 2.34.0 20080528 for 0000:01:05.0 on minor 0


It showed that it can't load the radeon driver.

Any help is greatly appreciated
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Mon Apr 14, 2014 8:48 am    Post subject: Reply with quote

Ηι. Did you run make Xorg -configure? I don't know if that helps but creates the xorg.conf file (in /root and you must move it /etc/X11)
_________________
Compile The Universe
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Mon Apr 14, 2014 10:49 am    Post subject: Reply with quote

You need to start it through the display manager, as that sets up what is necessary; I don't have a reference, but startx has regressed since around 3.7.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum