Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
LXDE - can't switch keyboard layout
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
apiaio
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2008
Posts: 100

PostPosted: Mon Feb 17, 2014 7:32 pm    Post subject: LXDE - can't switch keyboard layout Reply with quote

Hi there.
I can see both flags, us and sk into "Keyboard Layout Handler" but only us keyboard is working. I am not sure if all of my localization config - files are OK. Some informations:
Quote:
localhost / # locale
LANG=en_US.utf8
LC_CTYPE=sk_SK.utf8
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=
Quote:
localhost / # locale -a
C
en_US
en_US.iso88591
en_US.utf8
POSIX
sk_SK
sk_SK.iso88592
sk_SK.utf8
slovak
and in /etc/conf.d/keymaps I have
Quote:
keymap="us"
keymap="sk-qwerty"
What else is necessary to set up?
Back to top
View user's profile Send private message
roseZ
n00b
n00b


Joined: 17 Dec 2005
Posts: 31
Location: Finland

PostPosted: Wed Apr 09, 2014 12:11 pm    Post subject: Reply with quote

From the topic I'm assuming you want to set the keyboard layout in X. The settings in /etc/conf.d/keymap control layout in the console and have no bearing on X. I don't know if it's possible to use two layouts in the console; I'm guessing the later setting (sk-qwerty) from /etc/conf.d/keymap is in effect there.

I never used LXDE, but these commands should work under X in general (use only one):
Code:

setxkbmap sk
setxkbmap sk,us -option "grp:shifts_toggle"

The latter command will let you switch between the two layouts by pressing both shift keys simultaneously. You'll find the possible layouts under the subdirectories of /usr/share/X11/xkb/. Check inside the appropriate file to see the possible variants; you may want to try adding -variant "qwerty," (omit the comma if not using two layouts) to the above commands. See also the manpage of setxkbmap.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum