Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Cannot mount internal partitions in Nautilus
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 57

PostPosted: Sun Apr 06, 2014 7:53 am    Post subject: [SOLVED] Cannot mount internal partitions in Nautilus Reply with quote

I cannot mount my windows partitions on the same hard drive in Nautilus, it says "Not authorized to perform operation". However, my external hard drive works fine.

I really have no idea how to solve this problem. Can someone help me?


Last edited by yufw on Wed May 14, 2014 7:25 am; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Veteran
Veteran


Joined: 01 Feb 2006
Posts: 1802

PostPosted: Sun Apr 06, 2014 9:28 am    Post subject: Reply with quote

Please post /etc/fstab.
Back to top
View user's profile Send private message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 57

PostPosted: Sun Apr 06, 2014 10:56 am    Post subject: Reply with quote

Here it is:
Code:

/dev/sda7       /boot       ext2    noauto,noatime      0 2
/dev/sda8       none        swap    sw                  0 0
/dev/sda9       /           ext4    defaults,noatime    0 1

The windows partitions aren't listed in the /etc/fstab file.
Back to top
View user's profile Send private message
Keruskerfuerst
Veteran
Veteran


Joined: 01 Feb 2006
Posts: 1802

PostPosted: Sun Apr 06, 2014 11:24 am    Post subject: Reply with quote

Then add the line for the windows partition as follows:

/dev/your windows partition here /your mount point ntfs defaults 0 1

You can find out the correct /dev/sdax by using fdisk -l.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33262
Location: 56N 3W

PostPosted: Sun Apr 06, 2014 11:47 am    Post subject: Reply with quote

[Keruskerfuerst,

Careful ..
Code:
/dev/your windows partition here /your mount point ntfs defaults 0 1

Will use the read only kernel ntfs driver. The OP may want rw access, is which cas. the fs is ntfs3g.

Lastly, USB drives may be formatted as VFAT, in which case, the OP my not have any ntfs support available at all yet.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 57

PostPosted: Mon Apr 07, 2014 8:11 am    Post subject: Reply with quote

I added this line to /etc/fstab:
Code:
/dev/sda6               /mnt/windows  ntfs-3g   user,noauto,uid=yufw,gid=users,dmask=022,fmask=133 0 0
but I still cannot mount /dev/sda6 as user in either command line or nautilus.

The directory /mnt/windows is owned by the user and I have recompiled the ntfs3g package without the external-fuse USE flag.
Back to top
View user's profile Send private message
Keruskerfuerst
Veteran
Veteran


Joined: 01 Feb 2006
Posts: 1802

PostPosted: Mon Apr 07, 2014 9:06 am    Post subject: Reply with quote

What error message is displayed, when you try to mount the windows partition? (command line)
Back to top
View user's profile Send private message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 57

PostPosted: Mon Apr 07, 2014 2:19 pm    Post subject: Reply with quote

Code:
$ ntfs-3g /dev/sda6 /mnt/windows
The output is:
Code:
ntfs-3g-mount: mount failed: Operation not permitted
User doesn't have privilege to mount. For more information
please see: http://tuxera.com/community/ntfs-3g-faq/#unprivileged
Back to top
View user's profile Send private message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 57

PostPosted: Wed May 14, 2014 7:24 am    Post subject: Reply with quote

I found the solution here,
https://wiki.archlinux.org/index.php/Polkit#Allow_mounting_a_filesystem_on_a_system_device_for_any_user
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum