Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers, 4K monitors and xorg 1.15
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message

Joined: 07 Apr 2014
Posts: 1

PostPosted: Mon Apr 07, 2014 4:04 am    Post subject: ati-drivers, 4K monitors and xorg 1.15 Reply with quote

Hi there,

Longtime reader of this forum, first time poster. I wanted to finally contribute a solution to a problem I have discovered as thanks for many of the useful tips I've found on these forums through Google Search throughout the years.

I have a Seiki 4K TV used as an big screen monitor in 3840x2160 mode. Last monday, I was upgraded to both ati-drivers-14.3 (I have set ~amd64 in /usr/portage/package.keywords) and xorg-server-1.15 through emerge -uvDN world. After doing this, I found that the 3840x2160 display mode no longer worked. That is, whenever I tried to set this mode with xrandr, I would simply get a black screen. Initially I thought this was due to ati-drivers-14.3 being broken so I rolled back to ati-drivers-14.1, which I knew had worked previously. However, this did not solve the problem, so the issue I suspect must be related with xorg-server-1.15.

i'm not sure how the dependencies are set with xorg-server, but apparently, ati-drivers-14.3beta is the only version of the proprietary ati-drivers that supports xorg-server-1.15

I tried switching to the kernel 3.10.25 open-source radeon driver from the fglrx driver, however, this was even worse, as when the radeon module was loaded, my console screen would immediately go black with my monitor displaying a "signal out of range" error.

Finally I decided to switch to the latest kernel version in the gentoo-sources, which for me is 3.12.14. After recompiling the kernel, installing it through grub2 and re-emerging ati-drivers, I could once again set the 3840x2160 mode! Not sure if this was an isolated problem, but it seems like keeping your kernel updated is an essential part of getting new drivers to work :).

Hopefully this can help someone down the road in the way that the gentoo and arch message boards have helped me. You guys are an awesome community!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum