Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
starting authorization manager fail in gnome3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 711

PostPosted: Fri Apr 04, 2014 1:43 pm    Post subject: starting authorization manager fail in gnome3 Reply with quote

Hi,

I can login with root but I added new user and when I am trying to login
there is a line on the upside of the screen:
'starting authorization manager...' and can not login, gnome crashing.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Sat Apr 05, 2014 11:44 am    Post subject: Re: starting authorization manager fail in gnome3 Reply with quote

Did you follow the GNOME 3 upgrade guide on the Gentoo Wiki? How do you login? How does GNOME crash? Is there something in the logs (`dmesg`, /var/log/messages, `journalctl -rb`, ...) about it?
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 711

PostPosted: Sat Apr 05, 2014 1:15 pm    Post subject: Reply with quote

TomWij Hi,

I am quite new - I installed new gentoo with gnome/systemd.
I did not upgraded so I followed systemd guide, but may be I should be a ware to the GNOME 3 upgrade guide.
Anyway - I login with the default login dialog that came with gnome -
I succeed to login as root but not as other user. Now after viewing GNOME 3 upgrade guide I saw this command:
'systemctl enable gdm' and afterward it still not working and there are more message: 'Started account service...' on the upside screen.
In addition: Below the login dialog there is a line:'not Listed?' -What does it mean?

Here are some suspicious lines found in /var/log/messages - BTW, I could not open this file with the default editor but with libreoffice???
Code:
Apr  1 02:56:42 mg_host login[1867]: pam_unix(login:session): session opened for user root by LOGIN(uid=0)
Apr  1 02:56:42 mg_host gnome-keyring-daemon[1874]: couldn't create socket directory: No such file or directory
Apr  1 02:56:42 mg_host gnome-keyring-daemon[1874]: couldn't bind to control socket: /root/.cache/keyring-Ilf36j/control: No such file or directory
Apr  1 02:56:43 mg_host login[1875]: ROOT LOGIN  on '/dev/tty1'


Thanks
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Sat Apr 05, 2014 2:52 pm    Post subject: Reply with quote

pmam wrote:
'systemctl enable gdm'


Yes, you will want to start it through GDM.

pmam wrote:
and afterward it still not working and there are more message: 'Started account service...' on the upside screen.


Hmm, it might be that accountsservice is broken; try a different version of sys-apps/accountsservice, you can emerge it like `emerge =sys-apps/accountsservice-VERSION` (replace VERSION by the other version).

pmam wrote:
In addition: Below the login dialog there is a line:'not Listed?' -What does it mean?


That allows you to pick a different user if you click on it.

pmam wrote:
Here are some suspicious lines found in /var/log/messages - BTW, I could not open this file with the default editor but with libreoffice???
Code:
Apr  1 02:56:42 mg_host login[1867]: pam_unix(login:session): session opened for user root by LOGIN(uid=0)
Apr  1 02:56:42 mg_host gnome-keyring-daemon[1874]: couldn't create socket directory: No such file or directory
Apr  1 02:56:42 mg_host gnome-keyring-daemon[1874]: couldn't bind to control socket: /root/.cache/keyring-Ilf36j/control: No such file or directory
Apr  1 02:56:43 mg_host login[1875]: ROOT LOGIN  on '/dev/tty1'


That part is for when you login as root, the keyring isn't critical here; is there a part about your own user logging in and/or accountsservice? You can change the default editor in the preferences and/or with a mime editor.

As a last question, are you perhaps running this in VirtualBox? https://bugzilla.redhat.com/show_bug.cgi?id=904644 seems relevant and explains a solution (reinstall additions) if you do.
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 711

PostPosted: Sat Apr 05, 2014 6:22 pm    Post subject: Reply with quote

Dear TomWij,

First - This is not VM - This is the real thing... :D

I hope these lines from /var/log/messages can help - The user name is 'mg' but I am not finding it in file:
Code:
Mar 30 17:07:28 mg_host login[1867]: pam_tally2(login:auth): pam_get_uid; no such user
Mar 30 17:07:36 mg_host login[1867]: pam_unix(login:auth): check pass; user unknown
Mar 30 17:07:36 mg_host login[1867]: pam_unix(login:auth): authentication failure; logname=LOGIN uid=0 euid=0 tty=/dev/tty1 ruser= rhost=
Mar 30 17:07:36 mg_host login[1867]: gkr-pam: error looking up user information
Mar 30 17:07:39 mg_host login[1867]: FAILED LOGIN (1) on '/dev/tty1' FOR 'UNKNOWN', Authentication failure


Quote:
You can change the default editor in the preferences and/or with a mime editor.

Sorry, but I do not know how to do it - Where suppose to be 'preferences' - When I right-click on the file there is no...

I have another issue that you may help me - After login with root I am not getting always the same gnome's screen:
Some times there is a search symbol (in the upside of the screen) with a place to enter data, but after another login, only the symbol without the the line for the data - in this case also I can not click on shutdown button (in the upright corner) - It is not consistently and I prefer the first option - but do not know how to fix it?

Thanks for your nice response!
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Sat Apr 05, 2014 6:58 pm    Post subject: Reply with quote

pmam wrote:
Code:
Mar 30 17:07:36 mg_host login[1867]: gkr-pam: error looking up user information


Make sure the USE flags gnome-keyring, pam and systemd are enabled (add them to USE in /etc/portage/make.conf), then run `emerge -auvDN @world` to rebuild the packages. Additionally, do the step "systemd-logind & pam_systemd" at https://wiki.gentoo.org/wiki/Systemd#systemd-logind_.26_pam_systemd

pmam wrote:
Quote:
You can change the default editor in the preferences and/or with a mime editor.

Sorry, but I do not know how to do it - Where suppose to be 'preferences' - When I right-click on the file there is no...


Apparently you can't do this in the preferences, it has a rather limited list of options; however, on the CLI there is xdg-mime from x11-misc/xdg-utils (run `man xdg-mime` for instructions), some DEs provide an alternative for this (eg. http://docs.xfce.org/xfce/xfce4-settings/mime and http://rox.sourceforge.net/desktop/MIME-Editor) but I'm not aware of any graphical ones that are in the Portage tree. I change the underlying files (eg. mimeapps.list) myself; however, using a command-line or graphical tool should work out better.

pmam wrote:
I have another issue that you may help me - After login with root I am not getting always the same gnome's screen:
Some times there is a search symbol (in the upside of the screen) with a place to enter data, but after another login, only the symbol without the the line for the data - in this case also I can not click on shutdown button (in the upright corner) - It is not consistently and I prefer the first option - but do not know how to fix it?


That doesn't sound familiar to me, I don't see such search symbol; can you find, draw or upload a screenshot / photo of what you mean? Maybe it is a missing icon or so?
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 711

PostPosted: Sun Apr 06, 2014 7:28 am    Post subject: Reply with quote

Dear TomWij,

Quote:

Make sure the USE flags gnome-keyring, pam and systemd are enabled (add them to USE in /etc/portage/make.conf), then run `emerge -auvDN @world`

I have done it but regarding "systemd-logind & pam_systemd" - I understand that the following part is relevant for me ( I assume 'kde-misc/networkmanagement not being able' is not relevant because I do not have kde...) :
Quote:
In order to enable session tracking for systemd-logind, you have to enable the pam_systemd PAM module first. This can be done using USE=systemd on sys-auth/pambase.

I already have USE=systemd in /etc/portage/make.conf and I think that sys-auth/pambase is already installed - when I 'emrge -av sys-auth/pambase' the result is: 1 package reinstall.. - BTW, This is the way to find out if a package has already been emerged or there is another way?
In addition: Generally, In case that emerge ask me to add USE flag - How should I know if add it to /etc/portage/make.conf or to /etc/portage/package.use?

Quote:
That doesn't sound familiar to me, I don't see such search symbol;

It is more simple than it sound - I did not explain it quite clear - I will try again:
The problem is that the main screen of gnome does not show up the same design/view, each login -
When you click on 'Activities' (in the up-left corner) you get some icons in the left side and at the top side of the screen should be written: 'Type to search' -
In case that it goes wrong this feature is not available and other features, as well - It is quite weird but it seems that something is not consistent...

Thanks
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Sun Apr 06, 2014 10:56 am    Post subject: Reply with quote

pmam wrote:
I already have USE=systemd in /etc/portage/make.conf and I think that sys-auth/pambase is already installed - when I 'emrge -av sys-auth/pambase' the result is: 1 package reinstall.. - BTW, This is the way to find out if a package has already been emerged or there is another way?


Make sure Portage doesn't indicate that the USE flag has changed; if it does, it would put a * next to the USE flag. app-portage/eix is a good way to see these things; if it's already installed it will show a [I], if not, just a *.

pmam wrote:
In addition: Generally, In case that emerge ask me to add USE flag - How should I know if add it to /etc/portage/make.conf or to /etc/portage/package.use?


The former (make.conf) is for global USE flags over all packages, the latter (package.use) for local USE flags on specific package(s).

pmam wrote:
Quote:
That doesn't sound familiar to me, I don't see such search symbol;

It is more simple than it sound - I did not explain it quite clear - I will try again:
The problem is that the main screen of gnome does not show up the same design/view, each login -
When you click on 'Activities' (in the up-left corner) you get some icons in the left side and at the top side of the screen should be written: 'Type to search' -
In case that it goes wrong this feature is not available and other features, as well - It is quite weird but it seems that something is not consistent...


Ah, that one; yeah, it sounds like part of the GNOME shell don't load well.
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 711

PostPosted: Sun Apr 06, 2014 12:10 pm    Post subject: Reply with quote

TomWij Hi,

I emerged eix (it is really a good idea) and the command eix-update and then eix pambase - Yes, there is [I] -It is installed...

I would like to inform you that after done this:
Quote:
Make sure the USE flags gnome-keyring, pam and systemd are enabled (add them to USE in /etc/portage/make.conf), then run `emerge -auvDN @world`
- It did not solve the origin problem, however, added some new problems (I do not blame you... :D) -
I can not shut down the computer from gnome - when I do it - or it goes to the terminal and do nothing or freeze -
May be it can give any positive idea...

Quote:
The former (make.conf) is for global USE flags over all packages, the latter (package.use) for local USE flags on specific package(s).

OK - That I know - Let me guess: Generally, we should define USE flags in /etc/portage/make.conf -
However, if there is any conflict between packages, there we need to define in /etc/portage/package.use - Is it right or something else?

Thanks
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Sun Apr 06, 2014 2:19 pm    Post subject: Reply with quote

pmam wrote:
I can not shut down the computer from gnome - when I do it - or it goes to the terminal and do nothing or freeze - May be it can give any positive idea...


Could be a a lot of things, the logs can tell the true; reboot, then run `journalctl -r` (without the 'b' [= current boot]) and scroll down until where it marks the reboot, it should give the reason not far underneath that.

pmam wrote:
Generally, we should define USE flags in /etc/portage/make.conf -
However, if there is any conflict between packages, there we need to define in /etc/portage/package.use - Is it right or something else?


Affirmative; besides that, you could use it to micro manage the USE flags on the packages (eg. build one application with a specific feature, but don't build another package with it) but in general it's not necessarily needed to micro manage them.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum