Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Steam streaming and abi_x86_32
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
paraw
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 77
Location: Coventry (UK)

PostPosted: Sat Mar 08, 2014 10:21 am    Post subject: Steam streaming and abi_x86_32 Reply with quote

Hi guys, I'm trying to emerge the Steam client with the USE flag "streaming" enabled, but I'm ending up with this error message
Code:
emerge: there are no ebuilds built with USE flags to satisfy "dev-libs/libpthread-stubs[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?]".
!!! One of the following packages is required to complete your request:
- x11-libs/libdrm-2.4.52::gentoo (Change USE: -abi_x86_32)
[...]

It looks like the problem is that libpthread-stubs does not have abi_x86_32. In fact, if I emerge -pv it, I get
Code:
[ebuild   R    ] dev-libs/libpthread-stubs-0.3-r1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 199 kB


Any workarounds?

Thanks
Back to top
View user's profile Send private message
GenProm
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2011
Posts: 93
Location: Germany

PostPosted: Tue Mar 11, 2014 5:52 pm    Post subject: Reply with quote

Hi paraw :)

I would use the steam-launcher ebuild from the "gamerlay" overlay. This will download and install the orginal steam from Valve.

As far as i know everything works with it. But i did not try streaming. How do you get steam ebuild ?

Also on the abi problems, i tried to install ssr (simple screenrecorder) and had the same issue. In the end i just did not use the abi_x86_32 and it did still work perfectly.

Hope this helps a bit
_________________
Thank you for your help.

Manuel
Back to top
View user's profile Send private message
paraw
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 77
Location: Coventry (UK)

PostPosted: Wed Mar 12, 2014 8:01 am    Post subject: Reply with quote

Hi GenProm, I'm actually getting the steam ebuilds from the "steam" overlay. This seems to me to be more a problem of libpthread-stubs...
Back to top
View user's profile Send private message
anyc
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 119

PostPosted: Sun Mar 30, 2014 4:41 pm    Post subject: Reply with quote

"streaming" depends on x11-libs/libva. I assume not all ebuilds are prepared for abi_x86_32 and your VIDEO_CARDS setting. Can you post the emerge output with "--tree"?
Back to top
View user's profile Send private message
paraw
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 77
Location: Coventry (UK)

PostPosted: Sat Apr 05, 2014 11:27 am    Post subject: Reply with quote

Thank you anyc, actually I figured out that the problem depends on the infernal madness of abi_x86_32. In fact, as you suggested, not all ebuilds are ready for it, so much that, even without "streaming" in steam, I still need to mask some packages if I want to update world.
Thanks anyway!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum