Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] xonar soundcard is silent, no errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
daaaaang
n00b
n00b


Joined: 04 Jul 2010
Posts: 45
Location: Ann Arbor, Michigan, US

PostPosted: Wed Feb 26, 2014 12:39 am    Post subject: [solved] xonar soundcard is silent, no errors Reply with quote

I have the Asus Xonar DX sound card installed. Alsa supports it with snd-virtuoso. I went ahead and compiled that into the kernel with CONFIG_SND_VIRTUOSO=y.

cat /proc/asound/cards

Code:
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfb620000 irq 61
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfb080000 irq 17
 2 [DX             ]: AV200 - Xonar DX
                      Asus Virtuoso 100 at 0xa000, irq 19


aplay -l

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: DX [Xonar DX], device 0: Multichannel [Multichannel]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: DX [Xonar DX], device 1: Digital [Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


amixer -c 2 scontents

Code:
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right - Rear Left - Rear Right - Front Center - Woofer - Side Left - Side Right
  Limits: Playback 67 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]
  Rear Left: Playback 127 [100%] [0.00dB] [on]
  Rear Right: Playback 127 [100%] [0.00dB] [on]
  Front Center: Playback 127 [100%] [0.00dB] [on]
  Woofer: Playback 127 [100%] [0.00dB] [on]
  Side Left: Playback 127 [100%] [0.00dB] [on]
  Side Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Front Panel',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Line',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Mic',0
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 31
  Mono: Capture 31 [100%] [12.00dB] [off]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Mic Source',0
  Capabilities: cenum
  Items: 'Mic Jack' 'Front Panel'
  Item0: 'Mic Jack'
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Loopback',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Validity Check',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Aux',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 31 [100%] [12.00dB] [off]
  Front Right: Capture 31 [100%] [12.00dB] [off]
Simple mixer control 'Analog Input Monitor',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 1
  Mono: Playback 1 [100%] [0.00dB] [on]
Simple mixer control 'DAC Filter',0
  Capabilities: penum
  Items: 'Fast Roll-off' 'Slow Roll-off'
  Item0: 'Slow Roll-off'
Simple mixer control 'Digital Input Monitor',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 1
  Mono: Playback 1 [100%] [0.00dB] [on]
Simple mixer control 'Stereo Upmixing',0
  Capabilities: enum
  Items: 'Front' 'Front+Surround' 'Front+Surround+Back' 'Front+Surround+Center/LFE' 'Front+Surround+Center/LFE+Back'
  Item0: 'Front+Surround'


But when I try to run aplay -D plughw:2,0 (or plughw:2,1) I get no sound. I don't get any errors either though, just the usual

Code:
Playing WAVE '09-bottle-rocket.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo


until I hit ^C

If I plug the cord into the onboard jack instead and run it on plughw:0,0 or plughw:0,1, it plays loud and clear.

This is true for 2-channel analog as well as S/PDIF. Both work through the onboard sound; neither with the Xonar DX.

The most distressing thing to me is the total lack of error messages. I have no idea at all how to move forward, which is why I'm here.

Are there any logs anywhere that aplay might write errors to? Or really do you have any suggestions at all about how to move forward?

Thanks!
Matt

Update: I recompiled the kernel with CONFID_SND_VIRTUOSO and CONFIG_SND_OXYGEN_LIB as modules (all set to m instead of y), and now it works no problem. Thanks for reading!


Last edited by daaaaang on Wed May 07, 2014 5:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5365

PostPosted: Fri Feb 28, 2014 2:42 am    Post subject: Reply with quote

My first thought is you need to set your Xonar to be the default sound card. Try this, except make the file /etc/conf.d/alsasound instead of /etc/modprobe.d.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Linux 'Tude Tees: http://moodytudetees.com/index.php/linux-tude-tees
Back to top
View user's profile Send private message
chaseguard
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2004
Posts: 138

PostPosted: Mon Mar 03, 2014 1:05 am    Post subject: Reply with quote

I use a Xonar card. Never had any problems with it. Question: You did plugin the extra Molex power cable required for the Xonar card?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum