Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wpa_supplicant problems using iwlwifi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
pgu
Guru
Guru


Joined: 30 Jul 2009
Posts: 425
Location: Oslo, Norway

PostPosted: Mon Feb 03, 2014 7:40 pm    Post subject: wpa_supplicant problems using iwlwifi Reply with quote

I'm having problems getting wifi running on a new machine.


Code:
# lspci -s 03:00.0 -k
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
        Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN
        Kernel driver in use: iwlwifi


Code:
# dmesg |grep wl
[    1.421341] iwlwifi 0000:03:00.0: irq 43 for MSI/MSI-X
[    2.644112] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[    2.644125] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    2.644128] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[    2.644130] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[    2.644132] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled
[    2.644134] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_P2P enabled
[    2.644137] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
[    2.644253] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[    2.663091] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[    2.680021] systemd-udevd[1289]: renamed network interface wlan0 to wlp3s0


Code:
# /etc/init.d/net.wlp3s0 restart
 * Bringing down interface wlp3s0
 *   Removing addresses
 *     Stopping wpa_cli on wlp3s0 ...                                                                                         [ ok ]
 *     Stopping wpa_supplicant on wlp3s0 ...                                                                                  [ ok ]
 * Bringing up interface wlp3s0
 *   Starting wpa_supplicant on wlp3s0 ...
Successfully initialized wpa_supplicant
ioctl[SIOCSIWPMKSA]: Invalid argument
ioctl[SIOCSIWMODE]: Invalid argument
ioctl[SIOCGIWRANGE]: Invalid argument
ioctl[SIOCGIWMODE]: Invalid argument
ioctl[SIOCSIWAP]: Invalid argument
ioctl[SIOCSIWESSID]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWPMKSA]: Invalid argument                                                                                         [ ok ]
 *   Starting wpa_cli on wlp3s0 ...                                                                                           [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlp3s0 has started, but is inactive


Code:
# ifconfig wlp3s0
wlp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether a4:4e:31:13:db:08  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0



Also when I try to run a scan I get:

Code:
# wpa_cli

<4>Failed to initiate AP scan


/etc/conf.d/net contains:

Code:
modules_wlan0="wpa_supplicant"
config_wlan0="dhcp"
wpa_cli_wlan0="-G3600"
wpa_supplicant_wlan0="-D nl80211"
#wpa_supplicant_wlan0="-Dmadwifi"


Any pointers?
Back to top
View user's profile Send private message
spidark
n00b
n00b


Joined: 01 Sep 2011
Posts: 16

PostPosted: Mon Feb 03, 2014 11:18 pm    Post subject: Reply with quote

Hallo pgu,
These settings worked for me, hope it helps.

Code:
# lspci -s 02:00 -k
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
   Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN
   Kernel driver in use: iwlwifi


Code:
# dmesg |grep wl
    2.266114] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
    2.267176] iwlwifi 0000:02:00.0: irq 45 for MSI/MSI-X
    6.532051] iwlwifi 0000:02:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
    6.532063] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
    6.532064] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
    6.532065] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
    6.532066] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
    6.532068] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_P2P enabled
    6.532069] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
    6.532183] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
    6.549553] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
    6.819228] systemd-udevd[1647]: renamed network interface wlan0 to wlp2s0
   12.252007] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
   12.258886] iwlwifi 0000:02:00.0: Radio type=0x1-0x2-0x0
   12.641709] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
   12.648159] iwlwifi 0000:02:00.0: Radio type=0x1-0x2-0x0


Code:
/etc/conf.d/net

modules_wlp2s0="!wpa_supplicant"
modules_eno1="!plug wpa_supplicant dhcpcd"
wpa_supplicant_wlp2s0="-Dnl80211"
config_eno1="dhcp"
config_wlp2s0="dhcp"


Code:
.config
CONFIG_IWLWIFI=y
CONFIG_IWLDVM=y
CONFIG_IWLWIFI_DEVICE_TESTMODE=y
CONFIG_IWLWIFI_P2P=y

CONFIG_FIB_RULES=y
CONFIG_WIRELESS=y
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_CFG80211=y
CONFIG_NL80211_TESTMODE=y
CONFIG_CFG80211_DEFAULT_PS=y
CONFIG_CFG80211_WEXT=y
CONFIG_MAC80211=y
CONFIG_MAC80211_HAS_RC=y
CONFIG_MAC80211_RC_MINSTREL=y
CONFIG_MAC80211_RC_MINSTREL_HT=y
CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT="minstrel_ht"
CONFIG_MAC80211_LEDS=y
CONFIG_RFKILL=y
CONFIG_RFKILL_LEDS=y
CONFIG_RFKILL_INPUT=y

Only problem i have is that i cannot turn off my wifi with the switch on the machine,led on all the time.
RFKILL does not help.
Good luck.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum