Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hostapd e avvio automatico di wpa_supplicant
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
IlGab
Guru
Guru


Joined: 26 Nov 2004
Posts: 486

PostPosted: Sat Jan 18, 2014 10:38 pm    Post subject: hostapd e avvio automatico di wpa_supplicant Reply with quote

Titolo un po' controverso, vediamo se riesco a essere chiaro.
Sto provando hostapd su una macchina con una wireless Atheros AR5005G, funziona tutto tranne lo startup automatico, questo perchè lo script della scheda di rete cerca in automatico di avviare wpa_supplicant anzichè assegnarle un IP statico come da configurazione.
Code:

 conf.d # cat net
config_wlp2s3="192.168.50.1 netmask 255.255.255.0 brd 192.168.50.255"

 /etc/init.d/net.wlp2s3 start
 * Caching service dependencies ...                                                                                                                                                     [ ok ]
 * Bringing up interface wlp2s3
 *   Caching network module dependencies
need firewalld
 *   Starting wpa_supplicant on wlp2s3 ...
 *   /etc/wpa_supplicant/wpa_supplicant.conf not found                                                                                                                                  [ !! ]
 * ERROR: net.wlp2s3 failed to start


wpa_supplicant non è nemmeno installato sulla macchina :?

Se assegno manualmente l'ip alla scheda tramite ifconfig, avvio hostapd e dhcpd, tutto funziona a meraviglia, gli host si connettono e ottengono correttamente le informazioni di rete.

Idee ? Cosa sto trascurando ? Perchè, nonostante non abbia specificato di utilizzare il modulo wpa_supplicant nel file di configurazione, lo cerca ugualmente ?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4825
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sun Jan 19, 2014 2:40 pm    Post subject: Reply with quote

Visto il modo indecente con cui riporti i tuoi guai sarei tentato di non rispondere ma è domenica e non ho di meglio da fare...

Ti consiglio (solo consiglio, ma se vuoi fare diversamente t'arrangi) di rinominare i device di rete per evitare confusioni con
/etc/udev/rules.d/80-net-name-slot.rules wrote:
SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="indirizzo ethernet", NAME="net[0-9]"o"wan0"
.

Per gestire hostapd (riporto direttamente l'esempio con bridge perche così mi gira di fare) efficacemente devi avere
/etc/rc.conf wrote:
rc_hotplug="net.lo !net.*"
altrimenti operc (che ha le corna) potrebbe cercare di avviarli in hotplug, se nella conf del kernel hai rfkill con le atheros in genere devi aggiungere
Code:
rfkill.master_switch_mode=2
(preferibilmente nella conf del kernel se i driver sono builtin) alla linea di comando del kernel o potresti avere problemi con il lock hw/sf sul device riavviando l'interfaccia. Per evitare che openrc (che ha sempre le corna lunghe e ritorte) avvi automaticamente wpa_supplicant od iwconfig li devi disabilitare esplicitamente per il device quindi
/etc/conf.d/net wrote:
# net0 - ethernet
config_net1="null"
ifdown_net1="yes"

# net[1-9] - wlan (hostapd)
modules_net[1-9]="ifconfig !iwconfig !wpa_supplicant"
config_net[1-9]="null"
ifdown_net[1-9]="yes"
essid_net[1-9]="QuelCheTipare"

...

# br0
bridge_br0="net0" oppure bridge_br0="" se hai solo schede wlan da aggiungere al bridge
config_br0="xxx.xxx.xxx.xxx/xxx"
oppure se hai solo la scheda wlan
/etc/conf.d/net wrote:
# net[1-9] - wlan (hostapd)
modules_net[1-9]="ifconfig !iwconfig !wpa_supplicant"
config_net[1-9]="xxx.xxx.xxx.xxx/xxx"
ifdown_net[1-9]="yes"
essid_net[1-9]="QuelCheTipare"
edi infine
/etc/conf.d/hostapd wrote:
INTERFACES="net[1-9] br0"
CONFIGS="/etc/hostapd/hostapd[0-1].conf /etc/hostapd/hostapd[0-9].conf ..."
OPTIONS="-dd"
/etc/hostapd/hostapd[1-9].conf wrote:
interface=net[1-9]
bridge=br0
driver=nl80211
oppure
/etc/conf.d/hostapd wrote:
INTERFACES="net[1-9]"
CONFIGS="/etc/hostapd/hostapd[0-1].conf"
OPTIONS="-dd"
/etc/hostapd/hostapd[1-9].conf wrote:
interface=net[1-9]
driver=nl80211
se non usi il bridge, come vedi devi creare tanti file di conf per hostapd quante sono le interfacce perchè la conf su interfacce multiple al momento non funziona bene.
In avvio automatico avrai solo l'interfaccia per la connessione wan (od altre autonome) ed hostapd. Per net.brvattelappesca e net.netvattelappesca (asservite ad hostapd) dovrai creare i link in /etc/init.d ma le deve avviare lui e, se c'è il bridge, deve essere lui ad aggiungere l'interfaccia (in pratica è tutto qui il problema). Dhcpd se vuoi lo devi inserire nel runlevel.
Questa è la via corretta con openrc.

Mi sembra abbastanza semplice da non richiedere particolari chiarimenti; ma poiché la documentazione in materia è ancora datata a prima dell'introduzione di openrc ed abbondano i bimbiminkia che propongono senza pensare soluzioni pasticciate come intervenire sulle dipendenze o non installare wpa_supplicant (è tutto il contrario, è bene che ci sia) etc. ... tu devi perdere il tuo tempo a chiedere ed attendere risposta e le persone di buona volontà devono perder tempo a rispondenti (o si devono sobbarcare del lavoraccio infame di arrivarci per conto proprio, se ne hanno le capacità). E tutti bestemmiano per un problema banale... :twisted:

Se non mi sbaglio è un thread duplicato ma non ho intenzione di cercare dove lo ho già scritto (almeno un paio di volte, se non ricordo male).
Se tu che sei l'interessato non ti sprechi a cercare non vedo perché dovrei farlo io.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
IlGab
Guru
Guru


Joined: 26 Nov 2004
Posts: 486

PostPosted: Sun Jan 19, 2014 4:47 pm    Post subject: Reply with quote

djinnZ wrote:
Visto il modo indecente con cui riporti i tuoi guai sarei tentato di non rispondere ma è domenica e non ho di meglio da fare...

Ti consiglio (solo consiglio, ma se vuoi fare diversamente t'arrangi) di rinominare i device di rete per evitare confusioni con...

Mi sembra abbastanza semplice da non richiedere particolari chiarimenti; ma poiché la documentazione in materia è ancora datata a prima dell'introduzione di openrc ed abbondano i bimbiminkia che propongono senza pensare soluzioni pasticciate come intervenire sulle dipendenze o non installare wpa_supplicant (è tutto il contrario, è bene che ci sia) etc. ... tu devi perdere il tuo tempo a chiedere ed attendere risposta e le persone di buona volontà devono perder tempo a rispondenti (o si devono sobbarcare del lavoraccio infame di arrivarci per conto proprio, se ne hanno le capacità). E tutti bestemmiano per un problema banale...

Se non mi sbaglio è un thread duplicato ma non ho intenzione di cercare dove lo ho già scritto (almeno un paio di volte, se non ricordo male).
Se tu che sei l'interessato non ti sprechi a cercare non vedo perché dovrei farlo io.


Grazie per i consigli, vedrò cosa salta fuori e, visto che hai aperto un tema interessante, se la tua vita è triste certi commenti te li puoi anche risparmiare, se non ti va di fare una cosa fai a meno di farla ma non serve tanta boria per rispondere ad un 3d ne tanto meno tirarsela tanto.

Giusto per la cronaca, dipende dal tempo che uno ha a disposizione per fare una determinata cosa, se avessi avuto più possibilità non avrei certo disturbato sua maestà.

Buona domenica
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4825
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Mon Jan 20, 2014 2:39 pm    Post subject: Reply with quote

Dovevo ricordare che ero di fronte al solito imbecille che non capisce quando uno la prende a ridere.
Code:
 :twisted:
questo sconosciuto che tra l'altro non ha nulla a che vedere con
Code:
 :evil:
sfortunatamente non aderisco alla scuola di pensiero per cui ogni riga va terminata con un emoticon a rendere il discorso ancora più melenso.

Purtroppo questo forum non ha il blacklisting e va a finire che ci ricasco ad aiutare chi non lo merita. (per il cazziatone finale, ribadisco invece)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum