Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Can't rebuild dev-games/openscenegraph-3.0.1-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Sun Jan 12, 2014 11:10 pm    Post subject: [solved] Can't rebuild dev-games/openscenegraph-3.0.1-r1 Reply with quote

Compilation of dev-games/openscenegraph-3.0.1-r1 fails at 53%. USE flags don't seem to matter. There is no error message. Same for GCC 4.6.3 and 4.7.4. It built correctly in July, probably with some of GCC-4.6.

The last lines are:
Code:

[ 53%] Building CXX object src/osgWrappers/deprecated-dotosg/osg/CMakeFiles/osgdb_deprecated_osg.dir/LineWidth.o                                                                                                             
cd /var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build/src/osgWrappers/deprecated-dotosg/osg && /usr/bin/x86_64-pc-linux-gnu-g++  -Dosgdb_deprecated_osg_EXPORTS  -D__STDC_CONSTANT_MACROS -DNDEBUG -O2 -pipe -march=native  -Wall -Wparentheses -Wno-long-long -Wno-import -pedantic -Wreturn-type -Wmissing-braces -Wunknown-pragmas -Wunused -fpermissive -fPIC -I/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/include -I/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build/include    -o CMakeFiles/osgdb_deprecated_osg.dir/LineWidth.o -c /var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/src/osgWrappers/deprecated-dotosg/osg/LineWidth.cpp
Linking CXX shared module ../../../../lib/osgPlugins-3.0.1/osgdb_deprecated_osg.so
cd /var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build/src/osgWrappers/deprecated-dotosg/osg && /usr/bin/cmake -E cmake_link_script CMakeFiles/osgdb_deprecated_osg.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++  -fPIC -O2 -pipe -march=native  -Wall -Wparentheses -Wno-long-long -Wno-import -pedantic -Wreturn-type -Wmissing-braces -Wunknown-pragmas -Wunused -fpermissive  -Wl,-O1 -Wl,--as-needed -shared -Wl,-soname,osgdb_deprecated_osg.so -o ../../../../lib/osgPlugins-3.0.1/osgdb_deprecated_osg.so CMakeFiles/osgdb_deprecated_osg.dir/TexEnvCombine.o CMakeFiles/osgdb_deprecated_osg.dir/CoordinateSystemNode.o CMakeFiles/osgdb_deprecated_osg.dir/Node.o CMakeFiles/osgdb_deprecated_osg.dir/ImageSequence.o CMakeFiles/osgdb_deprecated_osg.dir/Object.o CMakeFiles/osgdb_deprecated_osg.dir/Switch.o CMakeFiles/osgdb_deprecated_osg.dir/OcclusionQueryNode.o CMakeFiles/osgdb_deprecated_osg.dir/Billboard.o CMakeFiles/osgdb_deprecated_osg.dir/Geometry.o CMakeFiles/osgdb_deprecated_osg.dir/VertexProgram.o CMakeFiles/osgdb_deprecated_osg.dir/CameraView.o CMakeFiles/osgdb_deprecated_osg.dir/Group.o CMakeFiles/osgdb_deprecated_osg.dir/StateAttribute.o CMakeFiles/osgdb_deprecated_osg.dir/LibraryWrapper.o CMakeFiles/osgdb_deprecated_osg.dir/Transform.o CMakeFiles/osgdb_deprecated_osg.dir/TexEnvFilter.o CMakeFiles/osgdb_deprecated_osg.dir/ShapeDrawable.o CMakeFiles/osgdb_deprecated_osg.dir/CullFace.o CMakeFiles/osgdb_deprecated_osg.dir/TexMat.o CMakeFiles/osgdb_deprecated_osg.dir/LightModel.o CMakeFiles/osgdb_deprecated_osg.dir/BlendColor.o CMakeFiles/osgdb_deprecated_osg.dir/Drawable.o CMakeFiles/osgdb_deprecated_osg.dir/Matrix.o CMakeFiles/osgdb_deprecated_osg.dir/ClusterCullingCallback.o CMakeFiles/osgdb_deprecated_osg.dir/Camera.o CMakeFiles/osgdb_deprecated_osg.dir/ShadeModel.o CMakeFiles/osgdb_deprecated_osg.dir/Depth.o CMakeFiles/osgdb_deprecated_osg.dir/MatrixTransform.o CMakeFiles/osgdb_deprecated_osg.dir/ClearNode.o CMakeFiles/osgdb_deprecated_osg.dir/ColorMatrix.o CMakeFiles/osgdb_deprecated_osg.dir/Cylinder.o CMakeFiles/osgdb_deprecated_osg.dir/ClipPlane.o CMakeFiles/osgdb_deprecated_osg.dir/PositionAttitudeTransform.o CMakeFiles/osgdb_deprecated_osg.dir/AlphaFunc.o CMakeFiles/osgdb_deprecated_osg.dir/OccluderNode.o CMakeFiles/osgdb_deprecated_osg.dir/PolygonOffset.o CMakeFiles/osgdb_deprecated_osg.dir/Sphere.o CMakeFiles/osgdb_deprecated_osg.dir/FragmentProgram.o CMakeFiles/osgdb_deprecated_osg.dir/TextureCubeMap.o CMakeFiles/osgdb_deprecated_osg.dir/Fog.o CMakeFiles/osgdb_deprecated_osg.dir/EllipsoidModel.o CMakeFiles/osgdb_deprecated_osg.dir/Texture.o CMakeFiles/osgdb_deprecated_osg.dir/Capsule.o CMakeFiles/osgdb_deprecated_osg.dir/AnimationPath.o CMakeFiles/osgdb_deprecated_osg.dir/ClipNode.o CMakeFiles/osgdb_deprecated_osg.dir/Geode.o CMakeFiles/osgdb_deprecated_osg.dir/Light.o CMakeFiles/osgdb_deprecated_osg.dir/TexEnv.o CMakeFiles/osgdb_deprecated_osg.dir/ConvexPlanarOccluder.o CMakeFiles/osgdb_deprecated_osg.dir/LightSource.o CMakeFiles/osgdb_deprecated_osg.dir/TextureRectangle.o CMakeFiles/osgdb_deprecated_osg.dir/Sequence.o CMakeFiles/osgdb_deprecated_osg.dir/Program.o CMakeFiles/osgdb_deprecated_osg.dir/LineStipple.o CMakeFiles/osgdb_deprecated_osg.dir/FrontFace.o CMakeFiles/osgdb_deprecated_osg.dir/PolygonMode.o CMakeFiles/osgdb_deprecated_osg.dir/PagedLOD.o CMakeFiles/osgdb_deprecated_osg.dir/Texture3D.o CMakeFiles/osgdb_deprecated_osg.dir/Box.o CMakeFiles/osgdb_deprecated_osg.dir/AutoTransform.o CMakeFiles/osgdb_deprecated_osg.dir/TransferFunction.o CMakeFiles/osgdb_deprecated_osg.dir/Texture1D.o CMakeFiles/osgdb_deprecated_osg.dir/ColorMask.o CMakeFiles/osgdb_deprecated_osg.dir/HeightField.o CMakeFiles/osgdb_deprecated_osg.dir/PointSprite.o CMakeFiles/osgdb_deprecated_osg.dir/TexGenNode.o CMakeFiles/osgdb_deprecated_osg.dir/Shader.o CMakeFiles/osgdb_deprecated_osg.dir/Stencil.o CMakeFiles/osgdb_deprecated_osg.dir/BlendFunc.o CMakeFiles/osgdb_deprecated_osg.dir/NodeCallback.o CMakeFiles/osgdb_deprecated_osg.dir/TessellationHints.o CMakeFiles/osgdb_deprecated_osg.dir/Uniform.o CMakeFiles/osgdb_deprecated_osg.dir/CompositeShape.o CMakeFiles/osgdb_deprecated_osg.dir/Cone.o CMakeFiles/osgdb_deprecated_osg.dir/ProxyNode.o CMakeFiles/osgdb_deprecated_osg.dir/BlendEquation.o CMakeFiles/osgdb_deprecated_osg.dir/Scissor.o CMakeFiles/osgdb_deprecated_osg.dir/Texture2D.o CMakeFiles/osgdb_deprecated_osg.dir/Viewport.o CMakeFiles/osgdb_deprecated_osg.dir/Material.o CMakeFiles/osgdb_deprecated_osg.dir/StateSet.o CMakeFiles/osgdb_deprecated_osg.dir/Point.o CMakeFiles/osgdb_deprecated_osg.dir/LOD.o CMakeFiles/osgdb_deprecated_osg.dir/Image.o CMakeFiles/osgdb_deprecated_osg.dir/TexGen.o CMakeFiles/osgdb_deprecated_osg.dir/Projection.o CMakeFiles/osgdb_deprecated_osg.dir/LineWidth.o ../../../../lib/libOpenThreads.so.2.6.0 ../../../../lib/libosg.so.3.0.1 ../../../../lib/libosgDB.so.3.0.1 ../../../../lib/libosgUtil.so.3.0.1 ../../../../lib/libosg.so.3.0.1 ../../../../lib/libOpenThreads.so.2.6.0 -lpthread -lm -lrt -ldl -lz -lGL -Wl,-rpath,/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build/lib:
make[2]: Leaving directory `/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build/CMakeFiles  39 40 41 42 43 44 45
[ 53%] Built target osgdb_deprecated_osg
make[1]: Leaving directory `/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build'
make: *** [all] Error 2
emake failed
 * ERROR: dev-games/openscenegraph-3.0.1-r1::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 2641:  Called cmake-utils_src_compile
 *   environment, line  721:  Called _execute_optionaly 'src_compile'
 *   environment, line  316:  Called enable_cmake-utils_src_compile
 *   environment, line  909:  Called cmake-utils_src_make
 *   environment, line  736:  Called emake_src_make
 *   environment, line  877:  Called die
 * The specific snippet of code:
 *           emake VERBOSE=1 "$@" || die;
 *


Code:

# emerge --info '=dev-games/openscenegraph-3.0.1-r1::gentoo'
Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.1.6-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.1.6-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.2
KiB Mem:    16429912 total,   1698444 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sun, 12 Jan 2014 17:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo local_overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ ftp://mirror.netcologne.de/gentoo/ rsync://mirror.neolabs.kz/gentoo ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo http://ftp.snt.utwente.nl/pub/os/linux/gentoo rsync://de-mirror.org/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ rsync://mirror.netcologne.de/gentoo/ http://de-mirror.org/gentoo/ ftp://de-mirror.org/gentoo/ ftp://mirror.yandex.ru/gentoo-distfiles/"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.ru.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 cli cracklib crypt cxx dri ffmpeg fortran gdbm gif iconv idn ipv6 jbig jpeg jpeg2k lzma mmx modules mudflap multilib ncurses nls nptl opengl openmp pam pcre png pnm qt3support readline session sqlite sse sse2 ssl tcpd threads tiff unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-games/openscenegraph-3.0.1-r1 was built with the following:
USE="ffmpeg gif jpeg jpeg2k (multilib) png tiff zlib -curl -debug -doc -examples -fltk -fox -gdal -glut -gtk -itk -openexr -openinventor -osgapps -pdf -qt4 -sdl -svg -truetype -vnc -wxwidgets -xine -xrandr" ABI_X86="64"


Code:

# emerge -pqv '=dev-games/openscenegraph-3.0.1-r1::gentoo'
[ebuild   R   ] dev-games/openscenegraph-3.0.1-r1  USE="curl* ffmpeg fltk* gdal* gif jpeg jpeg2k openexr* png qt4* sdl* svg* tiff truetype* xrandr* zlib -debug -doc -examples -fox -glut -gtk -itk -openinventor -osgapps -pdf -vnc -wxwidgets -xine"


The log is at http://bpaste.net/show/167393/

What's wrong?

Correct answer: dev-games/openscenegraph-3.0.1 doesn't compile with media-video/ffmpeg-0.10.10 or media-video/ffmpeg-2.0.2. If the programs using openscenegraph (such as games-simulation/flightgear) don't need it, disabling "ffmpeg" USE flag solves the problem.


Last edited by acheron2 on Mon Jan 13, 2014 12:36 am; edited 1 time in total
Back to top
View user's profile Send private message
i4dnf
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2005
Posts: 144
Location: Bucharest, Romania

PostPosted: Sun Jan 12, 2014 11:41 pm    Post subject: Reply with quote

The error is related to ffmpeg. Did you update ffmpeg in the meantime?
Depending on what you need openscenegraph for, you could try to temporarily set USE="-ffmpeg' for it, and see if that gets it to complete the build.
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 742
Location: Here and Away Again

PostPosted: Mon Jan 13, 2014 12:07 am    Post subject: Reply with quote

Teegrins, acheron2!


It seems to build fine here, and actually, your error happens a bit before that snippet (joys of -j7, heh!), at around 50%:

Code:
[ 50%] Building CXX object src/osgPlugins/freetype/CMakeFiles/osgdb_freetype.dir/FreeTypeLibrary.o
cd /var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build/src/osgPlugins/freetype && /usr/bin/x86_64-pc-linux-gnu-g++  -Dosgdb_freetype_EXPORTS  -D__STDC_CONSTANT_MACROS -DNDEBUG -O2 -pipe -march=native  -Wall -Wparentheses -Wno-long-long -Wno-import -pedantic -Wreturn-type -Wmissing-braces -Wunknown-pragmas -Wunused -fpermissive -fPIC -I/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/include -I/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build/include -I/usr/include/freetype2    -o CMakeFiles/osgdb_freetype.dir/FreeTypeLibrary.o -c /var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/src/osgPlugins/freetype/FreeTypeLibrary.cpp
/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp: In function ‘int osgFFmpeg::decode_audio(AVCodecContext*, int16_t*, int*, const uint8_t*, int)’:
/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp:28:12: warning: ‘int avcodec_decode_audio3(AVCodecContext*, int16_t*, int*, AVPacket*)’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3682) [-Wdeprecated-declarations]
/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp:28:72: warning: ‘int avcodec_decode_audio3(AVCodecContext*, int16_t*, int*, AVPacket*)’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3682) [-Wdeprecated-declarations]
/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp: In constructor ‘osgFFmpeg::FFmpegDecoderAudio::FFmpegDecoderAudio(osgFFmpeg::FFmpegDecoderAudio::PacketQueue&, osgFFmpeg::FFmpegClocks&)’:
/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/OpenSceneGraph-3.0.1/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp:43:21: error: ‘AVCODEC_MAX_AUDIO_FRAME_SIZE’ was not declared in this scope
make[2]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/FFmpegDecoderAudio.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-games/openscenegraph-3.0.1-r1/work/openscenegraph-3.0.1_build'
make[1]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....


Does not disabling ffmpeg USE flag really make no difference?

In any case, I just tried to build it here, and it was a success:

Code:
dev-games/openscenegraph-3.0.1-r1 was built with the following:
USE="ffmpeg gif jpeg jpeg2k (multilib) png qt4 svg truetype wxwidgets zlib -curl -debug -doc -examples -fltk -fox -gdal -glut -gtk -itk -openexr -openinventor -osgapps -pdf -sdl -tiff -vnc -xine -xrandr" ABI_X86="64"

This is with

Code:
media-video/ffmpeg-1.2.4 was built with the following:
USE="3dnow 3dnowext X aac alsa bzip2 encode faac gnutls hardcoded-tables iconv jack jpeg2k libcaca mmx mmxext mp3 (multilib) network openal rtmp schroedinger sdl ssse3 threads truetype v4l vorbis x264 xvid zlib -aacplus (-altivec) -amr -avx -bindist -bluray -cdio (-celt) -cpudetection -debug -doc -examples -fdk -flite -fontconfig -frei0r -gsm -iec61883 -ieee1394 -libass -libsoxr -libv4l -modplug (-neon) -openssl -opus -oss -pic -pulseaudio -speex -static-libs -test -theora -twolame -vaapi -vdpau (-vis) -vpx" ABI_X86="64" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"

I'm not entirely sure if it's to be blamed, but that's where I would look into first.


Edit:

Oh, I'm late now. :E
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Mon Jan 13, 2014 12:12 am    Post subject: Reply with quote

i4dnf wrote:
The error is related to ffmpeg. Did you update ffmpeg in the meantime?
Depending on what you need openscenegraph for, you could try to temporarily set USE="-ffmpeg' for it, and see if that gets it to complete the build.


Yes, I did update it. I use openscenegraph only for FlightGear (and simgear, for FlightGear too). Does it need ffmpeg for that?
Back to top
View user's profile Send private message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Mon Jan 13, 2014 12:31 am    Post subject: Reply with quote

Chiitoo wrote:

your error happens a bit before that snippet (joys of -j7, heh!),

Thanks! Didn't find it.
Quote:

Code:
media-video/ffmpeg-1.2.4 was built with the following:
USE="3dnow 3dnowext X aac alsa bzip2 encode faac gnutls hardcoded-tables iconv jack jpeg2k libcaca mmx mmxext mp3 (multilib) network openal rtmp schroedinger sdl ssse3 threads truetype v4l vorbis x264 xvid zlib -aacplus (-altivec) -amr -avx -bindist -bluray -cdio (-celt) -cpudetection -debug -doc -examples -fdk -flite -fontconfig -frei0r -gsm -iec61883 -ieee1394 -libass -libsoxr -libv4l -modplug (-neon) -openssl -opus -oss -pic -pulseaudio -speex -static-libs -test -theora -twolame -vaapi -vdpau (-vis) -vpx" ABI_X86="64" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"




Thanks. But I need a recent version for G2M4 video format (created by new GoToMeeting). I don't think 1.2.4 supports it :(

Well, at least FlightGear works without ffmpeg flag.
Back to top
View user's profile Send private message
i4dnf
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2005
Posts: 144
Location: Bucharest, Romania

PostPosted: Mon Jan 13, 2014 8:44 am    Post subject: Reply with quote

Yep, if it's only for flightgear, OSG's ffmpeg suport is not used anywhere.
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum