Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-libs/harfbuzz-0.9.23::gentoo failed (compile phase)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
tameritoke
n00b
n00b


Joined: 08 Sep 2005
Posts: 38
Location: Germany

PostPosted: Thu Jan 09, 2014 1:40 am    Post subject: media-libs/harfbuzz-0.9.23::gentoo failed (compile phase) Reply with quote

tried to merge libreoffice-bin, and the dependency failed to compile. Any ideas what might be the problem or how to solve that?!

http://pastebin.com/raw.php?i=dwMcutSq


Tamer
Back to top
View user's profile Send private message
DanZ
n00b
n00b


Joined: 24 Sep 2004
Posts: 47
Location: Erie PA USA

PostPosted: Thu Jan 09, 2014 3:15 am    Post subject: Reply with quote

I had the same problem with media-libs/harfbuzz-0.9.23 while installing LibreOffice. I masked that version and 0.9.12 installed just fine.
Back to top
View user's profile Send private message
tameritoke
n00b
n00b


Joined: 08 Sep 2005
Posts: 38
Location: Germany

PostPosted: Thu Jan 09, 2014 3:28 am    Post subject: still... Reply with quote

So I did!
But portage persist in installing that version, even after I masked it:
Quote:
tamer@tux ~ $ sudo emerge libreoffice-bin
Calculating dependencies... done!

!!! All ebuilds that could satisfy "=media-libs/harfbuzz-0.9.23[icu]" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/harfbuzz-0.9.23::gentoo (masked by: package.mask)

(dependency required by "app-office/libreoffice-bin-4.1.3.2-r2" [ebuild])
(dependency required by "libreoffice-bin" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


How do I go on?!
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8600

PostPosted: Thu Jan 09, 2014 4:27 am    Post subject: Re: still... Reply with quote

tameritoke wrote:
So I did!
But portage persist in installing that version, even after I masked it:
Quote:
tamer@tux ~ $ sudo emerge libreoffice-bin
Calculating dependencies... done!

!!! All ebuilds that could satisfy "=media-libs/harfbuzz-0.9.23[icu]" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/harfbuzz-0.9.23::gentoo (masked by: package.mask)

(dependency required by "app-office/libreoffice-bin-4.1.3.2-r2" [ebuild])
(dependency required by "libreoffice-bin" [argument])


How do I go on?!
If you want to install =app-office/libreoffice-bin-4.1.3.2-r2, then you must unmask and fix the new harfbuzz. If you want to leave the new harfbuzz masked, then you must not install =app-office/libreoffice-bin-4.1.3.2-r2.
Back to top
View user's profile Send private message
tameritoke
n00b
n00b


Joined: 08 Sep 2005
Posts: 38
Location: Germany

PostPosted: Thu Jan 09, 2014 5:48 am    Post subject: Re: still... Reply with quote

Hu wrote:
tameritoke wrote:
So I did!
But portage persist in installing that version, even after I masked it:
Quote:
tamer@tux ~ $ sudo emerge libreoffice-bin
Calculating dependencies... done!

!!! All ebuilds that could satisfy "=media-libs/harfbuzz-0.9.23[icu]" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/harfbuzz-0.9.23::gentoo (masked by: package.mask)

(dependency required by "app-office/libreoffice-bin-4.1.3.2-r2" [ebuild])
(dependency required by "libreoffice-bin" [argument])


How do I go on?!
If you want to install =app-office/libreoffice-bin-4.1.3.2-r2, then you must unmask and fix the new harfbuzz. If you want to leave the new harfbuzz masked, then you must not install =app-office/libreoffice-bin-4.1.3.2-r2.



The new harfbuzz ist not installable at all, there comes a compile error.

=media-libs/harfbuzz-0.9.23 throws a comile error!

http://pastebin.com/raw.php?i=dwMcutSq

I filed a bug at:

https://bugs.gentoo.org/show_bug.cgi?id=497562

as well.

So, can you tell me please how to solve the problem installing libreoffice-bin ?!


I wanted to install harfbuzz-9999, which I unmasked, here my steps:
Quote:
tamer@tux ~ $ emerge -pv =media-libs/harfbuzz-9999
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] dev-util/ragel-6.7-r1 USE="-vim-syntax" 0 kB
[ebuild N *] media-libs/harfbuzz-9999:0/0.9.18 USE="cairo glib graphite icu introspection truetype -static-libs" 0 kB

Total: 2 packages (2 new), Size of downloads: 0 kB

tamer@tux ~ $ emerge -pv libreoffice-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "=media-libs/harfbuzz-0.9.23[icu]" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/harfbuzz-0.9.23::gentoo (masked by: package.mask)

(dependency required by "app-office/libreoffice-bin-4.1.3.2-r2" [ebuild])
(dependency required by "libreoffice-bin" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Libreoffice persists using the 0.9.23 version, even when I unmask a newer unstable version.

How do I solve that ?!
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8600

PostPosted: Thu Jan 09, 2014 11:14 pm    Post subject: Reply with quote

I understand that =media-libs/harfbuzz-0.9.23 fails to compile for you, which is why I said you must unmask and fix it. The ebuild for libreoffice-bin specifically requests that one version and no other. Therefore, my prior post stands: your choices are to not use libreoffice-bin or to fix, either personally or through a bug report, =media-libs/harfbuzz-0.9.23.

You could modify the libreoffice-bin ebuild to relax its version requirement, but that will only help if the version you install is compatible with the version it specifies.
Back to top
View user's profile Send private message
ajclements
n00b
n00b


Joined: 20 Jan 2014
Posts: 1

PostPosted: Mon Jan 20, 2014 4:52 pm    Post subject: Reply with quote

I was able to get harfbuzz to install by manually updating gobject-introspection (emerge -a --oneshot gobject-introspection). As noted in the bug and by Hu this seems to be an incorrect dependency in the harfbuzz ebuild.

I upgraded to dev-libs/gobject-introspection-1.36.0-r1 from 1.32.1. This was the next and latest stable ebuild.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum