Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Can't install old firefox due to new python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
creaker
Guru
Guru


Joined: 14 Jul 2012
Posts: 480

PostPosted: Sat Dec 28, 2013 8:34 am    Post subject: [Solved] Can't install old firefox due to new python Reply with quote

I'd like to get back Firefox-17 because current Firefox-24 doesn't support KDE Oxygen theme addon.
So I removed the new Firefox and tried to install the old version.
emerge =www-clients/firefox-17.0.9 failed with message:
Code:
configure error python 2.5 or higher (but not python 3.x) is required

I checked available python versions that presented under dev-lang, they are: 2.6.8, 2.6.9, 2.7.5, 2.7.6. Currently I have v3.3.2 installed
But I do not want to install one of these versions due to possible python craziness with different versions installed.
Any idea on how to solve this issue?
_________________
Intel Core i3-2120 / 4Gb RAM / 250Gb HDD / NVidia GeForce-550Ti


Last edited by creaker on Sun Dec 29, 2013 10:02 am; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5191

PostPosted: Sat Dec 28, 2013 3:58 pm    Post subject: Reply with quote

Go ahead and install the Python version you want. These installs are slotted, so you won't lose existing versions. Then to install Firefox, just use eselect python to select the version you want (probably 2.7) and then emerge the version of Firefox you want. Afterward, you can run eselect python again to set it back to your preferred Python version.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2859
Location: Omnipresent

PostPosted: Sat Dec 28, 2013 3:59 pm    Post subject: Reply with quote

There should be no craziness keeping an older Python if PYTHON_TARGETS and PYTHON_SINGLE_TARGET are set to to python3_3 in make.conf
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
creaker
Guru
Guru


Joined: 14 Jul 2012
Posts: 480

PostPosted: Sat Dec 28, 2013 4:41 pm    Post subject: Reply with quote

Still, you advise to install an old python? OK, it seems no way to get old firefox with new python.
_________________
Intel Core i3-2120 / 4Gb RAM / 250Gb HDD / NVidia GeForce-550Ti
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8597

PostPosted: Sat Dec 28, 2013 4:45 pm    Post subject: Reply with quote

Beware that Firefox 17 likely is not receiving even the level of security patches given to Firefox 24. Use an old Firefox if you want, but understand the risks.
Back to top
View user's profile Send private message
creaker
Guru
Guru


Joined: 14 Jul 2012
Posts: 480

PostPosted: Sun Dec 29, 2013 10:01 am    Post subject: Reply with quote

Finally I followed your advices and installed python 2.7. and firefox 17. Eselect shows that python 3.3 selected.
In terms of security: we used firefox 17 for a long time and we was happy with it. Suddenly it became insecure due to new version was released. Hmm. There are far more dangerous things that we are forced to have installed, so firefox 17 in comparison to them is absolutely safe.
_________________
Intel Core i3-2120 / 4Gb RAM / 250Gb HDD / NVidia GeForce-550Ti
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2859
Location: Omnipresent

PostPosted: Sun Dec 29, 2013 3:45 pm    Post subject: Reply with quote

creaker,

I think Firefox 17 was fine while it was the Extended Support Release, since Mozilla committed to backporting security patches from mainline to 17. Now that the ESR release is 24, Mozilla will no longer reliably backport patches to 17, and instead focus their energies on 24.

If you want to use 17 I would advise looking for security alerts and backporting patches yourself.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8597

PostPosted: Sun Dec 29, 2013 4:35 pm    Post subject: Reply with quote

Hypnos elaborated on my point perfectly. The Mozilla project is very complex and has a huge attack surface. Security bugs can remain undiscovered for a long time, but once they are found in one version, it is easy to check older versions to see how long the bug was in the code. Suppose that Firefox 27 fixes a security bug triggered by using JavaScript in an invalid way. That bug may apply all the way back to Firefox 16 (or older), in which case your now-unsupported Firefox 17 ESR is vulnerable.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum